aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaho Nakata <maho@FreeBSD.org>2006-05-28 00:32:54 +0000
committerMaho Nakata <maho@FreeBSD.org>2006-05-28 00:32:54 +0000
commit3ceaf55a57937d6162048afbcc46d3774d8036c2 (patch)
treee4f546a83238c096ff28ad420dbd221062b71d44
parent289a693b0688db183337a7dc2d5cb1a7ce6775f8 (diff)
downloadports-3ceaf55a57937d6162048afbcc46d3774d8036c2.tar.gz
ports-3ceaf55a57937d6162048afbcc46d3774d8036c2.zip
Notes
-rw-r--r--editors/openoffice-3-devel/Makefile28
-rw-r--r--editors/openoffice.org-2-devel/Makefile28
-rw-r--r--editors/openoffice.org-2.0-devel/Makefile28
-rw-r--r--editors/openoffice.org-3-devel/Makefile28
-rw-r--r--editors/openoffice.org-vcltesttool/Makefile28
5 files changed, 135 insertions, 5 deletions
diff --git a/editors/openoffice-3-devel/Makefile b/editors/openoffice-3-devel/Makefile
index 97287600533b..2e115f45ad3c 100644
--- a/editors/openoffice-3-devel/Makefile
+++ b/editors/openoffice-3-devel/Makefile
@@ -47,18 +47,40 @@ USE_PERL5= yes
#USE_BZIP2= yes
WITHOUT_CPU_CFLAGS= true
-ONLY_FOR_ARCHS= i386
+ONLY_FOR_ARCHS= amd64 i386
+
+# XXX Cut & paste from bsd.port.mk.
+UNAME?= /usr/bin/uname
+.if !defined(ARCH)
+ARCH!= ${UNAME} -p
+.endif
+
+.if ${ARCH} == amd64
+BROKEN= "Work in progress"
+.endif
.if !defined(WITH_GNUGCJ)
USE_JAVA= yes
JAVA_VERSION= 1.4+
JAVA_BUILD= jdk
+.if ${ARCH} == amd64
+JAVA_VENDOR= bsdjava
+.else
JAVA_VENDOR= freebsd bsdjava
.endif
+.endif
.include <bsd.port.pre.mk>
.include <${FILESDIR}/Makefile.localized>
+.if ${ARCH} == amd64
+GCC_TARGET= x86_64-portbld-freebsd${OSREL}
+FREEBSD_ENV_SET= FreeBSDAMDEnv.Set
+.else
+GCC_TARGET= ${ARCH}-portbld-freebsd${OSREL}
+FREEBSD_ENV_SET= FreeBSDIntelEnv.Set
+.endif
+
.if ${PERL_LEVEL} < 500600
IGNORE= install lang/perl5.8 then try again
.endif
@@ -72,7 +94,11 @@ INSTALLATION_BASEDIR?= openoffice.org-${OOOTAG}
EXECBASE?= openoffice.org-${OOOTAG}
DIST_SUBDIR= openoffice.org2.0
SIMPLEOSVER= ${OSREL:C/\.//g}
+.if ${ARCH} == amd64
+PACKAGE_BASENAME= OOo_${OOOTAG}_${OPSYS}${SIMPLEOSVER}X86_64
+.else
PACKAGE_BASENAME= OOo_${OOOTAG}_${OPSYS}${SIMPLEOSVER}Intel
+.endif
LOCALIZED_LANG?= en-US
# FIXME (Somehow INDEX build fails)
diff --git a/editors/openoffice.org-2-devel/Makefile b/editors/openoffice.org-2-devel/Makefile
index 97287600533b..2e115f45ad3c 100644
--- a/editors/openoffice.org-2-devel/Makefile
+++ b/editors/openoffice.org-2-devel/Makefile
@@ -47,18 +47,40 @@ USE_PERL5= yes
#USE_BZIP2= yes
WITHOUT_CPU_CFLAGS= true
-ONLY_FOR_ARCHS= i386
+ONLY_FOR_ARCHS= amd64 i386
+
+# XXX Cut & paste from bsd.port.mk.
+UNAME?= /usr/bin/uname
+.if !defined(ARCH)
+ARCH!= ${UNAME} -p
+.endif
+
+.if ${ARCH} == amd64
+BROKEN= "Work in progress"
+.endif
.if !defined(WITH_GNUGCJ)
USE_JAVA= yes
JAVA_VERSION= 1.4+
JAVA_BUILD= jdk
+.if ${ARCH} == amd64
+JAVA_VENDOR= bsdjava
+.else
JAVA_VENDOR= freebsd bsdjava
.endif
+.endif
.include <bsd.port.pre.mk>
.include <${FILESDIR}/Makefile.localized>
+.if ${ARCH} == amd64
+GCC_TARGET= x86_64-portbld-freebsd${OSREL}
+FREEBSD_ENV_SET= FreeBSDAMDEnv.Set
+.else
+GCC_TARGET= ${ARCH}-portbld-freebsd${OSREL}
+FREEBSD_ENV_SET= FreeBSDIntelEnv.Set
+.endif
+
.if ${PERL_LEVEL} < 500600
IGNORE= install lang/perl5.8 then try again
.endif
@@ -72,7 +94,11 @@ INSTALLATION_BASEDIR?= openoffice.org-${OOOTAG}
EXECBASE?= openoffice.org-${OOOTAG}
DIST_SUBDIR= openoffice.org2.0
SIMPLEOSVER= ${OSREL:C/\.//g}
+.if ${ARCH} == amd64
+PACKAGE_BASENAME= OOo_${OOOTAG}_${OPSYS}${SIMPLEOSVER}X86_64
+.else
PACKAGE_BASENAME= OOo_${OOOTAG}_${OPSYS}${SIMPLEOSVER}Intel
+.endif
LOCALIZED_LANG?= en-US
# FIXME (Somehow INDEX build fails)
diff --git a/editors/openoffice.org-2.0-devel/Makefile b/editors/openoffice.org-2.0-devel/Makefile
index 97287600533b..2e115f45ad3c 100644
--- a/editors/openoffice.org-2.0-devel/Makefile
+++ b/editors/openoffice.org-2.0-devel/Makefile
@@ -47,18 +47,40 @@ USE_PERL5= yes
#USE_BZIP2= yes
WITHOUT_CPU_CFLAGS= true
-ONLY_FOR_ARCHS= i386
+ONLY_FOR_ARCHS= amd64 i386
+
+# XXX Cut & paste from bsd.port.mk.
+UNAME?= /usr/bin/uname
+.if !defined(ARCH)
+ARCH!= ${UNAME} -p
+.endif
+
+.if ${ARCH} == amd64
+BROKEN= "Work in progress"
+.endif
.if !defined(WITH_GNUGCJ)
USE_JAVA= yes
JAVA_VERSION= 1.4+
JAVA_BUILD= jdk
+.if ${ARCH} == amd64
+JAVA_VENDOR= bsdjava
+.else
JAVA_VENDOR= freebsd bsdjava
.endif
+.endif
.include <bsd.port.pre.mk>
.include <${FILESDIR}/Makefile.localized>
+.if ${ARCH} == amd64
+GCC_TARGET= x86_64-portbld-freebsd${OSREL}
+FREEBSD_ENV_SET= FreeBSDAMDEnv.Set
+.else
+GCC_TARGET= ${ARCH}-portbld-freebsd${OSREL}
+FREEBSD_ENV_SET= FreeBSDIntelEnv.Set
+.endif
+
.if ${PERL_LEVEL} < 500600
IGNORE= install lang/perl5.8 then try again
.endif
@@ -72,7 +94,11 @@ INSTALLATION_BASEDIR?= openoffice.org-${OOOTAG}
EXECBASE?= openoffice.org-${OOOTAG}
DIST_SUBDIR= openoffice.org2.0
SIMPLEOSVER= ${OSREL:C/\.//g}
+.if ${ARCH} == amd64
+PACKAGE_BASENAME= OOo_${OOOTAG}_${OPSYS}${SIMPLEOSVER}X86_64
+.else
PACKAGE_BASENAME= OOo_${OOOTAG}_${OPSYS}${SIMPLEOSVER}Intel
+.endif
LOCALIZED_LANG?= en-US
# FIXME (Somehow INDEX build fails)
diff --git a/editors/openoffice.org-3-devel/Makefile b/editors/openoffice.org-3-devel/Makefile
index 97287600533b..2e115f45ad3c 100644
--- a/editors/openoffice.org-3-devel/Makefile
+++ b/editors/openoffice.org-3-devel/Makefile
@@ -47,18 +47,40 @@ USE_PERL5= yes
#USE_BZIP2= yes
WITHOUT_CPU_CFLAGS= true
-ONLY_FOR_ARCHS= i386
+ONLY_FOR_ARCHS= amd64 i386
+
+# XXX Cut & paste from bsd.port.mk.
+UNAME?= /usr/bin/uname
+.if !defined(ARCH)
+ARCH!= ${UNAME} -p
+.endif
+
+.if ${ARCH} == amd64
+BROKEN= "Work in progress"
+.endif
.if !defined(WITH_GNUGCJ)
USE_JAVA= yes
JAVA_VERSION= 1.4+
JAVA_BUILD= jdk
+.if ${ARCH} == amd64
+JAVA_VENDOR= bsdjava
+.else
JAVA_VENDOR= freebsd bsdjava
.endif
+.endif
.include <bsd.port.pre.mk>
.include <${FILESDIR}/Makefile.localized>
+.if ${ARCH} == amd64
+GCC_TARGET= x86_64-portbld-freebsd${OSREL}
+FREEBSD_ENV_SET= FreeBSDAMDEnv.Set
+.else
+GCC_TARGET= ${ARCH}-portbld-freebsd${OSREL}
+FREEBSD_ENV_SET= FreeBSDIntelEnv.Set
+.endif
+
.if ${PERL_LEVEL} < 500600
IGNORE= install lang/perl5.8 then try again
.endif
@@ -72,7 +94,11 @@ INSTALLATION_BASEDIR?= openoffice.org-${OOOTAG}
EXECBASE?= openoffice.org-${OOOTAG}
DIST_SUBDIR= openoffice.org2.0
SIMPLEOSVER= ${OSREL:C/\.//g}
+.if ${ARCH} == amd64
+PACKAGE_BASENAME= OOo_${OOOTAG}_${OPSYS}${SIMPLEOSVER}X86_64
+.else
PACKAGE_BASENAME= OOo_${OOOTAG}_${OPSYS}${SIMPLEOSVER}Intel
+.endif
LOCALIZED_LANG?= en-US
# FIXME (Somehow INDEX build fails)
diff --git a/editors/openoffice.org-vcltesttool/Makefile b/editors/openoffice.org-vcltesttool/Makefile
index 97287600533b..2e115f45ad3c 100644
--- a/editors/openoffice.org-vcltesttool/Makefile
+++ b/editors/openoffice.org-vcltesttool/Makefile
@@ -47,18 +47,40 @@ USE_PERL5= yes
#USE_BZIP2= yes
WITHOUT_CPU_CFLAGS= true
-ONLY_FOR_ARCHS= i386
+ONLY_FOR_ARCHS= amd64 i386
+
+# XXX Cut & paste from bsd.port.mk.
+UNAME?= /usr/bin/uname
+.if !defined(ARCH)
+ARCH!= ${UNAME} -p
+.endif
+
+.if ${ARCH} == amd64
+BROKEN= "Work in progress"
+.endif
.if !defined(WITH_GNUGCJ)
USE_JAVA= yes
JAVA_VERSION= 1.4+
JAVA_BUILD= jdk
+.if ${ARCH} == amd64
+JAVA_VENDOR= bsdjava
+.else
JAVA_VENDOR= freebsd bsdjava
.endif
+.endif
.include <bsd.port.pre.mk>
.include <${FILESDIR}/Makefile.localized>
+.if ${ARCH} == amd64
+GCC_TARGET= x86_64-portbld-freebsd${OSREL}
+FREEBSD_ENV_SET= FreeBSDAMDEnv.Set
+.else
+GCC_TARGET= ${ARCH}-portbld-freebsd${OSREL}
+FREEBSD_ENV_SET= FreeBSDIntelEnv.Set
+.endif
+
.if ${PERL_LEVEL} < 500600
IGNORE= install lang/perl5.8 then try again
.endif
@@ -72,7 +94,11 @@ INSTALLATION_BASEDIR?= openoffice.org-${OOOTAG}
EXECBASE?= openoffice.org-${OOOTAG}
DIST_SUBDIR= openoffice.org2.0
SIMPLEOSVER= ${OSREL:C/\.//g}
+.if ${ARCH} == amd64
+PACKAGE_BASENAME= OOo_${OOOTAG}_${OPSYS}${SIMPLEOSVER}X86_64
+.else
PACKAGE_BASENAME= OOo_${OOOTAG}_${OPSYS}${SIMPLEOSVER}Intel
+.endif
LOCALIZED_LANG?= en-US
# FIXME (Somehow INDEX build fails)