aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-01-05 20:38:57 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-01-05 20:38:57 +0000
commit532d11741d620482361d18005183384e36c4ef44 (patch)
tree5820861e0637bfa98c71e7b496a8d21fc33d6c74
parent0bb764c0bb164edaa1eed1147054fcb6562e2bfe (diff)
downloadports-532d11741d620482361d18005183384e36c4ef44.tar.gz
ports-532d11741d620482361d18005183384e36c4ef44.zip
Notes
-rw-r--r--multimedia/Makefile1
-rw-r--r--multimedia/bsdbktr_tvtune/Makefile22
-rw-r--r--multimedia/bsdbktr_tvtune/distinfo1
-rw-r--r--multimedia/bsdbktr_tvtune/files/patch-bsdbktr_tvtune.c67
-rw-r--r--multimedia/bsdbktr_tvtune/pkg-descr10
-rw-r--r--multimedia/bsdbktr_tvtune/pkg-plist1
6 files changed, 102 insertions, 0 deletions
diff --git a/multimedia/Makefile b/multimedia/Makefile
index 43e40367923c..15b0fc100b3f 100644
--- a/multimedia/Makefile
+++ b/multimedia/Makefile
@@ -7,6 +7,7 @@
SUBDIR += avifile
SUBDIR += avinfo
SUBDIR += beep-media-player
+ SUBDIR += bsdbktr_tvtune
SUBDIR += camserv
SUBDIR += dtv
SUBDIR += dumpmpeg
diff --git a/multimedia/bsdbktr_tvtune/Makefile b/multimedia/bsdbktr_tvtune/Makefile
new file mode 100644
index 000000000000..b0bfde26e821
--- /dev/null
+++ b/multimedia/bsdbktr_tvtune/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: bsdbktr_tvtune
+# Date created: Sun Jan 4 17:49:00 EST 2004
+# Whom: Mina Naguib <webmaster@topfx.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= bsdbktr_tvtune
+PORTVERSION= 0.01
+CATEGORIES= multimedia
+MASTER_SITES= http://www.topfx.com/dist/
+
+MAINTAINER= webmaster@topfx.com
+COMMENT= A console Brooktree (bktr) TV tuner
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+ALL_TARGET= bsdbktr_tvtune
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/bsdbktr_tvtune ${PREFIX}/bin/
+
+.include <bsd.port.mk>
diff --git a/multimedia/bsdbktr_tvtune/distinfo b/multimedia/bsdbktr_tvtune/distinfo
new file mode 100644
index 000000000000..0f33450527b3
--- /dev/null
+++ b/multimedia/bsdbktr_tvtune/distinfo
@@ -0,0 +1 @@
+MD5 (bsdbktr_tvtune-0.01.tar.gz) = 49f979a86581eb3adf5d26c6ad898257
diff --git a/multimedia/bsdbktr_tvtune/files/patch-bsdbktr_tvtune.c b/multimedia/bsdbktr_tvtune/files/patch-bsdbktr_tvtune.c
new file mode 100644
index 000000000000..c87d86cc4c44
--- /dev/null
+++ b/multimedia/bsdbktr_tvtune/files/patch-bsdbktr_tvtune.c
@@ -0,0 +1,67 @@
+--- bsdbktr_tvtune.c.orig Sun Jan 4 23:43:58 2004
++++ bsdbktr_tvtune.c Mon Jan 5 21:19:01 2004
+@@ -159,35 +159,35 @@
+ * Shows propper utility usage then exits
+ */
+ void show_usage(char *programname) {
+- printf("
+-
+-Usage:
+- %s [-d TVTUNERDEVICE] [-s CHANNELSET] -c CHANNEL
+- %s -h
+- %s -l
+- %s -v
+-
+-Where:
+-
+- -c
+- The channel to tune to
+-
+- -d
+- The device to open for tuning. If unspecified defaults to /dev/tuner0
+-
+- -h
+- This help you're seeing
+-
+- -l
+- List all valid CHANNELSETs you could pass to the -s option
+-
+- -s
+- The channel set configuration to use. If unspecified defaults to NABCST
+-
+- -v
+- Show program version
+-
+-", programname, programname, programname, programname);
++ printf("\n"\
++" \n"\
++"Usage:\n"\
++" %s [-d TVTUNERDEVICE] [-s CHANNELSET] -c CHANNEL\n"\
++" %s -h\n"\
++" %s -l\n"\
++" %s -v\n"\
++"\n"\
++"Where:\n"\
++"\n"\
++" -c\n"\
++" The channel to tune to\n"\
++"\n"\
++" -d\n"\
++" The device to open for tuning. If unspecified defaults to /dev/tuner0\n"\
++"\n"\
++" -h\n"\
++" This help you're seeing\n"\
++"\n"\
++" -l\n"\
++" List all valid CHANNELSETs you could pass to the -s option\n"\
++"\n"\
++" -s\n"\
++" The channel set configuration to use. If unspecified defaults to NABCST\n"\
++"\n"\
++" -v\n"\
++" Show program version\n"\
++"\n"\
++"\n", programname, programname, programname, programname);
+ exit(1);
+ }
+
diff --git a/multimedia/bsdbktr_tvtune/pkg-descr b/multimedia/bsdbktr_tvtune/pkg-descr
new file mode 100644
index 000000000000..ed8c92636224
--- /dev/null
+++ b/multimedia/bsdbktr_tvtune/pkg-descr
@@ -0,0 +1,10 @@
+This is a commandline / console TV channel tuner for Brooktree-based TV capture
+cards running under FreeBSD using the bktr driver
+
+It does not require any other utilities (fxtv/xawtv) and does NOT require
+XFree86
+
+WWW: http://www.topfx.com
+
+- Mina Naguib
+webmaster@topfx.com
diff --git a/multimedia/bsdbktr_tvtune/pkg-plist b/multimedia/bsdbktr_tvtune/pkg-plist
new file mode 100644
index 000000000000..6d542342d351
--- /dev/null
+++ b/multimedia/bsdbktr_tvtune/pkg-plist
@@ -0,0 +1 @@
+bin/bsdbktr_tvtune