aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2005-02-24 21:46:40 +0000
committerThierry Thomas <thierry@FreeBSD.org>2005-02-24 21:46:40 +0000
commit575cd613e9562c2ec6b0ed59444f0085451433b4 (patch)
treeea4d115ca79c203e4682909a6eeaf13e552f754a
parentb966078b4df05d3155633920de533a6ced3b1b47 (diff)
downloadports-575cd613e9562c2ec6b0ed59444f0085451433b4.tar.gz
ports-575cd613e9562c2ec6b0ed59444f0085451433b4.zip
Notes
-rw-r--r--databases/pear-DB/Makefile38
-rw-r--r--databases/pear-DB/distinfo4
-rw-r--r--databases/pear-DB/pkg-descr19
3 files changed, 31 insertions, 30 deletions
diff --git a/databases/pear-DB/Makefile b/databases/pear-DB/Makefile
index cbbf938f8c79..0cf56ef9f1cc 100644
--- a/databases/pear-DB/Makefile
+++ b/databases/pear-DB/Makefile
@@ -6,34 +6,34 @@
#
PORTNAME= DB
-PORTVERSION= 1.6.5
+PORTVERSION= 1.6.8
PORTEPOCH= 1
CATEGORIES= databases www pear
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= antonio@php.net
COMMENT= PEAR Database Abstraction Layer
BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear-PEAR
RUN_DEPENDS= ${BUILD_DEPENDS}
-FILES= DB.php DB/common.php DB/dbase.php DB/fbsql.php \
- DB/ibase.php DB/ifx.php DB/msql.php DB/mssql.php \
- DB/mysql.php DB/mysqli.php DB/oci8.php DB/odbc.php DB/pgsql.php \
- DB/sqlite.php DB/storage.php DB/sybase.php
+FILES= DB.php DB/common.php DB/dbase.php DB/fbsql.php DB/ibase.php \
+ DB/ifx.php DB/msql.php DB/mssql.php DB/mysql.php DB/mysqli.php \
+ DB/oci8.php DB/odbc.php DB/pgsql.php DB/sybase.php DB/storage.php \
+ DB/sqlite.php
DOCS= IDEAS MAINTAINERS STATUS TESTERS
-TESTS= db_error.phpt db_error2.phpt db_factory.phpt db_ismanip.phpt \
- db_parsedsn.phpt errors.inc fetchmode_object.inc fetchmodes.inc \
- include.inc limit.inc numcols.inc numrows.inc prepexe.inc \
- run.cvs sequences.inc simplequery.inc transactions.inc \
- skipif.inc driver/01connect.phpt driver/02fetch.phpt \
- driver/03simplequery.phpt driver/04numcols.phpt \
- driver/05sequences.phpt driver/06prepexec.phpt \
- driver/08affectedrows.phpt driver/09numrows.phpt \
- driver/10errormap.phpt driver/11transactions.phpt \
- driver/13limit.phpt driver/14fetchmode_object.phpt \
- driver/15quote.phpt driver/16tableinfo.phpt driver/17query.phpt \
- driver/18get.phpt driver/bug22328.phpt driver/connect.inc \
- driver/mktable.inc driver/run.cvs driver/setup.inc.cvs \
+TESTS= db_error.phpt db_parsedsn.phpt db_factory.phpt db_ismanip.phpt \
+ db_error2.phpt errors.inc fetchmode_object.inc fetchmodes.inc \
+ include.inc limit.inc numcols.inc numrows.inc prepexe.inc \
+ run.cvs sequences.inc simplequery.inc transactions.inc \
+ skipif.inc driver/01connect.phpt driver/02fetch.phpt \
+ driver/03simplequery.phpt driver/04numcols.phpt \
+ driver/05sequences.phpt driver/06prepexec.phpt \
+ driver/08affectedrows.phpt driver/09numrows.phpt \
+ driver/10errormap.phpt driver/11transactions.phpt \
+ driver/13limit.phpt driver/14fetchmode_object.phpt \
+ driver/15quote.phpt driver/16tableinfo.phpt driver/17query.phpt \
+ driver/18get.phpt driver/bug22328.phpt driver/connect.inc \
+ driver/mktable.inc driver/run.cvs driver/setup.inc.cvs \
driver/skipif.inc
_DOCSDIR= doc
diff --git a/databases/pear-DB/distinfo b/databases/pear-DB/distinfo
index 9fdc679f4e53..7b910c91e42c 100644
--- a/databases/pear-DB/distinfo
+++ b/databases/pear-DB/distinfo
@@ -1,2 +1,2 @@
-MD5 (PEAR/DB-1.6.5.tgz) = fb62ce9e84f48110304638816ad1b01b
-SIZE (PEAR/DB-1.6.5.tgz) = 92741
+MD5 (PEAR/DB-1.6.8.tgz) = 7f67e1fd3b68d0468e7f665bfd998a1c
+SIZE (PEAR/DB-1.6.8.tgz) = 92460
diff --git a/databases/pear-DB/pkg-descr b/databases/pear-DB/pkg-descr
index 7e345ddfd5c4..531e7fdb72e6 100644
--- a/databases/pear-DB/pkg-descr
+++ b/databases/pear-DB/pkg-descr
@@ -1,21 +1,22 @@
PEAR::DB is a database abstraction layer providing:
* an OO-style query API
+* portability features that make programs written for one DBMS work with other
+DBMS's
* a DSN (data source name) format for specifying database servers
* prepare/execute (bind) emulation for databases that don't support it natively
* a result object for each query response
* portable error codes
* sequence emulation
-* sequential and non sequential row fetching as well as bulk fetching
-* ordered array, associative array and object formats supported for the fetched
- rows
+* sequential and non-sequential row fetching as well as bulk fetching
+* formats fetched rows as associative arrays, ordered arrays or objects
* row limit support
* transactions support
* table information interface
-* DocBook and PHPDoc API documentation
+* DocBook and phpDocumentor API documentation
-DB layers itself on top of PHP's existing database extensions. The currently
-supported extensions are: dbase, fbsql, interbase, informix, msql, mssql,
-mysql, oci8, odbc, pgsql and sybase (DB style interfaces to LDAP servers and
-MS ADO (using COM) are also avaible from a separate package).
+Drivers for the following extensions pass the complete test suite and provide
+interchangeability when all of DB's portability options are enabled: fbsql,
+ibase, informix, msql, mssql, mysql, mysqli, oci8, odbc, pgsql, sqlite and
+sybase.
-WWW: http://pear.php.net/package/DB
+WWW: http://pear.php.net/package/DB/