aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2010-06-07 11:18:02 +0000
committerRenato Botelho <garga@FreeBSD.org>2010-06-07 11:18:02 +0000
commit5ab73a670411e79a112697902db4b71dd6f20df0 (patch)
treed1acbc8670754aad0f755bce27b4c1d3e438521c
parent5c532bfe19123ce94f23cdffa9891ba9b05e7805 (diff)
downloadports-5ab73a670411e79a112697902db4b71dd6f20df0.tar.gz
ports-5ab73a670411e79a112697902db4b71dd6f20df0.zip
Notes
-rw-r--r--www/Makefile1
-rw-r--r--www/thundersnarf/Makefile69
-rw-r--r--www/thundersnarf/distinfo3
-rw-r--r--www/thundersnarf/files/pkg-message.in11
-rw-r--r--www/thundersnarf/pkg-descr8
-rw-r--r--www/thundersnarf/pkg-plist6
6 files changed, 98 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 74cdce0c2c27..a9853c12314f 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1627,6 +1627,7 @@
SUBDIR += thttpd
SUBDIR += thumbnail_index
SUBDIR += thundercache
+ SUBDIR += thundersnarf
SUBDIR += tidy
SUBDIR += tidy-devel
SUBDIR += tidy-lib
diff --git a/www/thundersnarf/Makefile b/www/thundersnarf/Makefile
new file mode 100644
index 000000000000..f0b0cef26f68
--- /dev/null
+++ b/www/thundersnarf/Makefile
@@ -0,0 +1,69 @@
+# New ports collection makefile for: thundersnarf
+# Date created: 2010-05-20
+# Whom: Patrick Tracanelli <eksffa@freebsdbrasil.com.br>
+#
+# $FreeBSD$
+#
+
+PORTNAME= thundersnarf
+PORTVERSION= 1.0b
+CATEGORIES= www
+MASTER_SITES= http://www6.freebsdbrasil.com.br/~eksffa/l/dev/thunder/ \
+ ${MASTER_SITE_LOCAL}/jmelo
+
+MAINTAINER= eksffa@freebsdbrasil.com.br
+COMMENT= Web reporting and trending analysis for Thunder Cache Pro
+
+OPTIONS= APACHE "Install apache for reporting viewing" on \
+ PHP "Install PHP for reporting generating" on \
+ PGSQL "Install PostgreSQL (report data storing)" on
+
+USE_BZIP2= yes
+
+NO_BUILD= yes
+WRKSRC= ${WRKDIR}/${PORTNAME:R}
+
+MANUAL_PACKAGE_BUILD= This port wants PGSQL 8.4, but 8.2 is default and used to build php5-pgsql dependency.
+
+.include <bsd.port.pre.mk>
+
+.if defined (WITH_APACHE)
+USE_APACHE= 2.0+
+.endif
+
+.if defined (WITH_PGSQL)
+USE_PGSQL= yes
+WANT_PGSQL_VER= 84
+RUN_DEPENDS+= postgresql-server>=0:${PORTSDIR}/databases/postgresql${PGSQL_VER}-server
+.endif
+
+.if defined(WITH_PHP) && defined(WITH_PGSQL)
+RUN_DEPENDS+= ${LOCALBASE}/lib/php/${PHP_EXT_DIR}/pdo_pgsql.so:${PORTSDIR}/databases/php5-pdo_pgsql
+.endif
+
+.if defined(WITH_PHP)
+USE_PHP+= curl pcre bcmath pdo mcrypt mhash session pgsql spl dom xmlrpc ctype
+.endif
+
+LIB_DEPENDS+= curl.6:${PORTSDIR}/ftp/curl:install
+
+SUB_FILES= pkg-message
+
+do-install:
+ @${CP} -R ${WRKSRC} ${WWWDIR}
+ @${INSTALL_SCRIPT} -m 555 ${WRKSRC}/protected/data/bin/thundersnarf ${PREFIX}/bin/
+ @${INSTALL_SCRIPT} -m 555 ${WRKSRC}/protected/data/bin/thundersnarf-poll ${PREFIX}/bin/
+ @${CHGRP} -R ${WWWGRP} ${WWWDIR}/protected/runtime \
+ ${WWWDIR}/assets
+ @${CHMOD} -R g+rwx ${WWWDIR}/protected/runtime \
+ ${WWWDIR}/assets
+
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${CP} -Rv ${WRKSRC}/README ${DOCSDIR}/README.pt_BR
+.endif
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/www/thundersnarf/distinfo b/www/thundersnarf/distinfo
new file mode 100644
index 000000000000..5b885b617e6e
--- /dev/null
+++ b/www/thundersnarf/distinfo
@@ -0,0 +1,3 @@
+MD5 (thundersnarf-1.0b.tar.bz2) = 3b45d927a7538bdfd449e43c80d9f069
+SHA256 (thundersnarf-1.0b.tar.bz2) = 8febf4f21d9155f24261836625c6b9f87650c312b64b8f70e7b671c4fed33241
+SIZE (thundersnarf-1.0b.tar.bz2) = 1875667
diff --git a/www/thundersnarf/files/pkg-message.in b/www/thundersnarf/files/pkg-message.in
new file mode 100644
index 000000000000..2452d4406a8f
--- /dev/null
+++ b/www/thundersnarf/files/pkg-message.in
@@ -0,0 +1,11 @@
+
+If you haven't setup your PostgreSQL server, set it up accordingly and create
+snortsnarf's database:
+
+%%PREFIX%%/bin/psql postgres -U pgsql < \
+ %%WWWDIR%%/protected/data/db/pg_thundersnarf.sql
+
+Run Thunder Snarf from /etc/crontab. Schedule it according to your machine
+load availability, for example:
+
+*/20 * * * * root %%PREFIX%%/bin/thundersnarf >/dev/null 2>&1
diff --git a/www/thundersnarf/pkg-descr b/www/thundersnarf/pkg-descr
new file mode 100644
index 000000000000..b816d79a39b0
--- /dev/null
+++ b/www/thundersnarf/pkg-descr
@@ -0,0 +1,8 @@
+ThunderSnarf is a web reporting and trending tool for Thunder Cache Pro which
+has the main goal to provide a strategic overview of how Thunder is caching and
+what it is caching, aggregating value and helping on decision making regarding
+the real web acceleration rates and allowing one to identify unefficient cache
+patterns, plugins, as well as domains which should have a plugin written for
+and, off course, the top efficient domains and caching patterns as well.
+
+WWW: http://www.thundercache.com.br
diff --git a/www/thundersnarf/pkg-plist b/www/thundersnarf/pkg-plist
new file mode 100644
index 000000000000..7c0b8caf03a2
--- /dev/null
+++ b/www/thundersnarf/pkg-plist
@@ -0,0 +1,6 @@
+bin/thundersnarf
+bin/thundersnarf-poll
+%%DOCSDIR%%/README.pt_BR
+@dirrm %%DOCSDIR%%
+@unexec echo "completely uninstalling %D/%%WWWDIR%%"
+@unexec /bin/rm -rf %D/%%WWWDIR%% 2>/dev/null || true