aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlli Hauer <ohauer@FreeBSD.org>2013-08-28 05:05:06 +0000
committerOlli Hauer <ohauer@FreeBSD.org>2013-08-28 05:05:06 +0000
commit65b27fc45a67ae4476d0c980124105e5528a1783 (patch)
tree1e751b3c701eb3c44a93fafe994febbe5d758984
parent9fc865efdb71436705f56a0c6b3b5f853b47197a (diff)
downloadports-65b27fc45a67ae4476d0c980124105e5528a1783.tar.gz
ports-65b27fc45a67ae4476d0c980124105e5528a1783.zip
Notes
-rw-r--r--www/mod_fcgid/Makefile9
-rw-r--r--www/mod_fcgid/distinfo4
-rw-r--r--www/mod_fcgid/files/patch-modules-fcgid-fcgid_spawn_ctl.c17
3 files changed, 6 insertions, 24 deletions
diff --git a/www/mod_fcgid/Makefile b/www/mod_fcgid/Makefile
index 71b692925983..27fa006f4348 100644
--- a/www/mod_fcgid/Makefile
+++ b/www/mod_fcgid/Makefile
@@ -2,16 +2,15 @@
# $FreeBSD$
PORTNAME= mod_fcgid
-PORTVERSION= 2.3.6
-PORTREVISION= 1
+PORTVERSION= 2.3.7
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_APACHE_HTTPD}
MASTER_SITE_SUBDIR= ${PORTNAME}
PKGNAMEPREFIX= ${APACHE_PKGNAMEPREFIX}
+DIST_SUBDIR= apache2
-MAINTAINER= hemi@puresimplicity.net
-COMMENT= An alternative FastCGI module for Apache2
-
+MAINTAINER= freebsd.ports@webstyle.ch
+COMMENT= Alternative FastCGI module for Apache2
USE_APACHE= 22+
diff --git a/www/mod_fcgid/distinfo b/www/mod_fcgid/distinfo
index c735627edad1..041200b74e61 100644
--- a/www/mod_fcgid/distinfo
+++ b/www/mod_fcgid/distinfo
@@ -1,2 +1,2 @@
-SHA256 (mod_fcgid-2.3.6.tar.gz) = e831795498d91cf27a519ea1332c2a92a2a9920b0844d817b2ea7f079056d12b
-SIZE (mod_fcgid-2.3.6.tar.gz) = 101883
+SHA256 (apache2/mod_fcgid-2.3.7.tar.gz) = b72810cb34942945156f29ce60946da7dc941bb4cfca8b9d224573535bd8ef6d
+SIZE (apache2/mod_fcgid-2.3.7.tar.gz) = 104818
diff --git a/www/mod_fcgid/files/patch-modules-fcgid-fcgid_spawn_ctl.c b/www/mod_fcgid/files/patch-modules-fcgid-fcgid_spawn_ctl.c
deleted file mode 100644
index 1b9304f6487c..000000000000
--- a/www/mod_fcgid/files/patch-modules-fcgid-fcgid_spawn_ctl.c
+++ /dev/null
@@ -1,17 +0,0 @@
-#
-# Fix regression in 2.3.6 which broke process controls when using vhost-
-# specific configuration.
-#
-Index: modules/fcgid/fcgid_spawn_ctl.c
-===================================================================
---- modules/fcgid/fcgid_spawn_ctl.c (revision 1037726)
-+++ modules/fcgid/fcgid_spawn_ctl.c (revision 1037727)
-@@ -178,7 +178,7 @@
- if (current_node->inode == command->inode
- && current_node->deviceid == command->deviceid
- && !strcmp(current_node->cmdline, command->cmdline)
-- && current_node->vhost_id == sconf->vhost_id
-+ && current_node->vhost_id == command->vhost_id
- && current_node->uid == command->uid
- && current_node->gid == command->gid)
- break;