aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKyle Evans <kevans@FreeBSD.org>2020-03-18 01:58:08 +0000
committerKyle Evans <kevans@FreeBSD.org>2020-03-18 01:58:08 +0000
commit68e0c8c52a98b8b3837cf34aa9986176ddddcf79 (patch)
treed24735d3f5cb9b396da8f1fdd260364e9386d96e
parentbab5719cdd352d46866ae482aef91eef51e6ebfa (diff)
downloadports-68e0c8c52a98b8b3837cf34aa9986176ddddcf79.tar.gz
ports-68e0c8c52a98b8b3837cf34aa9986176ddddcf79.zip
MFH: r528547
sysutils/u-boot-rpi{3,4}: Add patch to fix PSCI stub reservation For the traditional spin table setup, only the lowest page needs to be reserved. However, our PSCI stubs are slightly bigger and occupy a little over one page. These patches, already sent upstream, allow a variable number of initial pages to be reserved for the SMP stubs. We then set the values for these in our fragment to '2' to reserve the first and second page. Approved by: koobs (mentor) Approved by: manu (uboot, maintainer) Differential Revision: https://reviews.freebsd.org/D24085 Approved by: ports-secteam (joneum)
Notes
Notes: svn path=/branches/2020Q1/; revision=528622
-rw-r--r--sysutils/u-boot-master/distinfo6
-rw-r--r--sysutils/u-boot-rpi3/Makefile4
-rw-r--r--sysutils/u-boot-rpi3/files/rpi3_fragment1
-rw-r--r--sysutils/u-boot-rpi4/Makefile4
-rw-r--r--sysutils/u-boot-rpi4/files/rpi4_fragment1
5 files changed, 15 insertions, 1 deletions
diff --git a/sysutils/u-boot-master/distinfo b/sysutils/u-boot-master/distinfo
index 7774e276126c..04ddabc5f4ba 100644
--- a/sysutils/u-boot-master/distinfo
+++ b/sysutils/u-boot-master/distinfo
@@ -1,4 +1,4 @@
-TIMESTAMP = 1573202420
+TIMESTAMP = 1584323217
SHA256 (u-boot/u-boot-2019.10.tar.bz2) = 8d6d6070739522dd236cba7055b8736bfe92b4fac0ea18ad809829ca79667014
SIZE (u-boot/u-boot-2019.10.tar.bz2) = 14214608
SHA256 (u-boot/939129/raw) = 2a4ebf283aec8e74ec77b3cb071c6883f73807454ca94fea78361c7391187b97
@@ -23,3 +23,7 @@ SHA256 (u-boot/1189497/raw) = 3c433ddf46b8c64f56a9699aeead85954d922e5fcfad52a7bf
SIZE (u-boot/1189497/raw) = 2241
SHA256 (u-boot/1189495/raw) = ad1233a1da6171b83936e422c67467a54559364cc426d6804d20d425949a933d
SIZE (u-boot/1189495/raw) = 3918
+SHA256 (u-boot/1245351/raw) = 02cec0ca1934ba64d010ec7f0453faa127b19aaae679d6bd9b946a3653837434
+SIZE (u-boot/1245351/raw) = 707
+SHA256 (u-boot/1245352/raw) = a4f48937cd9403b7f7708ba1fc5b9405da97bdedff25fdeb198ab613294e7d45
+SIZE (u-boot/1245352/raw) = 465
diff --git a/sysutils/u-boot-rpi3/Makefile b/sysutils/u-boot-rpi3/Makefile
index 867657cce3de..1fae2cd36d1a 100644
--- a/sysutils/u-boot-rpi3/Makefile
+++ b/sysutils/u-boot-rpi3/Makefile
@@ -2,8 +2,12 @@
MASTERDIR= ${.CURDIR}/../u-boot-master
+U_BOOT_SLAVE_PORTREVISION_2019.10= 1
+
EXTRA_PATCHES= ${.CURDIR}/files/
PATCHFILES+= 939129/raw
+# Allow variable reservation of lowest pages for increased PSCI stub size.
+PATCHFILES+= 1245351/raw 1245352/raw
MODEL= rpi3
BOARD_CONFIG= rpi_3_defconfig
diff --git a/sysutils/u-boot-rpi3/files/rpi3_fragment b/sysutils/u-boot-rpi3/files/rpi3_fragment
index af01102588ee..1dbf430f1931 100644
--- a/sysutils/u-boot-rpi3/files/rpi3_fragment
+++ b/sysutils/u-boot-rpi3/files/rpi3_fragment
@@ -1,3 +1,4 @@
CONFIG_OF_EMBED=n
CONFIG_OF_BOARD=y
CONFIG_ENV_FAT_DEVICE_AND_PART="1:1"
+CONFIG_RPI_EFI_NR_SPIN_PAGES=2
diff --git a/sysutils/u-boot-rpi4/Makefile b/sysutils/u-boot-rpi4/Makefile
index e2e7dedea6ca..58583630e7f3 100644
--- a/sysutils/u-boot-rpi4/Makefile
+++ b/sysutils/u-boot-rpi4/Makefile
@@ -2,12 +2,16 @@
MASTERDIR= ${.CURDIR}/../u-boot-master
+U_BOOT_SLAVE_PORTREVISION_2019.10= 1
+
EXTRA_PATCHES= ${.CURDIR}/files/
PATCHFILES+= 939129/raw
# Updated libfdt, pre-req to the next set
PATCHFILES+= 1137331/raw 1137330/raw
# Fix memory bank issues
PATCHFILES+= 1189494/raw 1189493/raw 1189497/raw 1189495/raw
+# Allow variable reservation of lowest pages for increased PSCI stub size.
+PATCHFILES+= 1245351/raw 1245352/raw
MODEL= rpi4
BOARD_CONFIG= rpi_4_defconfig
diff --git a/sysutils/u-boot-rpi4/files/rpi4_fragment b/sysutils/u-boot-rpi4/files/rpi4_fragment
index 1c909d3e8d2c..7a61bd18844a 100644
--- a/sysutils/u-boot-rpi4/files/rpi4_fragment
+++ b/sysutils/u-boot-rpi4/files/rpi4_fragment
@@ -1 +1,2 @@
CONFIG_ENV_FAT_DEVICE_AND_PART="1:1"
+CONFIG_RPI_EFI_NR_SPIN_PAGES=2