aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Nottebrock <lofi@FreeBSD.org>2004-02-18 12:33:12 +0000
committerMichael Nottebrock <lofi@FreeBSD.org>2004-02-18 12:33:12 +0000
commit6f9df5a38ec9ecc1b817733f86180ec416290b4d (patch)
tree3bb4dcdd59ca3b172c6327c9874f9751659efceb
parentdfcbc367555d4dc640f2315ca7272146d9e5ba2d (diff)
downloadports-6f9df5a38ec9ecc1b817733f86180ec416290b4d.tar.gz
ports-6f9df5a38ec9ecc1b817733f86180ec416290b4d.zip
Notes
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/dcraw/Makefile23
-rw-r--r--graphics/dcraw/distinfo2
-rw-r--r--graphics/dcraw/files/patch-dcraw.c10
-rw-r--r--graphics/dcraw/pkg-descr11
5 files changed, 47 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 88e23df809a5..1643b8cb00ea 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -39,6 +39,7 @@
SUBDIR += dc20ctrl
SUBDIR += dc20pack
SUBDIR += dc3play
+ SUBDIR += dcraw
SUBDIR += deep_zoom
SUBDIR += dia
SUBDIR += diacanvas
diff --git a/graphics/dcraw/Makefile b/graphics/dcraw/Makefile
new file mode 100644
index 000000000000..dd6b37fb8a54
--- /dev/null
+++ b/graphics/dcraw/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: dcraw
+# Date created: 14 February 2004
+# Whom: Arjan van Leeuwen <avleeuwen@piwebs.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= dcraw
+PORTVERSION= 1.166
+CATEGORIES= graphics
+MASTER_SITES= http://people.fruitsalad.org/avleeuwen/distfiles/${PORTNAME}/
+
+MAINTAINER= avleeuwen@piwebs.com
+COMMENT= Decoder for RAW files from digital cameras
+
+PLIST_FILES= bin/dcraw
+
+.include <bsd.port.pre.mk>
+
+do-install::
+ ${INSTALL_PROGRAM} ${WRKSRC}/dcraw ${PREFIX}/bin
+
+.include <bsd.port.post.mk>
diff --git a/graphics/dcraw/distinfo b/graphics/dcraw/distinfo
new file mode 100644
index 000000000000..269bafd8471b
--- /dev/null
+++ b/graphics/dcraw/distinfo
@@ -0,0 +1,2 @@
+MD5 (dcraw-1.166.tar.gz) = 370ffb53fa113410171d4f72e93a3acc
+SIZE (dcraw-1.166.tar.gz) = 40578
diff --git a/graphics/dcraw/files/patch-dcraw.c b/graphics/dcraw/files/patch-dcraw.c
new file mode 100644
index 000000000000..084224233e89
--- /dev/null
+++ b/graphics/dcraw/files/patch-dcraw.c
@@ -0,0 +1,10 @@
+--- dcraw.c.orig Tue Feb 17 10:58:29 2004
++++ dcraw.c Tue Feb 17 10:59:27 2004
+@@ -53,7 +53,6 @@
+ #endif
+
+ typedef unsigned char uchar;
+-typedef unsigned short ushort;
+
+ /* Global Variables */
+
diff --git a/graphics/dcraw/pkg-descr b/graphics/dcraw/pkg-descr
new file mode 100644
index 000000000000..215905b1673b
--- /dev/null
+++ b/graphics/dcraw/pkg-descr
@@ -0,0 +1,11 @@
+dcraw is an ANSI C program that decodes any raw image from any digital camera
+on any computer running any operating system. It's become a standard tool
+within and without the Open Source world. It's small (about 3000 lines),
+portable (standard C libraries only), free (both "gratis" and "libre"), and
+when used skillfully, produces better-quality output than the tools provided by
+the camera vendor.
+
+WWW: http://www.cybercom.net/~dcoffin/dcraw/
+
+- Arjan
+avleeuwen@piwebs.com