aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVasil Dimov <vd@FreeBSD.org>2006-02-09 14:59:10 +0000
committerVasil Dimov <vd@FreeBSD.org>2006-02-09 14:59:10 +0000
commit72c8e7cbb251d53ec5df8beec37821169b963581 (patch)
treecad023aca0cd3e5b96316220dc6837b920ff4e9e
parentb775c0abecdfd51fa88291ff0ce000277ea3e0a6 (diff)
downloadports-72c8e7cbb251d53ec5df8beec37821169b963581.tar.gz
ports-72c8e7cbb251d53ec5df8beec37821169b963581.zip
Notes
-rw-r--r--textproc/libextractor/Makefile21
-rw-r--r--textproc/libextractor/distinfo6
-rw-r--r--textproc/libextractor/pkg-plist1
3 files changed, 20 insertions, 8 deletions
diff --git a/textproc/libextractor/Makefile b/textproc/libextractor/Makefile
index b0784612d47d..09c497ea062f 100644
--- a/textproc/libextractor/Makefile
+++ b/textproc/libextractor/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= libextractor
-PORTVERSION= 0.5.7
+PORTVERSION= 0.5.9
CATEGORIES= textproc
MASTER_SITES= http://gnunet.org/libextractor/download/ \
${MASTER_SITE_GNU}
@@ -15,10 +15,10 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= kevlo@FreeBSD.org
COMMENT= Library for keyword extraction
+USE_GCC= 3.4+
USE_GNOME= glib20
USE_PYTHON= yes
-USE_REINPLACE= yes
-USE_AUTOTOOLS= libtool:15 libltdl
+USE_AUTOTOOLS= libtool:15:inc libltdl:15
INSTALLS_SHLIB= yes
CONFIGURE_ARGS= --disable-ltdl-install
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
@@ -36,9 +36,13 @@ post-extract:
post-patch:
@${FIND} ${WRKSRC} -type f | ${XARGS} ${TOUCH} -f
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' \
- ${WRKSRC}/src/plugins/Makefile.*
+ ${WRKSRC}/src/plugins/Makefile.* \
+ ${WRKSRC}/src/plugins/exiv2/Makefile.* \
+ ${WRKSRC}/src/plugins/rpm/Makefile.*
@${REINPLACE_CMD} -e 's|-lc_r|${PTHREAD_LIBS}|g' \
${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|^#ifdef EXV_HAVE_STDINT_H$$|#if EXV_HAVE_STDINT_H|' \
+ ${WRKSRC}/src/plugins/exiv2/types.hpp
check: build
@(cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} check)
@@ -59,4 +63,13 @@ PLIST_SUB+= VORBIS:=""
PLIST_SUB+= VORBIS:="@comment "
.endif
+patch-autotools::
+ @(cd ${PATCH_WRKSRC}; \
+ for file in ${LIBTOOLFILES}; do \
+ ${CP} $$file $$file.tmp; \
+ ${SED} -e "/^ltmain=/s^\$$ac_aux_dir/ltmain.sh^${LTMAIN}^g" \
+ $$file.tmp > $$file; \
+ ${RM} $$file.tmp; \
+ done);
+
.include <bsd.port.post.mk>
diff --git a/textproc/libextractor/distinfo b/textproc/libextractor/distinfo
index 2ffbca3cbd73..8d7c60660632 100644
--- a/textproc/libextractor/distinfo
+++ b/textproc/libextractor/distinfo
@@ -1,3 +1,3 @@
-MD5 (libextractor-0.5.7.tar.gz) = fe08d8f9473fcea6963afcb3d7e858c4
-SHA256 (libextractor-0.5.7.tar.gz) = 680d6a48af9aadaec82a30f4cb6344464c35e15a5eeb10e7481312e971265594
-SIZE (libextractor-0.5.7.tar.gz) = 6127292
+MD5 (libextractor-0.5.9.tar.gz) = 21c22bf2653a3200968417d6642b6662
+SHA256 (libextractor-0.5.9.tar.gz) = 99a837dbe267d1d18267f9cdb5ee3b1583447c935765b32bb939a1c23edd2ea0
+SIZE (libextractor-0.5.9.tar.gz) = 6138887
diff --git a/textproc/libextractor/pkg-plist b/textproc/libextractor/pkg-plist
index d6b8faa5fa09..19e1160b4829 100644
--- a/textproc/libextractor/pkg-plist
+++ b/textproc/libextractor/pkg-plist
@@ -1,6 +1,5 @@
bin/extract
include/extractor.h
-lib/libextractor.a
lib/libextractor.so
lib/libextractor.so.2
lib/libextractor/libextractor_asf.so