aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2009-03-22 15:31:09 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2009-03-22 15:31:09 +0000
commit755c293dc37ac6a6538d47c4e79d2d397b151d8e (patch)
tree53c450325841c7ea4eb95a68564ec1a372dbec23
parente5e16bf6f6c667b1ee2dfcf79134be057ea854e0 (diff)
downloadports-755c293dc37ac6a6538d47c4e79d2d397b151d8e.tar.gz
ports-755c293dc37ac6a6538d47c4e79d2d397b151d8e.zip
Notes
-rw-r--r--games/crafty-open-enormous/Makefile5
-rw-r--r--games/crafty-open-large/Makefile6
-rw-r--r--games/crafty-open-medium/Makefile6
-rw-r--r--games/crafty/Makefile17
-rw-r--r--games/crafty/pkg-plist2
5 files changed, 26 insertions, 10 deletions
diff --git a/games/crafty-open-enormous/Makefile b/games/crafty-open-enormous/Makefile
index 69d8604435c5..6d1ae271d8bb 100644
--- a/games/crafty-open-enormous/Makefile
+++ b/games/crafty-open-enormous/Makefile
@@ -7,13 +7,14 @@
PORTNAME= crafty-open-enormous
PORTVERSION= 20070924
+PORTREVISION= 1
CATEGORIES= games
MASTER_SITES= ftp://ftp.cis.uab.edu/pub/hyatt/pgn/ \
${MASTER_SITE_LOCAL}
DISTFILES= enormous.zip
EXTRACT_ONLY= ${DISTFILES}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= flo@kasimir.com
COMMENT= The enormous opening book (about 85-90 MByte) for crafty
BUILD_DEPENDS= crafty:${PORTSDIR}/games/crafty
@@ -23,7 +24,7 @@ DIST_SUBDIR= crafty
USE_ZIP= yes
NO_WRKSUBDIR= yes
NO_PACKAGE= Package is way too big
-CONFLICTS= crafty-open-large-* crafty-open-medium-*
+CONFLICTS= crafty-open-large-* crafty-open-medium-* crafty-open-default-*
.include <bsd.port.pre.mk>
diff --git a/games/crafty-open-large/Makefile b/games/crafty-open-large/Makefile
index c03b0fdc89db..0c2a94986a20 100644
--- a/games/crafty-open-large/Makefile
+++ b/games/crafty-open-large/Makefile
@@ -7,13 +7,13 @@
PORTNAME= crafty-open-large
PORTVERSION= 20070909
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= dd/crafty
DISTFILES= large1.zip large2.zip large3.zip large4.zip
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= flo@kasimir.com
COMMENT= The large opening book for crafty
BUILD_DEPENDS= crafty:${PORTSDIR}/games/crafty
@@ -22,7 +22,7 @@ RUN_DEPENDS= crafty:${PORTSDIR}/games/crafty
DIST_SUBDIR= crafty
USE_ZIP= yes
NO_WRKSUBDIR= yes
-CONFLICTS= crafty-open-enormous-* crafty-open-medium-*
+CONFLICTS= crafty-open-enormous-* crafty-open-medium-* crafty-open-default-*
post-extract:
@${ECHO_MSG} '================================================================'
diff --git a/games/crafty-open-medium/Makefile b/games/crafty-open-medium/Makefile
index de1fd6de5d1f..087e69efe7e0 100644
--- a/games/crafty-open-medium/Makefile
+++ b/games/crafty-open-medium/Makefile
@@ -7,13 +7,13 @@
PORTNAME= crafty-open-medium
PORTVERSION= 20070909
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= dd/crafty
DISTNAME= medium
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= flo@kasimir.com
COMMENT= The medium opening book (about 1.9 MByte) for crafty
BUILD_DEPENDS= crafty:${PORTSDIR}/games/crafty
@@ -22,7 +22,7 @@ RUN_DEPENDS= crafty:${PORTSDIR}/games/crafty
DIST_SUBDIR= crafty
USE_ZIP= yes
NO_WRKSUBDIR= yes
-CONFLICTS= crafty-open-enormous-* crafty-open-large-*
+CONFLICTS= crafty-open-enormous-* crafty-open-large-* crafty-open-default-*
do-build:
@${ECHO_MSG} '================================================================'
diff --git a/games/crafty/Makefile b/games/crafty/Makefile
index fb66c8e7c5fa..db3013fc46d6 100644
--- a/games/crafty/Makefile
+++ b/games/crafty/Makefile
@@ -7,6 +7,7 @@
PORTNAME= crafty
PORTVERSION= 22.10
+PORTREVISION= 1
CATEGORIES= games
MASTER_SITES= ftp://ftp.cis.uab.edu/pub/hyatt/pgn/:data \
ftp://ftp.cis.uab.edu/pub/hyatt/documentation/:doc \
@@ -24,7 +25,7 @@ COMMENT= A chess programm for playing and analyzing games
USE_ZIP= yes
USE_GMAKE= yes
-BOOKS= book.bin books.bin
+BOOKS= books.bin
DISTFILES+= ${BOOKS:S/$/:books/}
.if !defined(NOPORTDOCS)
@@ -58,11 +59,23 @@ OPT+= -DINLINE32
BROKEN= Does not compile on sparc64
.endif
+.if defined(WITH_BOOK)
+BOOKS+= book.bin
+DISTFILES+= ${BOOKS:S/$/:books/}
+PKGNAMESUFFIX= -open-default
+CONFLICTS+= crafty-open-enormous-* crafty-open-large-* crafty-open-medium-*
+PLIST_SUB+= BOOK=""
+.else
+PLIST_SUB+= BOOK="@comment "
+.endif
+
MAKE_ENV+= opt="${OPT}" target=${OPSYS} CXFLAGS="${CXXFLAGS}"
post-extract:
${CP} ${DISTDIR}/${DIST_SUBDIR}/start.pgn ${WRKSRC}/start.pgn
+.if defined(WITH_BOOK)
${CP} ${DISTDIR}/${DIST_SUBDIR}/book.bin ${WRKSRC}/book.bin
+.endif
${CP} ${DISTDIR}/${DIST_SUBDIR}/books.bin ${WRKSRC}/books.bin
post-build:
@@ -75,7 +88,9 @@ do-install:
${MKDIR} ${PREFIX}/lib/crafty/cpf
${CHOWN} -R root:nogroup ${PREFIX}/lib/crafty
${CHMOD} 775 ${PREFIX}/lib/crafty ${PREFIX}/lib/crafty/cpf
+.if defined(WITH_BOOK)
${INSTALL_DATA} ${WRKSRC}/book.bin ${PREFIX}/lib/crafty/book.bin
+.endif
${INSTALL_DATA} ${WRKSRC}/books.bin ${PREFIX}/lib/crafty/books.bin
${INSTALL_DATA} ${WRKSRC}/crafty.hlp ${PREFIX}/lib/crafty/crafty.hlp
${CHOWN} root:nogroup ${PREFIX}/lib/crafty/book*
diff --git a/games/crafty/pkg-plist b/games/crafty/pkg-plist
index 9f4701ff5209..90289a6e013d 100644
--- a/games/crafty/pkg-plist
+++ b/games/crafty/pkg-plist
@@ -1,5 +1,5 @@
bin/crafty
-lib/crafty/book.bin
+%%BOOK%%lib/crafty/book.bin
lib/crafty/books.bin
lib/crafty/crafty.hlp
%%PORTDOCS%%share/doc/crafty/crafty.doc.ascii