aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiane Bruce <db@FreeBSD.org>2011-05-17 11:08:32 +0000
committerDiane Bruce <db@FreeBSD.org>2011-05-17 11:08:32 +0000
commit772fb240ec3c82ebd3bb08d52cf9a63a8a28fdcb (patch)
tree34232d7abd2914f509b635d269b3006e663aae23
parent1b784959fb79999b408789677957a35afc996c89 (diff)
downloadports-772fb240ec3c82ebd3bb08d52cf9a63a8a28fdcb.tar.gz
ports-772fb240ec3c82ebd3bb08d52cf9a63a8a28fdcb.zip
Notes
-rw-r--r--comms/qrq/Makefile2
-rw-r--r--comms/qrq/distinfo4
-rw-r--r--comms/qrq/files/patch-Makefile57
-rw-r--r--comms/qrq/pkg-plist3
4 files changed, 35 insertions, 31 deletions
diff --git a/comms/qrq/Makefile b/comms/qrq/Makefile
index 302ee08f0242..90b6661665ab 100644
--- a/comms/qrq/Makefile
+++ b/comms/qrq/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= qrq
-PORTVERSION= 0.1.4
+PORTVERSION= 0.2.0
CATEGORIES= comms hamradio
MASTER_SITES= http://fkurz.net/ham/qrq/ \
${MASTER_SITE_LOCAL}
diff --git a/comms/qrq/distinfo b/comms/qrq/distinfo
index 3a41d13d53ff..43bb22560272 100644
--- a/comms/qrq/distinfo
+++ b/comms/qrq/distinfo
@@ -1,2 +1,2 @@
-SHA256 (qrq-0.1.4.tar.gz) = 6c9bd2e3d5c1d06c6a84e910deeff3c1e7a7f2c4c0f0376ddfb11fa4855aff9a
-SIZE (qrq-0.1.4.tar.gz) = 95912
+SHA256 (qrq-0.2.0.tar.gz) = b2af16921700bb2dd00858d976d6ca169c45313c1d82ea83a00732dfe566ee94
+SIZE (qrq-0.2.0.tar.gz) = 112657
diff --git a/comms/qrq/files/patch-Makefile b/comms/qrq/files/patch-Makefile
index b78aad3b6a2b..44fe6adfcae9 100644
--- a/comms/qrq/files/patch-Makefile
+++ b/comms/qrq/files/patch-Makefile
@@ -1,43 +1,46 @@
---- Makefile.orig 2008-06-22 15:27:57.000000000 -0400
-+++ Makefile 2008-06-23 21:33:21.000000000 -0400
-@@ -1,7 +1,8 @@
+--- Makefile.orig 2011-05-07 17:00:51.000000000 -0400
++++ Makefile 2011-05-16 11:43:02.000000000 -0400
+@@ -1,14 +1,14 @@
# qrq Makefile -- Fabian Kurz, DJ1YFK -- http://fkurz.net/ham/qrq.html
- VERSION=0.1.4
+ VERSION=0.2.0
-DESTDIR?=/usr
-+DESTDIR=%%PREFIX%%
-+LDFLAGS+=%%PTHREAD_LIBS%%
++DESTDIR?=%%PREFIX%%
# set to YES if you want to use OpenAL instead of OSS
# note that you must use OpenAL for OSX
-@@ -38,13 +39,13 @@
+ USE_OPENAL=NO
+
+ # set to YES if you want to use PulseAudio instead of OSS
+-USE_PA=YES
++USE_PA=NO
+
+ # set to YES if building on OSX
+ OSX_PLATFORM=NO
+@@ -49,10 +49,10 @@
all: qrq
qrq: $(OBJECTS)
- g++ -pthread -Wall -lm -lncurses $(LDFLAGS) -o $@ $^
-+ g++ -Wall -lm -lncurses $(LDFLAGS) -o $@ $^
++ ${CC} -pthread -Wall -lm -lncurses $(LDFLAGS) -o $@ $^
.c.o:
-- gcc $(CFLAGS) -c $<
-+ $(CC) $(CFLAGS) -c $<
+- gcc -Wall $(CFLAGS) -c $<
++ ${CC} -Wall $(CFLAGS) -c $<
.cpp.o:
-- g++ $(CFLAGS) -c $<
-+ $(CPP) $(CFLAGS) -c $<
-
- ifeq ($(OSX_BUNDLE), YES)
-
-@@ -71,11 +72,11 @@
+ g++ $(CFLAGS) -c $<
+@@ -83,11 +83,11 @@
install: qrq
- install -d -v $(DESTDIR)/share/qrq/
-- install -d -v $(DESTDIR)/share/man/man1/
-+ install -d -v $(DESTDIR)/man/man1/
- install -d -v $(DESTDIR)/bin/
- install -s -m 0755 qrq $(DESTDIR)/bin/
- install -m 0755 qrqscore $(DESTDIR)/bin/
-- install -m 0644 qrq.1 $(DESTDIR)/share/man/man1/
-+ install -m 0644 qrq.1 $(DESTDIR)/man/man1/
- install -m 0644 callbase $(DESTDIR)/share/qrq/
- install -m 0644 qrqrc $(DESTDIR)/share/qrq/
- install -m 0644 toplist $(DESTDIR)/share/qrq/
+ install -d -v $(DESTDIR)/share/qrq/
+- install -d -v $(DESTDIR)/share/man/man1/
++ install -d -v $(DESTDIR)/man/man1/
+ install -d -v $(DESTDIR)/bin/
+ install -s -m 0755 qrq $(DESTDIR)/bin/
+ install -m 0755 qrqscore $(DESTDIR)/bin/
+- install -m 0644 qrq.1 $(DESTDIR)/share/man/man1/
++ install -m 0644 qrq.1 $(DESTDIR)/man/man1/
+ install -m 0644 callbase.qcb $(DESTDIR)/share/qrq/
+ install -m 0644 english.qcb $(DESTDIR)/share/qrq/
+ install -m 0644 qrqrc $(DESTDIR)/share/qrq/
diff --git a/comms/qrq/pkg-plist b/comms/qrq/pkg-plist
index 4ed0328be6a4..942a2c4eea61 100644
--- a/comms/qrq/pkg-plist
+++ b/comms/qrq/pkg-plist
@@ -1,6 +1,7 @@
bin/qrq
bin/qrqscore
-%%DATADIR%%/callbase
+%%DATADIR%%/callbase.qcb
+%%DATADIR%%/english.qcb
%%DATADIR%%/qrqrc
%%DATADIR%%/toplist
@dirrm %%DATADIR%%