aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEdward Tomasz Napierala <trasz@FreeBSD.org>2008-05-14 17:25:19 +0000
committerEdward Tomasz Napierala <trasz@FreeBSD.org>2008-05-14 17:25:19 +0000
commit7f671d2b95604a494c8004929ee0ec7c94d9ec06 (patch)
treec524ae82bc475ee944d2ac035b61d4195a71e17d
parent33a7f4da8ffeae1428279f3afe07f9c480a1aaf7 (diff)
downloadports-7f671d2b95604a494c8004929ee0ec7c94d9ec06.tar.gz
ports-7f671d2b95604a494c8004929ee0ec7c94d9ec06.zip
Notes
-rw-r--r--emulators/hercules/Makefile3
-rw-r--r--emulators/hercules/distinfo6
-rw-r--r--emulators/hercules/files/patch-20080506-cvs-endian.diff168
-rw-r--r--emulators/hercules/files/patch-tuntap23
-rw-r--r--emulators/hercules/files/patch-tuntap-sin_len90
-rw-r--r--emulators/hercules/files/patch-util-dasdlist36
-rw-r--r--emulators/hercules/pkg-descr2
-rw-r--r--emulators/hercules/pkg-plist3
8 files changed, 176 insertions, 155 deletions
diff --git a/emulators/hercules/Makefile b/emulators/hercules/Makefile
index c55d65e49336..a001d00793d8 100644
--- a/emulators/hercules/Makefile
+++ b/emulators/hercules/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= hercules
-PORTVERSION= 3.04
-PORTREVISION= 1
+PORTVERSION= 3.05
CATEGORIES= emulators
MASTER_SITES= http://www.hercules-390.org/
diff --git a/emulators/hercules/distinfo b/emulators/hercules/distinfo
index 23269a3f3310..14c0f4208ae9 100644
--- a/emulators/hercules/distinfo
+++ b/emulators/hercules/distinfo
@@ -1,3 +1,3 @@
-MD5 (hercules-3.04.tar.gz) = 7c7df7d52bf0365d5cbe051dc9e2e481
-SHA256 (hercules-3.04.tar.gz) = 4512a7c2b86b4a92c337c99761295aa4eaa54e90da3d0881c283b69c03b1eed5
-SIZE (hercules-3.04.tar.gz) = 2079774
+MD5 (hercules-3.05.tar.gz) = da8d85ac18c140b460574a0454abb936
+SHA256 (hercules-3.05.tar.gz) = f190221fa25692c0316be331f618c0675f9f9875c44b8af3efa7a431d138b1e2
+SIZE (hercules-3.05.tar.gz) = 2470621
diff --git a/emulators/hercules/files/patch-20080506-cvs-endian.diff b/emulators/hercules/files/patch-20080506-cvs-endian.diff
new file mode 100644
index 000000000000..4afac262d7c4
--- /dev/null
+++ b/emulators/hercules/files/patch-20080506-cvs-endian.diff
@@ -0,0 +1,168 @@
+Index: control.c
+===================================================================
+RCS file: /usr/cvs/hercules/hercules/control.c,v
+retrieving revision 1.266
+retrieving revision 1.267
+diff -u -p -r1.266 -r1.267
+--- control.c 11 Apr 2008 14:28:00 -0000 1.266
++++ control.c 6 May 2008 22:15:42 -0000 1.267
+@@ -1968,16 +1971,16 @@ U16 updated = 0;
+ m = n;
+
+ /* Copy from operand beginning */
+- for (i = 0; i < m; i++)
++ for (i = 0; i < m; i++, p1++)
+ {
+- regs->CR_L((r1 + i) & 0xF) = fetch_fw (p1++);
++ regs->CR_L((r1 + i) & 0xF) = fetch_fw (p1);
+ updated |= BIT((r1 + i) & 0xF);
+ }
+
+ /* Copy from next page */
+- for ( ; i < n; i++)
++ for ( ; i < n; i++, p2++)
+ {
+- regs->CR_L((r1 + i) & 0xF) = fetch_fw (p2++);
++ regs->CR_L((r1 + i) & 0xF) = fetch_fw (p2);
+ updated |= BIT((r1 + i) & 0xF);
+ }
+
+Index: esame.c
+===================================================================
+RCS file: /usr/cvs/hercules/hercules/esame.c,v
+retrieving revision 1.201
+retrieving revision 1.202
+diff -u -p -r1.201 -r1.202
+--- esame.c 11 Apr 2008 14:28:29 -0000 1.201
++++ esame.c 6 May 2008 22:15:42 -0000 1.202
+@@ -4038,8 +4041,8 @@ U32 *p1, *p2;
+ {
+ /* Boundary not crossed */
+ n >>= 2;
+- for (i = 0; i < n; i++)
+- regs->GR_H((r1 + i) & 0xF) = fetch_fw (p1++);
++ for (i = 0; i < n; i++, p1++)
++ regs->GR_H((r1 + i) & 0xF) = fetch_fw (p1);
+ }
+ else
+ {
+@@ -4052,11 +4055,11 @@ U32 *p1, *p2;
+ {
+ /* Addresses are word aligned */
+ m >>= 2;
+- for (i = 0; i < m; i++)
+- regs->GR_H((r1 + i) & 0xF) = fetch_fw (p1++);
++ for (i = 0; i < m; i++, p1++)
++ regs->GR_H((r1 + i) & 0xF) = fetch_fw (p1);
+ n >>= 2;
+- for ( ; i < n; i++)
+- regs->GR_H((r1 + i) & 0xF) = fetch_fw (p2++);
++ for ( ; i < n; i++, p2++)
++ regs->GR_H((r1 + i) & 0xF) = fetch_fw (p2);
+ }
+ else
+ {
+@@ -6728,16 +6731,16 @@ U32 *p1, *p2 = NULL;
+ m = n;
+
+ /* Load from first page */
+- for (i = 0; i < m; i++)
++ for (i = 0; i < m; i++, p1++)
+ {
+- regs->AR((r1 + i) & 0xF) = fetch_fw (p1++);
++ regs->AR((r1 + i) & 0xF) = fetch_fw (p1);
+ SET_AEA_AR(regs, (r1 + i) & 0xF);
+ }
+
+ /* Load from next page */
+- for ( ; i < n; i++)
++ for ( ; i < n; i++, p2++)
+ {
+- regs->AR((r1 + i) & 0xF) = fetch_fw (p2++);
++ regs->AR((r1 + i) & 0xF) = fetch_fw (p2);
+ SET_AEA_AR(regs, (r1 + i) & 0xF);
+ }
+
+@@ -6811,8 +6814,8 @@ U32 *p1, *p2;
+ {
+ /* Boundary not crossed */
+ n >>= 2;
+- for (i = 0; i < n; i++)
+- regs->GR_L((r1 + i) & 0xF) = fetch_fw (p1++);
++ for (i = 0; i < n; i++, p1++)
++ regs->GR_L((r1 + i) & 0xF) = fetch_fw (p1);
+ }
+ else
+ {
+@@ -6825,11 +6828,11 @@ U32 *p1, *p2;
+ {
+ /* Addresses are word aligned */
+ m >>= 2;
+- for (i = 0; i < m; i++)
+- regs->GR_L((r1 + i) & 0xF) = fetch_fw (p1++);
++ for (i = 0; i < m; i++, p1++)
++ regs->GR_L((r1 + i) & 0xF) = fetch_fw (p1);
+ n >>= 2;
+- for ( ; i < n; i++)
+- regs->GR_L((r1 + i) & 0xF) = fetch_fw (p2++);
++ for ( ; i < n; i++, p2++)
++ regs->GR_L((r1 + i) & 0xF) = fetch_fw (p2);
+ }
+ else
+ {
+Index: general1.c
+===================================================================
+RCS file: /usr/cvs/hercules/hercules/general1.c,v
+retrieving revision 1.165
+retrieving revision 1.166
+diff -u -p -r1.165 -r1.166
+--- general1.c 11 Apr 2008 14:28:44 -0000 1.165
++++ general1.c 6 May 2008 22:15:42 -0000 1.166
+@@ -3413,16 +3416,16 @@ U32 *p1, *p2 = NULL;
+ m = n;
+
+ /* Copy from operand beginning */
+- for (i = 0; i < m; i++)
++ for (i = 0; i < m; i++, p1++)
+ {
+- regs->AR((r1 + i) & 0xF) = fetch_fw (p1++);
++ regs->AR((r1 + i) & 0xF) = fetch_fw (p1);
+ SET_AEA_AR (regs, (r1 + i) & 0xF);
+ }
+
+ /* Copy from next page */
+- for ( ; i < n; i++)
++ for ( ; i < n; i++, p2++)
+ {
+- regs->AR((r1 + i) & 0xF) = fetch_fw (p2++);
++ regs->AR((r1 + i) & 0xF) = fetch_fw (p2);
+ SET_AEA_AR (regs, (r1 + i) & 0xF);
+ }
+
+@@ -3580,8 +3583,8 @@ U32 *p1, *p2;
+ {
+ /* Boundary not crossed */
+ n >>= 2;
+- for (i = 0; i < n; i++)
+- regs->GR_L((r1 + i) & 0xF) = fetch_fw (p1++);
++ for (i = 0; i < n; i++, p1++)
++ regs->GR_L((r1 + i) & 0xF) = fetch_fw (p1);
+ }
+ else
+ {
+@@ -3594,11 +3597,11 @@ U32 *p1, *p2;
+ {
+ /* Addresses are word aligned */
+ m >>= 2;
+- for (i = 0; i < m; i++)
+- regs->GR_L((r1 + i) & 0xF) = fetch_fw (p1++);
++ for (i = 0; i < m; i++, p1++)
++ regs->GR_L((r1 + i) & 0xF) = fetch_fw (p1);
+ n >>= 2;
+- for ( ; i < n; i++)
+- regs->GR_L((r1 + i) & 0xF) = fetch_fw (p2++);
++ for ( ; i < n; i++, p2++)
++ regs->GR_L((r1 + i) & 0xF) = fetch_fw (p2);
+ }
+ else
+ {
diff --git a/emulators/hercules/files/patch-tuntap b/emulators/hercules/files/patch-tuntap
index 15969cd93681..473d3580c2c6 100644
--- a/emulators/hercules/files/patch-tuntap
+++ b/emulators/hercules/files/patch-tuntap
@@ -1,26 +1,3 @@
---- ctc_ctci.c.orig Wed Dec 14 17:17:22 2005
-+++ ctc_ctci.c Wed Jan 25 20:05:14 2006
-@@ -1114,7 +1114,7 @@ static int ParseArgs( DEVBLK* pDEVBLK,
- #if defined( WIN32 )
- strcpy( pCTCBLK->szTUNCharName, tt32_get_default_iface() );
- #else
-- strcpy( pCTCBLK->szTUNCharName, "/dev/net/tun" );
-+ strcpy( pCTCBLK->szTUNCharName, HERCTUN_DEV );
- #endif
-
- #if defined( WIN32 )
---- ctc_lcs.c.orig Thu Dec 29 19:47:06 2005
-+++ ctc_lcs.c Wed Jan 25 20:05:14 2006
-@@ -1024,7 +1024,9 @@ static void LCS_Shutdown( PLCSDEV pLCSD
- static void LCS_StartLan( PLCSDEV pLCSDEV, PLCSHDR pHeader )
- {
- PLCSPORT pPort;
-+#ifdef OPTION_TUNTAP_DELADD_ROUTES
- PLCSRTE pRoute;
-+#endif
- PLCSSTDFRM pReply;
-
- pPort = &pLCSDEV->pLCSBLK->Port[pLCSDEV->bPort];
--- tuntap.c.orig Sun Dec 11 16:44:16 2005
+++ tuntap.c Wed Jan 25 20:05:14 2006
@@ -159,6 +159,25 @@ int TUNTAP_CreateInterface(
diff --git a/emulators/hercules/files/patch-tuntap-sin_len b/emulators/hercules/files/patch-tuntap-sin_len
deleted file mode 100644
index cb4be7f86241..000000000000
--- a/emulators/hercules/files/patch-tuntap-sin_len
+++ /dev/null
@@ -1,90 +0,0 @@
---- ./tuntap.c.orig Sun Apr 9 12:00:35 2006
-+++ ./tuntap.c Sun Apr 9 12:01:35 2006
-@@ -230,6 +230,7 @@ int TUNTAP_SetIPAddr( char*
- sin = (struct sockaddr_in*)&ifreq.ifr_addr;
-
- sin->sin_family = AF_INET;
-+ sin->sin_len = sizeof( struct sockaddr_in );
-
- if( !pszNetDevName || !*pszNetDevName )
- {
-@@ -266,6 +267,7 @@ int TUNTAP_SetDestAddr( char
- sin = (struct sockaddr_in*)&ifreq.ifr_addr;
-
- sin->sin_family = AF_INET;
-+ sin->sin_len = sizeof( struct sockaddr_in );
-
- if( !pszNetDevName || !*pszNetDevName )
- {
-@@ -302,6 +304,7 @@ int TUNTAP_SetNetMask( char*
- sin = (struct sockaddr_in*)&ifreq.ifr_netmask;
-
- sin->sin_family = AF_INET;
-+ sin->sin_len = sizeof( struct sockaddr_in );
-
- if( !pszNetDevName || !*pszNetDevName )
- {
-@@ -339,6 +342,7 @@ int TUNTAP_SetMTU( char* p
- sin = (struct sockaddr_in*)&ifreq.ifr_addr;
-
- sin->sin_family = AF_INET;
-+ sin->sin_len = sizeof( struct sockaddr_in );
-
- if( !pszNetDevName || !*pszNetDevName )
- {
-@@ -424,6 +428,7 @@ int TUNTAP_SetFlags ( char*
- sin = (struct sockaddr_in*)&ifreq.ifr_addr;
-
- sin->sin_family = AF_INET;
-+ sin->sin_len = sizeof( struct sockaddr_in );
-
- if( !pszNetDevName || !*pszNetDevName )
- {
-@@ -465,6 +470,7 @@ int TUNTAP_AddRoute( char* p
-
- sin = (struct sockaddr_in*)&rtentry.rt_dst;
- sin->sin_family = AF_INET;
-+ sin->sin_len = sizeof( struct sockaddr_in );
-
- if( !pszDestAddr ||
- !inet_aton( pszDestAddr, &sin->sin_addr ) )
-@@ -476,6 +482,7 @@ int TUNTAP_AddRoute( char* p
-
- sin = (struct sockaddr_in*)&rtentry.rt_genmask;
- sin->sin_family = AF_INET;
-+ sin->sin_len = sizeof( struct sockaddr_in );
-
- if( !pszNetMask ||
- !inet_aton( pszNetMask, &sin->sin_addr ) )
-@@ -489,6 +496,7 @@ int TUNTAP_AddRoute( char* p
- {
- sin = (struct sockaddr_in*)&rtentry.rt_gateway;
- sin->sin_family = AF_INET;
-+ sin->sin_len = sizeof( struct sockaddr_in );
-
- if( !inet_aton( pszGWAddr, &sin->sin_addr ) )
- {
-@@ -530,6 +538,7 @@ int TUNTAP_DelRoute( char* p
-
- sin = (struct sockaddr_in*)&rtentry.rt_dst;
- sin->sin_family = AF_INET;
-+ sin->sin_len = sizeof( struct sockaddr_in );
-
- if( !pszDestAddr ||
- !inet_aton( pszDestAddr, &sin->sin_addr ) )
-@@ -541,6 +550,7 @@ int TUNTAP_DelRoute( char* p
-
- sin = (struct sockaddr_in*)&rtentry.rt_genmask;
- sin->sin_family = AF_INET;
-+ sin->sin_len = sizeof( struct sockaddr_in );
-
- if( !pszNetMask ||
- !inet_aton( pszNetMask, &sin->sin_addr ) )
-@@ -552,6 +562,7 @@ int TUNTAP_DelRoute( char* p
-
- sin = (struct sockaddr_in*)&rtentry.rt_gateway;
- sin->sin_family = AF_INET;
-+ sin->sin_len = sizeof( struct sockaddr_in );
-
- if( !pszGWAddr ||
- !inet_aton( pszGWAddr, &sin->sin_addr ) )
diff --git a/emulators/hercules/files/patch-util-dasdlist b/emulators/hercules/files/patch-util-dasdlist
deleted file mode 100644
index 3e38eae338d2..000000000000
--- a/emulators/hercules/files/patch-util-dasdlist
+++ /dev/null
@@ -1,36 +0,0 @@
---- util/dasdlist.orig Tue Nov 14 10:19:08 2006
-+++ util/dasdlist Tue Nov 14 10:48:16 2006
-@@ -1,4 +1,4 @@
--#!/bin/bash
-+#!/bin/sh
- #
- # This command prints a track from a CKD DASD image file.
- # It uses the GNU Octal Dump (od) command to firstly obtain
-@@ -22,7 +22,7 @@ fi
- #
- # Check the first 8 bytes of the header for valid CKD DASD image file
- #
--ckdid=`od -An -s --read-bytes=8 $filename`
-+ckdid=`hexdump -n 8 -e '"%_p"' $filename`
- if [ $ckdid != "CKD_P370" ]; then
- echo "File $filename is not a CKD DASD image file"
- exit 2
-@@ -31,8 +31,8 @@ fi
- #
- # The next 8 bytes contain the tracks/cyl and track length constants
- #
--heads=`od -An -tu4 --skip-bytes=8 --read-bytes=4 $filename`
--trklen=`od -An -tu4 --skip-bytes=12 --read-bytes=4 $filename`
-+heads=`od -An -tu4 -j 8 -N 4 $filename`
-+trklen=`od -An -tu4 -j 12 -N 4 $filename`
-
- echo "$filename $(($heads)) trks/cyl, $(($trklen)) bytes/trk"
-
-@@ -54,5 +54,5 @@ num=$(($trklen))
- # Dump the requested track
- #
- echo "$filename Cyl $(($cyl)) Head $(($head))"
--echo "od -Ax -tx1 --skip-bytes=$offset --read-bytes=$num $filename"
--od -Ax -tx1 --skip-bytes=$offset --read-bytes=$num $filename
-+echo "od -Ax -tx1 -j $offset -N $num $filename"
-+od -Ax -tx1 -j $offset -N $num $filename
diff --git a/emulators/hercules/pkg-descr b/emulators/hercules/pkg-descr
index f27951877ad7..54acfdd6bcef 100644
--- a/emulators/hercules/pkg-descr
+++ b/emulators/hercules/pkg-descr
@@ -7,6 +7,6 @@ Jaeger designed and implemented many of the advanced features of Hercules,
including dynamic reconfiguration, integrated console, interpretive execution
and z/Architecture support.
-WWW: http://www.conmicro.cx/hercules/
+WWW: http://www.hercules-390.org/
-phk@FreeBSD.org
diff --git a/emulators/hercules/pkg-plist b/emulators/hercules/pkg-plist
index 0d143d6d346e..dd81e5f58eb6 100644
--- a/emulators/hercules/pkg-plist
+++ b/emulators/hercules/pkg-plist
@@ -38,6 +38,9 @@ lib/libherct.la
lib/libherct.so
lib/libhercu.la
lib/libhercu.so
+lib/libdecNumber.so
+lib/libdecNumber.la
+lib/libdecNumber.a
lib/hercules/dyncrypt.a
lib/hercules/dyncrypt.la
lib/hercules/dyncrypt.so