aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2004-08-19 13:45:32 +0000
committerMathieu Arnold <mat@FreeBSD.org>2004-08-19 13:45:32 +0000
commit814def5950802838b4cae47aa7878cd312308099 (patch)
treeb400c1bec5d876c22e657e695c2b851caed64cff
parente124e1bcb26b59a842740309f816697f7ff42e71 (diff)
downloadports-814def5950802838b4cae47aa7878cd312308099.tar.gz
ports-814def5950802838b4cae47aa7878cd312308099.zip
Notes
-rw-r--r--net/Makefile1
-rw-r--r--net/p5-POE-Component-Jabber/Makefile67
-rw-r--r--net/p5-POE-Component-Jabber/distinfo4
-rw-r--r--net/p5-POE-Component-Jabber/pkg-descr8
-rw-r--r--net/p5-POE-Component-Jabber/pkg-plist32
5 files changed, 112 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 20c2b44cdfc6..6868adea51c3 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -483,6 +483,7 @@
SUBDIR += p5-NetAddr-IP-Count
SUBDIR += p5-NetPacket
SUBDIR += p5-OAI-Harvester
+ SUBDIR += p5-POE-Component-Jabber
SUBDIR += p5-POE-Component-RRDTool
SUBDIR += p5-Parallel-MPI
SUBDIR += p5-Parallel-Pvm
diff --git a/net/p5-POE-Component-Jabber/Makefile b/net/p5-POE-Component-Jabber/Makefile
new file mode 100644
index 000000000000..d0b341498339
--- /dev/null
+++ b/net/p5-POE-Component-Jabber/Makefile
@@ -0,0 +1,67 @@
+# ex:ts=8
+# New ports collection makefile for: POE::Component::Jabber
+# Date created: 6 Aug 2004
+# Whom: Jeff Putsch <jdputsch@comcast.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= POE-Component-Jabber
+PORTVERSION= 1.0
+CATEGORIES= net devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN:S/$/:1,2/}
+MASTER_SITE_SUBDIR= POE/:1 ExtUtils/:2
+PKGNAMEPREFIX= p5-
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX}:1 \
+ ExtUtils-AutoInstall-0.59${EXTRACT_SUFX}:2
+
+MAINTAINER= jdputsch@comcast.net
+COMMENT= A POE Component for communicating over Jabber
+
+BUILD_DEPENDS= ${SITE_PERL}/POE.pm:${PORTSDIR}/devel/p5-POE \
+ ${SITE_PERL}/POE/Filter/XML.pm:${PORTSDIR}/textproc/p5-POE-Filter-XML \
+ ${SITE_PERL}/${PERL_ARCH}/Digest/SHA1.pm:${PORTSDIR}/security/p5-Digest-SHA1 \
+ ${SITE_PERL}/${PERL_ARCH}/Net/SSLeay.pm:${PORTSDIR}/security/p5-Net-SSLeay \
+ ${SITE_PERL}/Authen/SASL.pm:${PORTSDIR}/security/p5-Authen-SASL \
+ ${SITE_PERL}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= POE::Component::Jabber.3 \
+ POE::Component::Jabber::Client::Component.3 \
+ POE::Component::Jabber::Client::J2.3 \
+ POE::Component::Jabber::Client::Legacy.3 \
+ POE::Component::Jabber::Client::XMPP.3 \
+ POE::Component::Jabber::Client::XMPP::TLS.3 \
+ POE::Component::Jabber::Error.3 \
+ POE::Component::Jabber::Server::Socket::CTLS.3 \
+ POE::Component::Jabber::Server::Socket::STLS.3
+
+pre-configure:
+ @${ECHO_MSG} "===> Putting AutoInstall.pm in work dir"
+ @${MKDIR} ${WRKSRC}/install/ExtUtils
+ @${CP} ${WRKDIR}/ExtUtils-AutoInstall-0.59/lib/ExtUtils/AutoInstall.pm \
+ ${WRKSRC}/install/ExtUtils
+
+post-install:
+.ifndef(NOPORTDOCS)
+ @${ECHO_MSG} "===> Installing examples for ${PKGNAME}"
+ @${MKDIR} ${EXAMPLESDIR}
+ @${INSTALL_SCRIPT} ${WRKSRC}/examples/* ${EXAMPLESDIR}
+.endif
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+post-patch:
+ @${PERL} -pi -e 's/^our (\S+)/use vars qw($$1); $$1/' \
+ ${WRKSRC}/lib/POE/Component/Jabber/Client/Legacy.pm \
+ ${WRKSRC}/lib/POE/Component/Jabber/Client/Component.pm \
+ ${WRKSRC}/lib/POE/Component/Jabber/Client/XMPP.pm \
+ ${WRKSRC}/lib/POE/Component/Jabber/Client/J2.pm \
+ ${WRKSRC}/lib/POE/Component/Jabber/Error.pm \
+ ${WRKSRC}/lib/POE/Component/Jabber.pm
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net/p5-POE-Component-Jabber/distinfo b/net/p5-POE-Component-Jabber/distinfo
new file mode 100644
index 000000000000..e958cbd02891
--- /dev/null
+++ b/net/p5-POE-Component-Jabber/distinfo
@@ -0,0 +1,4 @@
+MD5 (POE-Component-Jabber-1.0.tar.gz) = 4e0a60020511c19403b53d6fc993a3dd
+SIZE (POE-Component-Jabber-1.0.tar.gz) = 24771
+MD5 (ExtUtils-AutoInstall-0.59.tar.gz) = 1dbcfe20069d125f5d2a0a351c2e9a57
+SIZE (ExtUtils-AutoInstall-0.59.tar.gz) = 25859
diff --git a/net/p5-POE-Component-Jabber/pkg-descr b/net/p5-POE-Component-Jabber/pkg-descr
new file mode 100644
index 000000000000..8cd4837f1d08
--- /dev/null
+++ b/net/p5-POE-Component-Jabber/pkg-descr
@@ -0,0 +1,8 @@
+POE::Component::Jabber is a module that simplies for the POE
+developer, access to the Jabber protocol through the use of one of
+the four Client classes. With built in events for common Jabber
+packets, all a POE developer need do is provide an event and arguments
+for most events so the responses to the requests can be properly
+handled by the coder.
+
+WWW: http://search.cpan.org/dist/POE-Component-Jabber/
diff --git a/net/p5-POE-Component-Jabber/pkg-plist b/net/p5-POE-Component-Jabber/pkg-plist
new file mode 100644
index 000000000000..0c5936c70473
--- /dev/null
+++ b/net/p5-POE-Component-Jabber/pkg-plist
@@ -0,0 +1,32 @@
+%%SITE_PERL%%/POE/Component/Jabber.pm
+%%SITE_PERL%%/POE/Component/Jabber/Client/Component.pm
+%%SITE_PERL%%/POE/Component/Jabber/Client/J2.pm
+%%SITE_PERL%%/POE/Component/Jabber/Client/Legacy.pm
+%%SITE_PERL%%/POE/Component/Jabber/Client/XMPP.pm
+%%SITE_PERL%%/POE/Component/Jabber/Client/XMPP/TLS.pm
+%%SITE_PERL%%/POE/Component/Jabber/Error.pm
+%%SITE_PERL%%/POE/Component/Jabber/Server/InputHandler.pm
+%%SITE_PERL%%/POE/Component/Jabber/Server/RouteProcessor.pm
+%%SITE_PERL%%/POE/Component/Jabber/Server/RouteTable.pm
+%%SITE_PERL%%/POE/Component/Jabber/Server/SelfRouter.pm
+%%SITE_PERL%%/POE/Component/Jabber/Server/Socket.pm
+%%SITE_PERL%%/POE/Component/Jabber/Server/Socket/CTLS.pm
+%%SITE_PERL%%/POE/Component/Jabber/Server/Socket/STLS.pm
+%%SITE_PERL%%/POE/Component/Jabber/Server/SocketServer.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component/Jabber/.packlist
+%%PORTDOCS%%%%EXAMPLESDIR%%/COMPTester.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/J2Tester.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/LEGACYTester.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/SERVERTester.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/XMPPTester.pl
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component/Jabber
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/POE 2>/dev/null || true
+@dirrm %%SITE_PERL%%/POE/Component/Jabber/Server/Socket
+@dirrm %%SITE_PERL%%/POE/Component/Jabber/Server
+@dirrm %%SITE_PERL%%/POE/Component/Jabber/Client/XMPP
+@dirrm %%SITE_PERL%%/POE/Component/Jabber/Client
+@dirrm %%SITE_PERL%%/POE/Component/Jabber
+@unexec rmdir %D/%%SITE_PERL%%/POE/Component 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/POE 2>/dev/null || true