aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrej Zverev <az@FreeBSD.org>2012-06-29 10:29:24 +0000
committerAndrej Zverev <az@FreeBSD.org>2012-06-29 10:29:24 +0000
commit9144df7eca431da9991b4a26c4890571235eb415 (patch)
tree7e281055c9f5d5e0c58728cc4ccbf2f1d58baad6
parentf7c6b31899f9b093dceb9de54003bad139d8da83 (diff)
downloadports-9144df7eca431da9991b4a26c4890571235eb415.tar.gz
ports-9144df7eca431da9991b4a26c4890571235eb415.zip
Notes
-rw-r--r--net/p5-Growl-GNTP/Makefile4
-rw-r--r--net/p5-WebService-Prowl/Makefile8
-rw-r--r--security/p5-Authen-DecHpwd/Makefile6
-rw-r--r--security/p5-Authen-Passphrase/Makefile22
-rw-r--r--security/p5-Crypt-Eksblowfish/Makefile4
-rw-r--r--www/ikiwiki/Makefile36
-rw-r--r--www/p5-Apache-Gallery/Makefile14
7 files changed, 47 insertions, 47 deletions
diff --git a/net/p5-Growl-GNTP/Makefile b/net/p5-Growl-GNTP/Makefile
index 5410b2916de8..aaf1af70b8f0 100644
--- a/net/p5-Growl-GNTP/Makefile
+++ b/net/p5-Growl-GNTP/Makefile
@@ -17,8 +17,8 @@ COMMENT= Perl implementation of the Growl GNTP Protocol (Client Part)
LICENSE= ART10 GPLv1
LICENSE_COMB= dual
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Data/UUID.pm:${PORTSDIR}/devel/p5-Data-UUID \
- ${SITE_PERL}/Crypt/CBC.pm:${PORTSDIR}/security/p5-Crypt-CBC
+BUILD_DEPENDS= p5-Data-UUID>=0:${PORTSDIR}/devel/p5-Data-UUID \
+ p5-Crypt-CBC>=0:${PORTSDIR}/security/p5-Crypt-CBC
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/net/p5-WebService-Prowl/Makefile b/net/p5-WebService-Prowl/Makefile
index da9ccd2dada0..b9edf8ff0c65 100644
--- a/net/p5-WebService-Prowl/Makefile
+++ b/net/p5-WebService-Prowl/Makefile
@@ -18,10 +18,10 @@ COMMENT= Perl interface to Prowl Public API
LICENSE= ART10 GPLv1
LICENSE_COMB= dual
-BUILD_DEPENDS= ${SITE_PERL}/LWP/UserAgent.pm:${PORTSDIR}/www/p5-libwww \
- ${SITE_PERL}/LWP/Protocol/https.pm:${PORTSDIR}/www/p5-LWP-Protocol-https \
- ${SITE_PERL}/${PERL_ARCH}/Crypt/SSLeay.pm:${PORTSDIR}/security/p5-Crypt-SSLeay \
- ${SITE_PERL}/XML/Simple.pm:${PORTSDIR}/textproc/p5-XML-Simple
+BUILD_DEPENDS= p5-libwww>=0:${PORTSDIR}/www/p5-libwww \
+ p5-LWP-Protocol-https>=0:${PORTSDIR}/www/p5-LWP-Protocol-https \
+ p5-Crypt-SSLeay>=0:${PORTSDIR}/security/p5-Crypt-SSLeay \
+ p5-XML-Simple>=0:${PORTSDIR}/textproc/p5-XML-Simple
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/security/p5-Authen-DecHpwd/Makefile b/security/p5-Authen-DecHpwd/Makefile
index 6b112617f0ee..13f8785ea9aa 100644
--- a/security/p5-Authen-DecHpwd/Makefile
+++ b/security/p5-Authen-DecHpwd/Makefile
@@ -14,9 +14,9 @@ PKGNAMEPREFIX= p5-
MAINTAINER= brix@FreeBSD.org
COMMENT= Perl module for DEC VMS password hashing
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Scalar/String.pm:${PORTSDIR}/devel/p5-Scalar-String \
- ${SITE_PERL}/Data/Integer.pm:${PORTSDIR}/devel/p5-Data-Integer \
- ${SITE_PERL}/${PERL_ARCH}/Digest/CRC.pm:${PORTSDIR}/security/p5-Digest-CRC
+BUILD_DEPENDS= p5-Scalar-String>=0:${PORTSDIR}/devel/p5-Scalar-String \
+ p5-Data-Integer>=0:${PORTSDIR}/devel/p5-Data-Integer \
+ p5-Digest-CRC>=0:${PORTSDIR}/security/p5-Digest-CRC
RUN_DEPENDS:= ${BUILD_DEPENDS}
LICENSE= GPLv2
diff --git a/security/p5-Authen-Passphrase/Makefile b/security/p5-Authen-Passphrase/Makefile
index 5461e6f9bc06..6b3773d9872c 100644
--- a/security/p5-Authen-Passphrase/Makefile
+++ b/security/p5-Authen-Passphrase/Makefile
@@ -17,17 +17,17 @@ COMMENT= Perl module for handling hashed passwords/passphrases as objects
LICENSE= ART10 GPLv1
LICENSE_COMB= dual
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Authen/DecHpwd.pm:${PORTSDIR}/security/p5-Authen-DecHpwd \
- ${SITE_PERL}/${PERL_ARCH}/Crypt/Blowfish.pm:${PORTSDIR}/security/p5-Crypt-Blowfish \
- ${SITE_PERL}/${PERL_ARCH}/Crypt/DES.pm:${PORTSDIR}/security/p5-Crypt-DES \
- ${SITE_PERL}/${PERL_ARCH}/Crypt/Eksblowfish.pm:${PORTSDIR}/security/p5-Crypt-Eksblowfish \
- ${SITE_PERL}/${PERL_ARCH}/Crypt/MySQL.pm:${PORTSDIR}/security/p5-Crypt-MySQL \
- ${SITE_PERL}/Crypt/PasswdMD5.pm:${PORTSDIR}/security/p5-Crypt-PasswdMD5 \
- ${SITE_PERL}/${PERL_ARCH}/Crypt/UnixCrypt_XS.pm:${PORTSDIR}/security/p5-Crypt-UnixCrypt_XS \
- ${SITE_PERL}/Data/Entropy/Algorithms.pm:${PORTSDIR}/security/p5-Data-Entropy \
- ${SITE_PERL}/${PERL_ARCH}/Digest/MD4.pm:${PORTSDIR}/security/p5-Digest-MD4 \
- ${SITE_PERL}/Module/Runtime.pm:${PORTSDIR}/devel/p5-Module-Runtime \
- ${SITE_PERL}/${PERL_ARCH}/Params/Classify.pm:${PORTSDIR}/devel/p5-Params-Classify
+BUILD_DEPENDS= p5-Authen-DecHpwd>=0:${PORTSDIR}/security/p5-Authen-DecHpwd \
+ p5-Crypt-Blowfish>=0:${PORTSDIR}/security/p5-Crypt-Blowfish \
+ p5-Crypt-DES>=0:${PORTSDIR}/security/p5-Crypt-DES \
+ p5-Crypt-Eksblowfish>=0:${PORTSDIR}/security/p5-Crypt-Eksblowfish \
+ p5-Crypt-MySQL>=0:${PORTSDIR}/security/p5-Crypt-MySQL \
+ p5-Crypt-PasswdMD5>=0:${PORTSDIR}/security/p5-Crypt-PasswdMD5 \
+ p5-Crypt-UnixCrypt_XS>=0:${PORTSDIR}/security/p5-Crypt-UnixCrypt_XS \
+ p5-Data-Entropy>=0:${PORTSDIR}/security/p5-Data-Entropy \
+ p5-Digest-MD4>=0:${PORTSDIR}/security/p5-Digest-MD4 \
+ p5-Module-Runtime>=0:${PORTSDIR}/devel/p5-Module-Runtime \
+ p5-Params-Classify>=0:${PORTSDIR}/devel/p5-Params-Classify
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_MODBUILD= yes
diff --git a/security/p5-Crypt-Eksblowfish/Makefile b/security/p5-Crypt-Eksblowfish/Makefile
index c0ef6e93cbe9..d034d9849774 100644
--- a/security/p5-Crypt-Eksblowfish/Makefile
+++ b/security/p5-Crypt-Eksblowfish/Makefile
@@ -14,8 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= brix@FreeBSD.org
COMMENT= Perl module for the Eksblowfish block cipher
-RUN_DEPENDS= ${SITE_PERL}/Class/Mix.pm:${PORTSDIR}/devel/p5-Class-Mix \
- ${SITE_PERL}/parent.pm:${PORTSDIR}/devel/p5-parent
+RUN_DEPENDS= p5-Class-Mix>=0:${PORTSDIR}/devel/p5-Class-Mix \
+ p5-parent>=0:${PORTSDIR}/devel/p5-parent
LICENSE_COMB= dual
LICENSE= ART10 GPLv1
diff --git a/www/ikiwiki/Makefile b/www/ikiwiki/Makefile
index 467bf4ff23fe..40b6abd26902 100644
--- a/www/ikiwiki/Makefile
+++ b/www/ikiwiki/Makefile
@@ -15,23 +15,23 @@ DISTNAME= ${PORTNAME}_${PORTVERSION}
MAINTAINER= brix@FreeBSD.org
COMMENT= A wiki compiler
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/HTML/Parser.pm:${PORTSDIR}/www/p5-HTML-Parser \
- ${SITE_PERL}/${PERL_ARCH}/Locale/gettext.pm:${PORTSDIR}/devel/p5-Locale-gettext \
- ${SITE_PERL}/CGI/FormBuilder.pm:${PORTSDIR}/www/p5-CGI-FormBuilder \
- ${SITE_PERL}/CGI/Session.pm:${PORTSDIR}/www/p5-CGI-Session \
- ${SITE_PERL}/Date/Parse.pm:${PORTSDIR}/devel/p5-TimeDate \
- ${SITE_PERL}/HTML/Scrubber.pm:${PORTSDIR}/www/p5-HTML-Scrubber \
- ${SITE_PERL}/HTML/Template.pm:${PORTSDIR}/www/p5-HTML-Template \
- ${SITE_PERL}/Mail/Sendmail.pm:${PORTSDIR}/mail/p5-Mail-Sendmail \
- ${SITE_PERL}/Text/Markdown.pm:${PORTSDIR}/textproc/p5-Text-Markdown \
- ${SITE_PERL}/URI.pm:${PORTSDIR}/net/p5-URI \
- ${SITE_PERL}/XML/Simple.pm:${PORTSDIR}/textproc/p5-XML-Simple \
- ${SITE_PERL}/YAML.pm:${PORTSDIR}/textproc/p5-YAML
+BUILD_DEPENDS= p5-HTML-Parser>=0:${PORTSDIR}/www/p5-HTML-Parser \
+ p5-Locale-gettext>=0:${PORTSDIR}/devel/p5-Locale-gettext \
+ p5-CGI-FormBuilder>=0:${PORTSDIR}/www/p5-CGI-FormBuilder \
+ p5-CGI-Session>=0:${PORTSDIR}/www/p5-CGI-Session \
+ p5-TimeDate>=0:${PORTSDIR}/devel/p5-TimeDate \
+ p5-HTML-Scrubber>=0:${PORTSDIR}/www/p5-HTML-Scrubber \
+ p5-HTML-Template>=0:${PORTSDIR}/www/p5-HTML-Template \
+ p5-Mail-Sendmail>=0:${PORTSDIR}/mail/p5-Mail-Sendmail \
+ p5-Text-Markdown>=0:${PORTSDIR}/textproc/p5-Text-Markdown \
+ p5-URI>=0:${PORTSDIR}/net/p5-URI \
+ p5-XML-Simple>=0:${PORTSDIR}/textproc/p5-XML-Simple \
+ p5-YAML>=0:${PORTSDIR}/textproc/p5-YAML
RUN_DEPENDS:= ${BUILD_DEPENDS} \
- ${SITE_PERL}/File/MimeInfo.pm:${PORTSDIR}/devel/p5-File-MimeInfo \
- ${SITE_PERL}/RPC/XML.pm:${PORTSDIR}/net/p5-RPC-XML \
- ${SITE_PERL}/XML/Feed.pm:${PORTSDIR}/textproc/p5-XML-Feed \
- ${SITE_PERL}/Authen/Passphrase.pm:${PORTSDIR}/security/p5-Authen-Passphrase
+ p5-File-MimeInfo>=0:${PORTSDIR}/devel/p5-File-MimeInfo \
+ p5-RPC-XML>=0:${PORTSDIR}/net/p5-RPC-XML \
+ p5-XML-Feed>=0:${PORTSDIR}/textproc/p5-XML-Feed \
+ p5-Authen-Passphrase>=0:${PORTSDIR}/security/p5-Authen-Passphrase
WRKSRC= ${WRKDIR}/${PORTNAME}
@@ -60,8 +60,8 @@ PLIST_SUB+= PO4A="@comment "
.endif
.if defined(WITH_SEARCH)
-RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Digest/SHA1.pm:${PORTSDIR}/security/p5-Digest-SHA1 \
- ${SITE_PERL}/${PERL_ARCH}/Search/Xapian.pm:${PORTSDIR}/databases/p5-Search-Xapian \
+RUN_DEPENDS+= p5-Digest-SHA1>=0:${PORTSDIR}/security/p5-Digest-SHA1 \
+ p5-Search-Xapian>=0:${PORTSDIR}/databases/p5-Search-Xapian \
${LOCALBASE}/www/xapian-omega/cgi-bin/omega:${PORTSDIR}/www/xapian-omega
.endif
diff --git a/www/p5-Apache-Gallery/Makefile b/www/p5-Apache-Gallery/Makefile
index 2d113ce526fd..1c6a1393231d 100644
--- a/www/p5-Apache-Gallery/Makefile
+++ b/www/p5-Apache-Gallery/Makefile
@@ -19,13 +19,13 @@ COMMENT= Apache::Gallery - mod_perl handler to create an image gallery
LICENSE= ART10
-BUILD_DEPENDS= ${SITE_PERL}/URI/Escape.pm:${PORTSDIR}/net/p5-URI \
- ${SITE_PERL}/Text/Template.pm:${PORTSDIR}/textproc/p5-Text-Template \
- ${SITE_PERL}/Image/Info.pm:${PORTSDIR}/graphics/p5-Image-Info \
- ${SITE_PERL}/Image/Size.pm:${PORTSDIR}/graphics/p5-Image-Size \
- ${SITE_PERL}/${PERL_ARCH}/Image/Imlib2.pm:${PORTSDIR}/graphics/p5-Image-Imlib2 \
- ${SITE_PERL}/${PERL_ARCH}/Apache2/Request.pm:${PORTSDIR}/www/p5-libapreq2 \
- ${SITE_PERL}/CGI.pm:${PORTSDIR}/www/p5-CGI.pm
+BUILD_DEPENDS= p5-URI>=0:${PORTSDIR}/net/p5-URI \
+ p5-Text-Template>=0:${PORTSDIR}/textproc/p5-Text-Template \
+ p5-Image-Info>=0:${PORTSDIR}/graphics/p5-Image-Info \
+ p5-Image-Size>=0:${PORTSDIR}/graphics/p5-Image-Size \
+ p5-Image-Imlib2>=0:${PORTSDIR}/graphics/p5-Image-Imlib2 \
+ p5-libapreq2>=0:${PORTSDIR}/www/p5-libapreq2 \
+ p5-CGI.pm>=0:${PORTSDIR}/www/p5-CGI.pm
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes