aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2014-02-28 10:16:02 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2014-02-28 10:16:02 +0000
commit9766293b0b7d8ceaed50c29a850b962aabbbc405 (patch)
treeca1bf5eddc6e8bedb4108b4bb132b2bb143b5c4a
parentfe8748bcbd13a8a2939ad302b8a3c5d56408641f (diff)
Notes
-rw-r--r--devel/pecl-expect/Makefile7
-rw-r--r--misc/dejagnu/Makefile3
-rw-r--r--misc/sshbuddy/Makefile14
-rw-r--r--misc/sshbuddy/files/patch-sshbuddy.expk17
-rw-r--r--net-mgmt/rancid-devel/Makefile5
-rw-r--r--net-mgmt/rancid/Makefile5
-rw-r--r--net/freenx/Makefile4
7 files changed, 31 insertions, 24 deletions
diff --git a/devel/pecl-expect/Makefile b/devel/pecl-expect/Makefile
index cabb1054c3e3..b71a2cec6379 100644
--- a/devel/pecl-expect/Makefile
+++ b/devel/pecl-expect/Makefile
@@ -12,7 +12,7 @@ DIST_SUBDIR= PECL
MAINTAINER= miwi@FreeBSD.org
COMMENT= A PHP extension for expect library
-LIB_DEPENDS= expect543:${PORTSDIR}/lang/expect
+LIB_DEPENDS= libexpect.so:${PORTSDIR}/lang/expect
LICENSE= PHP301
@@ -21,9 +21,4 @@ USE_PHPEXT= yes
CONFIGURE_ARGS+=--with-expect=${LOCALBASE}
-post-patch:
- @${REINPLACE_CMD} -e \
- 's/\(LIBRARY_WITH_PATH(\)expect/\1expect543/' \
- ${WRKSRC}/config.m4
-
.include <bsd.port.mk>
diff --git a/misc/dejagnu/Makefile b/misc/dejagnu/Makefile
index 59d7074040e3..870a5fd1a473 100644
--- a/misc/dejagnu/Makefile
+++ b/misc/dejagnu/Makefile
@@ -11,8 +11,7 @@ COMMENT= Automated program/system tester
LICENSE= GPLv3
-BUILD_DEPENDS= expect:${PORTSDIR}/lang/expect
-RUN_DEPENDS= expect:${PORTSDIR}/lang/expect
+LIB_DEPENDS= libexpect.so:${PORTSDIR}/lang/expect
USES+= gmake tcl
GNU_CONFIGURE= yes
diff --git a/misc/sshbuddy/Makefile b/misc/sshbuddy/Makefile
index 7e4968b2b7e1..19941c4c91ca 100644
--- a/misc/sshbuddy/Makefile
+++ b/misc/sshbuddy/Makefile
@@ -10,19 +10,17 @@ MASTER_SITES= http://linuxmafia.com/pub/linux/security/sshbuddy/
MAINTAINER= wrighrc@gmail.com
COMMENT= Simple and small GUI utility to manage ssh sessions
-RUN_DEPENDS= expectk:${PORTSDIR}/lang/expect
+RUN_DEPENDS= expect:${PORTSDIR}/lang/expect
-USES= shebangfix
-USE_XORG= x11
-SHEBANG_FILES= ${WRKSRC}/sshbuddy.expk
-SHEBANG_LANG= expectk
-expectk_OLD_CMD= /usr/bin/expectk
-expectk_CMD= ${LOCALBASE}/bin/expectk
+USES= tk
NO_BUILD= yes
PLIST_FILES= bin/sshbuddy
+post-patch:
+ ${REINPLACE_CMD} -e 's|%%WISH%%|${WISH}|' ${WRKSRC}/sshbuddy.expk
+
do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/sshbuddy.expk ${STAGEDIR}${PREFIX}/bin/sshbuddy
+ ${INSTALL_SCRIPT} ${WRKSRC}/sshbuddy.expk ${STAGEDIR}${PREFIX}/bin/sshbuddy
.include <bsd.port.mk>
diff --git a/misc/sshbuddy/files/patch-sshbuddy.expk b/misc/sshbuddy/files/patch-sshbuddy.expk
new file mode 100644
index 000000000000..1980c726841d
--- /dev/null
+++ b/misc/sshbuddy/files/patch-sshbuddy.expk
@@ -0,0 +1,17 @@
+--- sshbuddy.expk.orig 2014-02-28 10:41:40.000000000 +0100
++++ sshbuddy.expk 2014-02-28 10:41:58.000000000 +0100
+@@ -1,4 +1,4 @@
+-#!/usr/bin/expectk
++#!%%WISH%%
+ #
+ # EDIT THE ABOVE LINE TO POINT TO WHERE expectk LIVES
+ #
+@@ -10,6 +10,8 @@
+ #
+ # Version Beta1.05
+
++package require Expect
++
+ set expect_path [exec which expect]
+
+ ########################################################################
diff --git a/net-mgmt/rancid-devel/Makefile b/net-mgmt/rancid-devel/Makefile
index 6561bad08b5d..4f23d48ba6dc 100644
--- a/net-mgmt/rancid-devel/Makefile
+++ b/net-mgmt/rancid-devel/Makefile
@@ -11,9 +11,8 @@ PKGNAMESUFFIX= -devel
MAINTAINER= jmohacsi@bsd.hu
COMMENT= Really Awesome New Cisco confIg Differ
-BUILD_DEPENDS= expect:${PORTSDIR}/lang/expect-devel
-RUN_DEPENDS= expect:${PORTSDIR}/lang/expect-devel \
- p5-LockFile-Simple>=0:${PORTSDIR}/devel/p5-LockFile-Simple
+LIB_DEPENDS= libexpect.so:${PORTSDIR}/lang/expect-devel
+RUN_DEPENDS= p5-LockFile-Simple>=0:${PORTSDIR}/devel/p5-LockFile-Simple
USES= perl5 gmake
SUB_FILES= pkg-message
diff --git a/net-mgmt/rancid/Makefile b/net-mgmt/rancid/Makefile
index ed959662152d..2cb0e940821a 100644
--- a/net-mgmt/rancid/Makefile
+++ b/net-mgmt/rancid/Makefile
@@ -10,9 +10,8 @@ MASTER_SITES= ftp://ftp.shrubbery.net/pub/rancid/
MAINTAINER= jmohacsi@bsd.hu
COMMENT= Really Awesome New Cisco confIg Differ
-BUILD_DEPENDS= expect:${PORTSDIR}/lang/expect-devel
-RUN_DEPENDS= expect:${PORTSDIR}/lang/expect-devel \
- p5-LockFile-Simple>=0:${PORTSDIR}/devel/p5-LockFile-Simple
+LIB_DEPENDS= libexpect.so:${PORTSDIR}/lang/expect
+RUN_DEPENDS= p5-LockFile-Simple>=0:${PORTSDIR}/devel/p5-LockFile-Simple
USES= gmake perl5 shebangfix
perl_OLD_CMD= @PERLV_PATH@
diff --git a/net/freenx/Makefile b/net/freenx/Makefile
index dce63e02c3e7..fd745a53a91e 100644
--- a/net/freenx/Makefile
+++ b/net/freenx/Makefile
@@ -25,8 +25,8 @@ NXPREFIX?= ${PREFIX}/NX
NO_STAGE= yes
post-patch:
@cd ${WRKSRC} && ${REINPLACE_CMD} -e "s|/usr/local/|${PREFIX}/|" \
- -e "s|!/bin/bash|!${PREFIX}/bin/bash|" \
- -e "s|/usr/bin/expect|${PREFIX}/bin/expect|" \
+ -e "s|!/bin/bash|!${LOCALBASE}/bin/bash|" \
+ -e "s|/usr/bin/expect|${LOCALBASE}/bin/expect|" \
-e "s|/usr/NX|${NXPREFIX}|" \
node.conf.sample nxclient nxkeygen nxloadconfig nxnode \
nxnode-login nxprint nxserver nxsetup