aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Kozlov <ak@FreeBSD.org>2014-05-22 09:51:35 +0000
committerAlex Kozlov <ak@FreeBSD.org>2014-05-22 09:51:35 +0000
commit98052ca1a2edc43a4644041a991121d9643db7ef (patch)
tree0436854f6230bf67036c82c55f4545695302b703
parent4850bdc1e69f0ad5e1e4fcb235cf295f92231bb4 (diff)
downloadports-98052ca1a2edc43a4644041a991121d9643db7ef.tar.gz
ports-98052ca1a2edc43a4644041a991121d9643db7ef.zip
Notes
-rw-r--r--Mk/Uses/zip.mk10
-rw-r--r--Mk/bsd.commands.mk1
-rw-r--r--games/ioquake3/Makefile3
-rw-r--r--games/urbanterror-data/Makefile2
-rw-r--r--polish/hunspell/Makefile2
-rw-r--r--textproc/no-hunspell/Makefile4
6 files changed, 13 insertions, 9 deletions
diff --git a/Mk/Uses/zip.mk b/Mk/Uses/zip.mk
index 87719c954ee7..c81687a2cd9a 100644
--- a/Mk/Uses/zip.mk
+++ b/Mk/Uses/zip.mk
@@ -14,13 +14,15 @@ zip_ARGS?= none
EXTRACT_SUFX?= .zip
+EXTRACT_BEFORE_ARGS?= -qo
+EXTRACT_AFTER_ARGS?= -d ${WRKDIR}
+
.if ${zip_ARGS} == infozip
EXTRACT_DEPENDS+= ${UNZIP_CMD}:${PORTSDIR}/archivers/unzip
-
EXTRACT_CMD?= ${UNZIP_CMD}
-EXTRACT_BEFORE_ARGS?= -qo
-EXTRACT_AFTER_ARGS?= -d ${WRKDIR}
-.elif ${zip_ARGS} != none
+.elif ${zip_ARGS} == none
+EXTRACT_CMD?= ${UNZIP_NATIVE_CMD}
+.else
IGNORE= Incorrect 'USES+=zip:${zip_ARGS}' expecting 'USES+=zip[:infozip]'
.endif
.endif
diff --git a/Mk/bsd.commands.mk b/Mk/bsd.commands.mk
index 3d3406f37f07..845701a6a35c 100644
--- a/Mk/bsd.commands.mk
+++ b/Mk/bsd.commands.mk
@@ -95,6 +95,7 @@ UMOUNT?= /sbin/umount
UNAME?= /usr/bin/uname
UNMAKESELF_CMD?= ${LOCALBASE}/bin/unmakeself
UNZIP_CMD?= ${LOCALBASE}/bin/unzip
+UNZIP_NATIVE_CMD?= /usr/bin/unzip
WHICH?= /usr/bin/which
XARGS?= /usr/bin/xargs
XMKMF?= ${LOCALBASE}/bin/xmkmf
diff --git a/games/ioquake3/Makefile b/games/ioquake3/Makefile
index 2c3ada8fc078..db5c822912b6 100644
--- a/games/ioquake3/Makefile
+++ b/games/ioquake3/Makefile
@@ -7,11 +7,12 @@ PORTREVISION?= 13
CATEGORIES= games
MASTER_SITES?= http://ioquake3.org/files/${DISTVERSION}/
# Using zip this way enables slaves to override it.
+EXTRACT_SUFX?= .zip
MAINTAINER?= kamikaze@bsdforen.de
COMMENT?= Cleaned-up and enhanced version of Quake 3
-USES= pkgconfig gmake zip
+USES= pkgconfig gmake
NO_STAGE= yes
# Port configuration flags:
diff --git a/games/urbanterror-data/Makefile b/games/urbanterror-data/Makefile
index c6b308248967..48a8d638e241 100644
--- a/games/urbanterror-data/Makefile
+++ b/games/urbanterror-data/Makefile
@@ -9,12 +9,12 @@ MASTER_SITES= http://cdn.urbanterror.info/urt/42/zips/ \
http://mirror.urtstats.net/urbanterror/
PKGNAMEPREFIX= urbanterror-
DISTNAME= UrbanTerror${URT_VER}_full${URT_REV}
+EXTRACT_SUFX= .zip
EXTRACT_ONLY=
MAINTAINER= kamikaze@bsdforen.de
COMMENT= Standalone realism based mod originally for Quake III Arena
-USES= zip
NO_BUILD= yes
NO_CDROM= The mod files may not be sold or distributed on physical media unless with permission from id Software.
diff --git a/polish/hunspell/Makefile b/polish/hunspell/Makefile
index 79e468732e99..37f66558eb40 100644
--- a/polish/hunspell/Makefile
+++ b/polish/hunspell/Makefile
@@ -22,7 +22,7 @@ PLIST_DIRSTRY= %%DATADIR%%
post-extract:
@${MKDIR} ${WRKSRC}
- @${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} ${WRKDIR}/pl_PL.zip -C ${WRKSRC}/
+ @${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} ${WRKDIR}/pl_PL.zip -d ${WRKSRC}
do-install:
${MKDIR} ${STAGEDIR}${DATADIR}/
diff --git a/textproc/no-hunspell/Makefile b/textproc/no-hunspell/Makefile
index 888ccea84eaf..3f2b2e59717f 100644
--- a/textproc/no-hunspell/Makefile
+++ b/textproc/no-hunspell/Makefile
@@ -23,8 +23,8 @@ PLIST_DIRSTRY= %%DATADIR%%
post-extract:
@${MKDIR} ${WRKSRC}
- @${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} ${WRKDIR}/nb_NO.zip -C ${WRKSRC}/
- @${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} ${WRKDIR}/nn_NO.zip -C ${WRKSRC}/
+ @${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} ${WRKDIR}/nb_NO.zip -d ${WRKSRC}
+ @${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} ${WRKDIR}/nn_NO.zip -d ${WRKSRC}
do-install:
${MKDIR} ${STAGEDIR}${DATADIR}/