aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2005-10-18 09:15:21 +0000
committerRenato Botelho <garga@FreeBSD.org>2005-10-18 09:15:21 +0000
commita8fef3569c3619b77c61b3b4b93ef773799eb964 (patch)
tree2e86906a462278533cb93390a7e2b44b9e1700b5
parent5d2e46fd1fc6196300ca585b2ec8426938d3b00c (diff)
downloadports-a8fef3569c3619b77c61b3b4b93ef773799eb964.tar.gz
ports-a8fef3569c3619b77c61b3b4b93ef773799eb964.zip
Notes
-rw-r--r--graphics/flphoto/Makefile29
-rw-r--r--graphics/flphoto/distinfo4
-rw-r--r--graphics/flphoto/files/patch-Makefile.in18
-rw-r--r--graphics/flphoto/pkg-plist59
4 files changed, 57 insertions, 53 deletions
diff --git a/graphics/flphoto/Makefile b/graphics/flphoto/Makefile
index c34caac69853..7b38008a8f7f 100644
--- a/graphics/flphoto/Makefile
+++ b/graphics/flphoto/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= flphoto
-PORTVERSION= 1.1
-PORTREVISION= 1
+PORTVERSION= 1.2
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= fltk
@@ -19,13 +18,33 @@ COMMENT= A basic image management and display program
LIB_DEPENDS= gphoto2.2:${PORTSDIR}/graphics/libgphoto2 \
fltk.1:${PORTSDIR}/x11-toolkits/fltk
-USE_X_PREFIX= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
USE_BZIP2= yes
+USE_X_PREFIX= yes
+USE_REINPLACE= yes
GNU_CONFIGURE= yes
-
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
MAN1= flphoto.1
MAN5= album.5
+post-patch:
+ @${REINPLACE_CMD} -e 's|@OPTIM@|-DHAVE_CONFIG_H|g' ${WRKSRC}/Makefile.in
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/flphoto ${PREFIX}/bin/flphoto
+ ${INSTALL_MAN} ${WRKSRC}/doc/flphoto.man ${MANPREFIX}/man/man1/flphoto.1
+ ${INSTALL_MAN} ${WRKSRC}/doc/album.man ${MAN5PREFIX}/man/man5/album.5
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/*.jpg ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/*.html ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/*.png ${DOCSDIR}
+.for lang in de en_CA en_GB es fr it nl pt
+ @${MKDIR} ${PREFIX}/share/locale/${lang}
+ ${INSTALL_DATA} ${WRKSRC}/po/${lang}.po \
+ ${PREFIX}/share/locale/${lang}/flphoto_${lang}
+.endfor
+
.include <bsd.port.mk>
diff --git a/graphics/flphoto/distinfo b/graphics/flphoto/distinfo
index 9f89062e8a35..db539832ecdc 100644
--- a/graphics/flphoto/distinfo
+++ b/graphics/flphoto/distinfo
@@ -1,2 +1,2 @@
-MD5 (flphoto-1.1-source.tar.bz2) = 2cf2938ea1c6f88f9df279a77ec8af96
-SIZE (flphoto-1.1-source.tar.bz2) = 408538
+MD5 (flphoto-1.2-source.tar.bz2) = 13c9b6803b2fd159e8f082b7735ce8ab
+SIZE (flphoto-1.2-source.tar.bz2) = 501459
diff --git a/graphics/flphoto/files/patch-Makefile.in b/graphics/flphoto/files/patch-Makefile.in
deleted file mode 100644
index cf8f43e38bb4..000000000000
--- a/graphics/flphoto/files/patch-Makefile.in
+++ /dev/null
@@ -1,18 +0,0 @@
---- Makefile.in.orig Sun Sep 14 01:00:35 2003
-+++ Makefile.in Mon Dec 8 20:48:49 2003
-@@ -182,15 +182,9 @@
- $(CP) flphoto$(EXEEXT) $(DESTDIR)$(bindir)
- $(FLTKCONFIG) --post $(DESTDIR)$(bindir)/flphoto$(EXEEXT)
- echo Installing flPhoto manpages in $(DESTDIR)$(mandir)
-- -$(MKDIR) $(DESTDIR)$(mandir)/cat1
-- $(RM) $(DESTDIR)$(mandir)/cat1/flphoto.$(CAT1EXT)
-- $(CP) $(srcdir)/doc/flphoto.1 $(DESTDIR)$(mandir)/cat1/flphoto.$(CAT1EXT)
- -$(MKDIR) $(DESTDIR)$(mandir)/man1
- $(RM) $(DESTDIR)$(mandir)/man1/flphoto.1
- $(CP) $(srcdir)/doc/flphoto.man $(DESTDIR)$(mandir)/man1/flphoto.1
-- -$(MKDIR) $(DESTDIR)$(mandir)/cat5
-- $(RM) $(DESTDIR)$(mandir)/cat5/album.$(CAT5EXT)
-- $(CP) $(srcdir)/doc/album.5 $(DESTDIR)$(mandir)/cat5/album.$(CAT5EXT)
- -$(MKDIR) $(DESTDIR)$(mandir)/man5
- $(RM) $(DESTDIR)$(mandir)/man5/album.5
- $(CP) $(srcdir)/doc/album.man $(DESTDIR)$(mandir)/man5/album.5
diff --git a/graphics/flphoto/pkg-plist b/graphics/flphoto/pkg-plist
index 74495a3566eb..7573a7a493cc 100644
--- a/graphics/flphoto/pkg-plist
+++ b/graphics/flphoto/pkg-plist
@@ -1,31 +1,34 @@
bin/flphoto
-share/doc/flphoto/COPYING
-share/doc/flphoto/README
-share/doc/flphoto/about.html
-share/doc/flphoto/slideshow.html
-share/doc/flphoto/relnotes.html
-share/doc/flphoto/print.html
-share/doc/flphoto/license.html
-share/doc/flphoto/index.html
-share/doc/flphoto/import.html
-share/doc/flphoto/images.html
-share/doc/flphoto/export.html
-share/doc/flphoto/download.html
-share/doc/flphoto/contents.html
-share/doc/flphoto/albums.html
-share/doc/flphoto/view.html
-share/doc/flphoto/camera.jpg
-share/doc/flphoto/scale.jpg
-share/doc/flphoto/print4.jpg
-share/doc/flphoto/print3.jpg
-share/doc/flphoto/print2.jpg
-share/doc/flphoto/print.jpg
-share/doc/flphoto/jpeg.jpg
-share/doc/flphoto/flphoto.jpg
-share/doc/flphoto/export.jpg
-share/doc/flphoto/crop.jpg
-share/doc/flphoto/slideshow.jpg
-share/doc/flphoto/flphoto.png
+%%DOCSDIR%%/README
+%%DOCSDIR%%/about.html
+%%DOCSDIR%%/albums.html
+%%DOCSDIR%%/camera.jpg
+%%DOCSDIR%%/contents.html
+%%DOCSDIR%%/crop.jpg
+%%DOCSDIR%%/download.html
+%%DOCSDIR%%/export.html
+%%DOCSDIR%%/export.jpg
+%%DOCSDIR%%/flphoto.jpg
+%%DOCSDIR%%/flphoto.png
+%%DOCSDIR%%/images.html
+%%DOCSDIR%%/import.html
+%%DOCSDIR%%/index.html
+%%DOCSDIR%%/jpeg.jpg
+%%DOCSDIR%%/license.html
+%%DOCSDIR%%/options.html
+%%DOCSDIR%%/options1.jpg
+%%DOCSDIR%%/options2.jpg
+%%DOCSDIR%%/options3.jpg
+%%DOCSDIR%%/print.html
+%%DOCSDIR%%/print.jpg
+%%DOCSDIR%%/print2.jpg
+%%DOCSDIR%%/print3.jpg
+%%DOCSDIR%%/print4.jpg
+%%DOCSDIR%%/relnotes.html
+%%DOCSDIR%%/scale.jpg
+%%DOCSDIR%%/slideshow.html
+%%DOCSDIR%%/slideshow.jpg
+%%DOCSDIR%%/view.html
share/locale/de/flphoto_de
share/locale/en_CA/flphoto_en_CA
share/locale/en_GB/flphoto_en_GB
@@ -34,4 +37,4 @@ share/locale/fr/flphoto_fr
share/locale/it/flphoto_it
share/locale/nl/flphoto_nl
share/locale/pt/flphoto_pt
-@dirrm share/doc/flphoto
+@dirrm %%DOCSDIR%%