aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2004-02-26 20:25:02 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2004-02-26 20:25:02 +0000
commitae12e2aa4145aa48d203443b8ed927734af7f747 (patch)
tree0076b419cdccaa623e2d43fd2887f051d6aab37f
parent81250a8ee9bf12d5e3546858c4e476c6ac5adb87 (diff)
downloadports-ae12e2aa4145aa48d203443b8ed927734af7f747.tar.gz
ports-ae12e2aa4145aa48d203443b8ed927734af7f747.zip
Notes
-rw-r--r--net/Makefile1
-rw-r--r--net/tinyldap/Makefile45
-rw-r--r--net/tinyldap/distinfo2
-rw-r--r--net/tinyldap/files/patch-Makefile46
-rw-r--r--net/tinyldap/files/patch-auth.c9
-rw-r--r--net/tinyldap/files/patch-idx2ldif.c18
-rw-r--r--net/tinyldap/files/patch-md5password.c9
-rw-r--r--net/tinyldap/files/patch-mstorage_add.c14
-rw-r--r--net/tinyldap/files/patch-tinyldap.c15
-rw-r--r--net/tinyldap/pkg-descr5
-rw-r--r--net/tinyldap/pkg-plist17
11 files changed, 181 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index ad9942d652ef..79e06b474338 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -623,6 +623,7 @@
SUBDIR += tintin++
SUBDIR += tintin++-devel
SUBDIR += tinyfugue
+ SUBDIR += tinyldap
SUBDIR += tkabber
SUBDIR += tn3270
SUBDIR += tn5250
diff --git a/net/tinyldap/Makefile b/net/tinyldap/Makefile
new file mode 100644
index 000000000000..61b489d7140e
--- /dev/null
+++ b/net/tinyldap/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: tinyldap
+# Date Created: 26 Feb 2004
+# Whom: dirk.meyer@dinoex.sub.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= tinyldap
+PORTVERSION= 0.0.20040226
+CATEGORIES= net
+MASTER_SITES= ftp://ftp.dinoex.de/pub/tinyldap/
+
+MAINTAINER= dinoex@FreeBSD.org
+COMMENT= A small LDAP implementation
+
+BUILD_DEPENDS+= ${LOCALBASE}/lib/libowfat.a:${PORTSDIR}/${LIBOWFAT_PORT}
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}
+LIBOWFAT_PORT?= devel/libowfat
+SBINFILES= dumpidx idx2ldif addindex parse tinyldap_debug \
+ tinyldap_standalone
+BINFILES= ldapclient ldapclient_str md5password
+DOCFILES= FORMAT GETTING.STARTED README RFCs THANKS TODO
+
+post-patch:
+ ${TOUCH} ${WRKSRC}/alloca.h
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/tinyldap ${PREFIX}/libexec/
+.for i in ${BINFILES}
+ ${INSTALL_PROGRAM} ${WRKSRC}/${i} ${PREFIX}/bin/
+.endfor
+.for i in ${SBINFILES}
+ ${INSTALL_PROGRAM} ${WRKSRC}/${i} ${PREFIX}/sbin/
+.endfor
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for i in ${DOCFILES}
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}/
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/net/tinyldap/distinfo b/net/tinyldap/distinfo
new file mode 100644
index 000000000000..9d05debb4b58
--- /dev/null
+++ b/net/tinyldap/distinfo
@@ -0,0 +1,2 @@
+MD5 (tinyldap-0.0.20040226.tar.bz2) = 2863609a4aab26e1b0b9d0086d8b34fc
+SIZE (tinyldap-0.0.20040226.tar.bz2) = 33755
diff --git a/net/tinyldap/files/patch-Makefile b/net/tinyldap/files/patch-Makefile
new file mode 100644
index 000000000000..dc53c069c531
--- /dev/null
+++ b/net/tinyldap/files/patch-Makefile
@@ -0,0 +1,46 @@
+--- Makefile.orig Sat Feb 14 01:31:42 2004
++++ Makefile Thu Feb 26 16:06:04 2004
+@@ -32,13 +32,16 @@
+
+ auth.a: auth.o
+
+-DIET=/opt/diet/bin/diet -Os
+-CC=gcc
+-CFLAGS=-pipe -I. -Wall -W
++DIET=
++CC?=gcc
++CFLAGS?=-pipe -I. -Wall -W
+ ifneq ($(DEBUG),)
+-DIET=/opt/diet/bin/diet
+-CFLAGS=-pipe -I. -Wall -W -g
++DIET=
++CFLAGS+=-g
+ endif
++CFLAGS+=-I. -I/usr/local/include/libowfat
++LDFLAGS+=-L/usr/local/lib
++LIBS+=-lmd
+
+ %.o: %.c
+ $(DIET) $(CC) $(CFLAGS) -c $<
+@@ -47,7 +50,7 @@
+ ar cru $@ $^
+
+ %: %.c
+- $(DIET) $(CC) $(CFLAGS) -o $@ $^ $(LDFLAGS) -lowfat
++ $(DIET) $(CC) $(CFLAGS) -o $@ $^ $(LDFLAGS) -lowfat ${LIBS}
+
+ t1 parse: ldif.a storage.a
+ t2: ldap.a asn1.a
+@@ -58,10 +61,10 @@
+ idx2ldif: ldap.a
+
+ tinyldap_standalone: tinyldap.c
+- $(DIET) $(CC) $(CFLAGS) -DSTANDALONE -o $@ $^ $(LDFLAGS) -lowfat
++ $(DIET) $(CC) $(CFLAGS) -DSTANDALONE -o $@ $^ $(LDFLAGS) -lowfat ${LIBS}
+
+ tinyldap_debug: tinyldap.c
+- $(DIET) $(CC) $(CFLAGS) -DSTANDALONE -DDEBUG -o $@ $^ $(LDFLAGS) -lowfat
++ $(DIET) $(CC) $(CFLAGS) -DSTANDALONE -DDEBUG -o $@ $^ $(LDFLAGS) -lowfat ${LIBS}
+
+ .PHONY: clean tar
+ clean:
diff --git a/net/tinyldap/files/patch-auth.c b/net/tinyldap/files/patch-auth.c
new file mode 100644
index 000000000000..f22e9eb7d111
--- /dev/null
+++ b/net/tinyldap/files/patch-auth.c
@@ -0,0 +1,9 @@
+--- auth.c.orig Tue May 14 22:26:20 2002
++++ auth.c Thu Feb 26 16:03:58 2004
+@@ -1,3 +1,6 @@
++#ifdef __FreeBSD__
++#include <sys/types.h>
++#endif
+ #include <md5.h>
+ #include "ldap.h"
+ #include "auth.h"
diff --git a/net/tinyldap/files/patch-idx2ldif.c b/net/tinyldap/files/patch-idx2ldif.c
new file mode 100644
index 000000000000..f8b20b0a625c
--- /dev/null
+++ b/net/tinyldap/files/patch-idx2ldif.c
@@ -0,0 +1,18 @@
+--- idx2ldif.c.orig Thu Feb 5 01:02:52 2004
++++ idx2ldif.c Thu Feb 26 16:03:58 2004
+@@ -35,6 +35,7 @@
+ unsigned long filelen;
+ char* fn=argc<2?"data":argv[1];
+ char* map=mmap_read(fn,&filelen);
++ uint32 magic,attribute_count,record_count,indices_offset,size_of_string_table;
+ if (!map) {
+ buffer_puts(buffer_2,"could not open ");
+ buffer_puts(buffer_2,fn);
+@@ -43,7 +44,6 @@
+ buffer_putnlflush(buffer_2);
+ return 1;
+ }
+- uint32 magic,attribute_count,record_count,indices_offset,size_of_string_table;
+ uint32_unpack(map,&magic);
+ uint32_unpack(map+4,&attribute_count);
+ uint32_unpack(map+2*4,&record_count);
diff --git a/net/tinyldap/files/patch-md5password.c b/net/tinyldap/files/patch-md5password.c
new file mode 100644
index 000000000000..836a1e2023fe
--- /dev/null
+++ b/net/tinyldap/files/patch-md5password.c
@@ -0,0 +1,9 @@
+--- md5password.c.orig Thu Feb 5 01:08:49 2004
++++ md5password.c Thu Feb 26 16:03:58 2004
+@@ -1,3 +1,6 @@
++#ifdef __FreeBSD__
++#include <sys/types.h>
++#endif
+ #include <md5.h>
+ #include <string.h>
+ #include "buffer.h"
diff --git a/net/tinyldap/files/patch-mstorage_add.c b/net/tinyldap/files/patch-mstorage_add.c
new file mode 100644
index 000000000000..d93d3b1e6e73
--- /dev/null
+++ b/net/tinyldap/files/patch-mstorage_add.c
@@ -0,0 +1,14 @@
+--- mstorage_add.c.orig Thu Feb 5 00:27:01 2004
++++ mstorage_add.c Thu Feb 26 16:03:58 2004
+@@ -54,9 +54,9 @@
+ if (!tmp) return -1;
+ } else {
+ munmap(p->root,p->used);
+- tmp=mmap(0,need,PROT_READ|PROT_WRITE,MAP_SHARED,fd,0);
++ tmp=mmap(0,need,PROT_READ|PROT_WRITE,MAP_SHARED,p->fd,0);
+ if (tmp==-1) {
+- tmp=mmap(0,p->used,PROT_READ|PROT_WRITE,MAP_SHARED,fd,0);
++ tmp=mmap(0,p->used,PROT_READ|PROT_WRITE,MAP_SHARED,p->fd,0);
+ /* this can never fail, because we mmap exactly as much as we
+ * had mmapped previously. We need to munmap before doing the
+ * new mmap, though, because we may run into the address space
diff --git a/net/tinyldap/files/patch-tinyldap.c b/net/tinyldap/files/patch-tinyldap.c
new file mode 100644
index 000000000000..76eb407f07fd
--- /dev/null
+++ b/net/tinyldap/files/patch-tinyldap.c
@@ -0,0 +1,15 @@
+--- tinyldap.c.orig Thu Feb 5 02:29:18 2004
++++ tinyldap.c Thu Feb 26 16:03:58 2004
+@@ -14,7 +14,12 @@
+ #ifdef STANDALONE
+ #include "socket.h"
+ #include "ip6.h"
++#ifdef __FreeBSD__
++#include <sys/types.h>
++#include <sys/wait.h>
++#else
+ #include <wait.h>
++#endif
+ #endif
+ #include "case.h"
+ #include <signal.h>
diff --git a/net/tinyldap/pkg-descr b/net/tinyldap/pkg-descr
new file mode 100644
index 000000000000..c2b2bdf9693b
--- /dev/null
+++ b/net/tinyldap/pkg-descr
@@ -0,0 +1,5 @@
+tinyldap is an attempt to write a very small and very fast LDAP server.
+openldap is the reference when it comes to LDAP servers, and it performs
+very poorly despite using techniques such as thread pools.
+
+WWW: http://www.fefe.de/tinyldap/
diff --git a/net/tinyldap/pkg-plist b/net/tinyldap/pkg-plist
new file mode 100644
index 000000000000..2ad00c19bc79
--- /dev/null
+++ b/net/tinyldap/pkg-plist
@@ -0,0 +1,17 @@
+bin/ldapclient
+bin/ldapclient_str
+bin/md5password
+libexec/tinyldap
+sbin/addindex
+sbin/dumpidx
+sbin/idx2ldif
+sbin/parse
+sbin/tinyldap_debug
+sbin/tinyldap_standalone
+%%PORTDOCS%%%%DOCSDIR%%/FORMAT
+%%PORTDOCS%%%%DOCSDIR%%/GETTING.STARTED
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/RFCs
+%%PORTDOCS%%%%DOCSDIR%%/THANKS
+%%PORTDOCS%%%%DOCSDIR%%/TODO
+%%PORTDOCS%%@dirrm %%DOCSDIR%%