aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2006-12-12 12:39:56 +0000
committerMartin Wilke <miwi@FreeBSD.org>2006-12-12 12:39:56 +0000
commitaf0eab71845ec803b0be3030eb6aa7ba298dec51 (patch)
tree881bf92e8b75ba2cb4f67f0321bc42a139f27119
parent3d8a32784d3aa8d6e26d58f8b3f3fa0280a7d090 (diff)
downloadports-af0eab71845ec803b0be3030eb6aa7ba298dec51.tar.gz
ports-af0eab71845ec803b0be3030eb6aa7ba298dec51.zip
Notes
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/isomaster/Makefile35
-rw-r--r--sysutils/isomaster/distinfo3
-rw-r--r--sysutils/isomaster/files/patch-Makefile11
-rw-r--r--sysutils/isomaster/files/patch-bk-Makefile11
-rw-r--r--sysutils/isomaster/files/patch-bk.h10
-rw-r--r--sysutils/isomaster/pkg-descr8
-rw-r--r--sysutils/isomaster/pkg-plist7
8 files changed, 86 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index fed006a9fd30..3c97848f4a0b 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -288,6 +288,7 @@
SUBDIR += ipmi-kmod
SUBDIR += ipmitool
SUBDIR += ipsc
+ SUBDIR += isomaster
SUBDIR += jailadmin
SUBDIR += jailctl
SUBDIR += jailer
diff --git a/sysutils/isomaster/Makefile b/sysutils/isomaster/Makefile
new file mode 100644
index 000000000000..d50643dd8fbd
--- /dev/null
+++ b/sysutils/isomaster/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: isomaster
+# Date created: 2006-12-11
+# Whom: Babak Farrokhi <farrokhi@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= isomaster
+PORTVERSION= 0.6
+CATEGORIES= sysutils
+MASTER_SITES= http://littlesvr.ca/isomaster/releases/
+
+MAINTAINER= farrokhi@FreeBSD.org
+COMMENT= GTK2 (bootable) CD ISO Image editor
+
+USE_BZIP2= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}
+USE_GNOME= gtk20 pkgconfig intlhack gnomehier
+USE_GMAKE= yes
+USE_GETTEXT= yes
+INSTALLS_ICON= yes
+ALL_TARGET= ${PORTNAME}
+
+MAKE_ENV= PREFIX=${PREFIX}
+CFLAGS+= ${PTHREAD_CFLAGS} ${PTHREAD_LIBS:S/"//g} \
+ -D_FILE_OFFSET_BITS=64 \
+ `pkg-config --cflags gtk+-2.0`
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= does not compile on 4.x
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/sysutils/isomaster/distinfo b/sysutils/isomaster/distinfo
new file mode 100644
index 000000000000..1b7c7e8adcac
--- /dev/null
+++ b/sysutils/isomaster/distinfo
@@ -0,0 +1,3 @@
+MD5 (isomaster-0.6.tar.bz2) = a098b7879fe109cc28fa501050998446
+SHA256 (isomaster-0.6.tar.bz2) = b2e14c090000ca01df9962ae1f986454467ebfa774729a9279459d578eff7f1c
+SIZE (isomaster-0.6.tar.bz2) = 151174
diff --git a/sysutils/isomaster/files/patch-Makefile b/sysutils/isomaster/files/patch-Makefile
new file mode 100644
index 000000000000..ccdb593f2f47
--- /dev/null
+++ b/sysutils/isomaster/files/patch-Makefile
@@ -0,0 +1,11 @@
+--- Makefile.orig Tue Dec 12 12:08:11 2006
++++ Makefile Tue Dec 12 12:08:20 2006
+@@ -24,7 +24,7 @@
+ GTKLIBS = `pkg-config --libs gtk+-2.0`
+ GTKFLAGS = `pkg-config --cflags gtk+-2.0`
+ # the _FILE_OFFSET_BITS=64 is to enable stat() for large files
+-GLOBALFLAGS = -D_FILE_OFFSET_BITS=64 -Wall
++GLOBALFLAGS = ${CFLAGS}
+ GLOBALDEPS = bk/bk.h Makefile
+
+ isomaster: lib iniparser translations isomaster.o window.o browser.o fsbrowser.o isobrowser.o error.o about.o settings.o boot.o $(GLOBALDEPS)
diff --git a/sysutils/isomaster/files/patch-bk-Makefile b/sysutils/isomaster/files/patch-bk-Makefile
new file mode 100644
index 000000000000..01006d168600
--- /dev/null
+++ b/sysutils/isomaster/files/patch-bk-Makefile
@@ -0,0 +1,11 @@
+--- bk/Makefile.orig Tue Dec 12 12:11:07 2006
++++ bk/Makefile Tue Dec 12 12:11:22 2006
+@@ -2,7 +2,7 @@
+ GLOBALDEPS = Makefile bk.h
+ # the _FILE_OFFSET_BITS=64 is to enable stat() for large files
+ # DEBUG and -g only used during development
+-GLOBALFLAGS = -D_FILE_OFFSET_BITS=64 -Wall
++GLOBALFLAGS = ${CFLAGS}
+
+ bk.a: $(OBJECTS)
+ ar -cr bk.a $(OBJECTS)
diff --git a/sysutils/isomaster/files/patch-bk.h b/sysutils/isomaster/files/patch-bk.h
new file mode 100644
index 000000000000..16e5345d4127
--- /dev/null
+++ b/sysutils/isomaster/files/patch-bk.h
@@ -0,0 +1,10 @@
+--- bk/bk.h.orig Mon Dec 11 15:55:38 2006
++++ bk/bk.h Mon Dec 11 15:56:01 2006
+@@ -22,6 +22,7 @@
+
+ #include <stdbool.h>
+ #include <stdlib.h>
++#include <unistd.h>
+
+ #include "bkError.h"
+
diff --git a/sysutils/isomaster/pkg-descr b/sysutils/isomaster/pkg-descr
new file mode 100644
index 000000000000..81a916bdb72e
--- /dev/null
+++ b/sysutils/isomaster/pkg-descr
@@ -0,0 +1,8 @@
+ISO Master is an open-source, graphical CD image editor
+that runs on Linux; and bkisofs, the underlying library
+used for reading, modifying and writing ISO images.
+
+Basically you can use this program to extract files from
+an ISO, add files to an ISO and create bootable ISOs.
+
+WWW: http://littlesvr.ca/isomaster/
diff --git a/sysutils/isomaster/pkg-plist b/sysutils/isomaster/pkg-plist
new file mode 100644
index 000000000000..d28e02e6ae0b
--- /dev/null
+++ b/sysutils/isomaster/pkg-plist
@@ -0,0 +1,7 @@
+bin/isomaster
+%%DATADIR%%/icons/add2-kearone.png
+%%DATADIR%%/icons/extract-kearone.png
+%%DATADIR%%/icons/folder-new-tango.png
+%%DATADIR%%/icons/isomaster.png
+@dirrm %%DATADIR%%/icons
+@dirrm %%DATADIR%%