aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYen-Ming Lee <leeym@FreeBSD.org>2005-08-31 17:53:15 +0000
committerYen-Ming Lee <leeym@FreeBSD.org>2005-08-31 17:53:15 +0000
commitb404c7cd9d48cfe9b2a2803bb093303beb0f3a8d (patch)
treef3b79e4e5b13afe67033c4f1cabf5fed150d72e0
parentf0e2ba185348fe87d1977a983653796f12498438 (diff)
downloadports-b404c7cd9d48cfe9b2a2803bb093303beb0f3a8d.tar.gz
ports-b404c7cd9d48cfe9b2a2803bb093303beb0f3a8d.zip
Notes
-rw-r--r--www/p5-Apache-ParseFormData/Makefile11
-rw-r--r--www/p5-Apache-ParseFormData/files/patch-ParseFormData.pm58
2 files changed, 63 insertions, 6 deletions
diff --git a/www/p5-Apache-ParseFormData/Makefile b/www/p5-Apache-ParseFormData/Makefile
index 2eceedb28d65..12a941c77281 100644
--- a/www/p5-Apache-ParseFormData/Makefile
+++ b/www/p5-Apache-ParseFormData/Makefile
@@ -15,22 +15,21 @@ PKGNAMEPREFIX= p5-
MAINTAINER= nistor@snickers.org
COMMENT= Module allows you to easily decode/parse form and query data
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Apache2/mod_perl.pm:${PORTSDIR}/www/mod_perl2
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/mod_perl2.pm:${PORTSDIR}/www/mod_perl2
RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
-BROKEN= Broken due the new mod_perl2 API
-DEPRECATED= ${BROKEN}
-EXPIRATION_DATE=2005-09-22
-
MAN3= Apache::ParseFormData.3
+post-patch:
+ @${FIND} ${WRKSRC} -name "*.orig" -delete
+
.include <bsd.port.pre.mk>
# mod_perl 2 requires it
.if ${PERL_LEVEL} < 500800
-IGNORE= requires perl 5.8.x or later. Install lang/perl5.8 then try again
+IGNORE= requires perl 5.8.x or later. Install lang/perl5.8 then try again
.endif
.include <bsd.port.post.mk>
diff --git a/www/p5-Apache-ParseFormData/files/patch-ParseFormData.pm b/www/p5-Apache-ParseFormData/files/patch-ParseFormData.pm
new file mode 100644
index 000000000000..345f4c6cff37
--- /dev/null
+++ b/www/p5-Apache-ParseFormData/files/patch-ParseFormData.pm
@@ -0,0 +1,58 @@
+--- ParseFormData.pm.orig Fri Jul 29 00:00:48 2005
++++ ParseFormData.pm Fri Jul 29 00:01:41 2005
+@@ -11,9 +11,9 @@
+ package Apache::ParseFormData;
+
+ use strict;
+-use Apache::Log;
+-use Apache::Const -compile => qw(OK M_POST M_GET FORBIDDEN HTTP_REQUEST_ENTITY_TOO_LARGE);
+-use Apache::RequestIO ();
++use Apache2::Log;
++use Apache2::Const -compile => qw(OK M_POST M_GET FORBIDDEN HTTP_REQUEST_ENTITY_TOO_LARGE);
++use Apache2::RequestIO ();
+ use APR::Table;
+ use IO::File;
+ use POSIX qw(tmpnam);
+@@ -44,12 +44,12 @@
+ if(my $data = $self->headers_in->get('cookie')) {
+ &_parse_query($self, $data, " *; *");
+ }
+- if($self->method_number == Apache::M_POST) {
++ if($self->method_number == Apache2::Const::M_POST) {
+ $self->pnotes('apr_req_result' => &parse_content($self, \%args));
+- } elsif($self->method_number == Apache::M_GET) {
++ } elsif($self->method_number == Apache2::Const::M_GET) {
+ my $data = $self->args();
+ &_parse_query($self, $data) if($data);
+- $self->pnotes('apr_req_result' => Apache::OK);
++ $self->pnotes('apr_req_result' => Apache2::Const::OK);
+ }
+ return($self);
+ }
+@@ -139,7 +139,7 @@
+ my $error_str = "[Apache::ParseFormData] file upload forbidden";
+ $r->notes->set("error-notes" => $error_str);
+ $r->log_error($error_str);
+- return(Apache::FORBIDDEN);
++ return(Apache2::Const::FORBIDDEN);
+ }
+ my $rm = $r->remaining;
+ if($args->{'post_max'} && ($rm > $args->{'post_max'})) {
+@@ -147,7 +147,7 @@
+ my $error_str = "[Apache::ParseFormData] entity too large ($rm, max=$pm)";
+ $r->notes->set("error-notes" => $error_str);
+ $r->log_error($error_str);
+- return(Apache::HTTP_REQUEST_ENTITY_TOO_LARGE);
++ return(Apache2::Const::HTTP_REQUEST_ENTITY_TOO_LARGE);
+ }
+ if($ct =~ /^multipart\/form-data; boundary=(.+)$/) {
+ my $boundary = $1;
+@@ -196,7 +196,7 @@
+ $r->get_client_block($buf, $len);
+ &_parse_query($r, $buf) if($buf);
+ }
+- return(Apache::OK);
++ return(Apache2::Const::OK);
+ }
+
+ sub extract_headers {