aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2001-08-15 11:33:32 +0000
committerAnton Berezin <tobez@FreeBSD.org>2001-08-15 11:33:32 +0000
commitb8c21a03d97020d827071ddc9797cb053fa51058 (patch)
tree2eed9738eedd735a98085eb2758dfac6c40a6a57
parent05a66bcaf302fae631e9e83dff6d2809a4d4e8ee (diff)
downloadports-b8c21a03d97020d827071ddc9797cb053fa51058.tar.gz
ports-b8c21a03d97020d827071ddc9797cb053fa51058.zip
Notes
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/p5-URI-Find/Makefile26
-rw-r--r--textproc/p5-URI-Find/distinfo1
-rw-r--r--textproc/p5-URI-Find/pkg-comment1
-rw-r--r--textproc/p5-URI-Find/pkg-descr11
-rw-r--r--textproc/p5-URI-Find/pkg-plist7
6 files changed, 47 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 103ebecbb72a..309fb9d01476 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -122,6 +122,7 @@
SUBDIR += p5-Text-Wrapper
SUBDIR += p5-Tk-XMLViewer
SUBDIR += p5-Tree-Nary
+ SUBDIR += p5-URI-Find
SUBDIR += p5-XML-DOM
SUBDIR += p5-XML-DT
SUBDIR += p5-XML-Dumper
diff --git a/textproc/p5-URI-Find/Makefile b/textproc/p5-URI-Find/Makefile
new file mode 100644
index 000000000000..24fd8b01f326
--- /dev/null
+++ b/textproc/p5-URI-Find/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: p5-URI-Find
+# Date created: 13 August 2001
+# Whom: Pete Fritchman <petef@databits.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= URI-Find
+PORTVERSION= 0.11
+CATEGORIES= textproc net perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= URI
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= petef@databits.net
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/URI.pm:${PORTSDIR}/net/p5-URI
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= URI::Find.3 \
+ URI::Find::Schemeless.3
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-URI-Find/distinfo b/textproc/p5-URI-Find/distinfo
new file mode 100644
index 000000000000..b048a56c8690
--- /dev/null
+++ b/textproc/p5-URI-Find/distinfo
@@ -0,0 +1 @@
+MD5 (URI-Find-0.11.tar.gz) = 7d17d6f420415f4b351cdec5e5c42a82
diff --git a/textproc/p5-URI-Find/pkg-comment b/textproc/p5-URI-Find/pkg-comment
new file mode 100644
index 000000000000..2ce8af1e5bc3
--- /dev/null
+++ b/textproc/p5-URI-Find/pkg-comment
@@ -0,0 +1 @@
+Perl module to find URIs in arbitrary text
diff --git a/textproc/p5-URI-Find/pkg-descr b/textproc/p5-URI-Find/pkg-descr
new file mode 100644
index 000000000000..de59fe0b0e7d
--- /dev/null
+++ b/textproc/p5-URI-Find/pkg-descr
@@ -0,0 +1,11 @@
+This module does one thing: finds URIs and URLs in plain text. It
+finds them quickly and it finds them all (or what URI::URL considers
+a URI to be). It employs a series of heuristics too:
+ - Find schemeless URIs (ie. www.foo.com)
+ - Avoid picking up trailing characters from the text
+ - Avoid picking up URL-like things such as Perl module names.
+
+WWW: http://search.cpan.org/search?dist=URI-Find
+
+- Pete
+petef@databits.net
diff --git a/textproc/p5-URI-Find/pkg-plist b/textproc/p5-URI-Find/pkg-plist
new file mode 100644
index 000000000000..02e00aca6b45
--- /dev/null
+++ b/textproc/p5-URI-Find/pkg-plist
@@ -0,0 +1,7 @@
+lib/perl5/site_perl/%%PERL_VER%%/URI/Find.pm
+lib/perl5/site_perl/%%PERL_VER%%/URI/Find/Schemeless.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/URI/Find/.packlist
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/URI/Find
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/URI 2>/dev/null || true
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/URI/Find
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/URI 2>/dev/null || true