aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2015-05-15 19:59:30 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2015-05-15 19:59:30 +0000
commitbb1d25a091cd60e602e858a4e5ae6b14de436de6 (patch)
tree0e4ee10469d439b767440160ad9c1473e4957dc9
parent61fe94530ad8af5ea87f8689aacfea5911d109a0 (diff)
downloadports-bb1d25a091cd60e602e858a4e5ae6b14de436de6.tar.gz
ports-bb1d25a091cd60e602e858a4e5ae6b14de436de6.zip
- Update www/kannel to 1.4.4 (note that it's newer than development version 1.5.0)
- Add license - Add kannel user/group - Split and fix rc script - Pass maintainership to submitter PR: 200061 Submitted by: dbaio@bsd.com.br
Notes
Notes: svn path=/head/; revision=386476
-rw-r--r--GIDs1
-rw-r--r--UIDs1
-rw-r--r--www/kannel/Makefile23
-rw-r--r--www/kannel/distinfo4
-rw-r--r--www/kannel/files/kannel.in80
-rw-r--r--www/kannel/files/kannel_bearerbox.in55
-rw-r--r--www/kannel/files/kannel_smsbox.in65
-rw-r--r--www/kannel/files/kannel_wapbox.in65
-rw-r--r--www/kannel/files/patch-debian__kannel.conf15
-rw-r--r--www/kannel/files/patch-gw_smskannel.conf29
-rw-r--r--www/kannel/files/patch-gw_wapkannel.conf28
-rw-r--r--www/kannel/files/patch-gwlib__gwthread-pthread.c45
-rw-r--r--www/kannel/pkg-descr5
-rw-r--r--www/kannel/pkg-plist8
14 files changed, 274 insertions, 150 deletions
diff --git a/GIDs b/GIDs
index f20faa32f494..716f205d61d2 100644
--- a/GIDs
+++ b/GIDs
@@ -310,6 +310,7 @@ emby:*:989:
oozie:*:990:
sguil:*:991:
hive:*:992:
+kannel:*:993:
ebnetd:*:999:
nogroup:*:65533:
nobody:*:65534:
diff --git a/UIDs b/UIDs
index 2198318615e8..662778c156f4 100644
--- a/UIDs
+++ b/UIDs
@@ -319,5 +319,6 @@ emby:*:989:989::0:0:Emby:/nonexistent:/usr/sbin/nologin
oozie:*:990:990::0:0:Apache Oozie user:/nonexistent:/usr/sbin/nologin
sguil:*:991:991::0:0:Sguil:/nonexistent:/usr/sbin/nologin
hive:*:992:992::0:0:Apache Hive user:/nonexistent:/usr/sbin/nologin
+kannel:*:993:993::0:0:Kannel User:/nonexistent:/usr/sbin/nologin
ebnetd:*:999:999::0:0:EBNETD:/nonexistent:/usr/sbin/nologin
nobody:*:65534:65534::0:0:Unprivileged user:/nonexistent:/usr/sbin/nologin
diff --git a/www/kannel/Makefile b/www/kannel/Makefile
index 59f7a4ce685d..e1ec2d634df7 100644
--- a/www/kannel/Makefile
+++ b/www/kannel/Makefile
@@ -2,21 +2,30 @@
# $FreeBSD$
PORTNAME= kannel
-PORTVERSION= 1.5.0
-PORTREVISION= 5
+PORTVERSION= 1.4.4
+PORTEPOCH= 1
CATEGORIES= www
MASTER_SITES= http://www.kannel.org/download/${PORTVERSION}/
DISTNAME= gateway-${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= dbaio@bsd.com.br
COMMENT= WAP/SMS gateway
+LICENSE= The_Kannel_Software_License
+LICENSE_NAME= The Kannel Software License, Version 1.0
+LICENSE_FILE= ${WRKSRC}/LICENSE
+LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
+
LIB_DEPENDS= libpcre.so:${PORTSDIR}/devel/pcre
-USES= tar:bzip2 gmake
+USERS= kannel
+GROUPS= kannel
+
+USES= tar:bzip2 gmake bison
+USE_GCC= yes
USE_GNOME= libxml2
USE_OPENSSL= yes
-USE_RC_SUBR= ${PORTNAME}
+USE_RC_SUBR= ${PORTNAME}_bearerbox ${PORTNAME}_smsbox ${PORTNAME}_wapbox
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-cflags="${CPPFLAGS}" --with-libs="${LDFLAGS}" \
--enable-pcre=yes --enable-docs=no --with-malloc=native \
@@ -42,11 +51,13 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/gw/${filename} \
${STAGEDIR}${PREFIX}/etc/${filename}.sample
.endfor
-.for filename in mtbatch seewbmp wmlsc wmlsdasm
+.for filename in mtbatch seewbmp wmlsc wmlsdasm decode_emimsg
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${filename}
.endfor
.for filename in bearerbox run_kannel_box smsbox wapbox
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/sbin/${filename}
.endfor
+ @${MKDIR} ${STAGEDIR}/var/log/kannel
+ @${MKDIR} ${STAGEDIR}/var/run/kannel
.include <bsd.port.mk>
diff --git a/www/kannel/distinfo b/www/kannel/distinfo
index ec52fdc90c9d..bb8b99a2d998 100644
--- a/www/kannel/distinfo
+++ b/www/kannel/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gateway-1.5.0.tar.bz2) = e882cd2641985922a6629788691f12deb3e1d36a96cc1091df9416825bb1506a
-SIZE (gateway-1.5.0.tar.bz2) = 2897146
+SHA256 (gateway-1.4.4.tar.bz2) = df665b600d1960708637d0c2875f11d296677b931add0a6b3cdd102024d1a717
+SIZE (gateway-1.4.4.tar.bz2) = 2949852
diff --git a/www/kannel/files/kannel.in b/www/kannel/files/kannel.in
deleted file mode 100644
index 55eb348558b3..000000000000
--- a/www/kannel/files/kannel.in
+++ /dev/null
@@ -1,80 +0,0 @@
-#!/bin/sh
-
-# $FreeBSD$
-#
-# PROVIDE: kannel_smsbox kannel_wapbox kannel_bearerbox
-# REQUIRE: NETWORKING SERVERS
-# BEFORE: LOGIN
-# KEYWORD: shutdown
-
-. /etc/rc.subr
-
-name=kannel
-rcvar=kannel_enable
-
-command="%%PREFIX%%/sbin/run_kannel_box"
-extra_commands="reload"
-sig_reload=SIGUSR1
-
-load_rc_config $name
-# Set defaults
-kannel_config=${kannel_config:-"%%PREFIX%%/etc/kannel.conf"}
-kannel_user=${kannel_user:-"kannel"}
-# Config file is required
-if [ ! -r ${kannel_config} ]; then
- warn "${kannel_config} is not readable."
- case $1 in
- force*) : ;;
- *) exit 1 ;;
- esac
-fi
-
-if test -n ${kannel_enable:-""} && checkyesno kannel_enable; then
- kannel_bearerbox_enable=${kannel_bearerbox_enable:-"YES"}
- kannel_smsbox_enable=${kannel_smsbox_enable:-"YES"}
- kannel_wapbox_enable=${kannel_wapbox_enable:-"YES"}
-fi
-
-# bearerbox
-name=kannel_bearerbox
-rcvar=kannel_bearerbox_enable
-pidfile=/var/run/kannel/${name}.pid
-# Defaults
-kannel_bearerbox_user=${kannel_bearerbox_user:-"${kannel_user}"}
-kannel_bearerbox_enable=${kannel_bearerbox_enable:-"NO"}
-kannel_bearerbox_config=${kannel_bearerbox_config:-"${kannel_config}"}
-kannel_bearerbox_flags=${kannel_bearerbox_flags:-"--pidfile ${pidfile} %%PREFIX%%/sbin/bearerbox ${kannel_bearerbox_flags} ${kannel_bearerbox_config}"}
-#
-load_rc_config $name
-run_rc_command "$1"
-#
-_rc_restart_done=false
-
-# smsbox
-name=kannel_smsbox
-rcvar=kannel_smsbox_enable
-pidfile=/var/run/kannel/${name}.pid
-# Defaults
-kannel_smsbox_user=${kannel_smsbox_user:-"${kannel_user}"}
-kannel_smsbox_enable=${kannel_smsbox_enable:-"NO"}
-kannel_smsbox_config=${kannel_smsbox_config:-"${kannel_config}"}
-kannel_smsbox_flags=${kannel_smsbox_flags:-"--pidfile ${pidfile} %%PREFIX%%/sbin/smsbox ${kannel_smsbox_flags} ${kannel_smsbox_config}"}
-#
-load_rc_config $name
-run_rc_command "$1"
-#
-_rc_restart_done=false
-
-# wapbox
-name=kannel_wapbox
-rcvar=kannel_wapbox_enable
-pidfile=/var/run/kannel/${name}.pid
-# Defaults
-kannel_wapbox_user=${kannel_wapbox_user:-"${kannel_user}"}
-kannel_wapbox_enable=${kannel_wapbox_enable:-"NO"}
-kannel_wapbox_config=${kannel_wapbox_config:-"${kannel_config}"}
-kannel_wapbox_flags=${kannel_wapbox_flags:-"--pidfile ${pidfile} %%PREFIX%%/sbin/wapbox ${kannel_wapbox_flags} ${kannel_wapbox_config}"}
-#
-load_rc_config $name
-run_rc_command "$1"
-
diff --git a/www/kannel/files/kannel_bearerbox.in b/www/kannel/files/kannel_bearerbox.in
new file mode 100644
index 000000000000..d13605948a50
--- /dev/null
+++ b/www/kannel/files/kannel_bearerbox.in
@@ -0,0 +1,55 @@
+#!/bin/sh
+
+# $FreeBSD$
+#
+# PROVIDE: bearerbox
+# REQUIRE: LOGIN
+# KEYWORD: shutdown
+#
+# Add these lines to /etc/rc.conf.local or /etc/rc.conf
+# to enable this service:
+#
+# kannel_bearerbox_enable (bool): Set to NO by default.
+# Set it to YES to enable kannel_bearerbox.
+# kannel_bearerbox_config (path): Set to %%PREFIX%%/etc/kannel.conf
+# by default.
+
+. /etc/rc.subr
+
+name=kannel_bearerbox
+rcvar=${name}_enable
+kannel_piddir="/var/run/kannel"
+
+load_rc_config $name
+
+: ${kannel_bearerbox_enable:="NO"}
+: ${kannel_bearerbox_config="%%PREFIX%%/etc/kannel.conf"}
+: ${kannel_bearerbox_user:="kannel"}
+: ${kannel_bearerbox_group:="kannel"}
+
+command="%%PREFIX%%/sbin/run_kannel_box"
+start_precmd="${name}_prestart"
+extra_commands="reload"
+sig_reload=SIGUSR1
+
+pidfile="${kannel_piddir}/${name}.pid"
+
+command_args="--pidfile ${pidfile} %%PREFIX%%/sbin/bearerbox ${kannel_bearerbox_flags} ${kannel_bearerbox_config}"
+
+kannel_bearerbox_prestart()
+{
+ if [ ! -d "${kannel_piddir}" ]; then
+ install -d -o $kannel_bearerbox_user -g $kannel_bearerbox_group $kannel_piddir
+ fi
+ kannel_bearerbox_checkconfig
+}
+
+kannel_bearerbox_checkconfig() {
+ # Config file is required
+ if [ ! -r ${kannel_bearerbox_config} ]; then
+ warn "${kannel_bearerbox_config} is not readable."
+ exit 1
+ fi
+}
+
+run_rc_command "$1"
diff --git a/www/kannel/files/kannel_smsbox.in b/www/kannel/files/kannel_smsbox.in
new file mode 100644
index 000000000000..0ce3f34ca403
--- /dev/null
+++ b/www/kannel/files/kannel_smsbox.in
@@ -0,0 +1,65 @@
+#!/bin/sh
+
+# $FreeBSD$
+#
+# PROVIDE: smsbox
+# REQUIRE: LOGIN bearerbox
+# KEYWORD: shutdown
+#
+# Add these lines to /etc/rc.conf.local or /etc/rc.conf
+# to enable this service:
+#
+# kannel_smsbox_enable (bool): Set to NO by default.
+# Set it to YES to enable kannel_smsbox.
+# kannel_smsbox_config (path): Set to %%PREFIX%%/etc/kannel.conf
+# by default.
+
+. /etc/rc.subr
+
+name=kannel_smsbox
+rcvar=${name}_enable
+kannel_piddir="/var/run/kannel"
+
+load_rc_config $name
+
+: ${kannel_smsbox_enable:="NO"}
+: ${kannel_smsbox_config="%%PREFIX%%/etc/kannel.conf"}
+: ${kannel_smsbox_user:="kannel"}
+: ${kannel_smsbox_group:="kannel"}
+
+command="%%PREFIX%%/sbin/run_kannel_box"
+start_precmd="${name}_prestart"
+extra_commands="reload"
+sig_reload=SIGUSR1
+
+pidfile="${kannel_piddir}/${name}.pid"
+bearerbox_pidfile="${kannel_piddir}/kannel_bearerbox.pid"
+
+command_args="--pidfile ${pidfile} %%PREFIX%%/sbin/smsbox ${kannel_smsbox_flags} ${kannel_smsbox_config}"
+
+kannel_smsbox_prestart()
+{
+ if [ ! -d "${kannel_piddir}" ]; then
+ install -d -o $kannel_smsbox_user -g $kannel_smsbox_group $kannel_piddir
+ fi
+ kannel_smsbox_checkconfig
+ kannel_bearerbox_checkpid
+}
+
+kannel_smsbox_checkconfig() {
+ # Config file is required
+ if [ ! -r ${kannel_smsbox_config} ]; then
+ warn "${kannel_smsbox_config} is not readable."
+ exit 1
+ fi
+}
+
+kannel_bearerbox_checkpid() {
+ # Check if kannel bearerbox is running
+ if [ ! -e "${bearerbox_pidfile}" ]; then
+ warn "In order to run ${name} you need to run first kannel_bearerbox."
+ exit 1
+ fi
+}
+
+run_rc_command "$1"
diff --git a/www/kannel/files/kannel_wapbox.in b/www/kannel/files/kannel_wapbox.in
new file mode 100644
index 000000000000..82fd9c334841
--- /dev/null
+++ b/www/kannel/files/kannel_wapbox.in
@@ -0,0 +1,65 @@
+#!/bin/sh
+
+# $FreeBSD$
+#
+# PROVIDE: wapbox
+# REQUIRE: LOGIN bearerbox
+# KEYWORD: shutdown
+#
+# Add these lines to /etc/rc.conf.local or /etc/rc.conf
+# to enable this service:
+#
+# kannel_wapbox_enable (bool): Set to NO by default.
+# Set it to YES to enable kannel_wapbox.
+# kannel_wapbox_config (path): Set to %%PREFIX%%/etc/kannel.conf
+# by default.
+
+. /etc/rc.subr
+
+name=kannel_wapbox
+rcvar=${name}_enable
+kannel_piddir="/var/run/kannel"
+
+load_rc_config $name
+
+: ${kannel_wapbox_enable:="NO"}
+: ${kannel_wapbox_config="%%PREFIX%%/etc/kannel.conf"}
+: ${kannel_wapbox_user:="kannel"}
+: ${kannel_wapbox_group:="kannel"}
+
+command="%%PREFIX%%/sbin/run_kannel_box"
+start_precmd="${name}_prestart"
+extra_commands="reload"
+sig_reload=SIGUSR1
+
+pidfile="${kannel_piddir}/${name}.pid"
+bearerbox_pidfile="${kannel_piddir}/kannel_bearerbox.pid"
+
+command_args="--pidfile ${pidfile} %%PREFIX%%/sbin/wapbox ${kannel_wapbox_flags} ${kannel_wapbox_config}"
+
+kannel_wapbox_prestart()
+{
+ if [ ! -d "${kannel_piddir}" ]; then
+ install -d -o $kannel_wapbox_user -g $kannel_wapbox_group $kannel_piddir
+ fi
+ kannel_wapbox_checkconfig
+ kannel_bearerbox_checkpid
+}
+
+kannel_wapbox_checkconfig() {
+ # Config file is required
+ if [ ! -r ${kannel_wapbox_config} ]; then
+ warn "${kannel_wapbox_config} is not readable."
+ exit 1
+ fi
+}
+
+kannel_bearerbox_checkpid() {
+ # Check if kannel bearerbox is running
+ if [ ! -e "${bearerbox_pidfile}" ]; then
+ warn "In order to run ${name} you need to run first kannel_bearerbox."
+ exit 1
+ fi
+}
+
+run_rc_command "$1"
diff --git a/www/kannel/files/patch-debian__kannel.conf b/www/kannel/files/patch-debian__kannel.conf
deleted file mode 100644
index 64a8964b3d90..000000000000
--- a/www/kannel/files/patch-debian__kannel.conf
+++ /dev/null
@@ -1,15 +0,0 @@
---- debian/kannel.conf.orig Mon Dec 11 14:00:30 2000
-+++ debian/kannel.conf Wed Jan 3 20:11:13 2001
-@@ -13,10 +13,10 @@
- admin-allow-ip = "127.0.0.1"
- wapbox-port = 13002
- wdp-interface-name = "*"
--log-file = "/var/log/kannel/bearerbox.log"
-+log-file = "/var/log/bearerbox.log"
- box-deny-ip = "*.*.*.*"
- box-allow-ip = "127.0.0.1"
-
- group = wapbox
- bearerbox-host = localhost
--log-file = "/var/log/kannel/wapbox.log"
-+log-file = "/var/log/wapbox.log"
diff --git a/www/kannel/files/patch-gw_smskannel.conf b/www/kannel/files/patch-gw_smskannel.conf
new file mode 100644
index 000000000000..9baa54e46664
--- /dev/null
+++ b/www/kannel/files/patch-gw_smskannel.conf
@@ -0,0 +1,29 @@
+--- gw/smskannel.conf.orig 2009-02-10 16:15:58 UTC
++++ gw/smskannel.conf
+@@ -41,12 +41,12 @@ admin-password = bar
+ #status-password = foo
+ #admin-deny-ip = ""
+ #admin-allow-ip = ""
+-#log-file = "/tmp/kannel.log"
++#log-file = "/var/log/kannel/kannel.log"
+ #log-level = 0
+ box-deny-ip = "*.*.*.*"
+ box-allow-ip = "127.0.0.1"
+ #unified-prefix = "+358,00358,0;+,00"
+-#access-log = "/tmp/access.log"
++#access-log = "/var/log/kannel/access.log"
+ #store-file = "kannel.store"
+ #ssl-server-cert-file = "cert.pem"
+ #ssl-server-key-file = "key.pem"
+@@ -80,9 +80,9 @@ bearerbox-host = 127.0.0.1
+ sendsms-port = 13013
+ global-sender = 13013
+ #sendsms-chars = "0123456789 +-"
+-#log-file = "/tmp/smsbox.log"
++#log-file = "/var/log/kannel/smsbox.log"
+ #log-level = 0
+-#access-log = "/tmp/access.log"
++#access-log = "/var/log/kannel/access.log"
+
+ #---------------------------------------------
+ # SEND-SMS USERS
diff --git a/www/kannel/files/patch-gw_wapkannel.conf b/www/kannel/files/patch-gw_wapkannel.conf
new file mode 100644
index 000000000000..ae5e7cb60e12
--- /dev/null
+++ b/www/kannel/files/patch-gw_wapkannel.conf
@@ -0,0 +1,28 @@
+--- gw/wapkannel.conf.orig 2009-02-10 16:15:58 UTC
++++ gw/wapkannel.conf
+@@ -28,20 +28,20 @@ admin-password = bar
+ #admin-deny-ip = ""
+ #admin-allow-ip = ""
+ wdp-interface-name = "127.0.0.1"
+-#log-file = "/tmp/bearerbox.log"
++#log-file = "/var/log/kannel/bearerbox.log"
+ #log-level = 0
+ box-deny-ip = "*.*.*.*"
+ box-allow-ip = "127.0.0.1"
+-#access-log = "/tmp/access.log"
+-#store-file = "/tmp/kannel.store"
++#access-log = "/var/log/kannel/access.log"
++#store-file = "/var/log/kannel/kannel.store"
+ #ssl-server-cert-file = "cert.pem"
+ #ssl-server-key-file = "key.pem"
+ #ssl-certkey-file = "mycertandprivkeyfile.pem"
+
+ group = wapbox
+ bearerbox-host = 127.0.0.1
+-#log-file = "/tmp/wapbox.log"
++#log-file = "/var/log/kannel/wapbox.log"
+ #log-level = 0
+ syslog-level = none
+-#access-log = "/tmp/wapaccess.log"
++#access-log = "/var/log/kannel/wapaccess.log"
+
diff --git a/www/kannel/files/patch-gwlib__gwthread-pthread.c b/www/kannel/files/patch-gwlib__gwthread-pthread.c
deleted file mode 100644
index d9166178c14a..000000000000
--- a/www/kannel/files/patch-gwlib__gwthread-pthread.c
+++ /dev/null
@@ -1,45 +0,0 @@
---- gwlib/gwthread-pthread.c.orig Thu Aug 12 19:53:30 2004
-+++ gwlib/gwthread-pthread.c Mon Dec 20 00:53:57 2004
-@@ -125,6 +125,11 @@
- static pthread_key_t tsd_key;
-
- static pthread_mutex_t threadtable_lock;
-+/*
-+ * Thread creation parameters.
-+ */
-+static pthread_attr_t thread_attr;
-+#define MIN_THREAD_STACK_SIZE (256 * 1024)
-
- static void lock(void)
- {
-@@ -263,6 +268,7 @@
- {
- int ret;
- int i;
-+ size_t stack_size;
-
- pthread_mutex_init(&threadtable_lock, NULL);
-
-@@ -275,6 +281,13 @@
- threadtable[i] = NULL;
- }
- active_threads = 0;
-+/*
-+ * Make sure that thread stack is large enough.
-+ */
-+ pthread_attr_init(&thread_attr);
-+ pthread_attr_getstacksize(&thread_attr, &stack_size);
-+ if (stack_size < MIN_THREAD_STACK_SIZE)
-+ pthread_attr_setstacksize(&thread_attr, MIN_THREAD_STACK_SIZE);
-
- create_threadinfo_main();
- }
-@@ -443,7 +456,7 @@
- return -1;
- }
-
-- ret = pthread_create(&id, NULL, &new_thread, p);
-+ ret = pthread_create(&id, &thread_attr, &new_thread, p);
- if (ret != 0) {
- unlock();
- error(ret, "Could not create new thread.");
diff --git a/www/kannel/pkg-descr b/www/kannel/pkg-descr
index 1f3e3e55cca4..dc19c86fcc46 100644
--- a/www/kannel/pkg-descr
+++ b/www/kannel/pkg-descr
@@ -1,4 +1,5 @@
-Kannel is an open source project to make a WAP gateway; it also can work as
-an SMS gateway.
+Kannel is a compact and very powerful open source WAP and SMS gateway, used
+widely across the globe both for serving trillions of short messages (SMS),
+WAP Push service indications and mobile internet connectivity.
WWW: http://www.kannel.org/
diff --git a/www/kannel/pkg-plist b/www/kannel/pkg-plist
index d3954440765f..f74c94909c99 100644
--- a/www/kannel/pkg-plist
+++ b/www/kannel/pkg-plist
@@ -71,6 +71,7 @@ include/kannel/gwlib/fdset.h
include/kannel/gwlib/gw-getopt.h
include/kannel/gwlib/gw-prioqueue.h
include/kannel/gwlib/gw-rwlock.h
+include/kannel/gwlib/gw-timer.h
include/kannel/gwlib/gw_uuid.h
include/kannel/gwlib/gw_uuid_types.h
include/kannel/gwlib/gwassert.h
@@ -139,6 +140,7 @@ include/kannel/wap/wtp_tid.h
lib/kannel/libgw.a
lib/kannel/libgwlib.a
lib/kannel/libwap.a
+lib/kannel/libwmlscript.a
man/man1/mtbatch.1.gz
man/man1/seewbmp.1.gz
man/man1/wmlsc.1.gz
@@ -149,3 +151,9 @@ sbin/bearerbox
sbin/run_kannel_box
sbin/smsbox
sbin/wapbox
+@owner kannel
+@group kannel
+@dir /var/log/kannel
+@dir /var/run/kannel
+@group
+@owner