aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2016-11-16 00:36:20 +0000
committerMark Linimon <linimon@FreeBSD.org>2016-11-16 00:36:20 +0000
commitbbc402e7d9a1174f69caa164687496171600f80a (patch)
tree9b934ed2ec76eeb108ad908378fb51f731a79cf6
parent39a24721e87c28f81c8ed675d8b43c885f7baba1 (diff)
downloadports-bbc402e7d9a1174f69caa164687496171600f80a.tar.gz
ports-bbc402e7d9a1174f69caa164687496171600f80a.zip
Mark as broken on various tier-2 archs.
While here, pet portlint. Approved by: portmgr (tier-2 blanket)
Notes
Notes: svn path=/head/; revision=426203
-rw-r--r--x11-servers/x11rdp/Makefile7
-rw-r--r--x11-toolkits/fox17/Makefile5
-rw-r--r--x11/keynav/Makefile1
-rw-r--r--x11/xfd/Makefile3
-rw-r--r--x11/xload/Makefile2
5 files changed, 14 insertions, 4 deletions
diff --git a/x11-servers/x11rdp/Makefile b/x11-servers/x11rdp/Makefile
index faf58a464ab6..738350952794 100644
--- a/x11-servers/x11rdp/Makefile
+++ b/x11-servers/x11rdp/Makefile
@@ -23,8 +23,6 @@ COMMENT= X11 server for xrdp
LICENSE= MIT
-BROKEN_powerpc64= Does not build
-
RUN_DEPENDS= xorg-fonts>=0:x11-fonts/xorg-fonts
# SVN revision of x11rdp
@@ -36,6 +34,11 @@ CONFLICTS_INSTALL= xrdp-devel-[0-9]* x11rdp-devel-[0-9]*
PLIST_FILES= bin/X11rdp
+BROKEN_aarch64= Fails to compile: error: GLYPHPADBYTES must be 4
+BROKEN_armv6= Fails to compile: error: GLYPHPADBYTES must be 4
+BROKEN_mips64= Fails to compile: No PCI support available for this architecture/OS combination
+BROKEN_powerpc64= Does not build
+
post-extract:
@${MKDIR} ${WRKSRC}/build_dir
diff --git a/x11-toolkits/fox17/Makefile b/x11-toolkits/fox17/Makefile
index 36d603c9ba33..b9b9571fd1ce 100644
--- a/x11-toolkits/fox17/Makefile
+++ b/x11-toolkits/fox17/Makefile
@@ -12,8 +12,6 @@ PKGNAMESUFFIX= ${PORTVERSION:R:S/.//}
MAINTAINER= ports@FreeBSD.org
COMMENT= Fast and extensive C++ GUI toolkit (development version)
-BROKEN_powerpc= missing __sync_bool_compare_and_swap_8()
-
USES= libtool pathfix
GNU_CONFIGURE= yes
USE_GL= glut
@@ -30,6 +28,9 @@ MAJORVER= ${PORTVERSION:R}
PLIST_SUB+= MAJORVER=${MAJORVER}
DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}-${MAJORVER}
+BROKEN_aarch64= Fails to compile: cannot initialize a parameter of type void * with an lvalue of type long
+BROKEN_powerpc= missing __sync_bool_compare_and_swap_8()
+
OPTIONS_DEFINE= DOCS JPEG PNG TIFF WEBP
OPTIONS_DEFAULT= JPEG PNG TIFF WEBP
diff --git a/x11/keynav/Makefile b/x11/keynav/Makefile
index 4d2aee63f0ce..33504963ca81 100644
--- a/x11/keynav/Makefile
+++ b/x11/keynav/Makefile
@@ -11,6 +11,7 @@ MAINTAINER= wxs@FreeBSD.org
COMMENT= Quickly select a portion of the screen using minimal keystrokes
BROKEN= Unfetchable (google code has gone away)
+BROKEN_aarch64= Fails to build: undefined reference to xdo_mouselocation
LIB_DEPENDS= libxdo.so:x11/xdotool \
libcairo.so:graphics/cairo
diff --git a/x11/xfd/Makefile b/x11/xfd/Makefile
index a2dbc827afc8..5fe8bbb5b82b 100644
--- a/x11/xfd/Makefile
+++ b/x11/xfd/Makefile
@@ -16,4 +16,7 @@ RUN_DEPENDS= fc-cache:x11-fonts/fontconfig
XORG_CAT= app
USE_XORG= xft xt xaw
+
+BROKEN_aarch64= Fails to build: exec(xgettext) failed (No such file or directory)
+
.include <bsd.port.mk>
diff --git a/x11/xload/Makefile b/x11/xload/Makefile
index feaeae0b9d3c..661d88a608e3 100644
--- a/x11/xload/Makefile
+++ b/x11/xload/Makefile
@@ -12,4 +12,6 @@ LICENSE= MIT
XORG_CAT= app
USE_XORG= xt xaw
+BROKEN_aarch64= Fails to build: exec(xgettext) failed (No such file or directory)
+
.include <bsd.port.mk>