aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-11-12 11:02:48 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-11-12 11:02:48 +0000
commitbd06807d1deac47009f7254757bebdbf39d371bb (patch)
tree9a4bd0d1ed7e6adf08196228125c2b725bcb009d
parent56229801f3dffa25dbf06263955447f870415112 (diff)
downloadports-bd06807d1deac47009f7254757bebdbf39d371bb.tar.gz
ports-bd06807d1deac47009f7254757bebdbf39d371bb.zip
Notes
-rw-r--r--www/Makefile1
-rw-r--r--www/blogsum/Makefile70
-rw-r--r--www/blogsum/distinfo3
-rw-r--r--www/blogsum/files/pkg-message.in39
-rw-r--r--www/blogsum/pkg-descr4
-rw-r--r--www/blogsum/pkg-plist32
6 files changed, 149 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 5c4a96f956d6..7d12b32b73a1 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -56,6 +56,7 @@
SUBDIR += bk_edit
SUBDIR += bkmrkconv
SUBDIR += blogd
+ SUBDIR += blogsum
SUBDIR += bluefish
SUBDIR += boa
SUBDIR += bookmarkbridge
diff --git a/www/blogsum/Makefile b/www/blogsum/Makefile
new file mode 100644
index 000000000000..43e293902d7a
--- /dev/null
+++ b/www/blogsum/Makefile
@@ -0,0 +1,70 @@
+# New ports collection makefile for: blogsum
+# Date created: 2 November 2009
+# Whom: jhuldtgren
+#
+# $FreeBSD$
+#
+
+PORTNAME= blogsum
+PORTVERSION= 0.9
+CATEGORIES= www
+MASTER_SITES= http://www.dixongroup.net/
+
+MAINTAINER= jhuldtgren@gmail.com
+COMMENT= Simple weblog
+
+WWWROOT?= ${PREFIX}/www/
+
+PERL_MODULES= ${APXS}:${PORTSDIR}/${APACHE_PORT} \
+ ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI \
+ ${SITE_PERL}/${PERL_ARCH}/DBD/SQLite.pm:${PORTSDIR}/databases/p5-DBD-SQLite \
+ ${SITE_PERL}/XML/RSS.pm:${PORTSDIR}/textproc/p5-XML-RSS \
+ ${SITE_PERL}/XML/Simple.pm:${PORTSDIR}/textproc/p5-XML-Simple \
+ ${SITE_PERL}/HTML/Template.pm:${PORTSDIR}/www/p5-HTML-Template \
+ ${SITE_PERL}/HTTP/Lite.pm:${PORTSDIR}/www/p5-HTTP-Lite
+
+NO_BUILD= yes
+USE_PERL5_RUN= yes
+
+.if defined(WITH_APACHE2)
+USE_APACHE= 2.0+
+.else
+USE_APACHE= 1.3+
+.endif
+
+.if defined(WITH_APACHE2)
+PERL_MODULES+= ${LOCALBASE}/${APACHEMODDIR}/mod_perl.so:${PORTSDIR}/www/mod_perl2
+DEPENDS_ARGS+= WITHOUT_MODPERL=yes
+DEPENDS_ARGS+= WITH_MODPERL2=yes
+.else
+# XXX - probe for static mod_perl using `httpd -l | grep perl`
+PERL_MODULES+= ${LOCALBASE}/libexec/apache/libperl.so:${PORTSDIR}/www/mod_perl \
+ ${SITE_PERL}/${PERL_ARCH}/Apache/Request.pm:${PORTSDIR}/www/p5-libapreq
+.endif
+
+RUN_DEPENDS+= ${PERL_MODULES}
+PLIST_SUB= WWWROOT=${WWWROOT:S,${PREFIX}/,,}
+
+SUB_FILES= pkg-message
+SUB_LIST= WWWROOT=${WWWROOT} APACHEETCDIR=${APACHEETCDIR} APACHEMODDIR=${APACHEMODDIR}
+
+.include <bsd.port.pre.mk>
+
+pre-everything::
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "You may set following options:"
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "WITH_APACHE2=1 Use apache2+ instead of apache 1.3"
+ @${ECHO_MSG} "WWWROOT=${PREFIX}/www/ Where do you put httpd's document root?"
+ @${ECHO_MSG} ""
+
+do-install:
+ ${MKDIR} ${WWWROOT}/blogsum
+ @ cd ${WRKSRC} && ${COPYTREE_SHARE} . ${WWWROOT}/blogsum
+
+post-install:
+ @${ECHO_MSG} ""
+ @${CAT} ${PKGMESSAGE}
+ @${ECHO_MSG} ""
+
+.include <bsd.port.post.mk>
diff --git a/www/blogsum/distinfo b/www/blogsum/distinfo
new file mode 100644
index 000000000000..4eba20281d92
--- /dev/null
+++ b/www/blogsum/distinfo
@@ -0,0 +1,3 @@
+MD5 (blogsum-0.9.tar.gz) = 0eaf8b13cd3a2720ee7a93e3e2c4bcd9
+SHA256 (blogsum-0.9.tar.gz) = 2d5b5cdf7f9013df179b5df781a097c3d258d2794aa388ad69b1a0df1fcdda42
+SIZE (blogsum-0.9.tar.gz) = 19444
diff --git a/www/blogsum/files/pkg-message.in b/www/blogsum/files/pkg-message.in
new file mode 100644
index 000000000000..9dc75ce006b3
--- /dev/null
+++ b/www/blogsum/files/pkg-message.in
@@ -0,0 +1,39 @@
+# To finish installing Blogsum, the following steps must be completed.
+
+1) Setup the SQLite database:
+
+ $ sudo -u www sqlite3 %%WWWROOT%%/blogsum/data/site.db < \
+ %%WWWROOT%%/blogsum/examples/create_sqlite.sql
+
+2) Create your local configuration and modify as necessary:
+
+ $ sudo cp %%WWWROOT%%/blogsum/Blogsum/Config.pm.dist \
+ %%WWWROOT%%/blogsum/Blogsum/Config.pm
+
+3) If comments will be enabled, visit the CAPTCHA (http://www.captcha.net/)
+ project and register your account. Add your keys to Config.pm.
+
+4) Edit the example httpd-blogsum.conf and enable it for your site:
+
+ $ sudo cp %%WWWROOT%%/blogsum/examples/httpd-blogsum.conf %%PREFIX%%/%%APACHEETCDIR%%/conf
+
+5) Create your AuthUserFile file as defined in httpd-blogsum.conf:
+
+ $ sudo htpasswd -c %%APACHEETCDIR%%/conf/blogsum.htpasswd
+
+6) Enable the following modules in %%APACHEETCDIR%%/httpd.conf:
+
+ LoadModule rewrite_module %%APACHEMODDIR%%/mod_rewrite.so
+ LoadModule proxy_module %%APACHEMODDIR%%/libproxy.so
+ LoadModule perl_module %%APACHEMODDIR%%/mod_perl.so
+
+7) Stop and start your Apache service.
+
+
+The installation should now be complete. Your blogsum installation can be
+viewed at http://localhost/blogsum/index.cgi. Posts can be created and
+edited at http://localhost/blogsum/admin.cgi.
+
+Please refer to the online support resources if you have questions.
+
+ http://blogsum.obfuscurity.com/
diff --git a/www/blogsum/pkg-descr b/www/blogsum/pkg-descr
new file mode 100644
index 000000000000..3221f8ad8e69
--- /dev/null
+++ b/www/blogsum/pkg-descr
@@ -0,0 +1,4 @@
+Blogsum is a weblog application with a focus on simplicity and security.
+It was designed from scratch to be easy to use and easier to maintain.
+
+WWW: http://blogsum.obfuscurity.com/
diff --git a/www/blogsum/pkg-plist b/www/blogsum/pkg-plist
new file mode 100644
index 000000000000..f18861f65be9
--- /dev/null
+++ b/www/blogsum/pkg-plist
@@ -0,0 +1,32 @@
+%%WWWROOT%%/blogsum/Blogsum/Config.pm.dist
+%%WWWROOT%%/blogsum/admin.cgi
+%%WWWROOT%%/blogsum/docs/LICENSE
+%%WWWROOT%%/blogsum/docs/LICENSE.images
+%%WWWROOT%%/blogsum/docs/README
+%%WWWROOT%%/blogsum/examples/create_sqlite.sql
+%%WWWROOT%%/blogsum/examples/httpd-blogsum.conf
+%%WWWROOT%%/blogsum/examples/wp2blogsum.pl
+%%WWWROOT%%/blogsum/index.cgi
+%%WWWROOT%%/blogsum/startup.pl
+%%WWWROOT%%/blogsum/themes/default/admin.tmpl
+%%WWWROOT%%/blogsum/themes/default/images/asterisk-green.gif
+%%WWWROOT%%/blogsum/themes/default/images/asterisk-red.gif
+%%WWWROOT%%/blogsum/themes/default/images/check.gif
+%%WWWROOT%%/blogsum/themes/default/images/delete.gif
+%%WWWROOT%%/blogsum/themes/default/images/draft-disabled.gif
+%%WWWROOT%%/blogsum/themes/default/images/draft.gif
+%%WWWROOT%%/blogsum/themes/default/images/play-disabled.gif
+%%WWWROOT%%/blogsum/themes/default/images/play.gif
+%%WWWROOT%%/blogsum/themes/default/images/plus.gif
+%%WWWROOT%%/blogsum/themes/default/images/xml.gif
+%%WWWROOT%%/blogsum/themes/default/index.tmpl
+%%WWWROOT%%/blogsum/themes/default/style.css
+@exec mkdir -p %D %%WWWROOT%%/blogsum/data/
+@dirrm %%WWWROOT%%/blogsum/Blogsum
+@dirrm %%WWWROOT%%/blogsum/data
+@dirrm %%WWWROOT%%/blogsum/docs
+@dirrm %%WWWROOT%%/blogsum/examples
+@dirrm %%WWWROOT%%/blogsum/themes/default/images
+@dirrm %%WWWROOT%%/blogsum/themes/default
+@dirrm %%WWWROOT%%/blogsum/themes
+@dirrm %%WWWROOT%%/blogsum/