aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-07-19 14:00:50 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-07-19 14:00:50 +0000
commitc0e18c2aff4e808aa1cf1e75ab403e48b57c584f (patch)
tree0d9fedbd516e29e2f0f90c9345885027c81e75e6
parentbe504f9f94fce3b61338065bacc2e1a5fdda580d (diff)
downloadports-c0e18c2aff4e808aa1cf1e75ab403e48b57c584f.tar.gz
ports-c0e18c2aff4e808aa1cf1e75ab403e48b57c584f.zip
Notes
-rw-r--r--deskutils/Makefile1
-rw-r--r--deskutils/libopensync-plugin-python/Makefile24
-rw-r--r--deskutils/libopensync-plugin-python/distinfo3
-rw-r--r--deskutils/libopensync-plugin-python/pkg-descr3
-rw-r--r--deskutils/libopensync-plugin-python/pkg-plist6
5 files changed, 37 insertions, 0 deletions
diff --git a/deskutils/Makefile b/deskutils/Makefile
index c71101abb3aa..6fbdb9cae1fb 100644
--- a/deskutils/Makefile
+++ b/deskutils/Makefile
@@ -127,6 +127,7 @@
SUBDIR += ktagebuch
SUBDIR += kuake
SUBDIR += libopensync-plugin-evolution2
+ SUBDIR += libopensync-plugin-python
SUBDIR += lightning-xpi
SUBDIR += linux-sunbird
SUBDIR += ljcharm
diff --git a/deskutils/libopensync-plugin-python/Makefile b/deskutils/libopensync-plugin-python/Makefile
new file mode 100644
index 000000000000..1a7340b6aa0b
--- /dev/null
+++ b/deskutils/libopensync-plugin-python/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: libopensync-plugin-python
+# Date created: 18 July 2008
+# Whom: Alexander Logvinov <ports@logvinov.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libopensync-plugin-python
+PORTVERSION= 0.22
+CATEGORIES= deskutils
+MASTER_SITES= http://www.opensync.org/download/releases/${PORTVERSION}/
+
+MAINTAINER= ports@logvinov.com
+COMMENT= Python plugin for the OpenSync framework
+
+LIB_DEPENDS= opensync.0:${PORTSDIR}/devel/libopensync022
+
+CONFLICTS= libopensync-plugin-python-devel-[0-9]*
+
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+USE_PYTHON= yes
+
+.include <bsd.port.mk>
diff --git a/deskutils/libopensync-plugin-python/distinfo b/deskutils/libopensync-plugin-python/distinfo
new file mode 100644
index 000000000000..f5848fd84a2a
--- /dev/null
+++ b/deskutils/libopensync-plugin-python/distinfo
@@ -0,0 +1,3 @@
+MD5 (libopensync-plugin-python-0.22.tar.bz2) = ad5aba28ee66adc1c62e17cdd27c7dc7
+SHA256 (libopensync-plugin-python-0.22.tar.bz2) = 49815fb498679cb0cb3713874da9ee60012753b25ff1dafc60cfca7cc38f3766
+SIZE (libopensync-plugin-python-0.22.tar.bz2) = 215702
diff --git a/deskutils/libopensync-plugin-python/pkg-descr b/deskutils/libopensync-plugin-python/pkg-descr
new file mode 100644
index 000000000000..79d86d6bb3b9
--- /dev/null
+++ b/deskutils/libopensync-plugin-python/pkg-descr
@@ -0,0 +1,3 @@
+A python module for the OpenSync framework.
+
+WWW: http://www.opensync.org/
diff --git a/deskutils/libopensync-plugin-python/pkg-plist b/deskutils/libopensync-plugin-python/pkg-plist
new file mode 100644
index 000000000000..f9be5ab2ecbf
--- /dev/null
+++ b/deskutils/libopensync-plugin-python/pkg-plist
@@ -0,0 +1,6 @@
+lib/opensync/plugins/python_module.so
+lib/opensync/plugins/python_module.la
+lib/opensync/python-plugins/sample.py
+@dirrmtry lib/opensync/python-plugins
+@dirrmtry lib/opensync/plugins
+@dirrmtry lib/opensync