aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Slusar <anray@FreeBSD.org>2007-03-11 01:46:03 +0000
committerAndrey Slusar <anray@FreeBSD.org>2007-03-11 01:46:03 +0000
commitc505a741c91cb2a3523e94d571c715af4c691b04 (patch)
tree5c3261f873620633b7ec0b0255c72a6ee5ff924c
parentdaa600d6b9499989bdcc55f963ead36b32ff8bc9 (diff)
downloadports-c505a741c91cb2a3523e94d571c715af4c691b04.tar.gz
ports-c505a741c91cb2a3523e94d571c715af4c691b04.zip
Notes
-rw-r--r--graphics/freeimage/Makefile2
-rw-r--r--graphics/freeimage/distinfo6
-rw-r--r--graphics/freeimage/files/patch-Makefile.gnu (renamed from graphics/freeimage/files/patch-Makefile)30
-rw-r--r--graphics/freeimage/pkg-plist1
4 files changed, 22 insertions, 17 deletions
diff --git a/graphics/freeimage/Makefile b/graphics/freeimage/Makefile
index 98e83c845755..46b7a00b5d6e 100644
--- a/graphics/freeimage/Makefile
+++ b/graphics/freeimage/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= freeimage
-PORTVERSION= 3.8.0
+PORTVERSION= 3.9.3
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/graphics/freeimage/distinfo b/graphics/freeimage/distinfo
index 0dcdf2ba0c48..c5f31a09ed38 100644
--- a/graphics/freeimage/distinfo
+++ b/graphics/freeimage/distinfo
@@ -1,3 +1,3 @@
-MD5 (FreeImage380.zip) = aff6c252030bda5cff2bb32efcf726fa
-SHA256 (FreeImage380.zip) = 787ea946aef51bb0a21bd89715ce88cfc3ab7a16d37bbabc0467af8e7c9b56cc
-SIZE (FreeImage380.zip) = 2358545
+MD5 (FreeImage393.zip) = bf3574fa4e6135cf511d5ff4bc871ec3
+SHA256 (FreeImage393.zip) = 59f6b75d778e40eff7cb4068e556c65230f9fe1af8d17ad74fec48f334a34fc0
+SIZE (FreeImage393.zip) = 2507055
diff --git a/graphics/freeimage/files/patch-Makefile b/graphics/freeimage/files/patch-Makefile.gnu
index 4a26d1dcc7db..16e2615cb3d9 100644
--- a/graphics/freeimage/files/patch-Makefile
+++ b/graphics/freeimage/files/patch-Makefile.gnu
@@ -1,5 +1,5 @@
---- Makefile.orig Tue May 3 18:53:46 2005
-+++ Makefile Mon Sep 5 00:21:22 2005
+--- Makefile.gnu.orig Sun Mar 11 02:46:54 2007
++++ Makefile.gnu Sun Mar 11 02:53:21 2007
@@ -4,27 +4,27 @@
include Makefile.srcs
@@ -10,13 +10,15 @@
+CXX ?= g++
AR = ar
+-INCDIR = /usr/include
-INSTALLDIR = /usr/lib
++INCDIR = ${PREFIX}/include
+INSTALLDIR = ${PREFIX}/lib
# Converts cr/lf to just lf
DOS2UNIX = dos2unix
--COMPILERFLAGS = -O3
+-COMPILERFLAGS = -O3 -fPIC
+COMPILERFLAGS := ${CFLAGS}
LIBRARIES = -lstdc++
@@ -25,18 +27,16 @@
-CFLAGS = $(COMPILERFLAGS) $(INCLUDE)
-CXXFLAGS = $(COMPILERFLAGS) -Wno-ctor-dtor-privacy $(INCLUDE)
+CFLAGS = $(COMPILERFLAGS) -fPIC $(INCLUDE)
-+CXXFLAGS = $(COMPILERFLAGS) -fPIC -Wno-ctor-dtor-privacy $(INCLUDE)
++CXXFLAGS = $(COMPILERFLAGS) -fPIC -Wno-ctor-dtor-privacy $(INCLUDE)
TARGET = freeimage
STATICLIB = lib$(TARGET).a
-SHAREDLIB = lib$(TARGET)-$(VER_MAJOR).$(VER_MINOR).so
--LIBNAME = lib$(TARGET).so.$(VER_MAJOR)
+SHAREDLIB = lib$(TARGET).so.$(VER_MAJOR)
-+LIBNAME = lib$(TARGET).so
-
-
-
-@@ -34,7 +34,7 @@
+ LIBNAME = lib$(TARGET).so
+ VERLIBNAME = $(LIBNAME).$(VER_MAJOR)
+ HEADER = Source/FreeImage.h
+@@ -37,7 +37,7 @@
dist: FreeImage
cp *.a Dist
@@ -45,16 +45,20 @@
cp Source/FreeImage.h Dist
dos2unix:
-@@ -55,10 +55,9 @@
- $(CC) -s -shared -Wl,-soname,$(LIBNAME) -o $@ $(MODULES) $(LIBRARIES)
+@@ -58,12 +58,11 @@
+ $(CC) -s -shared -Wl,-soname,$(VERLIBNAME) -o $@ $(MODULES) $(LIBRARIES)
install:
+- install -m 644 -o root -g root $(HEADER) $(INCDIR)
- install -m 644 -o root -g root $(STATICLIB) $(INSTALLDIR)
- install -m 755 -o root -g root $(SHAREDLIB) $(INSTALLDIR)
++ install -m 644 -o root -g wheel $(HEADER) $(INCDIR)
+ install -m 644 -o root -g wheel $(STATICLIB) $(INSTALLDIR)
+ install -m 755 -o root -g wheel $(SHAREDLIB) $(INSTALLDIR)
- ln -sf $(SHAREDLIB) $(INSTALLDIR)/$(LIBNAME)
+ ln -sf $(SHAREDLIB) $(INSTALLDIR)/$(VERLIBNAME)
+- ln -sf $(VERLIBNAME) $(INSTALLDIR)/$(LIBNAME)
- ldconfig
++ ln -sf $(VERLIBNAME) $(INSTALLDIR)/$(LIBNAME)
clean:
rm -f core Dist/*.* u2dtmp* $(MODULES) $(STATICLIB) $(SHAREDLIB) $(LIBNAME)
diff --git a/graphics/freeimage/pkg-plist b/graphics/freeimage/pkg-plist
index 22b72f6efa7c..047ac8c88bf3 100644
--- a/graphics/freeimage/pkg-plist
+++ b/graphics/freeimage/pkg-plist
@@ -1,3 +1,4 @@
+include/FreeImage.h
lib/libfreeimage.a
lib/libfreeimage.so
lib/libfreeimage.so.3