aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2008-04-11 07:41:41 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2008-04-11 07:41:41 +0000
commitc681de11ed52999870abff967056b16882c2d5c0 (patch)
treee2f9ef1864632e70990f9bcc0c303d50bbb0ec68
parenta68e9bf63f22fcf831f30f23d350e20807306dde (diff)
downloadports-c681de11ed52999870abff967056b16882c2d5c0.tar.gz
ports-c681de11ed52999870abff967056b16882c2d5c0.zip
Notes
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-cfgparse/Makefile34
-rw-r--r--devel/py-cfgparse/distinfo3
-rw-r--r--devel/py-cfgparse/pkg-descr3
-rw-r--r--devel/py-cfgparse/pkg-plist52
5 files changed, 93 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 272ffe36af81..ddbb38912ddd 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1978,6 +1978,7 @@
SUBDIR += py-bison
SUBDIR += py-boto
SUBDIR += py-celementtree
+ SUBDIR += py-cfgparse
SUBDIR += py-cheetah
SUBDIR += py-ciphon
SUBDIR += py-cjson
diff --git a/devel/py-cfgparse/Makefile b/devel/py-cfgparse/Makefile
new file mode 100644
index 000000000000..91130ff83b89
--- /dev/null
+++ b/devel/py-cfgparse/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: cfgparse
+# Date created: March 18, 2008
+# Whom: John Ferrell
+#
+# $FreeBSD$
+#
+
+PORTNAME= cfgparse
+PORTVERSION= 1.2
+CATEGORIES= devel python
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= cfgparse
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= cfgparse-v01_02
+
+MAINTAINER= jdferrell3@yahoo.com
+COMMENT= Python module for parsing configuration files
+
+USE_PYTHON= 2.3+
+USE_PYDISTUTILS=yes
+PYDISTUTILS_PKGNAME= cfgparse
+PYDISTUTILS_EGGINFO= ${PYDISTUTILS_PKGNAME:C/[^A-Za-z0-9.]+/_/g}-v01_02-${PYTHON_VERSION:S/thon//}.egg-info
+
+DOCSDIR= ${PREFIX}/share/doc/py-${PORTNAME}
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/docs/cfgparse/* ${DOCSDIR}
+.endif
+
+PLIST_SUB= PYTHONVER=${PYTHON_VERSION:S/python//}
+
+.include <bsd.port.mk>
diff --git a/devel/py-cfgparse/distinfo b/devel/py-cfgparse/distinfo
new file mode 100644
index 000000000000..c9a3422e2f91
--- /dev/null
+++ b/devel/py-cfgparse/distinfo
@@ -0,0 +1,3 @@
+MD5 (cfgparse-v01_02.tar.gz) = 9add1b0bbf828f7c7383407cdeefea94
+SHA256 (cfgparse-v01_02.tar.gz) = 59189e3886be58f344c2b85956ff97089aaa546f7a342bd26144ed94c991a61c
+SIZE (cfgparse-v01_02.tar.gz) = 128803
diff --git a/devel/py-cfgparse/pkg-descr b/devel/py-cfgparse/pkg-descr
new file mode 100644
index 000000000000..1a7ce9fc3bcc
--- /dev/null
+++ b/devel/py-cfgparse/pkg-descr
@@ -0,0 +1,3 @@
+cfgparse is Python module for parsing configuration files.
+
+WWW: http://cfgparse.sourceforge.net/
diff --git a/devel/py-cfgparse/pkg-plist b/devel/py-cfgparse/pkg-plist
new file mode 100644
index 000000000000..03d3509a9e1b
--- /dev/null
+++ b/devel/py-cfgparse/pkg-plist
@@ -0,0 +1,52 @@
+%%PYTHON_SITELIBDIR%%/cfgparse.py
+%%PYTHON_SITELIBDIR%%/cfgparse.pyc
+%%PYTHON_SITELIBDIR%%/cfgparse.pyo
+%%PORTDOCS%%%%DOCSDIR%%/about.html
+%%PORTDOCS%%%%DOCSDIR%%/blank.png
+%%PORTDOCS%%%%DOCSDIR%%/cfgparse-adding-files.html
+%%PORTDOCS%%%%DOCSDIR%%/cfgparse-adding-options.html
+%%PORTDOCS%%%%DOCSDIR%%/cfgparse-cmd-line-coop.html
+%%PORTDOCS%%%%DOCSDIR%%/cfgparse-coop-files.html
+%%PORTDOCS%%%%DOCSDIR%%/cfgparse-coop-help.html
+%%PORTDOCS%%%%DOCSDIR%%/cfgparse-coop-keys.html
+%%PORTDOCS%%%%DOCSDIR%%/cfgparse-coop-option.html
+%%PORTDOCS%%%%DOCSDIR%%/cfgparse-create-parser.html
+%%PORTDOCS%%%%DOCSDIR%%/cfgparse-default-keys.html
+%%PORTDOCS%%%%DOCSDIR%%/cfgparse-env-keys.html
+%%PORTDOCS%%%%DOCSDIR%%/cfgparse-groups.html
+%%PORTDOCS%%%%DOCSDIR%%/cfgparse-help-notes.html
+%%PORTDOCS%%%%DOCSDIR%%/cfgparse-keys.html
+%%PORTDOCS%%%%DOCSDIR%%/cfgparse-option-check.html
+%%PORTDOCS%%%%DOCSDIR%%/cfgparse-option-help.html
+%%PORTDOCS%%%%DOCSDIR%%/cfgparse-option-name.html
+%%PORTDOCS%%%%DOCSDIR%%/cfgparse-option-type.html
+%%PORTDOCS%%%%DOCSDIR%%/cfgparse-parsing.html
+%%PORTDOCS%%%%DOCSDIR%%/cfgparse-printing-help.html
+%%PORTDOCS%%%%DOCSDIR%%/cfgparse-python.html
+%%PORTDOCS%%%%DOCSDIR%%/cfgparse-round-trip-set-option.html
+%%PORTDOCS%%%%DOCSDIR%%/cfgparse-round-trip-set.html
+%%PORTDOCS%%%%DOCSDIR%%/cfgparse-round-trip-write.html
+%%PORTDOCS%%%%DOCSDIR%%/cfgparse-section-keys.html
+%%PORTDOCS%%%%DOCSDIR%%/cfgparse-sections.html
+%%PORTDOCS%%%%DOCSDIR%%/cfgparse-text-sub.html
+%%PORTDOCS%%%%DOCSDIR%%/cfgparse.css
+%%PORTDOCS%%%%DOCSDIR%%/cfgparse.html
+%%PORTDOCS%%%%DOCSDIR%%/contents.png
+%%PORTDOCS%%%%DOCSDIR%%/index.html
+%%PORTDOCS%%%%DOCSDIR%%/index.png
+%%PORTDOCS%%%%DOCSDIR%%/modules.png
+%%PORTDOCS%%%%DOCSDIR%%/next.png
+%%PORTDOCS%%%%DOCSDIR%%/node1.html
+%%PORTDOCS%%%%DOCSDIR%%/node10.html
+%%PORTDOCS%%%%DOCSDIR%%/node18.html
+%%PORTDOCS%%%%DOCSDIR%%/node2.html
+%%PORTDOCS%%%%DOCSDIR%%/node22.html
+%%PORTDOCS%%%%DOCSDIR%%/node23.html
+%%PORTDOCS%%%%DOCSDIR%%/node24.html
+%%PORTDOCS%%%%DOCSDIR%%/node28.html
+%%PORTDOCS%%%%DOCSDIR%%/node33.html
+%%PORTDOCS%%%%DOCSDIR%%/node36.html
+%%PORTDOCS%%%%DOCSDIR%%/previous.png
+%%PORTDOCS%%%%DOCSDIR%%/pyfav.png
+%%PORTDOCS%%%%DOCSDIR%%/up.png
+%%PORTDOCS%%@dirrm %%DOCSDIR%%