aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2009-01-05 21:36:39 +0000
committerPav Lucistnik <pav@FreeBSD.org>2009-01-05 21:36:39 +0000
commitd203b12054ad82d30bac1f0a0c022b1393f861b3 (patch)
treeaa853b3ada1746f7fe92c44b10a0a57900e6b933
parent90b2f12a8477639b13e1b928f143269e9284ead4 (diff)
downloadports-d203b12054ad82d30bac1f0a0c022b1393f861b3.tar.gz
ports-d203b12054ad82d30bac1f0a0c022b1393f861b3.zip
Notes
-rw-r--r--multimedia/avifile/Makefile2
-rw-r--r--multimedia/bmpx/Makefile8
-rw-r--r--multimedia/gdvrecv/Makefile8
-rw-r--r--multimedia/libxine/Makefile2
-rw-r--r--multimedia/motion/Makefile2
-rw-r--r--multimedia/mplayer/Makefile7
-rw-r--r--multimedia/nxtvepg/Makefile7
-rw-r--r--multimedia/ogle/Makefile2
-rw-r--r--multimedia/openquicktime/Makefile2
-rw-r--r--multimedia/toxine/Makefile5
-rw-r--r--multimedia/vlc-devel/Makefile.inc5
-rw-r--r--multimedia/vlc/Makefile.inc5
-rw-r--r--multimedia/xine/Makefile21
-rw-r--r--multimedia/xine/files/extra-patch-src:xitk:common.h11
-rw-r--r--multimedia/xine/files/extra-patch-src:xitk:common.h-115
-rw-r--r--net/AquaGatekeeper/Makefile2
-rw-r--r--net/AquaGatekeeper2/Makefile2
-rw-r--r--net/acx100/Makefile4
-rw-r--r--net/atmsupport/Makefile8
-rw-r--r--net/bittwist/Makefile8
-rw-r--r--net/bpfstat/Makefile4
-rw-r--r--net/coda6_server/Makefile5
-rw-r--r--net/dhcperf/Makefile14
-rw-r--r--net/dhcprelya/Makefile8
-rw-r--r--net/freenx/Makefile4
-rw-r--r--net/frickin/Makefile8
-rw-r--r--net/ifdepd/Makefile8
-rw-r--r--net/ifstated/Makefile8
-rw-r--r--net/ipa_ipfw/Makefile6
29 files changed, 15 insertions, 176 deletions
diff --git a/multimedia/avifile/Makefile b/multimedia/avifile/Makefile
index 7a4a418fc318..086fc52abced 100644
--- a/multimedia/avifile/Makefile
+++ b/multimedia/avifile/Makefile
@@ -62,9 +62,7 @@ PLIST_SUB+= QT="@comment "
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 600000
WITH_OPTIMIZED_CFLAGS= yes
-.endif
.if ${OSVERSION} >= 700000
USE_GCC= 3.4
diff --git a/multimedia/bmpx/Makefile b/multimedia/bmpx/Makefile
index 1e402e528469..49173bba0655 100644
--- a/multimedia/bmpx/Makefile
+++ b/multimedia/bmpx/Makefile
@@ -86,10 +86,4 @@ PLIST_SUB+= MPEG4IP=""
PLIST_SUB+= MPEG4IP="@comment "
.endif
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 600000
-BROKEN= Does not compile on 5.x
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/multimedia/gdvrecv/Makefile b/multimedia/gdvrecv/Makefile
index be53baf32fb3..729ac28a215b 100644
--- a/multimedia/gdvrecv/Makefile
+++ b/multimedia/gdvrecv/Makefile
@@ -28,10 +28,4 @@ DESKTOP_ENTRIES="Capture Video" \
CONFLICTS= dvts-[0-9]*
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 502000
-IGNORE= does not work on FreeBSD older than 5.2
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/multimedia/libxine/Makefile b/multimedia/libxine/Makefile
index 31fd829e10c3..217fcf31ab39 100644
--- a/multimedia/libxine/Makefile
+++ b/multimedia/libxine/Makefile
@@ -217,12 +217,10 @@ pre-configure:
s|-funroll-loops||g ; \
s|LIBFFMPEG_CFLAGS|LIBFFMPEG_CPPFLAGS|g ; \
s|echo aout|echo elf|g' ${WRKSRC}/configure
-.if ${OSVERSION} >= 500035
@${REINPLACE_CMD} -e \
's|-malign-loops|-falign-loops|g ; \
s|-malign-jumps|-falign-jumps|g ; \
s|-malign-functions|-falign-functions|g' ${WRKSRC}/configure
-.endif
pre-build:
@${CP} -p ${LOCALBASE}/include/dts.h ${WRKSRC}/src/libdts/
diff --git a/multimedia/motion/Makefile b/multimedia/motion/Makefile
index bc30556e9975..8cc285746426 100644
--- a/multimedia/motion/Makefile
+++ b/multimedia/motion/Makefile
@@ -52,7 +52,7 @@ BUILD_DEPENDS+= v4l_compat>=1.0.20060801:${PORTSDIR}/multimedia/v4l_compat
RUN_DEPENDS+= /boot/modules/pwc.ko:${PORTSDIR}/multimedia/pwcbsd
.endif
-.if defined(WITH_LINUXTHREADS) || ${OSVERSION} < 504000
+.if defined(WITH_LINUXTHREADS)
CONFIGURE_ARGS= --with-linuxthreads
LIB_DEPENDS+= lthread.[35]:${PORTSDIR}/devel/linuxthreads
.endif
diff --git a/multimedia/mplayer/Makefile b/multimedia/mplayer/Makefile
index 7a76dd0e960c..5b9eb65d2bb7 100644
--- a/multimedia/mplayer/Makefile
+++ b/multimedia/mplayer/Makefile
@@ -27,7 +27,6 @@ OPTIONS+= X11VM "X11 VidMode support" on
OPTIONS+= GUI "Enable GTK2 graphical user interface with X11" on
OPTIONS+= SDL "Enable SDL video output" off
OPTIONS+= VIDIX "Enable VIDIX video output on supported archs" on
-OPTIONS+= NVIDIA "Enable experimental nvidia xvmc driver" off
OPTIONS+= SKINS "Force dependency on mplayer-skins" on
OPTIONS+= FREETYPE "Use freetype for OSD fonts (TrueType!)" on
OPTIONS+= RTC "Add support for kernel real time clock timing" off
@@ -164,12 +163,6 @@ CONFIGURE_ENV+= CFLAGS+="-I/${LOCALBASE}/include"
CONFIGURE_ARGS+= --disable-rtc
.endif
-.if defined(WITH_NVIDIA) && ${OSVERSION} < 600033
-LIB_DEPENDS+= XvMCNVIDIA.1:${PORTSDIR}/x11/nvidia-driver
-CONFIGURE_ARGS+= --enable-xvmc \
- --enable-xvmclib=XvMCNVIDIA
-.endif
-
.if defined(WITH_ARTS)
LIB_DEPENDS+= artsc.0:${PORTSDIR}/audio/arts
CONFIGURE_ARGS+= --enable-arts
diff --git a/multimedia/nxtvepg/Makefile b/multimedia/nxtvepg/Makefile
index 973a2132bdc5..80ed19d42c6a 100644
--- a/multimedia/nxtvepg/Makefile
+++ b/multimedia/nxtvepg/Makefile
@@ -24,15 +24,10 @@ MAKE_ENV= PTHREAD_LIBS=${PTHREAD_LIBS} WRKSRC=${WRKSRC}
MAN1= nxtvepg.1
MYPORTDOCS= README TODO CHANGES manual.html
-
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} > 502100
post-patch:
${REINPLACE_CMD} -e "s,machine/ioctl_bt848.h,dev/bktr/ioctl_bt848.h,; \
s,machine/ioctl_meteor.h,dev/bktr/ioctl_meteor.h," \
${WRKSRC}/epgvbi/btdrv4linux.c ${WRKSRC}/tvsim/tvsim_main.c
-.endif
post-install:
${INSTALL_PROGRAM} ${WRKSRC}/nxtvepg ${LOCALBASE}/bin
@@ -46,4 +41,4 @@ post-install:
.endfor
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/multimedia/ogle/Makefile b/multimedia/ogle/Makefile
index 6e59739410d4..67e9fda2f229 100644
--- a/multimedia/ogle/Makefile
+++ b/multimedia/ogle/Makefile
@@ -60,9 +60,7 @@ pre-configure:
# XXX due to gcc-3.4 (20040706) bug in preprocessing of inline functions,
# this needs at least -O2 to compile. Fails with -O
-.if ${OSVERSION} >= 502126
CFLAGS+= -O2
-.endif
# hack to make ogle work with liba52 + djbfft
.if exists(${LOCALBASE}/lib/liba52.la)
diff --git a/multimedia/openquicktime/Makefile b/multimedia/openquicktime/Makefile
index 672545412888..ca8df8c86cba 100644
--- a/multimedia/openquicktime/Makefile
+++ b/multimedia/openquicktime/Makefile
@@ -47,11 +47,9 @@ post-patch:
${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
@${REINPLACE_CMD} -e 's|"m"|"g"|' \
${WRKSRC}/audioplugin/MP3/audioencoder/lame3.70/quantize-pvt.c
-.if ${OSVERSION} >= 502126
@${REINPLACE_CMD} \
-e 's|-fpic||' \
${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
-.endif
post-install:
@${SETENV} PKG_PREFIX=${PREFIX} ${SH} \
diff --git a/multimedia/toxine/Makefile b/multimedia/toxine/Makefile
index d7ab0a8c8ae3..bd1c57e03090 100644
--- a/multimedia/toxine/Makefile
+++ b/multimedia/toxine/Makefile
@@ -28,11 +28,6 @@ MAN1= toxine.1
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 502000
-LIB_DEPENDS+= readline.5:${PORTSDIR}/devel/readline
-CONFIGURE_ARGS+=--with-readline=${LOCALBASE}
-.endif
-
.if !defined(WITHOUT_AALIB)
LIB_DEPENDS+= aa.1:${PORTSDIR}/graphics/aalib
PLIST_SUB+= AALIB=""
diff --git a/multimedia/vlc-devel/Makefile.inc b/multimedia/vlc-devel/Makefile.inc
index eb78d2be790e..adb01ae41a4e 100644
--- a/multimedia/vlc-devel/Makefile.inc
+++ b/multimedia/vlc-devel/Makefile.inc
@@ -221,11 +221,6 @@ post-patch:
@${REINPLACE_CMD} -e 's|$$(libdir)/mozilla/plugins|${FAKEDIR}/mozilla|; \
s|$$(libdir)/mozilla/components|${FAKEDIR}/mozilla|' \
${WRKSRC}/projects/mozilla/Makefile.in
-# skins2 interface, no lrint on < 504000
-.if ${OSVERSION} < 504000
- @${REINPLACE_CMD} -e 's|lrint|rint|' \
- ${WRKSRC}/modules/gui/skins2/controls/ctrl_list.cpp
-.endif
# cdrom/dvd support
@${REINPLACE_CMD} -e 's|/dev/cdrom|${DEFAULT_CDROM_DEVICE}|; \
s|/dev/dvd|${DEFAULT_DVD_DEVICE}|' \
diff --git a/multimedia/vlc/Makefile.inc b/multimedia/vlc/Makefile.inc
index 34226d053b1d..6b88cc3bae3a 100644
--- a/multimedia/vlc/Makefile.inc
+++ b/multimedia/vlc/Makefile.inc
@@ -227,11 +227,6 @@ post-patch:
@${REINPLACE_CMD} -e 's|$$(libdir)/mozilla/plugins|${FAKEDIR}/mozilla|; \
s|$$(libdir)/mozilla/components|${FAKEDIR}/mozilla|' \
${WRKSRC}/mozilla/Makefile.in
-# skins2 interface, no lrint on < 504000
-.if ${OSVERSION} < 504000
- @${REINPLACE_CMD} -e 's|lrint|rint|' \
- ${WRKSRC}/modules/gui/skins2/controls/ctrl_list.cpp
-.endif
# s/Linux/FreeBSD/
@${REINPLACE_CMD} -e 's|Linux|FreeBSD|' \
${WRKSRC}/po/*
diff --git a/multimedia/xine/Makefile b/multimedia/xine/Makefile
index 96fe84e8a0a8..8533a02c21e8 100644
--- a/multimedia/xine/Makefile
+++ b/multimedia/xine/Makefile
@@ -52,27 +52,6 @@ CODEC_DETECTION_FILE!= ${MAKE} -f ${CODEC_PORT}/Makefile -V CODEC_DETECTION_FILE
.endif
.endif
-.if ${OSVERSION} == 500043
-EXTRA_PATCHES= ${PATCHDIR}/extra-patch-src:xitk:common.h
-.endif
-
-# PRIi64 macro is not defined
-.if ${OSVERSION} < 500040
-EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-src:xitk:common.h-1
-.endif
-
-# mbrtowc() is not implemented
-.if ${OSVERSION} < 500039
-CONFIGURE_ARGS+= --disable-mbs
-# Xft support requires --enable-mbs configure option
-WITHOUT_XFT= yes
-.endif
-
-.if ${OSVERSION} < 502000
-LIB_DEPENDS+= readline.5:${PORTSDIR}/devel/readline
-CONFIGURE_ARGS+= --with-readline=${LOCALBASE}
-.endif
-
.if defined(WITHOUT_NLS)
CONFIGURE_ARGS+=--disable-nls
PLIST_SUB+= NLS="@comment "
diff --git a/multimedia/xine/files/extra-patch-src:xitk:common.h b/multimedia/xine/files/extra-patch-src:xitk:common.h
deleted file mode 100644
index 55a644b31ff2..000000000000
--- a/multimedia/xine/files/extra-patch-src:xitk:common.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/xitk/common.h.orig Mon Feb 24 22:39:16 2003
-+++ src/xitk/common.h Mon Feb 24 22:39:46 2003
-@@ -31,6 +31,8 @@
- #include <xine.h>
- #include <xine/xineutils.h>
-
-+#define ushort unsigned short
-+
- #include "Imlib-light/Imlib.h"
-
- #include "xitk.h"
diff --git a/multimedia/xine/files/extra-patch-src:xitk:common.h-1 b/multimedia/xine/files/extra-patch-src:xitk:common.h-1
deleted file mode 100644
index 1b56caf35979..000000000000
--- a/multimedia/xine/files/extra-patch-src:xitk:common.h-1
+++ /dev/null
@@ -1,15 +0,0 @@
---- src/xitk/common.h.orig Fri Apr 16 04:20:51 2004
-+++ src/xitk/common.h Wed May 12 23:17:59 2004
-@@ -114,6 +114,12 @@
- #define PLAYLIST_CONTROL_STOP 0x00000001 /* Don't start next entry in playlist */
- #define PLAYLIST_CONTROL_IGNORE 0x00000002 /* Ignore some playlist adding action */
-
-+#if defined(__alpha__) || defined(__amd64__) || defined(__ia64__) || defined(__sparc64__)
-+#define PRIi64 "li"
-+#else if defined(__i386__) || defined(__powerpc__)
-+#define PRIi64 "lli"
-+#endif
-+
- #define SAFE_FREE(x) do { \
- if((x)) { \
- free((x)); \
diff --git a/net/AquaGatekeeper/Makefile b/net/AquaGatekeeper/Makefile
index cb1ca3b6a999..d66da058e8d7 100644
--- a/net/AquaGatekeeper/Makefile
+++ b/net/AquaGatekeeper/Makefile
@@ -52,7 +52,7 @@ post-install:
.if ${ARCH} == "i386"
LIB_DEPENDS= c.4:${PORTSDIR}/misc/compat4x
-.elif ${OSVERSION} >= 600000 && ${ARCH} == "amd64"
+.elif ${ARCH} == "amd64"
LIB_DEPENDS= c.5:${PORTSDIR}/misc/compat5x
.endif
diff --git a/net/AquaGatekeeper2/Makefile b/net/AquaGatekeeper2/Makefile
index b6b8e9a26771..a969e5f436ff 100644
--- a/net/AquaGatekeeper2/Makefile
+++ b/net/AquaGatekeeper2/Makefile
@@ -54,7 +54,7 @@ post-install:
.if ${ARCH} == "i386"
LIB_DEPENDS= c.4:${PORTSDIR}/misc/compat4x
-.elif ${OSVERSION} >= 600000 && ${ARCH} == "amd64"
+.elif ${ARCH} == "amd64"
LIB_DEPENDS= c.5:${PORTSDIR}/misc/compat5x
.endif
diff --git a/net/acx100/Makefile b/net/acx100/Makefile
index dec16a717363..3f19f0baec8b 100644
--- a/net/acx100/Makefile
+++ b/net/acx100/Makefile
@@ -54,10 +54,6 @@ post-install:
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 501107
-IGNORE= This port requires newer kernel sources that include /sys/dev/owi/if_ieee80211.h
-.endif
-
.if ${OSVERSION} >= 601104
BROKEN= Does not compile on FreeBSD >= 6.x
DEPRECATED= Has been broken for more than 6 months
diff --git a/net/atmsupport/Makefile b/net/atmsupport/Makefile
index 9c0af4203753..bfc2832fb963 100644
--- a/net/atmsupport/Makefile
+++ b/net/atmsupport/Makefile
@@ -25,10 +25,4 @@ USE_LDCONFIG= yes
MAN1= unidecode.1 uniencode.1
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 501114
-IGNORE= "ngATM not implemented on FreeBSD 4.x, 5.1 and earlier"
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/bittwist/Makefile b/net/bittwist/Makefile
index 344792a64615..e7c805745f68 100644
--- a/net/bittwist/Makefile
+++ b/net/bittwist/Makefile
@@ -20,10 +20,4 @@ MAKE_ARGS+= CC="${CC}" CFLAGS="${CFLAGS}"
MAN1= bittwist.1 bittwistb.1 bittwiste.1
PLIST_FILES= bin/bittwist bin/bittwistb bin/bittwiste
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 600032
-BUILD_DEPENDS+= ${LOCALBASE}/lib/libpcap.a:${PORTSDIR}/net/libpcap
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/bpfstat/Makefile b/net/bpfstat/Makefile
index 2dacad213138..6d9ce9a233ce 100644
--- a/net/bpfstat/Makefile
+++ b/net/bpfstat/Makefile
@@ -19,10 +19,6 @@ PLIST_FILES= sbin/bpfstat
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 600033
-IGNORE= will only work on systems >= 600033
-.endif
-
.if ${OSVERSION} >= 700000
IGNORE= this has been merged into netstat
.endif
diff --git a/net/coda6_server/Makefile b/net/coda6_server/Makefile
index e6a47f7418d9..5559befd6333 100644
--- a/net/coda6_server/Makefile
+++ b/net/coda6_server/Makefile
@@ -78,13 +78,8 @@ MAN8= venus-setup.8 \
.include <bsd.port.pre.mk>
.if ${CODA_SUITE} == client
-.if ${OSVERSION} < 501106
-IGNORE= lacks kernel support on this version of FreeBSD
-.endif
# this needs testing with the new version (6.1.1)
-#.if ${OSVERSION} >= 600000
#IGNORE= makes a kernel panic on this version of FreeBSD
-#.endif
pre-everything::
@${ECHO_CMD} ""
@${ECHO_CMD} "WARNING:"
diff --git a/net/dhcperf/Makefile b/net/dhcperf/Makefile
index 240b91fbc8c2..48d7e64c4614 100644
--- a/net/dhcperf/Makefile
+++ b/net/dhcperf/Makefile
@@ -14,6 +14,8 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}-1-freebsd-5.4-i386
MAINTAINER= edwin@mavetju.org
COMMENT= DHCPerf delivers accurate performance metrics of Dynamic Host Configuration Protocol service
+LIB_DEPENDS= c.5:${PORTSDIR}/misc/compat5x
+
ONLY_FOR_ARCHS= i386
ONLY_FOR_ARCHS_REASON= Rebuild of i386 package provided by Nominum.
NO_BUILD= yes
@@ -25,16 +27,6 @@ PLIST_FILES= bin/dhcperf \
PLIST_DIRS= share/doc/dhcperf
MAN1= dhcperf.1
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION}<504000
-IGNORE= requires FreeBSD 5.4 or higher
-.endif
-
-.if ${OSVERSION}>600000
-LIB_DEPENDS= c.5:${PORTSDIR}/misc/compat5x
-.endif
-
post-extract:
${TAR} -C ${WRKSRC} -zxvf ${WRKSRC}/${PORTNAME}-${PORTVERSION}_1.tgz
@@ -45,4 +37,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/usr/local/nom/doc/dhcperf/dcsevaltutorial.pdf ${PREFIX}/share/doc/dhcperf/dcsevaltutorial.pdf
${INSTALL_DATA} ${WRKSRC}/usr/local/nom/doc/dhcperf/dhcperf.pdf ${PREFIX}/share/doc/dhcperf/dhcperf.pdf
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/dhcprelya/Makefile b/net/dhcprelya/Makefile
index 5e306ca216d3..baf6191b593f 100644
--- a/net/dhcprelya/Makefile
+++ b/net/dhcprelya/Makefile
@@ -19,16 +19,10 @@ PORTDOCS= README
PLIST_FILES= sbin/${PORTNAME}
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 600000
-IGNORE= require pidfile_* finctions in libutils
-.endif
-
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/freenx/Makefile b/net/freenx/Makefile
index 46ca1c377b4b..e26824a7b910 100644
--- a/net/freenx/Makefile
+++ b/net/freenx/Makefile
@@ -27,10 +27,6 @@ NXPREFIX?= ${PREFIX}/NX
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 503102
-RUN_DEPENDS+= nc:${PORTSDIR}/net/netcat
-.endif
-
.if ${OSVERSION} < 601101
EXTRA_PATCHES= ${PATCHDIR}/extra-patch-freenx-nxserver \
${PATCHDIR}/extra-patch-freenx-nxsetup
diff --git a/net/frickin/Makefile b/net/frickin/Makefile
index fc0ecbc2a76d..3ed160306ed8 100644
--- a/net/frickin/Makefile
+++ b/net/frickin/Makefile
@@ -38,10 +38,4 @@ do-install:
.endif
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 600000
-IGNORE= does not compile with old version of pf
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/ifdepd/Makefile b/net/ifdepd/Makefile
index cffc32bba2db..4d97ae4f5060 100644
--- a/net/ifdepd/Makefile
+++ b/net/ifdepd/Makefile
@@ -18,12 +18,6 @@ PLIST_FILES= bin/ifdepd \
USE_RC_SUBR= yes
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 502113
-IGNORE= need link state change notification changes from May 2004
-.endif
-
post-patch:
@${REINPLACE_CMD} -e \
's|/etc/rc\.subr|${RC_SUBR}|; s|/usr/local|${PREFIX}|' \
@@ -32,4 +26,4 @@ post-patch:
post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/ifstated/Makefile b/net/ifstated/Makefile
index babbf799e26f..7f54cc5c2ba9 100644
--- a/net/ifstated/Makefile
+++ b/net/ifstated/Makefile
@@ -29,10 +29,4 @@ post-patch:
post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 502113
-IGNORE= need link state change notification changes from May 2004
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/ipa_ipfw/Makefile b/net/ipa_ipfw/Makefile
index 57873826319d..f81259c80660 100644
--- a/net/ipa_ipfw/Makefile
+++ b/net/ipa_ipfw/Makefile
@@ -29,12 +29,6 @@ MAKE_ENV+= WITH_PTHREAD=yes
CFLAGS+= ${PTHREAD_CFLAGS}
.endif
-.if ${OSVERSION} < 500038
-. if (defined(IPFW2) && !defined(WITH_IPFW2)) || defined(WITH_IPFW2)
-MAKE_ENV+= IPFW2=yes
-. endif
-.endif
-
.if !defined(WITH_DEBUG_INFO)
MAKE_ENV+= DEBUG_FLAGS=""
.endif