aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid E. O'Brien <obrien@FreeBSD.org>2004-03-17 08:18:15 +0000
committerDavid E. O'Brien <obrien@FreeBSD.org>2004-03-17 08:18:15 +0000
commitd9162f158941ddaab15292a53e4aa487f227017a (patch)
tree4e6c931070ff0e8f8504d55e4c937603d5f5064a
parentce7b03f269f658cafbe5e9ab0d23af29832e2754 (diff)
Don't hardcode CONFIGURE_TARGET anymore -- the value in bsd.port.mk has
finally caught up with newer autoconf's requirements. Allow to build on AMD64 by lying with CONFIGURE_TARGET.
Notes
Notes: svn path=/head/; revision=104261
-rw-r--r--lang/gcc-ooo/Makefile5
-rw-r--r--lang/gcc/Makefile5
-rw-r--r--lang/gcc34/Makefile5
-rw-r--r--lang/gcc35/Makefile5
-rw-r--r--lang/gcc40/Makefile5
-rw-r--r--lang/gcc41/Makefile5
-rw-r--r--lang/gcc42/Makefile5
-rw-r--r--lang/gcc43/Makefile5
-rw-r--r--lang/gcc44/Makefile5
-rw-r--r--lang/gcc45/Makefile5
-rw-r--r--lang/gcc46/Makefile5
-rw-r--r--lang/gcc47/Makefile5
-rw-r--r--lang/gcc48/Makefile5
13 files changed, 26 insertions, 39 deletions
diff --git a/lang/gcc-ooo/Makefile b/lang/gcc-ooo/Makefile
index c07880a55db3..8ff31da6c6b5 100644
--- a/lang/gcc-ooo/Makefile
+++ b/lang/gcc-ooo/Makefile
@@ -42,7 +42,8 @@ NOMANCOMPRESS= yes # too hard to deal with differences on 5-cur and releng4
.include <bsd.port.pre.mk>
.if ${ARCH} == "amd64"
-BROKEN= "Configure broken due to renaming this architecture from x86_84."
+# fscking Linux & GNU $*!%
+CONFIGURE_TARGET= x86_64-portbld-freebsd${OSREL}
.endif
.if ${ARCH} == sparc64
@@ -54,8 +55,6 @@ WITHOUT_LIBJAVA= yes
WITHOUT_LIBJAVA= yes
.endif
-CONFIGURE_TARGET= ${ARCH}-portbld-freebsd${OSREL}
-
SRCDIR= ${WRKDIR}/gcc-${VERSIONSTRING}
WRKSRC= ${WRKDIR}/build
SUFFIX= 34
diff --git a/lang/gcc/Makefile b/lang/gcc/Makefile
index c07880a55db3..8ff31da6c6b5 100644
--- a/lang/gcc/Makefile
+++ b/lang/gcc/Makefile
@@ -42,7 +42,8 @@ NOMANCOMPRESS= yes # too hard to deal with differences on 5-cur and releng4
.include <bsd.port.pre.mk>
.if ${ARCH} == "amd64"
-BROKEN= "Configure broken due to renaming this architecture from x86_84."
+# fscking Linux & GNU $*!%
+CONFIGURE_TARGET= x86_64-portbld-freebsd${OSREL}
.endif
.if ${ARCH} == sparc64
@@ -54,8 +55,6 @@ WITHOUT_LIBJAVA= yes
WITHOUT_LIBJAVA= yes
.endif
-CONFIGURE_TARGET= ${ARCH}-portbld-freebsd${OSREL}
-
SRCDIR= ${WRKDIR}/gcc-${VERSIONSTRING}
WRKSRC= ${WRKDIR}/build
SUFFIX= 34
diff --git a/lang/gcc34/Makefile b/lang/gcc34/Makefile
index c07880a55db3..8ff31da6c6b5 100644
--- a/lang/gcc34/Makefile
+++ b/lang/gcc34/Makefile
@@ -42,7 +42,8 @@ NOMANCOMPRESS= yes # too hard to deal with differences on 5-cur and releng4
.include <bsd.port.pre.mk>
.if ${ARCH} == "amd64"
-BROKEN= "Configure broken due to renaming this architecture from x86_84."
+# fscking Linux & GNU $*!%
+CONFIGURE_TARGET= x86_64-portbld-freebsd${OSREL}
.endif
.if ${ARCH} == sparc64
@@ -54,8 +55,6 @@ WITHOUT_LIBJAVA= yes
WITHOUT_LIBJAVA= yes
.endif
-CONFIGURE_TARGET= ${ARCH}-portbld-freebsd${OSREL}
-
SRCDIR= ${WRKDIR}/gcc-${VERSIONSTRING}
WRKSRC= ${WRKDIR}/build
SUFFIX= 34
diff --git a/lang/gcc35/Makefile b/lang/gcc35/Makefile
index c07880a55db3..8ff31da6c6b5 100644
--- a/lang/gcc35/Makefile
+++ b/lang/gcc35/Makefile
@@ -42,7 +42,8 @@ NOMANCOMPRESS= yes # too hard to deal with differences on 5-cur and releng4
.include <bsd.port.pre.mk>
.if ${ARCH} == "amd64"
-BROKEN= "Configure broken due to renaming this architecture from x86_84."
+# fscking Linux & GNU $*!%
+CONFIGURE_TARGET= x86_64-portbld-freebsd${OSREL}
.endif
.if ${ARCH} == sparc64
@@ -54,8 +55,6 @@ WITHOUT_LIBJAVA= yes
WITHOUT_LIBJAVA= yes
.endif
-CONFIGURE_TARGET= ${ARCH}-portbld-freebsd${OSREL}
-
SRCDIR= ${WRKDIR}/gcc-${VERSIONSTRING}
WRKSRC= ${WRKDIR}/build
SUFFIX= 34
diff --git a/lang/gcc40/Makefile b/lang/gcc40/Makefile
index c07880a55db3..8ff31da6c6b5 100644
--- a/lang/gcc40/Makefile
+++ b/lang/gcc40/Makefile
@@ -42,7 +42,8 @@ NOMANCOMPRESS= yes # too hard to deal with differences on 5-cur and releng4
.include <bsd.port.pre.mk>
.if ${ARCH} == "amd64"
-BROKEN= "Configure broken due to renaming this architecture from x86_84."
+# fscking Linux & GNU $*!%
+CONFIGURE_TARGET= x86_64-portbld-freebsd${OSREL}
.endif
.if ${ARCH} == sparc64
@@ -54,8 +55,6 @@ WITHOUT_LIBJAVA= yes
WITHOUT_LIBJAVA= yes
.endif
-CONFIGURE_TARGET= ${ARCH}-portbld-freebsd${OSREL}
-
SRCDIR= ${WRKDIR}/gcc-${VERSIONSTRING}
WRKSRC= ${WRKDIR}/build
SUFFIX= 34
diff --git a/lang/gcc41/Makefile b/lang/gcc41/Makefile
index c07880a55db3..8ff31da6c6b5 100644
--- a/lang/gcc41/Makefile
+++ b/lang/gcc41/Makefile
@@ -42,7 +42,8 @@ NOMANCOMPRESS= yes # too hard to deal with differences on 5-cur and releng4
.include <bsd.port.pre.mk>
.if ${ARCH} == "amd64"
-BROKEN= "Configure broken due to renaming this architecture from x86_84."
+# fscking Linux & GNU $*!%
+CONFIGURE_TARGET= x86_64-portbld-freebsd${OSREL}
.endif
.if ${ARCH} == sparc64
@@ -54,8 +55,6 @@ WITHOUT_LIBJAVA= yes
WITHOUT_LIBJAVA= yes
.endif
-CONFIGURE_TARGET= ${ARCH}-portbld-freebsd${OSREL}
-
SRCDIR= ${WRKDIR}/gcc-${VERSIONSTRING}
WRKSRC= ${WRKDIR}/build
SUFFIX= 34
diff --git a/lang/gcc42/Makefile b/lang/gcc42/Makefile
index c07880a55db3..8ff31da6c6b5 100644
--- a/lang/gcc42/Makefile
+++ b/lang/gcc42/Makefile
@@ -42,7 +42,8 @@ NOMANCOMPRESS= yes # too hard to deal with differences on 5-cur and releng4
.include <bsd.port.pre.mk>
.if ${ARCH} == "amd64"
-BROKEN= "Configure broken due to renaming this architecture from x86_84."
+# fscking Linux & GNU $*!%
+CONFIGURE_TARGET= x86_64-portbld-freebsd${OSREL}
.endif
.if ${ARCH} == sparc64
@@ -54,8 +55,6 @@ WITHOUT_LIBJAVA= yes
WITHOUT_LIBJAVA= yes
.endif
-CONFIGURE_TARGET= ${ARCH}-portbld-freebsd${OSREL}
-
SRCDIR= ${WRKDIR}/gcc-${VERSIONSTRING}
WRKSRC= ${WRKDIR}/build
SUFFIX= 34
diff --git a/lang/gcc43/Makefile b/lang/gcc43/Makefile
index c07880a55db3..8ff31da6c6b5 100644
--- a/lang/gcc43/Makefile
+++ b/lang/gcc43/Makefile
@@ -42,7 +42,8 @@ NOMANCOMPRESS= yes # too hard to deal with differences on 5-cur and releng4
.include <bsd.port.pre.mk>
.if ${ARCH} == "amd64"
-BROKEN= "Configure broken due to renaming this architecture from x86_84."
+# fscking Linux & GNU $*!%
+CONFIGURE_TARGET= x86_64-portbld-freebsd${OSREL}
.endif
.if ${ARCH} == sparc64
@@ -54,8 +55,6 @@ WITHOUT_LIBJAVA= yes
WITHOUT_LIBJAVA= yes
.endif
-CONFIGURE_TARGET= ${ARCH}-portbld-freebsd${OSREL}
-
SRCDIR= ${WRKDIR}/gcc-${VERSIONSTRING}
WRKSRC= ${WRKDIR}/build
SUFFIX= 34
diff --git a/lang/gcc44/Makefile b/lang/gcc44/Makefile
index c07880a55db3..8ff31da6c6b5 100644
--- a/lang/gcc44/Makefile
+++ b/lang/gcc44/Makefile
@@ -42,7 +42,8 @@ NOMANCOMPRESS= yes # too hard to deal with differences on 5-cur and releng4
.include <bsd.port.pre.mk>
.if ${ARCH} == "amd64"
-BROKEN= "Configure broken due to renaming this architecture from x86_84."
+# fscking Linux & GNU $*!%
+CONFIGURE_TARGET= x86_64-portbld-freebsd${OSREL}
.endif
.if ${ARCH} == sparc64
@@ -54,8 +55,6 @@ WITHOUT_LIBJAVA= yes
WITHOUT_LIBJAVA= yes
.endif
-CONFIGURE_TARGET= ${ARCH}-portbld-freebsd${OSREL}
-
SRCDIR= ${WRKDIR}/gcc-${VERSIONSTRING}
WRKSRC= ${WRKDIR}/build
SUFFIX= 34
diff --git a/lang/gcc45/Makefile b/lang/gcc45/Makefile
index c07880a55db3..8ff31da6c6b5 100644
--- a/lang/gcc45/Makefile
+++ b/lang/gcc45/Makefile
@@ -42,7 +42,8 @@ NOMANCOMPRESS= yes # too hard to deal with differences on 5-cur and releng4
.include <bsd.port.pre.mk>
.if ${ARCH} == "amd64"
-BROKEN= "Configure broken due to renaming this architecture from x86_84."
+# fscking Linux & GNU $*!%
+CONFIGURE_TARGET= x86_64-portbld-freebsd${OSREL}
.endif
.if ${ARCH} == sparc64
@@ -54,8 +55,6 @@ WITHOUT_LIBJAVA= yes
WITHOUT_LIBJAVA= yes
.endif
-CONFIGURE_TARGET= ${ARCH}-portbld-freebsd${OSREL}
-
SRCDIR= ${WRKDIR}/gcc-${VERSIONSTRING}
WRKSRC= ${WRKDIR}/build
SUFFIX= 34
diff --git a/lang/gcc46/Makefile b/lang/gcc46/Makefile
index c07880a55db3..8ff31da6c6b5 100644
--- a/lang/gcc46/Makefile
+++ b/lang/gcc46/Makefile
@@ -42,7 +42,8 @@ NOMANCOMPRESS= yes # too hard to deal with differences on 5-cur and releng4
.include <bsd.port.pre.mk>
.if ${ARCH} == "amd64"
-BROKEN= "Configure broken due to renaming this architecture from x86_84."
+# fscking Linux & GNU $*!%
+CONFIGURE_TARGET= x86_64-portbld-freebsd${OSREL}
.endif
.if ${ARCH} == sparc64
@@ -54,8 +55,6 @@ WITHOUT_LIBJAVA= yes
WITHOUT_LIBJAVA= yes
.endif
-CONFIGURE_TARGET= ${ARCH}-portbld-freebsd${OSREL}
-
SRCDIR= ${WRKDIR}/gcc-${VERSIONSTRING}
WRKSRC= ${WRKDIR}/build
SUFFIX= 34
diff --git a/lang/gcc47/Makefile b/lang/gcc47/Makefile
index c07880a55db3..8ff31da6c6b5 100644
--- a/lang/gcc47/Makefile
+++ b/lang/gcc47/Makefile
@@ -42,7 +42,8 @@ NOMANCOMPRESS= yes # too hard to deal with differences on 5-cur and releng4
.include <bsd.port.pre.mk>
.if ${ARCH} == "amd64"
-BROKEN= "Configure broken due to renaming this architecture from x86_84."
+# fscking Linux & GNU $*!%
+CONFIGURE_TARGET= x86_64-portbld-freebsd${OSREL}
.endif
.if ${ARCH} == sparc64
@@ -54,8 +55,6 @@ WITHOUT_LIBJAVA= yes
WITHOUT_LIBJAVA= yes
.endif
-CONFIGURE_TARGET= ${ARCH}-portbld-freebsd${OSREL}
-
SRCDIR= ${WRKDIR}/gcc-${VERSIONSTRING}
WRKSRC= ${WRKDIR}/build
SUFFIX= 34
diff --git a/lang/gcc48/Makefile b/lang/gcc48/Makefile
index c07880a55db3..8ff31da6c6b5 100644
--- a/lang/gcc48/Makefile
+++ b/lang/gcc48/Makefile
@@ -42,7 +42,8 @@ NOMANCOMPRESS= yes # too hard to deal with differences on 5-cur and releng4
.include <bsd.port.pre.mk>
.if ${ARCH} == "amd64"
-BROKEN= "Configure broken due to renaming this architecture from x86_84."
+# fscking Linux & GNU $*!%
+CONFIGURE_TARGET= x86_64-portbld-freebsd${OSREL}
.endif
.if ${ARCH} == sparc64
@@ -54,8 +55,6 @@ WITHOUT_LIBJAVA= yes
WITHOUT_LIBJAVA= yes
.endif
-CONFIGURE_TARGET= ${ARCH}-portbld-freebsd${OSREL}
-
SRCDIR= ${WRKDIR}/gcc-${VERSIONSTRING}
WRKSRC= ${WRKDIR}/build
SUFFIX= 34