aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2006-05-18 19:59:17 +0000
committerErwin Lansing <erwin@FreeBSD.org>2006-05-18 19:59:17 +0000
commitdba1679da6ba77781df20f3dd4fb2571472122a5 (patch)
tree3ef715469f1782823a082b3c59ec4b8da36b8ce7
parenta3c9a663c279fce09f7a82be6f394881317d48fe (diff)
downloadports-dba1679da6ba77781df20f3dd4fb2571472122a5.tar.gz
ports-dba1679da6ba77781df20f3dd4fb2571472122a5.zip
Notes
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Class-Gomor/Makefile30
-rw-r--r--devel/p5-Class-Gomor/distinfo3
-rw-r--r--devel/p5-Class-Gomor/pkg-descr5
-rw-r--r--devel/p5-Class-Gomor/pkg-plist8
5 files changed, 47 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 313c0014d289..6883c827b297 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -783,6 +783,7 @@
SUBDIR += p5-Class-Factory-Util
SUBDIR += p5-Class-Fields
SUBDIR += p5-Class-Generate
+ SUBDIR += p5-Class-Gomor
SUBDIR += p5-Class-Gomor-Hash
SUBDIR += p5-Class-Handle
SUBDIR += p5-Class-Hook
diff --git a/devel/p5-Class-Gomor/Makefile b/devel/p5-Class-Gomor/Makefile
new file mode 100644
index 000000000000..5aa7eff8120f
--- /dev/null
+++ b/devel/p5-Class-Gomor/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: Class-Gomor
+# Date created: 17 May 2006
+# Whom: Christopher Boumenot <boumenot@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Class-Gomor
+PORTVERSION= 1.00
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Class
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= boumenot@gmail.com
+COMMENT= Class and object builder
+
+PERL_CONFIGURE= yes
+
+MAN3= Class::Gomor.3 \
+ Class::Gomor::Hash.3 \
+ Class::Gomor::Array.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE=Needs perl 5.6.0 or higher, install lang/perl5.6 and try again.
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Class-Gomor/distinfo b/devel/p5-Class-Gomor/distinfo
new file mode 100644
index 000000000000..9afa25f6caaf
--- /dev/null
+++ b/devel/p5-Class-Gomor/distinfo
@@ -0,0 +1,3 @@
+MD5 (Class-Gomor-1.00.tar.gz) = 740731c9affd21fe4b6d623254e64f9f
+SHA256 (Class-Gomor-1.00.tar.gz) = 56468589b48d22372ff4171533bb4f6c9e2b54454506aea66a3d3ed5eafbcffb
+SIZE (Class-Gomor-1.00.tar.gz) = 8159
diff --git a/devel/p5-Class-Gomor/pkg-descr b/devel/p5-Class-Gomor/pkg-descr
new file mode 100644
index 000000000000..165a113cdaa7
--- /dev/null
+++ b/devel/p5-Class-Gomor/pkg-descr
@@ -0,0 +1,5 @@
+This module is yet another class builder. This one adds parameter checking in
+new constructor, that is to check for attributes existence, and definedness.
+
+Authors: GomoR <netpkt@gomor.org>
+WWW: http://search.cpan.org/dist/Class-Gomor/
diff --git a/devel/p5-Class-Gomor/pkg-plist b/devel/p5-Class-Gomor/pkg-plist
new file mode 100644
index 000000000000..790d1a03ec36
--- /dev/null
+++ b/devel/p5-Class-Gomor/pkg-plist
@@ -0,0 +1,8 @@
+%%SITE_PERL%%/Class/Gomor.pm
+%%SITE_PERL%%/Class/Gomor/Array.pm
+%%SITE_PERL%%/Class/Gomor/Hash.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Class/Gomor/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Class/Gomor
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Class
+@dirrm %%SITE_PERL%%/Class/Gomor
+@dirrmtry %%SITE_PERL%%/Class