aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2003-11-13 18:24:52 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2003-11-13 18:24:52 +0000
commite0d14f44e284923d25d62b89d4171e82ceeab782 (patch)
tree8aa95b0ef079a9e74af77bf2984f430b498e132f
parent1dfa0e9587e5ca02b139c28783e31ea4f43451c2 (diff)
downloadports-e0d14f44e284923d25d62b89d4171e82ceeab782.tar.gz
ports-e0d14f44e284923d25d62b89d4171e82ceeab782.zip
Notes
-rw-r--r--editors/Makefile1
-rw-r--r--editors/tpad/Makefile27
-rw-r--r--editors/tpad/distinfo1
-rw-r--r--editors/tpad/pkg-descr10
-rw-r--r--editors/tpad/pkg-plist1
5 files changed, 40 insertions, 0 deletions
diff --git a/editors/Makefile b/editors/Makefile
index d695843f7ad7..1bd857308125 100644
--- a/editors/Makefile
+++ b/editors/Makefile
@@ -172,6 +172,7 @@
SUBDIR += textedit
SUBDIR += the
SUBDIR += thoteditor
+ SUBDIR += tpad
SUBDIR += uemacs
SUBDIR += uzap
SUBDIR += ved
diff --git a/editors/tpad/Makefile b/editors/tpad/Makefile
new file mode 100644
index 000000000000..4712fd2d74f2
--- /dev/null
+++ b/editors/tpad/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: tpad
+# Date created: 10 November 2003
+# Whom: Antonio Bonifati <ant@monitor.deis.unical.it>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tpad
+PORTVERSION= 1.0
+CATEGORIES= editors tcl84 tk84
+MASTER_SITES= http://monitor.deis.unical.it/ant/tpad/ \
+ http://queen.rett.polimi.it/~ant/tcl/script/
+DISTNAME= ${PORTNAME}-${PORTVERSION}.tcl
+EXTRACT_SUFX=
+EXTRACT_ONLY=
+
+MAINTAINER= ant@monitor.deis.unical.it
+COMMENT= Win95/98 (TM) Notepad clone written in Tcl/Tk
+
+RUN_DEPENDS= wish8.4:${PORTSDIR}/x11-toolkits/tk84
+
+NO_BUILD= yes
+
+do-install:
+ ${INSTALL_SCRIPT} ${DISTDIR}/${DISTFILES} ${PREFIX}/bin/tpad
+
+.include <bsd.port.mk>
diff --git a/editors/tpad/distinfo b/editors/tpad/distinfo
new file mode 100644
index 000000000000..d13d0d697032
--- /dev/null
+++ b/editors/tpad/distinfo
@@ -0,0 +1 @@
+MD5 (tpad-1.0.tcl) = 145d45dd4954243c8e94a9d745c2721b
diff --git a/editors/tpad/pkg-descr b/editors/tpad/pkg-descr
new file mode 100644
index 000000000000..fd3874ff290e
--- /dev/null
+++ b/editors/tpad/pkg-descr
@@ -0,0 +1,10 @@
+The executable tpad is a wish(1) shell script.
+
+I think the only difference with Notepad
+is that it doesn't limit the size of the
+file to edit :-)
+
+WWW: http://monitor.deis.unical.it/ant/tpad/
+
+- Antonio Bonifati
+ant@monitor.deis.unical.it
diff --git a/editors/tpad/pkg-plist b/editors/tpad/pkg-plist
new file mode 100644
index 000000000000..7262d9dbb364
--- /dev/null
+++ b/editors/tpad/pkg-plist
@@ -0,0 +1 @@
+bin/tpad