aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2017-02-14 19:34:41 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2017-02-14 19:34:41 +0000
commite439d692634bccf72f04385f5f81e1bb0e428a02 (patch)
tree80946ea62cb2c30251b8fb975d6d050bbf236760
parent9375e1cb42321c38de1b13636a0b069ebe993c0b (diff)
downloadports-e439d692634bccf72f04385f5f81e1bb0e428a02.tar.gz
ports-e439d692634bccf72f04385f5f81e1bb0e428a02.zip
Notes
-rw-r--r--x11/tint/Makefile13
-rw-r--r--x11/tint/distinfo6
-rw-r--r--x11/tint/files/patch-src_tint2conf_po_CMakeLists.txt10
-rw-r--r--x11/tint/pkg-plist19
4 files changed, 33 insertions, 15 deletions
diff --git a/x11/tint/Makefile b/x11/tint/Makefile
index a6284601e741..80c586341e94 100644
--- a/x11/tint/Makefile
+++ b/x11/tint/Makefile
@@ -1,9 +1,8 @@
# $FreeBSD$
PORTNAME= tint2
-PORTVERSION= 0.12.11
+PORTVERSION= 0.12.12
CATEGORIES= x11
-MASTER_SITES= http://deponie.yamagi.org/freebsd/distfiles/tint/
MAINTAINER= yamagi@yamagi.org
COMMENT= Lightweight freedesktop-compliant panel/taskbar/systray/clock
@@ -16,7 +15,7 @@ LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
libImlib2.so:graphics/imlib2 \
libstartup-notification-1.so:x11/startup-notification \
-USES= alias cmake gettext pkgconfig tar:xz
+USES= alias cmake:outsource pkgconfig
USE_GNOME= cairo glib20 gtk20 librsvg2 pango
USE_XORG= x11 xcomposite xdamage xfixes xinerama xrandr xrender
INSTALLS_ICONS= yes
@@ -24,10 +23,12 @@ INSTALLS_ICONS= yes
CMAKE_ARGS= -DMANDIR:PATH=man -DSYSCONFDIR:PATH=etc
OPTIONS_DEFINE= EXAMPLES NLS
-EXAMPLES_CMAKE_ON= -DENABLE_EXAMPLES:BOOL=ON
-EXAMPLES_CMAKE_OFF= -DENABLE_EXAMPLES:BOOL=OFF
OPTIONS_SUB= yes
+EXAMPLES_CMAKE_BOOL= ENABLE_EXAMPLES
NLS_USES= gettext
-NLS_CONFIGURE_ENABLE= nls
+NLS_CMAKE_BOOL_OFF= CMAKE_DISABLE_FIND_PACKAGE_Gettext
+
+USE_GITHUB= yes
+GH_ACCOUNT= o9000
.include <bsd.port.mk>
diff --git a/x11/tint/distinfo b/x11/tint/distinfo
index 3ca91ee7e203..9a35eeca0435 100644
--- a/x11/tint/distinfo
+++ b/x11/tint/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1465539549
-SHA256 (tint2-0.12.11.tar.xz) = 16554b96a6a22b00126e8453e6f30cf3fde734582c526669c7c12b13657482c7
-SIZE (tint2-0.12.11.tar.xz) = 261380
+TIMESTAMP = 1487020660
+SHA256 (o9000-tint2-0.12.12_GH0.tar.gz) = e33c47fbea81fbfd0ac4ded2c506a542c6c727701ecdf8987927ae51f325a826
+SIZE (o9000-tint2-0.12.12_GH0.tar.gz) = 469147
diff --git a/x11/tint/files/patch-src_tint2conf_po_CMakeLists.txt b/x11/tint/files/patch-src_tint2conf_po_CMakeLists.txt
new file mode 100644
index 000000000000..4f93631bee22
--- /dev/null
+++ b/x11/tint/files/patch-src_tint2conf_po_CMakeLists.txt
@@ -0,0 +1,10 @@
+Make it possible to toggle NLS.
+
+--- src/tint2conf/po/CMakeLists.txt.orig 2017-02-13 22:12:47 UTC
++++ src/tint2conf/po/CMakeLists.txt
+@@ -1,4 +1,4 @@
+-include(FindGettext)
++find_package(Gettext)
+ if (GETTEXT_FOUND)
+ set(GETTEXT_PACKAGE tint2conf)
+ file(GLOB POTFILES RELATIVE ${CMAKE_CURRENT_SOURCE_DIR} "*.po")
diff --git a/x11/tint/pkg-plist b/x11/tint/pkg-plist
index 89a1ce90262a..f69ab216c4ad 100644
--- a/x11/tint/pkg-plist
+++ b/x11/tint/pkg-plist
@@ -7,14 +7,21 @@ share/applications/tint2conf.desktop
%%DOCSDIR%%/AUTHORS
%%DOCSDIR%%/ChangeLog
%%DOCSDIR%%/README.md
+%%DOCSDIR%%/images/panel_padding.jpg
+%%DOCSDIR%%/images/panel_size_margin.jpg
+%%DOCSDIR%%/images/task_padding.jpg
+%%DOCSDIR%%/images/taskbar_padding.jpg
+%%DOCSDIR%%/manual.html
+%%DOCSDIR%%/readme.html
+%%DOCSDIR%%/tint2.md
share/icons/hicolor/scalable/apps/tint2.svg
share/icons/hicolor/scalable/apps/tint2conf.svg
-share/locale/bs/LC_MESSAGES/tint2conf.mo
-share/locale/fr/LC_MESSAGES/tint2conf.mo
-share/locale/hr/LC_MESSAGES/tint2conf.mo
-share/locale/pl/LC_MESSAGES/tint2conf.mo
-share/locale/ru/LC_MESSAGES/tint2conf.mo
-share/locale/sr/LC_MESSAGES/tint2conf.mo
+%%NLS%%share/locale/bs/LC_MESSAGES/tint2conf.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/tint2conf.mo
+%%NLS%%share/locale/hr/LC_MESSAGES/tint2conf.mo
+%%NLS%%share/locale/pl/LC_MESSAGES/tint2conf.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/tint2conf.mo
+%%NLS%%share/locale/sr/LC_MESSAGES/tint2conf.mo
%%DATADIR%%/default_icon.png
%%EXAMPLES%%%%DATADIR%%/horizontal-dark-opaque.tint2rc
%%EXAMPLES%%%%DATADIR%%/horizontal-dark-transparent.tint2rc