aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2003-11-13 08:55:43 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2003-11-13 08:55:43 +0000
commitf9f67b7f19b5607aa295aeff944d82d447a509b5 (patch)
tree31196f1936d6efbb546d3e9fde5f7dde0a8e8f3a
parent3507ac4a08c491edbf0b4a070c11c1dc52705f87 (diff)
downloadports-f9f67b7f19b5607aa295aeff944d82d447a509b5.tar.gz
ports-f9f67b7f19b5607aa295aeff944d82d447a509b5.zip
Notes
-rw-r--r--x11/Makefile1
-rw-r--r--x11/gtk2-theme-switch/Makefile31
-rw-r--r--x11/gtk2-theme-switch/distinfo1
-rw-r--r--x11/gtk2-theme-switch/files/patch-aa12
-rw-r--r--x11/gtk2-theme-switch/pkg-descr3
-rw-r--r--x11/gtk2-theme-switch/pkg-plist3
6 files changed, 51 insertions, 0 deletions
diff --git a/x11/Makefile b/x11/Makefile
index 3e2f5aa470e9..7b1b2599dc9a 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -56,6 +56,7 @@
SUBDIR += gromit
SUBDIR += gswitchit
SUBDIR += gtk-theme-switch
+ SUBDIR += gtk2-theme-switch
SUBDIR += gxset
SUBDIR += gyroscope
SUBDIR += idesk
diff --git a/x11/gtk2-theme-switch/Makefile b/x11/gtk2-theme-switch/Makefile
new file mode 100644
index 000000000000..04e97c2a44e4
--- /dev/null
+++ b/x11/gtk2-theme-switch/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: gtk-theme-switch
+# Date Created: Thu Nov 13 01:44:28 EST 2003
+# Whom: Andrew J. Caines <A.J.Caines@halplant.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gtk2-theme-switch
+PORTVERSION= 2.0.0.r2
+CATEGORIES= x11
+MASTER_SITES= http://www.muhri.net/
+DISTNAME= ${PORTNAME:S/gtk2/gtk/}-${PORTVERSION:S/.r/rc/}
+
+MAINTAINER= A.J.Caines@halplant.com
+COMMENT= A command line tool for switching GTK themes
+
+USE_X_PREFIX= yes
+USE_GNOME= gtk20
+USE_GMAKE= yes
+
+MAN1= gtk2-theme-switch.1
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/switch2 ${PREFIX}/bin/${PORTNAME}
+ ${INSTALL_MAN} ${WRKSRC}/switch.1 ${MANPREFIX}/man/man1/${PORTNAME}.1
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/readme ${DOCSDIR}/README
+.endif
+
+.include <bsd.port.mk>
diff --git a/x11/gtk2-theme-switch/distinfo b/x11/gtk2-theme-switch/distinfo
new file mode 100644
index 000000000000..46bbce4fd39a
--- /dev/null
+++ b/x11/gtk2-theme-switch/distinfo
@@ -0,0 +1 @@
+MD5 (gtk-theme-switch-2.0.0rc2.tar.gz) = f51b254fb347a86feef12db4bd76be6f
diff --git a/x11/gtk2-theme-switch/files/patch-aa b/x11/gtk2-theme-switch/files/patch-aa
new file mode 100644
index 000000000000..63924ba6b688
--- /dev/null
+++ b/x11/gtk2-theme-switch/files/patch-aa
@@ -0,0 +1,12 @@
+--- Makefile.orig Wed Jun 11 01:16:36 2003
++++ Makefile Thu Nov 13 01:33:20 2003
+@@ -1,6 +1,6 @@
+-GCC = cc
+-PREFIX=/usr/local
+-CFLAGS = -O2 -Wall $(shell pkg-config --cflags gtk+-2.0)
++GCC = ${CC}
++PREFIX?=/usr/local
++CFLAGS += -Wall $(shell pkg-config --cflags gtk+-2.0)
+ LIBS = $(shell pkg-config --libs gtk+-2.0)
+ CFLAGS += -DGTK_DISABLE_BROKEN -DGTK_DISABLE_DEPRECATED
+
diff --git a/x11/gtk2-theme-switch/pkg-descr b/x11/gtk2-theme-switch/pkg-descr
new file mode 100644
index 000000000000..ad2403c5e386
--- /dev/null
+++ b/x11/gtk2-theme-switch/pkg-descr
@@ -0,0 +1,3 @@
+A command line and GUI tool for switching GTK2 themes.
+
+WWW: http://www.muhri.net/gthemeswitch.php3
diff --git a/x11/gtk2-theme-switch/pkg-plist b/x11/gtk2-theme-switch/pkg-plist
new file mode 100644
index 000000000000..d4b2ff3384f9
--- /dev/null
+++ b/x11/gtk2-theme-switch/pkg-plist
@@ -0,0 +1,3 @@
+bin/gtk2-theme-switch
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%@dirrm share/doc/gtk2-theme-switch