aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2016-12-27 12:20:41 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2016-12-27 12:20:41 +0000
commit0190983d134086e0e061993e8cdeebc3480bd350 (patch)
tree26de5254902fb1fa725c5b9bcd0e6ab43fb0b0b1
parentfdf1402dd49ec98de17b7e3aa721b7ff57b41274 (diff)
downloadports-0190983d134086e0e061993e8cdeebc3480bd350.tar.gz
ports-0190983d134086e0e061993e8cdeebc3480bd350.zip
Notes
-rw-r--r--audio/logitechmediaserver/Makefile2
-rw-r--r--deskutils/gnome-shell-extension-audio-output-switcher/Makefile2
-rw-r--r--deskutils/gnome-shell-extension-coverflow/Makefile2
-rw-r--r--deskutils/gnome-shell-extension-dashtodock/Makefile2
-rw-r--r--deskutils/gnome-shell-extension-filesmenu/Makefile2
-rw-r--r--deskutils/gnome-shell-extension-hidetopbar/Makefile2
-rw-r--r--deskutils/gnome-shell-extension-lockkeys/Makefile2
-rw-r--r--deskutils/gnome-shell-extension-mediaplayer/Makefile2
-rw-r--r--deskutils/gnome-shell-extension-openweather/Makefile2
-rw-r--r--deskutils/gnome-shell-extension-overlay-icons/Makefile2
-rw-r--r--deskutils/gnome-shell-extension-panel-osd/Makefile2
-rw-r--r--deskutils/gnome-shell-extension-trash/Makefile2
-rw-r--r--deskutils/gnome-shell-extension-weather/Makefile2
-rw-r--r--devel/libmowgli/Makefile3
-rw-r--r--devel/php-jq/Makefile3
-rw-r--r--dns/dnsrecon/Makefile2
-rw-r--r--graphics/pqiv/Makefile4
-rw-r--r--lang/tcc/Makefile2
-rw-r--r--multimedia/libvpx/Makefile2
-rw-r--r--net-im/diligent/Makefile6
-rw-r--r--net/exabgp/Makefile2
-rw-r--r--net/exaddos/Makefile3
-rw-r--r--net/mrouted/Makefile1
-rw-r--r--net/pimd/Makefile5
-rw-r--r--security/nikto/Makefile2
-rw-r--r--sysutils/nfcutils/Makefile5
-rw-r--r--sysutils/pcbsd-appweb/Makefile3
-rw-r--r--sysutils/pcbsd-libsh/Makefile3
-rw-r--r--sysutils/pcbsd-syscache/Makefile2
-rw-r--r--sysutils/warden/Makefile3
-rw-r--r--www/codeigniter/Makefile8
31 files changed, 45 insertions, 40 deletions
diff --git a/audio/logitechmediaserver/Makefile b/audio/logitechmediaserver/Makefile
index 5b98fefb94f5..932ee3ba47be 100644
--- a/audio/logitechmediaserver/Makefile
+++ b/audio/logitechmediaserver/Makefile
@@ -26,7 +26,7 @@ RESTRICTED= Contains non-redistributable firmware, documentation, and images
USERS= ${SLIMUSER}
GROUPS= ${SLIMGROUP}
-USES= gettext-runtime gmake perl5 shebangfix tar:tgz
+USES= gettext-runtime gmake perl5 shebangfix
EXTRA_PATCHES= ${FILESDIR}/vendorpatch-CPAN_buildme.sh
SHEBANG_FILES= Bin/darwin/check-update.pl \
Bin/dbish \
diff --git a/deskutils/gnome-shell-extension-audio-output-switcher/Makefile b/deskutils/gnome-shell-extension-audio-output-switcher/Makefile
index 4c73f33e57be..c0a4a5a07007 100644
--- a/deskutils/gnome-shell-extension-audio-output-switcher/Makefile
+++ b/deskutils/gnome-shell-extension-audio-output-switcher/Makefile
@@ -15,7 +15,7 @@ BUILD_DEPENDS= gnome-shell>=0:x11/gnome-shell \
RUN_DEPENDS= gnome-shell>=0:x11/gnome-shell \
gsettings-desktop-schemas>=3.12.0:devel/gsettings-desktop-schemas
-USES= gettext gmake gnome pkgconfig tar:xz
+USES= gettext gmake gnome pkgconfig
USE_GNOME= glib20
USE_GITHUB= yes
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/deskutils/gnome-shell-extension-coverflow/Makefile b/deskutils/gnome-shell-extension-coverflow/Makefile
index d6ee9a505bf0..a5a5b04856e6 100644
--- a/deskutils/gnome-shell-extension-coverflow/Makefile
+++ b/deskutils/gnome-shell-extension-coverflow/Makefile
@@ -14,7 +14,7 @@ BUILD_DEPENDS= gnome-shell>=0:x11/gnome-shell \
RUN_DEPENDS= gnome-shell>=0:x11/gnome-shell \
gsettings-desktop-schemas>=3.12.0:devel/gsettings-desktop-schemas
-USES= gettext gmake gnome pkgconfig tar:xz
+USES= gettext gmake gnome pkgconfig
USE_GNOME= glib20
USE_GITHUB= yes
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/deskutils/gnome-shell-extension-dashtodock/Makefile b/deskutils/gnome-shell-extension-dashtodock/Makefile
index 8fb1cd3090d0..4f63556d932a 100644
--- a/deskutils/gnome-shell-extension-dashtodock/Makefile
+++ b/deskutils/gnome-shell-extension-dashtodock/Makefile
@@ -14,7 +14,7 @@ BUILD_DEPENDS= gnome-shell>=0:x11/gnome-shell \
RUN_DEPENDS= gnome-shell>=0:x11/gnome-shell \
gsettings-desktop-schemas>=3.12.0:devel/gsettings-desktop-schemas
-USES= gettext gmake gnome pkgconfig tar:xz
+USES= gettext gmake gnome pkgconfig
USE_GNOME= glib20
USE_GITHUB= yes
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/deskutils/gnome-shell-extension-filesmenu/Makefile b/deskutils/gnome-shell-extension-filesmenu/Makefile
index fa20546cdb4f..8318de9aa0d0 100644
--- a/deskutils/gnome-shell-extension-filesmenu/Makefile
+++ b/deskutils/gnome-shell-extension-filesmenu/Makefile
@@ -14,7 +14,7 @@ BUILD_DEPENDS= gnome-shell>=0:x11/gnome-shell \
RUN_DEPENDS= gnome-shell>=0:x11/gnome-shell \
gsettings-desktop-schemas>=3.12.0:devel/gsettings-desktop-schemas
-USES= gettext gmake pkgconfig tar:xz
+USES= gettext gmake pkgconfig
USE_GNOME= glib20
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/deskutils/gnome-shell-extension-hidetopbar/Makefile b/deskutils/gnome-shell-extension-hidetopbar/Makefile
index 3076273a1011..0e302931ab8b 100644
--- a/deskutils/gnome-shell-extension-hidetopbar/Makefile
+++ b/deskutils/gnome-shell-extension-hidetopbar/Makefile
@@ -14,7 +14,7 @@ BUILD_DEPENDS= gnome-shell>=0:x11/gnome-shell \
RUN_DEPENDS= gnome-shell>=0:x11/gnome-shell \
gsettings-desktop-schemas>=3.12.0:devel/gsettings-desktop-schemas
-USES= gettext gmake gnome pkgconfig tar:xz
+USES= gettext gmake gnome pkgconfig
USE_GNOME= glib20
USE_GITHUB= yes
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/deskutils/gnome-shell-extension-lockkeys/Makefile b/deskutils/gnome-shell-extension-lockkeys/Makefile
index 4fa82e4a658a..2b5baf47dc94 100644
--- a/deskutils/gnome-shell-extension-lockkeys/Makefile
+++ b/deskutils/gnome-shell-extension-lockkeys/Makefile
@@ -14,7 +14,7 @@ BUILD_DEPENDS= gnome-shell>=0:x11/gnome-shell \
RUN_DEPENDS= gnome-shell>=0:x11/gnome-shell \
gsettings-desktop-schemas>=3.12.0:devel/gsettings-desktop-schemas
-USES= gettext gmake gnome pkgconfig tar:xz
+USES= gettext gmake gnome pkgconfig
USE_GNOME= glib20
USE_GITHUB= yes
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/deskutils/gnome-shell-extension-mediaplayer/Makefile b/deskutils/gnome-shell-extension-mediaplayer/Makefile
index ae4318abc6f8..f475228874f4 100644
--- a/deskutils/gnome-shell-extension-mediaplayer/Makefile
+++ b/deskutils/gnome-shell-extension-mediaplayer/Makefile
@@ -14,7 +14,7 @@ BUILD_DEPENDS= gnome-autogen.sh:devel/gnome-common \
RUN_DEPENDS= gnome-shell>=0:x11/gnome-shell \
gsettings-desktop-schemas>=3.12.0:devel/gsettings-desktop-schemas
-USES= autoreconf gettext gmake gnome libtool pkgconfig tar:xz
+USES= autoreconf gettext gmake gnome libtool pkgconfig
USE_GNOME= glib20 intltool
USE_GITHUB= yes
USE_LDCONFIG= yes
diff --git a/deskutils/gnome-shell-extension-openweather/Makefile b/deskutils/gnome-shell-extension-openweather/Makefile
index e687ad472432..ccab51c6d4b1 100644
--- a/deskutils/gnome-shell-extension-openweather/Makefile
+++ b/deskutils/gnome-shell-extension-openweather/Makefile
@@ -14,7 +14,7 @@ BUILD_DEPENDS= gnome-autogen.sh:devel/gnome-common \
RUN_DEPENDS= gnome-shell>=0:x11/gnome-shell \
gsettings-desktop-schemas>=3.12.0:devel/gsettings-desktop-schemas
-USES= autoreconf gettext gmake gnome libtool pkgconfig tar:xz
+USES= autoreconf gettext gmake gnome libtool pkgconfig
USE_GNOME= glib20 intltool
USE_GITHUB= yes
USE_LDCONFIG= yes
diff --git a/deskutils/gnome-shell-extension-overlay-icons/Makefile b/deskutils/gnome-shell-extension-overlay-icons/Makefile
index e572d9f1f944..e3ff74dde49f 100644
--- a/deskutils/gnome-shell-extension-overlay-icons/Makefile
+++ b/deskutils/gnome-shell-extension-overlay-icons/Makefile
@@ -14,7 +14,7 @@ BUILD_DEPENDS= gnome-shell>=0:x11/gnome-shell \
RUN_DEPENDS= gnome-shell>=0:x11/gnome-shell \
gsettings-desktop-schemas>=3.12.0:devel/gsettings-desktop-schemas
-USES= gettext gmake gnome pkgconfig tar:xz
+USES= gettext gmake gnome pkgconfig
USE_GNOME= glib20
USE_GITHUB= yes
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/deskutils/gnome-shell-extension-panel-osd/Makefile b/deskutils/gnome-shell-extension-panel-osd/Makefile
index 8c3924df29ba..32072bd7306a 100644
--- a/deskutils/gnome-shell-extension-panel-osd/Makefile
+++ b/deskutils/gnome-shell-extension-panel-osd/Makefile
@@ -13,7 +13,7 @@ BUILD_DEPENDS= gsettings-desktop-schemas>=3.12.0:devel/gsettings-desktop-schemas
RUN_DEPENDS= gnome-shell>=0:x11/gnome-shell \
gsettings-desktop-schemas>=3.12.0:devel/gsettings-desktop-schemas
-USES= autoreconf gettext gmake gnome libtool pkgconfig tar:xz
+USES= autoreconf gettext gmake gnome libtool pkgconfig
USE_GNOME= glib20 intltool
USE_GITHUB= yes
USE_LDCONFIG= yes
diff --git a/deskutils/gnome-shell-extension-trash/Makefile b/deskutils/gnome-shell-extension-trash/Makefile
index b51710c934cf..3d98a26c518c 100644
--- a/deskutils/gnome-shell-extension-trash/Makefile
+++ b/deskutils/gnome-shell-extension-trash/Makefile
@@ -14,7 +14,7 @@ BUILD_DEPENDS= gnome-shell>=0:x11/gnome-shell \
RUN_DEPENDS= gnome-shell>=0:x11/gnome-shell \
gsettings-desktop-schemas>=3.12.0:devel/gsettings-desktop-schemas
-USES= gettext gmake gnome pkgconfig tar:xz
+USES= gettext gmake gnome pkgconfig
USE_GNOME= glib20
USE_GITHUB= yes
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/deskutils/gnome-shell-extension-weather/Makefile b/deskutils/gnome-shell-extension-weather/Makefile
index 9b1b8c73ffa9..7d42eb9fe865 100644
--- a/deskutils/gnome-shell-extension-weather/Makefile
+++ b/deskutils/gnome-shell-extension-weather/Makefile
@@ -11,7 +11,7 @@ COMMENT= Weather extension for the GNOME3 shell
RUN_DEPENDS= gnome-shell>=0:x11/gnome-shell
-USES= autoreconf gettext gmake gnome libtool pkgconfig tar:xz
+USES= autoreconf gettext gmake gnome libtool pkgconfig
USE_GNOME= glib20 intlhack
USE_GITHUB= yes
USE_LDCONFIG= yes
diff --git a/devel/libmowgli/Makefile b/devel/libmowgli/Makefile
index 4b21b7b32584..b2dc67169a77 100644
--- a/devel/libmowgli/Makefile
+++ b/devel/libmowgli/Makefile
@@ -9,12 +9,13 @@ MAINTAINER= oliver@FreeBSD.org
COMMENT= Development framework for C
LICENSE= ISCL
+LICENSE_FILE= ${WRKSRC}/COPYING
USE_GITHUB= yes
GH_ACCOUNT= atheme-legacy
GH_TAGNAME= 5ab559e3af5b11767ada53d4401fb1c4443f3723
-USES= gmake pathfix tar:bzip2
+USES= gmake pathfix
PATHFIX_MAKEFILEIN= Makefile
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
diff --git a/devel/php-jq/Makefile b/devel/php-jq/Makefile
index 8ff4c1d7d517..65cf63402f41 100644
--- a/devel/php-jq/Makefile
+++ b/devel/php-jq/Makefile
@@ -11,6 +11,7 @@ MAINTAINER= gasol.wu@gmail.com
COMMENT= Jq shared extension for php
LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libjq.so:textproc/jq
@@ -19,7 +20,7 @@ GH_ACCOUNT= kjdev
GH_PROJECT= php-ext-jq
IGNORE_WITH_PHP= 70
-USES= php:ext tar:tgz
+USES= php:ext
JQ_CMD= ${LOCALBASE}/bin/jq
diff --git a/dns/dnsrecon/Makefile b/dns/dnsrecon/Makefile
index 575541472b3c..5ba34f772789 100644
--- a/dns/dnsrecon/Makefile
+++ b/dns/dnsrecon/Makefile
@@ -16,7 +16,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dnspython>=0:dns/py-dnspython \
USE_GITHUB= yes
GH_ACCOUNT= darkoperator
-USES= python:2.7+ shebangfix tar:tgz
+USES= python:2.7+ shebangfix
NO_BUILD= yes
NO_ARCH= yes
diff --git a/graphics/pqiv/Makefile b/graphics/pqiv/Makefile
index 925b89cfd501..befef91e752f 100644
--- a/graphics/pqiv/Makefile
+++ b/graphics/pqiv/Makefile
@@ -13,7 +13,7 @@ LICENSE= GPLv2
BUILD_DEPENDS= bash:shells/bash
-LIB_DEPENDS+= libfontconfig.so:x11-fonts/fontconfig \
+LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2
USE_GITHUB= yes
@@ -30,7 +30,7 @@ WAND_DESC= ImageMagick image processing support
OPTIONS_DEFAULT= GTK2 PIXBUF
-USES= gettext-runtime gmake pkgconfig tar:bzip2
+USES= gettext-runtime gmake pkgconfig
USE_XORG= x11
USE_GNOME= cairo gdkpixbuf2
HAS_CONFIGURE= yes
diff --git a/lang/tcc/Makefile b/lang/tcc/Makefile
index 7c4ed9b2e213..3e2a7d869687 100644
--- a/lang/tcc/Makefile
+++ b/lang/tcc/Makefile
@@ -20,7 +20,7 @@ USE_GITHUB= yes
GH_ACCOUNT= TinyCC
GH_PROJECT= tinycc
-USES= gmake makeinfo perl5 tar:bzip2
+USES= gmake makeinfo perl5
USE_PERL5= build
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --prefix="${PREFIX}" --cc="${CC}"
diff --git a/multimedia/libvpx/Makefile b/multimedia/libvpx/Makefile
index 3cbdb9c0cced..32b55fe6dc16 100644
--- a/multimedia/libvpx/Makefile
+++ b/multimedia/libvpx/Makefile
@@ -18,7 +18,7 @@ BUILD_DEPENDS= yasm:devel/yasm
USE_GITHUB= yes
GH_ACCOUNT= webmproject
-USES= compiler:c11 cpe gmake perl5 shebangfix tar:bzip2
+USES= compiler:c11 cpe gmake perl5 shebangfix
CPE_VENDOR= john_koleszar
HAS_CONFIGURE= yes
USE_PERL5= build
diff --git a/net-im/diligent/Makefile b/net-im/diligent/Makefile
index 8c34b931b554..c9148f6a43d9 100644
--- a/net-im/diligent/Makefile
+++ b/net-im/diligent/Makefile
@@ -16,8 +16,8 @@ LIB_DEPENDS= libQt5WebKitWidgets.so:www/webkit-qt5
USE_LDCONFIG= yes
USE_QT5= core gui network svg linguist \
buildtools x11extras widgets
-USE_GL+= gl
-USES= compiler:c++11-lang qmake tar:xz
+USE_GL= gl
+USES= compiler:c++11-lang qmake
QMAKE_ARGS= CONFIG+="configure"
@@ -32,7 +32,7 @@ SUB_FILES= diligent.desktop
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/diligent ${STAGEDIR}${PREFIX}/bin
${INSTALL_DATA} ${WRKDIR}/${SUB_FILES} ${STAGEDIR}${PREFIX}/share/applications/
- ${MKDIR} ${STAGEDIR}${PREFIX}/share/icons
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/icons
${INSTALL_DATA} ${WRKSRC}/images/png/Slack.png ${STAGEDIR}${PREFIX}/share/icons/diligent.png
.include <bsd.port.mk>
diff --git a/net/exabgp/Makefile b/net/exabgp/Makefile
index bb861dff765a..1f6f964edf04 100644
--- a/net/exabgp/Makefile
+++ b/net/exabgp/Makefile
@@ -15,7 +15,7 @@ LICENSE_FILE= ${WRKSRC}/COPYRIGHT
USE_GITHUB= yes
GH_ACCOUNT= Exa-Networks
-USES= python:2 tar:tgz
+USES= python:2
SUB_FILES= pkg-message exabgp.sh
SUB_LIST= PYTHON_LIBDIR=${PYTHON_LIBDIR} PYTHON_CMD=${PYTHON_CMD} \
PYTHON_SITELIBDIR=${PYTHON_SITELIBDIR}
diff --git a/net/exaddos/Makefile b/net/exaddos/Makefile
index d17d8b11026d..be56059518c9 100644
--- a/net/exaddos/Makefile
+++ b/net/exaddos/Makefile
@@ -17,11 +17,12 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}snmp4-mibs>=0.1.4:net-mgmt/py-snmp4-mibs \
USE_GITHUB= yes
GH_ACCOUNT= Exa-Networks
-USES= python tar:tgz
+USES= python
SUB_FILES= pkg-message exaddos.sh exaddos.conf.sample
SUB_LIST= PYTHON_LIBDIR=${PYTHON_LIBDIR} PYTHON_CMD=${PYTHON_CMD} \
PYTHON_SITELIBDIR=${PYTHON_SITELIBDIR}
USE_RC_SUBR= ${PORTNAME}
+NO_ARCH= yes
USERS= ${PORTNAME}
GROUPS= ${PORTNAME}
diff --git a/net/mrouted/Makefile b/net/mrouted/Makefile
index 708bc0ca5400..5c14b917eed4 100644
--- a/net/mrouted/Makefile
+++ b/net/mrouted/Makefile
@@ -12,7 +12,6 @@ COMMENT= Multicast routing daemon providing DVMRP for IPv4
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
-USES= tar:bzip2
USE_GITHUB= yes
USE_RC_SUBR= mrouted
GH_ACCOUNT= troglobit
diff --git a/net/pimd/Makefile b/net/pimd/Makefile
index 7338b6ab2044..00b8d7d052c4 100644
--- a/net/pimd/Makefile
+++ b/net/pimd/Makefile
@@ -16,11 +16,10 @@ GH_PROJECT= libite:libite
GH_TAGNAME= v1.4.4:libite
GH_SUBDIR= libite:libite
-USES= tar:bzip2
USE_RC_SUBR= ${PORTNAME}
HAS_CONFIGURE= yes
-MAKE_ARGS+= prefix="${PREFIX}" sysconfdir="${PREFIX}/etc/"
+MAKE_ARGS= prefix="${PREFIX}" sysconfdir="${PREFIX}/etc/"
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/pimd ${STAGEDIR}${PREFIX}/sbin/
@@ -28,6 +27,6 @@ do-install:
${STAGEDIR}${PREFIX}/etc/pimd.conf.sample
${INSTALL_SCRIPT} ${FILESDIR}/pimd.in \
${STAGEDIR}${PREFIX}/etc/rc.d/pimd
- ${INSTALL_MAN} ${WRKSRC}/pimd.8 ${STAGEDIR}${PREFIX}/man/man8/
+ ${INSTALL_MAN} ${WRKSRC}/pimd.8 ${STAGEDIR}${MANPREFIX}/man/man8/
.include <bsd.port.mk>
diff --git a/security/nikto/Makefile b/security/nikto/Makefile
index 1145de00719e..481a1dceb677 100644
--- a/security/nikto/Makefile
+++ b/security/nikto/Makefile
@@ -22,7 +22,7 @@ SSLEAY_RUN_DEPENDS= p5-Net-SSLeay>0:security/p5-Net-SSLeay
NO_BUILD= yes
NO_ARCH= yes
-USES= perl5 shebangfix tar:bzip2
+USES= perl5 shebangfix
USE_PERL5= run
SHEBANG_FILES= nikto.pl
WRKSRC_SUBDIR= program
diff --git a/sysutils/nfcutils/Makefile b/sysutils/nfcutils/Makefile
index be213f93bacd..6e437793d85d 100644
--- a/sysutils/nfcutils/Makefile
+++ b/sysutils/nfcutils/Makefile
@@ -8,11 +8,12 @@ CATEGORIES= sysutils
MAINTAINER= dengtooling@gmail.com
COMMENT= Listing NFC devices and in-field tags or targets
-LICENSE= GPLv3
+LICENSE= GPLv3+
+LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libnfc.so:devel/libnfc
-USES= autoreconf gmake libtool pkgconfig tar:tgz
+USES= autoreconf gmake libtool pkgconfig
USE_GITHUB= yes
GH_ACCOUNT= terence-deng
MAKE_ENV+= MKDIR="${MKDIR}"
diff --git a/sysutils/pcbsd-appweb/Makefile b/sysutils/pcbsd-appweb/Makefile
index 4b860bddb2eb..ba9539fd2da2 100644
--- a/sysutils/pcbsd-appweb/Makefile
+++ b/sysutils/pcbsd-appweb/Makefile
@@ -17,8 +17,9 @@ RUN_DEPENDS= syscache:sysutils/pcbsd-syscache \
USE_PHP= filter gd json session
WRKSRC_SUBDIR= src-webui
-USES= pkgconfig tar:xz
+USES= pkgconfig
NO_BUILD= yes
+NO_ARCH= yes
MAKE_ARGS= PREFIX=${STAGEDIR}${PREFIX}
USE_GITHUB= yes
diff --git a/sysutils/pcbsd-libsh/Makefile b/sysutils/pcbsd-libsh/Makefile
index 1c9096055719..8fd9e941511b 100644
--- a/sysutils/pcbsd-libsh/Makefile
+++ b/sysutils/pcbsd-libsh/Makefile
@@ -11,8 +11,9 @@ COMMENT= PC-BSD Shell Library
LICENSE= BSD3CLAUSE
WRKSRC_SUBDIR= src-sh/libsh
-USES= pkgconfig tar:xz
+USES= pkgconfig
NO_BUILD= yes
+NO_ARCH= yes
MAKE_ARGS= PREFIX=${STAGEDIR}${PREFIX}
USE_GITHUB= yes
diff --git a/sysutils/pcbsd-syscache/Makefile b/sysutils/pcbsd-syscache/Makefile
index 9c3d11c8a74d..2c3d53c31f5b 100644
--- a/sysutils/pcbsd-syscache/Makefile
+++ b/sysutils/pcbsd-syscache/Makefile
@@ -12,7 +12,7 @@ LICENSE= BSD3CLAUSE
WRKSRC_SUBDIR= src-sh/syscache
USE_QT5= core network buildtools qmake
-USES= pkgconfig tar:xz
+USES= pkgconfig
NO_BUILD= yes
MAKE_ARGS= PREFIX=${STAGEDIR}${PREFIX}
diff --git a/sysutils/warden/Makefile b/sysutils/warden/Makefile
index 7f6b23c7a4f9..b36064ee2267 100644
--- a/sysutils/warden/Makefile
+++ b/sysutils/warden/Makefile
@@ -15,8 +15,9 @@ RUN_DEPENDS= ${LOCALBASE}/share/pcbsd/scripts/functions.sh:sysutils/pcbsd-libsh
jailme:sysutils/jailme
WRKSRC_SUBDIR= src-sh/warden
-USES= pkgconfig tar:xz
+USES= pkgconfig
NO_BUILD= yes
+NO_ARCH= yes
MAKE_ARGS= PREFIX=${STAGEDIR}${PREFIX}
USE_GITHUB= yes
diff --git a/www/codeigniter/Makefile b/www/codeigniter/Makefile
index 0d61355ac293..6a16e2fdd38d 100644
--- a/www/codeigniter/Makefile
+++ b/www/codeigniter/Makefile
@@ -11,7 +11,6 @@ COMMENT= Framework for developing PHP web applications
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/license.txt
-USES= tar:tgz
USE_GITHUB= yes
GH_ACCOUNT= bcit-ci
@@ -106,10 +105,11 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/$$i ${STAGEDIR}${WWWDIR}/$$i.sample; \
done
-post-install-APACHE-on:
- ${MKDIR} ${STAGEDIR}${CONFDIR}
+do-install-APACHE-on:
+ @${MKDIR} ${STAGEDIR}${CONFDIR}
${CP} ${WRKDIR}/${CONF} ${STAGEDIR}${CONFDIR}/codeigniter.conf;
-post-install-DOCS-on:
+
+do-install-DOCS-on:
cd ${WRKSRC}/user_guide && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR}
${RM} ${STAGEDIR}${DOCSDIR}/.buildinfo
${CP} ${WRKSRC}/readme.rst ${STAGEDIR}${DOCSDIR}/readme.rst