aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2009-12-12 12:31:19 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2009-12-12 12:31:19 +0000
commit115a02a258489107cd3481ac5c5651207614531b (patch)
treecb845585bf370ed799b58465cd93f0bc849fe1f0
parent09aabef12ec8bf3f4842da549b3ddfa4d4bac8c7 (diff)
downloadports-115a02a258489107cd3481ac5c5651207614531b.tar.gz
ports-115a02a258489107cd3481ac5c5651207614531b.zip
Notes
-rw-r--r--security/Makefile1
-rw-r--r--security/yassl/Makefile42
-rw-r--r--security/yassl/distinfo3
-rw-r--r--security/yassl/pkg-descr23
-rw-r--r--security/yassl/pkg-plist26
5 files changed, 95 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 2c283750b765..36671730044d 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -856,6 +856,7 @@
SUBDIR += xyssl
SUBDIR += yafic
SUBDIR += yapet
+ SUBDIR += yassl
SUBDIR += yersinia
SUBDIR += zebedee
SUBDIR += zenmap
diff --git a/security/yassl/Makefile b/security/yassl/Makefile
new file mode 100644
index 000000000000..7cf4ea47b1f2
--- /dev/null
+++ b/security/yassl/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: cyassl
+# Date created: 10 Dec 2009
+# Whom: dirk.meyer@dinoex.sub.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= cyassl
+PORTVERSION= 1.2.0
+CATEGORIES= security devel
+MASTER_SITES= http://www.yassl.com/
+
+MAINTAINER= dinoex@FreeBSD.org
+COMMENT= A embedded SSL C-Library
+
+USE_ZIP= yes
+USE_AUTOTOOLS= libtool:22
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --disable-dependency-tracking
+CONFIGURE_ARGS+= --enable-shared --enable-static
+CONFIGURE_ARGS+= --enable-dtls --enable-opensslExtra --enable-ipv6
+CONFIGURE_ARGS+= --libdir=${PREFIX}/lib/${PORTNAME} --includedir=${PREFIX}/include/${PORTNAME}
+USE_LDCONFIG= ${PREFIX}/lib/${PORTNAME}
+PORTDOCS= AUTHORS ChangeLog NEWS README
+
+post-configure:
+ ${REINPLACE_CMD} \
+ -e 's|/usr/local/cyassl/include|${PREFIX}/include/cyassl|' \
+ -e 's|/usr/local/cyassl/lib|${PREFIX}/lib/cyassl|' \
+ ${WRKSRC}/Makefile
+
+post-install:
+ ${INSTALL_DATA} ${WRKSRC}/src/.libs/libcyassl.so.0 ${PREFIX}/lib/cyassl/libcyassl.so.0
+ ${LN} -s libcyassl.so.0 ${PREFIX}/lib/cyassl/libcyassl.so
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for i in ${PORTDOCS}
+ ${INSTALL_MAN} ${WRKSRC}/${i} ${DOCSDIR}/
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/security/yassl/distinfo b/security/yassl/distinfo
new file mode 100644
index 000000000000..79633c1a924f
--- /dev/null
+++ b/security/yassl/distinfo
@@ -0,0 +1,3 @@
+MD5 (cyassl-1.2.0.zip) = de12e76b3faf760107e45af487adcbde
+SHA256 (cyassl-1.2.0.zip) = 19ab14a2f1a80962b99f947e735b7c2de45efb3364b337533a095b848a62316d
+SIZE (cyassl-1.2.0.zip) = 740328
diff --git a/security/yassl/pkg-descr b/security/yassl/pkg-descr
new file mode 100644
index 000000000000..24c81321848f
--- /dev/null
+++ b/security/yassl/pkg-descr
@@ -0,0 +1,23 @@
+Cyassl is an embedded SSL Library for programmers building security
+functionality into their applications and devices.
+
+Features
+ SSL version 3 and TLS versions 1, 1.1 and 1.2 (client and server)
+ Minimum size of 60-100kb, depending on build options
+ Runtime memory usage between 5-50kb
+ DTLS support (client and server)
+ OpenSSL compatibility layer
+ zlib compression support
+ integration in MySQL, stunnel, Lighttpd availible.
+ MD2, MD4, MD5, SHA-1, RIPEMD, HMAC, DES, 3DES, AES, ARC4, TWOFISH, BLOWFISH,
+ RSA, DSS, DH, and PKCS#5 PBKDF2
+ ia32 assembly for AES, 3DES, BLOWFISH, TWOFISH, ARC4, MD5, SHA, and RIPEMD
+ SSE2 instructions for Large Integers
+ Simple API
+ Interchangeable crypto and certificate libraries
+ PEM and DER certificate support
+ Very fast
+
+LICENSE: GPL2 with FOSS extension
+
+WWW: http://www.yassl.com/
diff --git a/security/yassl/pkg-plist b/security/yassl/pkg-plist
new file mode 100644
index 000000000000..63006390eae6
--- /dev/null
+++ b/security/yassl/pkg-plist
@@ -0,0 +1,26 @@
+include/cyassl/openssl/crypto.h
+include/cyassl/openssl/cyassl_callbacks.h
+include/cyassl/openssl/des.h
+include/cyassl/openssl/engine.h
+include/cyassl/openssl/err.h
+include/cyassl/openssl/evp.h
+include/cyassl/openssl/hmac.h
+include/cyassl/openssl/lhash.h
+include/cyassl/openssl/md4.h
+include/cyassl/openssl/md5.h
+include/cyassl/openssl/ocsp.h
+include/cyassl/openssl/opensslconf.h
+include/cyassl/openssl/opensslv.h
+include/cyassl/openssl/rand.h
+include/cyassl/openssl/rsa.h
+include/cyassl/openssl/sha.h
+include/cyassl/openssl/ssl.h
+lib/cyassl/libcrypto.a
+lib/cyassl/libcyassl.a
+lib/cyassl/libcyassl.so
+lib/cyassl/libcyassl.so.0
+lib/cyassl/libssl.a
+@dirrm lib/cyassl
+@dirrm include/cyassl/openssl
+@dirrm include/cyassl
+@dirrm cyassl