aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-03-28 07:45:20 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-03-28 07:45:20 +0000
commit230be3b3af50fb3a962983822fdc0247122975d9 (patch)
tree05312a8612588f2dba83a991be19cf94513ab2a2
parent831a63b73c0e57eb3a88ad9cfa1b7265ef82e91b (diff)
Notes
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-gdata/Makefile34
-rw-r--r--devel/py-gdata/distinfo3
-rw-r--r--devel/py-gdata/files/setup.py19
-rw-r--r--devel/py-gdata/pkg-descr18
-rw-r--r--devel/py-gdata/pkg-plist41
6 files changed, 116 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 0f7367c8d65d..e5cf38fa0007 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1794,6 +1794,7 @@
SUBDIR += py-fusefs
SUBDIR += py-game
SUBDIR += py-gamin
+ SUBDIR += py-gdata
SUBDIR += py-generate
SUBDIR += py-gobject
SUBDIR += py-grouch
diff --git a/devel/py-gdata/Makefile b/devel/py-gdata/Makefile
new file mode 100644
index 000000000000..284c66b604b1
--- /dev/null
+++ b/devel/py-gdata/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: py-gdata
+# Date created: Mar. 28, 2007
+# Whom: Li-Wen Hsu <lwhsu@lwhsu.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gdata
+PORTVERSION= 1.0
+CATEGORIES= devel python
+MASTER_SITES= http://gdata-python-client.googlecode.com/files/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= gdata.py.${PORTVERSION}
+
+MAINTAINER= lwhsu@lwhsu.org
+COMMENT= GData Python Client Library
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+USE_ZIP= yes
+
+WRKSRC= ${WRKDIR}/gdata-python-client
+
+EXAMPLESDIR= ${TARGETDIR}/share/examples/py-${PORTNAME}
+
+do-patch:
+ ${SED} -e 's|%%PORTVERSION%%|${PORTVERSION}|g' ${FILESDIR}/setup.py \
+ > ${WRKSRC}/setup.py
+
+post-install:
+ @${MKDIR} ${EXAMPLESDIR}
+ ${CP} -R ${WRKSRC}/samples/ ${EXAMPLESDIR}
+
+.include <bsd.port.mk>
diff --git a/devel/py-gdata/distinfo b/devel/py-gdata/distinfo
new file mode 100644
index 000000000000..a4f4330955b7
--- /dev/null
+++ b/devel/py-gdata/distinfo
@@ -0,0 +1,3 @@
+MD5 (gdata.py.1.0.zip) = b6475fa6fdf3fd14a740a23ae045cff4
+SHA256 (gdata.py.1.0.zip) = 6528ffa2ad9d8de0675fb0c30682f345059a175ff9bb2ec9f26107acce31958b
+SIZE (gdata.py.1.0.zip) = 86450
diff --git a/devel/py-gdata/files/setup.py b/devel/py-gdata/files/setup.py
new file mode 100644
index 000000000000..33f0982fe43b
--- /dev/null
+++ b/devel/py-gdata/files/setup.py
@@ -0,0 +1,19 @@
+from distutils.core import setup
+
+setup(
+ name = 'gdata',
+ version = "%%PORTVERSION%%",
+ py_modules = [
+ 'app_service',
+ 'atom',
+ 'gbase',
+ 'gbase_service',
+ 'gcalendar',
+ 'gcalendar_service',
+ 'gdata',
+ 'gdata_client',
+ 'gdata_service',
+ 'gspreadsheet',
+ 'gspreadsheet_service',
+ ],
+)
diff --git a/devel/py-gdata/pkg-descr b/devel/py-gdata/pkg-descr
new file mode 100644
index 000000000000..2d0ac40983ec
--- /dev/null
+++ b/devel/py-gdata/pkg-descr
@@ -0,0 +1,18 @@
+The Google Data APIs (GData) provide a simple protocol for reading and
+writing data on the web.
+
+Each of the following Google services provides a Google data API:
+
+ * Base
+ * Blogger
+ * Calendar
+ * Picasa Web Albums
+ * Spreadsheets
+ * Google Apps Provisioning
+ * Code Search
+ * Notebook
+
+The GData Python Client Library provides a library and source code that
+make it easy to access data through Google Data APIs.
+
+WWW: http://code.google.com/p/gdata-python-client/
diff --git a/devel/py-gdata/pkg-plist b/devel/py-gdata/pkg-plist
new file mode 100644
index 000000000000..d88da2453222
--- /dev/null
+++ b/devel/py-gdata/pkg-plist
@@ -0,0 +1,41 @@
+%%PYTHON_SITELIBDIR%%/app_service.py
+%%PYTHON_SITELIBDIR%%/app_service.pyc
+%%PYTHON_SITELIBDIR%%/app_service.pyo
+%%PYTHON_SITELIBDIR%%/atom.py
+%%PYTHON_SITELIBDIR%%/atom.pyc
+%%PYTHON_SITELIBDIR%%/atom.pyo
+%%PYTHON_SITELIBDIR%%/gbase.py
+%%PYTHON_SITELIBDIR%%/gbase.pyc
+%%PYTHON_SITELIBDIR%%/gbase.pyo
+%%PYTHON_SITELIBDIR%%/gbase_service.py
+%%PYTHON_SITELIBDIR%%/gbase_service.pyc
+%%PYTHON_SITELIBDIR%%/gbase_service.pyo
+%%PYTHON_SITELIBDIR%%/gcalendar.py
+%%PYTHON_SITELIBDIR%%/gcalendar.pyc
+%%PYTHON_SITELIBDIR%%/gcalendar.pyo
+%%PYTHON_SITELIBDIR%%/gcalendar_service.py
+%%PYTHON_SITELIBDIR%%/gcalendar_service.pyc
+%%PYTHON_SITELIBDIR%%/gcalendar_service.pyo
+%%PYTHON_SITELIBDIR%%/gdata.py
+%%PYTHON_SITELIBDIR%%/gdata.pyc
+%%PYTHON_SITELIBDIR%%/gdata.pyo
+%%PYTHON_SITELIBDIR%%/gdata_client.py
+%%PYTHON_SITELIBDIR%%/gdata_client.pyc
+%%PYTHON_SITELIBDIR%%/gdata_client.pyo
+%%PYTHON_SITELIBDIR%%/gdata_service.py
+%%PYTHON_SITELIBDIR%%/gdata_service.pyc
+%%PYTHON_SITELIBDIR%%/gdata_service.pyo
+%%PYTHON_SITELIBDIR%%/gspreadsheet.py
+%%PYTHON_SITELIBDIR%%/gspreadsheet.pyc
+%%PYTHON_SITELIBDIR%%/gspreadsheet.pyo
+%%PYTHON_SITELIBDIR%%/gspreadsheet_service.py
+%%PYTHON_SITELIBDIR%%/gspreadsheet_service.pyc
+%%PYTHON_SITELIBDIR%%/gspreadsheet_service.pyo
+%%EXAMPLESDIR%%/base/baseQueryExample.py
+%%EXAMPLESDIR%%/base/dryRunInsert.py
+%%EXAMPLESDIR%%/calendar/calendarExample.py
+%%EXAMPLESDIR%%/spreadsheets/spreadsheetExample.py
+@dirrm %%EXAMPLESDIR%%/spreadsheets
+@dirrm %%EXAMPLESDIR%%/calendar
+@dirrm %%EXAMPLESDIR%%/base
+@dirrm %%EXAMPLESDIR%%