aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2020-06-09 20:43:04 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2020-06-09 20:43:04 +0000
commit25e704f496699d6177296d4f44105fcd52a33ffc (patch)
tree9ac377108a858a69feebebd5f1f82fb6c1a3360d
parent1a040427c472a63a8c8768c5e0e7fd17c89fb31c (diff)
downloadports-25e704f496699d6177296d4f44105fcd52a33ffc.tar.gz
ports-25e704f496699d6177296d4f44105fcd52a33ffc.zip
MFH: r538341
devel/xeus-cling: Unbreak on systems incompatible with the system where the package was built -march=native caused SEGVs on incompatible systems Also add USE_LDFLAGS. Approved by: ports-secteam (joenum)
Notes
Notes: svn path=/branches/2020Q2/; revision=538342
-rw-r--r--devel/xeus-cling/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/devel/xeus-cling/Makefile b/devel/xeus-cling/Makefile
index cb19897f79a2..a85f76a47e30 100644
--- a/devel/xeus-cling/Makefile
+++ b/devel/xeus-cling/Makefile
@@ -2,6 +2,7 @@
PORTNAME= xeus-cling
DISTVERSION= 0.8.1
+PORTREVISION= 1
CATEGORIES= devel
MAINTAINER= yuri@FreeBSD.org
@@ -24,7 +25,14 @@ LIB_DEPENDS= libclingInterpreter.so:lang/cling \
USES= cmake compiler:c++14-lang pkgconfig ssl
USE_GITHUB= yes
GH_ACCOUNT= jupyter-xeus
+USE_LDCONFIG= yes
LDFLAGS+= ${LOCALBASE}/lib/libLLVMSupport.so ${LOCALBASE}/lib/libclangAST.so -pthread # https://github.com/jupyter-xeus/xeus-cling/issues/234
+OPTIONS_DEFINE= NATIVE
+
+NATIVE_DESC= Build with native optimizations (-march=native)
+NATIVE_CMAKE_ON= -DDISABLE_ARCH_NATIVE=OFF
+NATIVE_CMAKE_OFF= -DDISABLE_ARCH_NATIVE=ON
+
.include <bsd.port.mk>