aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVeniamin Gvozdikov <vg@FreeBSD.org>2013-11-04 09:41:14 +0000
committerVeniamin Gvozdikov <vg@FreeBSD.org>2013-11-04 09:41:14 +0000
commit284265c537f02a1d864aa7608e88d1e8547998d5 (patch)
tree6022c0597ae3493d5f9b59aab78596fbac067076
parentbc2c8b9bf3ba79163dd2a096e9c89ebcee010fc8 (diff)
sysutils/dunst - Lightweight notification daemon
Dunst is a lightweight replacement for the notification-daemons provided by most desktop environments. It's very customizable, doesn't depend on any toolkits and therefore fits in those windowmanager centric setups we all love to customize to perfection. WWW: http://www.knopwob.org/dunst Also I fixed: - Fixed depends - Removed plist and added list of files at Makefile - Added stage support - Added more description of port to pkg-descr PR: ports/179624 Submitted by: Rod Person <rodperson@rodperson.com> Approved by: eadler, osa, rm (mentors, implicit)
Notes
Notes: svn path=/head/; revision=332677
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/dunst/Makefile39
-rw-r--r--sysutils/dunst/distinfo2
-rw-r--r--sysutils/dunst/pkg-descr6
4 files changed, 48 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index efc988b8481d..0f3b8adc95a7 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -196,6 +196,7 @@
SUBDIR += dtpstree
SUBDIR += du2ps
SUBDIR += duff
+ SUBDIR += dunst
SUBDIR += duplicity
SUBDIR += duply
SUBDIR += dupmerge
diff --git a/sysutils/dunst/Makefile b/sysutils/dunst/Makefile
new file mode 100644
index 000000000000..5d5f14ca86d6
--- /dev/null
+++ b/sysutils/dunst/Makefile
@@ -0,0 +1,39 @@
+# Created by: Rod Person <rodperson@rodperson.com>
+# $FreeBSD$
+
+PORTNAME= dunst
+PORTVERSION= 1.0.0
+CATEGORIES= sysutils
+MASTER_SITES= http://www.knopwob.org/public/dunst-release/
+
+MAINTAINER= rodperson@rodperson.com
+COMMENT= Lightweight notification deamon
+
+LIB_DEPENDS= cairo:${PORTSDIR}/graphics/cairo \
+ dbus:${PORTSDIR}/devel/dbus \
+ execinfo:${PORTSDIR}/devel/libexecinfo \
+ freetype:${PORTSDIR}/print/freetype2 \
+ notify:${PORTSDIR}/devel/libnotify \
+ pango:${PORTSDIR}/x11-toolkits/pango \
+ xdg-basedir:${PORTSDIR}/x11/libxdg-basedir
+
+USES= gmake pkgconfig:build
+USE_BZIP2= yes
+USE_GNOME= glib20
+USE_PERL= yes
+USE_XORG= xext xft xinerama xscrnsaver
+MAKE_ARGS+= MANPREFIX="${PREFIX}/man"
+
+ALL_TARGET= dunst dunstify dunst.1
+INSTALL_TARGET= install
+
+LDFLAGS+= -O3 -g -Wall -rdynamic -lexecinfo
+CFLAGS+= -I${LOCALBASE}/include
+
+PLIST_FILES= bin/dunst \
+ share/dunst/dunstrc \
+ man/man1/dunst.1.gz \
+ share/dbus-1/services/org.knopwob.dunst.service
+PLIST_DIRS= share/dunst
+
+.include <bsd.port.mk>
diff --git a/sysutils/dunst/distinfo b/sysutils/dunst/distinfo
new file mode 100644
index 000000000000..880b91cafc4a
--- /dev/null
+++ b/sysutils/dunst/distinfo
@@ -0,0 +1,2 @@
+SHA256 (dunst-1.0.0.tar.bz2) = 5c79ef11165421a4828453a42dfe9c60a4cb9d8743f970186a90c67e277f5280
+SIZE (dunst-1.0.0.tar.bz2) = 75306
diff --git a/sysutils/dunst/pkg-descr b/sysutils/dunst/pkg-descr
new file mode 100644
index 000000000000..8d637d55be69
--- /dev/null
+++ b/sysutils/dunst/pkg-descr
@@ -0,0 +1,6 @@
+Dunst is a lightweight replacement for the notification-daemons provided
+by most desktop environments. It's very customizable, doesn't depend on
+any toolkits and therefore fits in those windowmanager centric setups we
+all love to customize to perfection.
+
+WWW: http://www.knopwob.org/dunst