aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2012-05-25 01:49:08 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2012-05-25 01:49:08 +0000
commit359fcf18da3ffa1bd213f98b0018b4e4d22b9ce2 (patch)
tree93ffeb66b443101d827c14b6325063464a8d9546
parentd76f1d8bf4b8da1c3ec5552071c5b716f238a677 (diff)
downloadports-359fcf18da3ffa1bd213f98b0018b4e4d22b9ce2.tar.gz
ports-359fcf18da3ffa1bd213f98b0018b4e4d22b9ce2.zip
Notes
-rw-r--r--databases/py-qt4-sql/Makefile2
-rw-r--r--devel/py-qt4-assistant/Makefile2
-rw-r--r--devel/py-qt4-core/Makefile2
-rw-r--r--devel/py-qt4-declarative/Makefile2
-rw-r--r--devel/py-qt4-designer/Makefile2
-rw-r--r--devel/py-qt4-help/Makefile2
-rw-r--r--devel/py-qt4-qscintilla2/Makefile2
-rw-r--r--devel/py-qt4-qscintilla2/pkg-plist2
-rw-r--r--devel/py-qt4-script/Makefile2
-rw-r--r--devel/py-qt4-scripttools/Makefile2
-rw-r--r--devel/py-qt4-test/Makefile2
-rw-r--r--devel/py-qt4/distinfo4
-rw-r--r--devel/py-sip/distinfo4
-rw-r--r--devel/py-sip/files/bsd.pyqt.mk12
-rw-r--r--devel/qscintilla2-designerplugin/Makefile2
-rw-r--r--devel/qscintilla2/distinfo4
-rw-r--r--devel/qscintilla2/pkg-plist9
-rw-r--r--graphics/py-qt4-svg/Makefile2
-rw-r--r--misc/py-qt4-demo/pkg-plist27
-rw-r--r--misc/py-qt4-doc/pkg-plist30
-rw-r--r--multimedia/py-qt4-multimedia/Makefile2
-rw-r--r--multimedia/py-qt4-phonon/Makefile2
-rw-r--r--net/py-qt4-network/Makefile2
-rw-r--r--net/py-qt4-network/pkg-plist3
-rw-r--r--textproc/py-qt4-xml/Makefile2
-rw-r--r--textproc/py-qt4-xmlpatterns/Makefile2
-rw-r--r--www/py-qt4-webkit/Makefile2
-rw-r--r--x11-toolkits/py-qt4-gui/Makefile2
-rw-r--r--x11-toolkits/py-qt4-gui/pkg-plist3
-rw-r--r--x11/py-qt4-opengl/Makefile2
30 files changed, 101 insertions, 37 deletions
diff --git a/databases/py-qt4-sql/Makefile b/databases/py-qt4-sql/Makefile
index 968e538b9ca5..2f0a36d4ce69 100644
--- a/databases/py-qt4-sql/Makefile
+++ b/databases/py-qt4-sql/Makefile
@@ -50,7 +50,7 @@ ARGS+= --debug
ARGS+= --no-qsci-api
PLIST_SUB+= API="@comment "
.else
-LIB_DEPENDS+= qscintilla2.5:${PORTSDIR}/devel/qscintilla2
+LIB_DEPENDS+= qscintilla2.8:${PORTSDIR}/devel/qscintilla2
ARGS+= --qsci-api --qsci-api-destdir=${QSCIDIR}
PLIST_SUB+= API=""
.endif
diff --git a/devel/py-qt4-assistant/Makefile b/devel/py-qt4-assistant/Makefile
index 1d29b1c75d9f..521831a2a689 100644
--- a/devel/py-qt4-assistant/Makefile
+++ b/devel/py-qt4-assistant/Makefile
@@ -52,7 +52,7 @@ ARGS+= --debug
ARGS+= --no-qsci-api
PLIST_SUB+= API="@comment "
.else
-LIB_DEPENDS+= qscintilla2.5:${PORTSDIR}/devel/qscintilla2
+LIB_DEPENDS+= qscintilla2.8:${PORTSDIR}/devel/qscintilla2
ARGS+= --qsci-api --qsci-api-destdir=${QSCIDIR}
PLIST_SUB+= API=""
.endif
diff --git a/devel/py-qt4-core/Makefile b/devel/py-qt4-core/Makefile
index 9481cca578cd..b53e5510f27c 100644
--- a/devel/py-qt4-core/Makefile
+++ b/devel/py-qt4-core/Makefile
@@ -50,7 +50,7 @@ ARGS+= --debug
ARGS+= --no-qsci-api
PLIST_SUB+= API="@comment "
.else
-LIB_DEPENDS+= qscintilla2.5:${PORTSDIR}/devel/qscintilla2
+LIB_DEPENDS+= qscintilla2.8:${PORTSDIR}/devel/qscintilla2
ARGS+= --qsci-api --qsci-api-destdir=${QSCIDIR}
PLIST_SUB+= API=""
.endif
diff --git a/devel/py-qt4-declarative/Makefile b/devel/py-qt4-declarative/Makefile
index e1a1f9064063..97a48a3ee770 100644
--- a/devel/py-qt4-declarative/Makefile
+++ b/devel/py-qt4-declarative/Makefile
@@ -51,7 +51,7 @@ ARGS+= --debug
ARGS+= --no-qsci-api
PLIST_SUB+= API="@comment "
.else
-LIB_DEPENDS+= qscintilla2.5:${PORTSDIR}/devel/qscintilla2
+LIB_DEPENDS+= qscintilla2.8:${PORTSDIR}/devel/qscintilla2
ARGS+= --qsci-api --qsci-api-destdir=${QSCIDIR}
PLIST_SUB+= API=""
.endif
diff --git a/devel/py-qt4-designer/Makefile b/devel/py-qt4-designer/Makefile
index 90ce86bc8ebd..27cc8b639dd5 100644
--- a/devel/py-qt4-designer/Makefile
+++ b/devel/py-qt4-designer/Makefile
@@ -54,7 +54,7 @@ ARGS+= --debug
ARGS+= --no-qsci-api
PLIST_SUB+= API="@comment "
.else
-LIB_DEPENDS+= qscintilla2.5:${PORTSDIR}/devel/qscintilla2
+LIB_DEPENDS+= qscintilla2.8:${PORTSDIR}/devel/qscintilla2
ARGS+= --qsci-api --qsci-api-destdir=${QSCIDIR}
PLIST_SUB+= API=""
.endif
diff --git a/devel/py-qt4-help/Makefile b/devel/py-qt4-help/Makefile
index 19ff7ab6eadd..bd5f8a9f3074 100644
--- a/devel/py-qt4-help/Makefile
+++ b/devel/py-qt4-help/Makefile
@@ -51,7 +51,7 @@ ARGS+= --debug
ARGS+= --no-qsci-api
PLIST_SUB+= API="@comment "
.else
-LIB_DEPENDS+= qscintilla2.5:${PORTSDIR}/devel/qscintilla2
+LIB_DEPENDS+= qscintilla2.8:${PORTSDIR}/devel/qscintilla2
ARGS+= --qsci-api --qsci-api-destdir=${QSCIDIR}
PLIST_SUB+= API=""
.endif
diff --git a/devel/py-qt4-qscintilla2/Makefile b/devel/py-qt4-qscintilla2/Makefile
index 980e9f01d64e..9b09afc2be68 100644
--- a/devel/py-qt4-qscintilla2/Makefile
+++ b/devel/py-qt4-qscintilla2/Makefile
@@ -15,7 +15,7 @@ DISTNAME= ${QSCI2_DISTNAME}
MAINTAINER= kde@FreeBSD.org
COMMENT= Python bindings for QScintilla2 (PyQt4), QSci module
-LIB_DEPENDS= qscintilla2.5:${PORTSDIR}/devel/qscintilla2
+LIB_DEPENDS= qscintilla2.8:${PORTSDIR}/devel/qscintilla2
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sip>=${SIP_VERSION}:${PORTSDIR}/devel/py-sip \
${PYTHON_PKGNAMEPREFIX}qt4-core>=${PYQT_VERSION}:${PORTSDIR}/devel/py-qt4-core \
${PYTHON_PKGNAMEPREFIX}qt4-gui>=${PYQT_VERSION}:${PORTSDIR}/x11-toolkits/py-qt4-gui
diff --git a/devel/py-qt4-qscintilla2/pkg-plist b/devel/py-qt4-qscintilla2/pkg-plist
index fe0de158eeec..e0e19dac51df 100644
--- a/devel/py-qt4-qscintilla2/pkg-plist
+++ b/devel/py-qt4-qscintilla2/pkg-plist
@@ -22,6 +22,8 @@
%%SIP%%share/py-sip/Qsci/qscilexerjavascript.sip
%%SIP%%share/py-sip/Qsci/qscilexerlua.sip
%%SIP%%share/py-sip/Qsci/qscilexermakefile.sip
+%%SIP%%share/py-sip/Qsci/qscilexermatlab.sip
+%%SIP%%share/py-sip/Qsci/qscilexeroctave.sip
%%SIP%%share/py-sip/Qsci/qscilexerpascal.sip
%%SIP%%share/py-sip/Qsci/qscilexerperl.sip
%%SIP%%share/py-sip/Qsci/qscilexerpostscript.sip
diff --git a/devel/py-qt4-script/Makefile b/devel/py-qt4-script/Makefile
index 2a6be097c51d..88721c779f18 100644
--- a/devel/py-qt4-script/Makefile
+++ b/devel/py-qt4-script/Makefile
@@ -51,7 +51,7 @@ ARGS+= --debug
ARGS+= --no-qsci-api
PLIST_SUB+= API="@comment "
.else
-LIB_DEPENDS+= qscintilla2.5:${PORTSDIR}/devel/qscintilla2
+LIB_DEPENDS+= qscintilla2.8:${PORTSDIR}/devel/qscintilla2
ARGS+= --qsci-api --qsci-api-destdir=${QSCIDIR}
PLIST_SUB+= API=""
.endif
diff --git a/devel/py-qt4-scripttools/Makefile b/devel/py-qt4-scripttools/Makefile
index 6207a00888d7..09340bccb3b9 100644
--- a/devel/py-qt4-scripttools/Makefile
+++ b/devel/py-qt4-scripttools/Makefile
@@ -52,7 +52,7 @@ ARGS+= --debug
ARGS+= --no-qsci-api
PLIST_SUB+= API="@comment "
.else
-LIB_DEPENDS+= qscintilla2.5:${PORTSDIR}/devel/qscintilla2
+LIB_DEPENDS+= qscintilla2.8:${PORTSDIR}/devel/qscintilla2
ARGS+= --qsci-api --qsci-api-destdir=${QSCIDIR}
PLIST_SUB+= API=""
.endif
diff --git a/devel/py-qt4-test/Makefile b/devel/py-qt4-test/Makefile
index f7f44c5974c9..e8130807befe 100644
--- a/devel/py-qt4-test/Makefile
+++ b/devel/py-qt4-test/Makefile
@@ -51,7 +51,7 @@ ARGS+= --debug
ARGS+= --no-qsci-api
PLIST_SUB+= API="@comment "
.else
-LIB_DEPENDS+= qscintilla2.5:${PORTSDIR}/devel/qscintilla2
+LIB_DEPENDS+= qscintilla2.8:${PORTSDIR}/devel/qscintilla2
ARGS+= --qsci-api --qsci-api-destdir=${QSCIDIR}
PLIST_SUB+= API=""
.endif
diff --git a/devel/py-qt4/distinfo b/devel/py-qt4/distinfo
index 2ac8bcc5e5bb..c0ed07bd67c9 100644
--- a/devel/py-qt4/distinfo
+++ b/devel/py-qt4/distinfo
@@ -1,2 +1,2 @@
-SHA256 (PyQt-x11-gpl-4.8.5.tar.gz) = c9e2df3a2fc7cba2f0c93e957bfaa8ee454f823c3032f688154976a3a3b36820
-SIZE (PyQt-x11-gpl-4.8.5.tar.gz) = 9798545
+SHA256 (PyQt-x11-gpl-4.9.1.tar.gz) = f283557f2190ffc00d72fe8451ac15536cab777c36a9b573031328f401629bb1
+SIZE (PyQt-x11-gpl-4.9.1.tar.gz) = 9742132
diff --git a/devel/py-sip/distinfo b/devel/py-sip/distinfo
index 7569fcc2cdd5..e6bea0e39816 100644
--- a/devel/py-sip/distinfo
+++ b/devel/py-sip/distinfo
@@ -1,2 +1,2 @@
-SHA256 (sip-4.12.4.tar.gz) = 768c1f0ae7ccdc2a75cb4ca6dfd22a46832e06b3c96b1f0e8d3e955cbec047b3
-SIZE (sip-4.12.4.tar.gz) = 753270
+SHA256 (sip-4.13.2.tar.gz) = 4bc3f5353c75918e1c8499ec1474e7b3392c30513ea6d7a6334f88b88271eebf
+SIZE (sip-4.13.2.tar.gz) = 733120
diff --git a/devel/py-sip/files/bsd.pyqt.mk b/devel/py-sip/files/bsd.pyqt.mk
index ee9e39394666..4d2cf0d42873 100644
--- a/devel/py-sip/files/bsd.pyqt.mk
+++ b/devel/py-sip/files/bsd.pyqt.mk
@@ -6,20 +6,18 @@ MASTER_SITE_RIVERBANK= http://www.riverbankcomputing.com/static/Downloads/
MASTER_SITE_FLUFFY= http://ns.ael.ru/~fluffy.khv/pyqt/
MASTER_SITES_SIP= ${MASTER_SITE_RIVERBANK}sip4/ \
- ${MASTER_SITE_GENTOO:S,%SUBDIR%,distfiles,} \
- ${MASTER_SITE_FLUFFY}sip4/
+ ${MASTER_SITE_GENTOO:S,%SUBDIR%,distfiles,}
MASTER_SITES_PYQT4= ${MASTER_SITE_RIVERBANK}PyQt4/ \
- ${MASTER_SITE_GENTOO:S,%SUBDIR%,distfiles,} \
- ${MASTER_SITE_FLUFFY}PyQt4/
+ ${MASTER_SITE_GENTOO:S,%SUBDIR%,distfiles,}
MASTER_SITES_QSCI2= ${MASTER_SITE_RIVERBANK}QScintilla2/ \
${MASTER_SITE_GENTOO:S,%SUBDIR%,distfiles,} \
${MASTER_SITE_FLUFFY}QScintilla2/
-SIP_VERSION= 4.12.4
+SIP_VERSION= 4.13.2
#SIP_SNAP= -snapshot-20100102
-PYQT4_VERSION= 4.8.5
+PYQT4_VERSION= 4.9.1
#PYQT4_SNAP= -snapshot-20100110
-QSCI2_VERSION= 2.4.6
+QSCI2_VERSION= 2.6.1
#QSCI2_SNAP= -snapshot-20091222
SIP_DISTNAME= sip-${SIP_VERSION}${SIP_SNAP}
diff --git a/devel/qscintilla2-designerplugin/Makefile b/devel/qscintilla2-designerplugin/Makefile
index 5c5ac9966f64..bbf8df9b691b 100644
--- a/devel/qscintilla2-designerplugin/Makefile
+++ b/devel/qscintilla2-designerplugin/Makefile
@@ -15,7 +15,7 @@ DISTNAME= ${QSCI2_DISTNAME}
MAINTAINER= kde@FreeBSD.org
COMMENT= Qt Designer plugin for QScintilla2 (Qt4)
-LIB_DEPENDS= qscintilla2.5:${PORTSDIR}/devel/qscintilla2
+LIB_DEPENDS= qscintilla2.8:${PORTSDIR}/devel/qscintilla2
DISTINFO_FILE= ${QSCI2_DISTINFO_FILE}
USE_QT_VER= 4
diff --git a/devel/qscintilla2/distinfo b/devel/qscintilla2/distinfo
index a46c77e54d2a..4f28bbc715cb 100644
--- a/devel/qscintilla2/distinfo
+++ b/devel/qscintilla2/distinfo
@@ -1,2 +1,2 @@
-SHA256 (QScintilla-gpl-2.4.6.tar.gz) = ad4dcc34922358aab8b0ce643e38e12188b41d00a87513ebfd2d6186c5824eab
-SIZE (QScintilla-gpl-2.4.6.tar.gz) = 2442792
+SHA256 (QScintilla-gpl-2.6.1.tar.gz) = 34b7052b820dfedd4af897d6865d94e81a7aeb7f037f70f5516e9b0ea88afb63
+SIZE (QScintilla-gpl-2.6.1.tar.gz) = 2657005
diff --git a/devel/qscintilla2/pkg-plist b/devel/qscintilla2/pkg-plist
index 815eba4cec8a..eee4478e66c9 100644
--- a/devel/qscintilla2/pkg-plist
+++ b/devel/qscintilla2/pkg-plist
@@ -22,6 +22,8 @@
%%QT_INCDIR_REL%%/Qsci/qscilexerjavascript.h
%%QT_INCDIR_REL%%/Qsci/qscilexerlua.h
%%QT_INCDIR_REL%%/Qsci/qscilexermakefile.h
+%%QT_INCDIR_REL%%/Qsci/qscilexermatlab.h
+%%QT_INCDIR_REL%%/Qsci/qscilexeroctave.h
%%QT_INCDIR_REL%%/Qsci/qscilexerpascal.h
%%QT_INCDIR_REL%%/Qsci/qscilexerperl.h
%%QT_INCDIR_REL%%/Qsci/qscilexerpostscript.h
@@ -44,14 +46,15 @@
%%QT_INCDIR_REL%%/Qsci/qscistyle.h
%%QT_INCDIR_REL%%/Qsci/qscistyledtext.h
%%QT_LIBDIR_REL%%/libqscintilla2.so
-%%QT_LIBDIR_REL%%/libqscintilla2.so.5
-%%QT_LIBDIR_REL%%/libqscintilla2.so.5.5
-%%QT_LIBDIR_REL%%/libqscintilla2.so.5.5.0
+%%QT_LIBDIR_REL%%/libqscintilla2.so.8
+%%QT_LIBDIR_REL%%/libqscintilla2.so.8.0
+%%QT_LIBDIR_REL%%/libqscintilla2.so.8.0.1
share/qt4/qsci/api/python/Python-2.4.api
share/qt4/qsci/api/python/Python-2.5.api
share/qt4/qsci/api/python/Python-2.6.api
share/qt4/qsci/api/python/Python-2.7.api
share/qt4/qsci/api/python/Python-3.1.api
+share/qt4/qsci/api/python/Python-3.2.api
%%NLS%%share/qt4/translations/qscintilla_cs.qm
%%NLS%%share/qt4/translations/qscintilla_de.qm
%%NLS%%share/qt4/translations/qscintilla_es.qm
diff --git a/graphics/py-qt4-svg/Makefile b/graphics/py-qt4-svg/Makefile
index e9855995fd5a..0026fb0caa67 100644
--- a/graphics/py-qt4-svg/Makefile
+++ b/graphics/py-qt4-svg/Makefile
@@ -51,7 +51,7 @@ ARGS+= --debug
ARGS+= --no-qsci-api
PLIST_SUB+= API="@comment "
.else
-LIB_DEPENDS+= qscintilla2.5:${PORTSDIR}/devel/qscintilla2
+LIB_DEPENDS+= qscintilla2.8:${PORTSDIR}/devel/qscintilla2
ARGS+= --qsci-api --qsci-api-destdir=${QSCIDIR}
PLIST_SUB+= API=""
.endif
diff --git a/misc/py-qt4-demo/pkg-plist b/misc/py-qt4-demo/pkg-plist
index 81147c6b9071..65ead40da9a6 100644
--- a/misc/py-qt4-demo/pkg-plist
+++ b/misc/py-qt4-demo/pkg-plist
@@ -56,6 +56,27 @@
%%EXAMPLESDIR%%/animation/stickman/stickman.py
%%EXAMPLESDIR%%/animation/stickman/stickman.pyc
%%EXAMPLESDIR%%/animation/stickman/stickman.qrc
+%%EXAMPLESDIR%%/dbus/chat/chat.py
+%%EXAMPLESDIR%%/dbus/chat/chat.pyc
+%%EXAMPLESDIR%%/dbus/chat/chatmainwindow.ui
+%%EXAMPLESDIR%%/dbus/chat/chatsetnickname.ui
+%%EXAMPLESDIR%%/dbus/chat/ui_chatmainwindow.py
+%%EXAMPLESDIR%%/dbus/chat/ui_chatmainwindow.pyc
+%%EXAMPLESDIR%%/dbus/chat/ui_chatsetnickname.py
+%%EXAMPLESDIR%%/dbus/chat/ui_chatsetnickname.pyc
+%%EXAMPLESDIR%%/dbus/listnames.py
+%%EXAMPLESDIR%%/dbus/listnames.pyc
+%%EXAMPLESDIR%%/dbus/pingpong/ping.py
+%%EXAMPLESDIR%%/dbus/pingpong/ping.pyc
+%%EXAMPLESDIR%%/dbus/pingpong/pong.py
+%%EXAMPLESDIR%%/dbus/pingpong/pong.pyc
+%%EXAMPLESDIR%%/dbus/remotecontrolledcar/car/car.py
+%%EXAMPLESDIR%%/dbus/remotecontrolledcar/car/car.pyc
+%%EXAMPLESDIR%%/dbus/remotecontrolledcar/controller/controller.py
+%%EXAMPLESDIR%%/dbus/remotecontrolledcar/controller/controller.pyc
+%%EXAMPLESDIR%%/dbus/remotecontrolledcar/controller/controller.ui
+%%EXAMPLESDIR%%/dbus/remotecontrolledcar/controller/ui_controller.py
+%%EXAMPLESDIR%%/dbus/remotecontrolledcar/controller/ui_controller.pyc
%%EXAMPLESDIR%%/declarative/modelviews/objectlistmodel/objectlistmodel.py
%%EXAMPLESDIR%%/declarative/modelviews/objectlistmodel/objectlistmodel.pyc
%%EXAMPLESDIR%%/declarative/modelviews/objectlistmodel/objectlistmodel.qrc
@@ -1011,6 +1032,12 @@
@dirrm %%EXAMPLESDIR%%/declarative/modelviews/objectlistmodel
@dirrm %%EXAMPLESDIR%%/declarative/modelviews
@dirrm %%EXAMPLESDIR%%/declarative
+@dirrm %%EXAMPLESDIR%%/dbus/remotecontrolledcar/controller
+@dirrm %%EXAMPLESDIR%%/dbus/remotecontrolledcar/car
+@dirrm %%EXAMPLESDIR%%/dbus/remotecontrolledcar
+@dirrm %%EXAMPLESDIR%%/dbus/pingpong
+@dirrm %%EXAMPLESDIR%%/dbus/chat
+@dirrm %%EXAMPLESDIR%%/dbus
@dirrm %%EXAMPLESDIR%%/animation/stickman/animations
@dirrm %%EXAMPLESDIR%%/animation/stickman
@dirrm %%EXAMPLESDIR%%/animation/states
diff --git a/misc/py-qt4-doc/pkg-plist b/misc/py-qt4-doc/pkg-plist
index fd569766ddc8..536ccdc9f47a 100644
--- a/misc/py-qt4-doc/pkg-plist
+++ b/misc/py-qt4-doc/pkg-plist
@@ -30,9 +30,15 @@
%%DOCSDIR%%/html/_sources/qvariant.txt
%%DOCSDIR%%/html/_sources/resources.txt
%%DOCSDIR%%/html/_sources/webkit.txt
+%%DOCSDIR%%/html/_static/ajax-loader.gif
%%DOCSDIR%%/html/_static/basic.css
+%%DOCSDIR%%/html/_static/comment-bright.png
+%%DOCSDIR%%/html/_static/comment-close.png
+%%DOCSDIR%%/html/_static/comment.png
%%DOCSDIR%%/html/_static/default.css
%%DOCSDIR%%/html/_static/doctools.js
+%%DOCSDIR%%/html/_static/down-pressed.png
+%%DOCSDIR%%/html/_static/down.png
%%DOCSDIR%%/html/_static/file.png
%%DOCSDIR%%/html/_static/jquery.js
%%DOCSDIR%%/html/_static/logo.png
@@ -43,6 +49,9 @@
%%DOCSDIR%%/html/_static/searchtools.js
%%DOCSDIR%%/html/_static/sidebar.js
%%DOCSDIR%%/html/_static/underscore.js
+%%DOCSDIR%%/html/_static/up-pressed.png
+%%DOCSDIR%%/html/_static/up.png
+%%DOCSDIR%%/html/_static/websupport.js
%%DOCSDIR%%/html/assistant-manual.html
%%DOCSDIR%%/html/buffer_interface.html
%%DOCSDIR%%/html/build_system.html
@@ -395,6 +404,7 @@
%%DOCSDIR%%/html/images/rb-logo.png
%%DOCSDIR%%/html/images/relationaltable.png
%%DOCSDIR%%/html/images/rintersect.png
+%%DOCSDIR%%/html/images/roaming-states.png
%%DOCSDIR%%/html/images/rsubtract.png
%%DOCSDIR%%/html/images/runion.png
%%DOCSDIR%%/html/images/rxor.png
@@ -557,6 +567,25 @@
%%DOCSDIR%%/html/qdatetime.html
%%DOCSDIR%%/html/qdatetimeedit-sections.html
%%DOCSDIR%%/html/qdatetimeedit.html
+%%DOCSDIR%%/html/qdbus.html
+%%DOCSDIR%%/html/qdbusabstractadaptor.html
+%%DOCSDIR%%/html/qdbusabstractinterface.html
+%%DOCSDIR%%/html/qdbusargument.html
+%%DOCSDIR%%/html/qdbusconnection-registeroptions.html
+%%DOCSDIR%%/html/qdbusconnection.html
+%%DOCSDIR%%/html/qdbusconnectioninterface.html
+%%DOCSDIR%%/html/qdbuserror.html
+%%DOCSDIR%%/html/qdbusinterface.html
+%%DOCSDIR%%/html/qdbusmessage.html
+%%DOCSDIR%%/html/qdbusobjectpath.html
+%%DOCSDIR%%/html/qdbuspendingcall.html
+%%DOCSDIR%%/html/qdbuspendingcallwatcher.html
+%%DOCSDIR%%/html/qdbuspendingreply.html
+%%DOCSDIR%%/html/qdbusreply.html
+%%DOCSDIR%%/html/qdbusservicewatcher-watchmode.html
+%%DOCSDIR%%/html/qdbusservicewatcher.html
+%%DOCSDIR%%/html/qdbussignature.html
+%%DOCSDIR%%/html/qdbusvariant.html
%%DOCSDIR%%/html/qdeclarativecomponent.html
%%DOCSDIR%%/html/qdeclarativecontext.html
%%DOCSDIR%%/html/qdeclarativeengine.html
@@ -1108,6 +1137,7 @@
%%DOCSDIR%%/html/qtcore.html
%%DOCSDIR%%/html/qtcpserver.html
%%DOCSDIR%%/html/qtcpsocket.html
+%%DOCSDIR%%/html/qtdbus.html
%%DOCSDIR%%/html/qtdeclarative.html
%%DOCSDIR%%/html/qtdesigner.html
%%DOCSDIR%%/html/qtemporaryfile.html
diff --git a/multimedia/py-qt4-multimedia/Makefile b/multimedia/py-qt4-multimedia/Makefile
index 4a527d2d6f77..7f0e5fa62c15 100644
--- a/multimedia/py-qt4-multimedia/Makefile
+++ b/multimedia/py-qt4-multimedia/Makefile
@@ -51,7 +51,7 @@ ARGS+= --debug
ARGS+= --no-qsci-api
PLIST_SUB+= API="@comment "
.else
-LIB_DEPENDS+= qscintilla2.5:${PORTSDIR}/devel/qscintilla2
+LIB_DEPENDS+= qscintilla2.8:${PORTSDIR}/devel/qscintilla2
ARGS+= --qsci-api --qsci-api-destdir=${QSCIDIR}
PLIST_SUB+= API=""
.endif
diff --git a/multimedia/py-qt4-phonon/Makefile b/multimedia/py-qt4-phonon/Makefile
index 164f9a7c1969..295e10318566 100644
--- a/multimedia/py-qt4-phonon/Makefile
+++ b/multimedia/py-qt4-phonon/Makefile
@@ -51,7 +51,7 @@ ARGS+= --debug
ARGS+= --no-qsci-api
PLIST_SUB+= API="@comment "
.else
-LIB_DEPENDS+= qscintilla2.5:${PORTSDIR}/devel/qscintilla2
+LIB_DEPENDS+= qscintilla2.8:${PORTSDIR}/devel/qscintilla2
ARGS+= --qsci-api --qsci-api-destdir=${QSCIDIR}
PLIST_SUB+= API=""
.endif
diff --git a/net/py-qt4-network/Makefile b/net/py-qt4-network/Makefile
index 2a1d049cdc2e..bb9a47442331 100644
--- a/net/py-qt4-network/Makefile
+++ b/net/py-qt4-network/Makefile
@@ -51,7 +51,7 @@ ARGS+= --debug
ARGS+= --no-qsci-api
PLIST_SUB+= API="@comment "
.else
-LIB_DEPENDS+= qscintilla2.5:${PORTSDIR}/devel/qscintilla2
+LIB_DEPENDS+= qscintilla2.8:${PORTSDIR}/devel/qscintilla2
ARGS+= --qsci-api --qsci-api-destdir=${QSCIDIR}
PLIST_SUB+= API=""
.endif
diff --git a/net/py-qt4-network/pkg-plist b/net/py-qt4-network/pkg-plist
index d94fd1f29fb8..024ab067b8dd 100644
--- a/net/py-qt4-network/pkg-plist
+++ b/net/py-qt4-network/pkg-plist
@@ -7,11 +7,12 @@
%%SIP%%share/py-sip/QtNetwork/qhostaddress.sip
%%SIP%%share/py-sip/QtNetwork/qhostinfo.sip
%%SIP%%share/py-sip/QtNetwork/qhttp.sip
+%%SIP%%share/py-sip/QtNetwork/qhttpmultipart.sip
%%SIP%%share/py-sip/QtNetwork/qlocalserver.sip
%%SIP%%share/py-sip/QtNetwork/qlocalsocket.sip
+%%SIP%%share/py-sip/QtNetwork/qnetworkaccessmanager.sip
%%SIP%%share/py-sip/QtNetwork/qnetworkconfigmanager.sip
%%SIP%%share/py-sip/QtNetwork/qnetworkconfiguration.sip
-%%SIP%%share/py-sip/QtNetwork/qnetworkaccessmanager.sip
%%SIP%%share/py-sip/QtNetwork/qnetworkcookie.sip
%%SIP%%share/py-sip/QtNetwork/qnetworkcookiejar.sip
%%SIP%%share/py-sip/QtNetwork/qnetworkdiskcache.sip
diff --git a/textproc/py-qt4-xml/Makefile b/textproc/py-qt4-xml/Makefile
index b32ca2e89222..9c9b09500efe 100644
--- a/textproc/py-qt4-xml/Makefile
+++ b/textproc/py-qt4-xml/Makefile
@@ -51,7 +51,7 @@ ARGS+= --debug
ARGS+= --no-qsci-api
PLIST_SUB+= API="@comment "
.else
-LIB_DEPENDS+= qscintilla2.5:${PORTSDIR}/devel/qscintilla2
+LIB_DEPENDS+= qscintilla2.8:${PORTSDIR}/devel/qscintilla2
ARGS+= --qsci-api --qsci-api-destdir=${QSCIDIR}
PLIST_SUB+= API=""
.endif
diff --git a/textproc/py-qt4-xmlpatterns/Makefile b/textproc/py-qt4-xmlpatterns/Makefile
index f4e24aa13335..214e48ee0919 100644
--- a/textproc/py-qt4-xmlpatterns/Makefile
+++ b/textproc/py-qt4-xmlpatterns/Makefile
@@ -50,7 +50,7 @@ ARGS+= --debug
ARGS+= --no-qsci-api
PLIST_SUB+= API="@comment "
.else
-LIB_DEPENDS+= qscintilla2.5:${PORTSDIR}/devel/qscintilla2
+LIB_DEPENDS+= qscintilla2.8:${PORTSDIR}/devel/qscintilla2
ARGS+= --qsci-api --qsci-api-destdir=${QSCIDIR}
PLIST_SUB+= API=""
.endif
diff --git a/www/py-qt4-webkit/Makefile b/www/py-qt4-webkit/Makefile
index 3b8a4496182c..8865369ee76b 100644
--- a/www/py-qt4-webkit/Makefile
+++ b/www/py-qt4-webkit/Makefile
@@ -50,7 +50,7 @@ ARGS+= --debug
ARGS+= --no-qsci-api
PLIST_SUB+= API="@comment "
.else
-LIB_DEPENDS+= qscintilla2.5:${PORTSDIR}/devel/qscintilla2
+LIB_DEPENDS+= qscintilla2.8:${PORTSDIR}/devel/qscintilla2
ARGS+= --qsci-api --qsci-api-destdir=${QSCIDIR}
PLIST_SUB+= API=""
.endif
diff --git a/x11-toolkits/py-qt4-gui/Makefile b/x11-toolkits/py-qt4-gui/Makefile
index f03afab45d8b..769d44392a42 100644
--- a/x11-toolkits/py-qt4-gui/Makefile
+++ b/x11-toolkits/py-qt4-gui/Makefile
@@ -52,7 +52,7 @@ ARGS+= --debug
ARGS+= --no-qsci-api
PLIST_SUB+= API="@comment "
.else
-LIB_DEPENDS+= qscintilla2.5:${PORTSDIR}/devel/qscintilla2
+LIB_DEPENDS+= qscintilla2.8:${PORTSDIR}/devel/qscintilla2
ARGS+= --qsci-api --qsci-api-destdir=${QSCIDIR}
PLIST_SUB+= API=""
.endif
diff --git a/x11-toolkits/py-qt4-gui/pkg-plist b/x11-toolkits/py-qt4-gui/pkg-plist
index 7b09ef05336d..8b089cf08923 100644
--- a/x11-toolkits/py-qt4-gui/pkg-plist
+++ b/x11-toolkits/py-qt4-gui/pkg-plist
@@ -55,6 +55,7 @@
%%SIP%%share/py-sip/QtGui/qgenericmatrix.sip
%%SIP%%share/py-sip/QtGui/qgesture.sip
%%SIP%%share/py-sip/QtGui/qgesturerecognizer.sip
+%%SIP%%share/py-sip/QtGui/qglyphrun.sip
%%SIP%%share/py-sip/QtGui/qgraphicsanchorlayout.sip
%%SIP%%share/py-sip/QtGui/qgraphicseffect.sip
%%SIP%%share/py-sip/QtGui/qgraphicsgridlayout.sip
@@ -74,6 +75,7 @@
%%SIP%%share/py-sip/QtGui/qheaderview.sip
%%SIP%%share/py-sip/QtGui/qicon.sip
%%SIP%%share/py-sip/QtGui/qiconengine.sip
+%%SIP%%share/py-sip/QtGui/qidentityproxymodel.sip
%%SIP%%share/py-sip/QtGui/qimage.sip
%%SIP%%share/py-sip/QtGui/qimageiohandler.sip
%%SIP%%share/py-sip/QtGui/qimagereader.sip
@@ -129,6 +131,7 @@
%%SIP%%share/py-sip/QtGui/qpytextobject.sip
%%SIP%%share/py-sip/QtGui/qquaternion.sip
%%SIP%%share/py-sip/QtGui/qradiobutton.sip
+%%SIP%%share/py-sip/QtGui/qrawfont.sip
%%SIP%%share/py-sip/QtGui/qregion.sip
%%SIP%%share/py-sip/QtGui/qrgb.sip
%%SIP%%share/py-sip/QtGui/qrubberband.sip
diff --git a/x11/py-qt4-opengl/Makefile b/x11/py-qt4-opengl/Makefile
index 2df3ab9a368f..3dd0e2bd5748 100644
--- a/x11/py-qt4-opengl/Makefile
+++ b/x11/py-qt4-opengl/Makefile
@@ -51,7 +51,7 @@ ARGS+= --debug
ARGS+= --no-qsci-api
PLIST_SUB+= API="@comment "
.else
-LIB_DEPENDS+= qscintilla2.5:${PORTSDIR}/devel/qscintilla2
+LIB_DEPENDS+= qscintilla2.8:${PORTSDIR}/devel/qscintilla2
ARGS+= --qsci-api --qsci-api-destdir=${QSCIDIR}
PLIST_SUB+= API=""
.endif