aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2005-04-10 21:46:47 +0000
committerKris Kennaway <kris@FreeBSD.org>2005-04-10 21:46:47 +0000
commit3c30966bd8733f5bb75dcde69e3838fa5421326a (patch)
tree5825673392add546cc243a8d00f2e83f10a5473f
parent7822883e4f2b20190732f5c7326ed4fa2d0dd4bc (diff)
Notes
-rw-r--r--devel/liboil/Makefile8
-rw-r--r--textproc/libwpd/Makefile8
-rw-r--r--textproc/libwpd08/Makefile8
3 files changed, 21 insertions, 3 deletions
diff --git a/devel/liboil/Makefile b/devel/liboil/Makefile
index 3f58245a64ad..f900b402c8f6 100644
--- a/devel/liboil/Makefile
+++ b/devel/liboil/Makefile
@@ -20,9 +20,15 @@ INSTALLS_SHLIB= yes
PLIST_SUB= VERSION=${PORTVERSION:R}
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= "Does not compile on FreeBSD 4.x"
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|stdint\.h|inttypes.h|g' \
${WRKSRC}/liboil/liboiltypes.h \
${WRKSRC}/liboil/liboil.h
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/textproc/libwpd/Makefile b/textproc/libwpd/Makefile
index 34950172cfcd..25d81d764780 100644
--- a/textproc/libwpd/Makefile
+++ b/textproc/libwpd/Makefile
@@ -20,4 +20,10 @@ USE_LIBTOOL_VER=15
USE_GNOME= gnomehack libgsf
INSTALLS_SHLIB= yes
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= "Does not compile on FreeBSD 4.x"
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/textproc/libwpd08/Makefile b/textproc/libwpd08/Makefile
index 34950172cfcd..25d81d764780 100644
--- a/textproc/libwpd08/Makefile
+++ b/textproc/libwpd08/Makefile
@@ -20,4 +20,10 @@ USE_LIBTOOL_VER=15
USE_GNOME= gnomehack libgsf
INSTALLS_SHLIB= yes
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= "Does not compile on FreeBSD 4.x"
+.endif
+
+.include <bsd.port.post.mk>