aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2020-06-14 13:51:09 +0000
committerMatthias Andree <mandree@FreeBSD.org>2020-06-14 13:51:09 +0000
commit3d9385c2c6070e3527c7c4a1080451704d9f32b6 (patch)
tree715d8138d3416ad152df3c7e02dd607d96bbf5d6
parent1f01be9b6d5d32bb0fc5c7c02313aa092cc82adc (diff)
downloadports-3d9385c2c6070e3527c7c4a1080451704d9f32b6.tar.gz
ports-3d9385c2c6070e3527c7c4a1080451704d9f32b6.zip
MFH: r538737
graphics/rawtherapee: fix SIGSEGV in RGB_denoise - Bug report https://github.com/Beep6581/RawTherapee/issues/5796 - Cherry-pick https://github.com/Beep6581/RawTherapee/commit/5239e61946870a5405e94b138b4196fc35159ab1 - Bump PORTREVISION Obtained from: Ingo Weyrich/upstream Github repo Approved by: ports-secteam@ (blanket approval for stability fixes)
Notes
Notes: svn path=/branches/2020Q2/; revision=538739
-rw-r--r--graphics/rawtherapee/Makefile2
-rw-r--r--graphics/rawtherapee/files/patch-rtengine_FTblockDN.cc23
2 files changed, 24 insertions, 1 deletions
diff --git a/graphics/rawtherapee/Makefile b/graphics/rawtherapee/Makefile
index b2079aeea1c6..25029384a022 100644
--- a/graphics/rawtherapee/Makefile
+++ b/graphics/rawtherapee/Makefile
@@ -3,7 +3,7 @@
PORTNAME= rawtherapee
PORTVERSION= 5.8
-PORTREVISION= 2
+PORTREVISION= 4
CATEGORIES= graphics
MASTER_SITES= https://rawtherapee.com/shared/source/ \
LOCAL/mandree/
diff --git a/graphics/rawtherapee/files/patch-rtengine_FTblockDN.cc b/graphics/rawtherapee/files/patch-rtengine_FTblockDN.cc
new file mode 100644
index 000000000000..b72e56759752
--- /dev/null
+++ b/graphics/rawtherapee/files/patch-rtengine_FTblockDN.cc
@@ -0,0 +1,23 @@
+From 5239e61946870a5405e94b138b4196fc35159ab1 Mon Sep 17 00:00:00 2001
+From: Ingo Weyrich <heckflosse@users.noreply.github.com>
+Date: Fri, 12 Jun 2020 12:57:52 +0200
+Subject: [PATCH] Fix segfault in denoise, fixes #5796
+
+--- rtengine/FTblockDN.cc.orig 2020-02-04 06:39:52 UTC
++++ rtengine/FTblockDN.cc
+@@ -957,13 +957,8 @@ BENCHFUN
+ labdn->b[i1][j1] = B_ < 65535.f ? gamcurve[B_] : Color::gammanf(B_ / 65535.f, gam) * 32768.f;
+
+ if (((i1 | j1) & 1) == 0) {
+- if (numTries == 1) {
+- noisevarlum[(i1 >> 1) * width2 + (j1 >> 1)] = useNoiseLCurve ? lumcalc[i >> 1][j >> 1] : noisevarL;
+- noisevarchrom[(i1 >> 1) * width2 + (j1 >> 1)] = useNoiseCCurve ? maxNoiseVarab * ccalc[i >> 1][j >> 1] : 1.f;
+- } else {
+- noisevarlum[(i1 >> 1) * width2 + (j1 >> 1)] = lumcalc[i >> 1][j >> 1];
+- noisevarchrom[(i1 >> 1) * width2 + (j1 >> 1)] = ccalc[i >> 1][j >> 1];
+- }
++ noisevarlum[(i1 >> 1) * width2 + (j1 >> 1)] = useNoiseLCurve ? lumcalc[i >> 1][j >> 1] : noisevarL;
++ noisevarchrom[(i1 >> 1) * width2 + (j1 >> 1)] = useNoiseCCurve ? maxNoiseVarab * ccalc[i >> 1][j >> 1] : 1.f;
+ }
+
+ //end chroma