aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanilo G. Baio <dbaio@FreeBSD.org>2020-06-15 11:22:38 +0000
committerDanilo G. Baio <dbaio@FreeBSD.org>2020-06-15 11:22:38 +0000
commit520dc9e74ab5dc71f4d4de39450b3b286da76249 (patch)
treef112fd8b7eb332d40522d9cf581dbdc52ca9c4fa
parenta1b0612cecc36bbbb69dc1586a111c0875d425b2 (diff)
downloadports-520dc9e74ab5dc71f4d4de39450b3b286da76249.tar.gz
ports-520dc9e74ab5dc71f4d4de39450b3b286da76249.zip
MFH: r536770 r536776 r538670
Recompile _sysconfigdata.py after reinplacing it PR: 246618 With hat: portmgr Fix build with various python ABI With hat: portmgr lang/python37: Fix security issues The patches for CVE-2019-18348 and CVE-2020-8492 are in the 3.7 branch and will be present on the next release. Patch for applying CVE-2020-8492 fix here in the ports tree was reported and submitted by Dani <i.dani@outlook.com>. PR: 246808 X-MFH-with: 536770, 536776 Security: ca595a25-91d8-11ea-b470-080027846a02 (CVE-2019-18348) Security: a27b0bb6-84fc-11ea-b5b4-641c67a117d8 (CVE-2020-8492) Approved by: ports-secteam (joneum)
Notes
Notes: svn path=/branches/2020Q2/; revision=538872
-rw-r--r--lang/python37/Makefile15
-rw-r--r--lang/python37/distinfo6
-rw-r--r--lang/python38/Makefile10
3 files changed, 26 insertions, 5 deletions
diff --git a/lang/python37/Makefile b/lang/python37/Makefile
index 14ce6165f6bc..b60aba4513ea 100644
--- a/lang/python37/Makefile
+++ b/lang/python37/Makefile
@@ -3,12 +3,17 @@
PORTNAME= python
PORTVERSION= ${PYTHON_PORTVERSION}
+PORTREVISION= 1
CATEGORIES= lang python
MASTER_SITES= PYTHON/ftp/python/${PORTVERSION}
PKGNAMESUFFIX= ${PYTHON_SUFFIX}
DISTNAME= Python-${PORTVERSION}
DIST_SUBDIR= python
+PATCH_SITES= https://github.com/python/cpython/commit/
+PATCHFILES= b57a73694e26e8b2391731b5ee0b1be59437388e.patch:-p1 \
+ 34f85af3229f86c004a954c3f261ceea1f5e9f95.patch:-p1
+
MAINTAINER= python@FreeBSD.org
COMMENT= Interpreted object-oriented programming language
@@ -124,9 +129,15 @@ post-install:
# FreeBSD base system provides. sbruno 02Aug2017
.if ${CC} == /nxb-bin/usr/bin/cc
@${REINPLACE_CMD} -e 's=/nxb-bin==' \
- ${STAGEDIR}${PREFIX}/lib/python${PYTHON_VER}/_sysconfigdata_m_freebsd${OSREL:R}_.py
+ ${STAGEDIR}${PREFIX}/lib/python${PYTHON_VER}/_sysconfigdata_${ABIFLAGS}_freebsd${OSREL:R}_.py
+ @cd ${WRKSRC} && ${SETENV} LD_LIBRARY_PATH=${WRKSRC} \
+ ./python -E -m compileall -d ${PREFIX}/lib/python${PYTHON_VER} \
+ ${STAGEDIR}${PREFIX}/lib/python${PYTHON_VER}/_sysconfigdata_${ABIFLAGS}_freebsd${OSREL:R}_.py
+ @cd ${WRKSRC} && ${SETENV} LD_LIBRARY_PATH=${WRKSRC} \
+ ./python -E -O -m compileall -d ${PREFIX}/lib/python${PYTHON_VER} \
+ ${STAGEDIR}${PREFIX}/lib/python${PYTHON_VER}/_sysconfigdata_${ABIFLAGS}_freebsd${OSREL:R}_.py
@${REINPLACE_CMD} -e 's=/nxb-bin==' \
- ${STAGEDIR}${PREFIX}/lib/python${PYTHON_VER}/config-${PYTHON_VER}m/Makefile
+ ${STAGEDIR}${PREFIX}/lib/python${PYTHON_VER}/config-${PYTHON_VER}${ABIFLAGS}/Makefile
.endif
for i in ${STAGEDIR}${PREFIX}/lib/python${PYTHON_VER}/lib-dynload/*.so; do \
${STRIP_CMD} $$i; done # Strip shared extensions
diff --git a/lang/python37/distinfo b/lang/python37/distinfo
index f708f72b9859..683037a880eb 100644
--- a/lang/python37/distinfo
+++ b/lang/python37/distinfo
@@ -1,3 +1,7 @@
-TIMESTAMP = 1583986224
+TIMESTAMP = 1591492488
SHA256 (python/Python-3.7.7.tar.xz) = 06a0a9f1bf0d8cd1e4121194d666c4e28ddae4dd54346de6c343206599f02136
SIZE (python/Python-3.7.7.tar.xz) = 17268888
+SHA256 (python/b57a73694e26e8b2391731b5ee0b1be59437388e.patch) = c0600667e20d931a6c03d109b6be2bda3eac3923db0ff39e090dc7727c5e45ac
+SIZE (python/b57a73694e26e8b2391731b5ee0b1be59437388e.patch) = 10979
+SHA256 (python/34f85af3229f86c004a954c3f261ceea1f5e9f95.patch) = 9fc707c3281b242e1448fd01a09e7dd7267d3ca84feeebc459786c644c79f9a3
+SIZE (python/34f85af3229f86c004a954c3f261ceea1f5e9f95.patch) = 6680
diff --git a/lang/python38/Makefile b/lang/python38/Makefile
index bf3a72f27576..53fb18ba0267 100644
--- a/lang/python38/Makefile
+++ b/lang/python38/Makefile
@@ -131,9 +131,15 @@ post-install:
# FreeBSD base system provides. sbruno 02Aug2017
.if ${CC} == /nxb-bin/usr/bin/cc
@${REINPLACE_CMD} -e 's=/nxb-bin==' \
- ${STAGEDIR}${PREFIX}/lib/python${PYTHON_VER}/_sysconfigdata_m_freebsd${OSREL:R}_.py
+ ${STAGEDIR}${PREFIX}/lib/python${PYTHON_VER}/_sysconfigdata_${ABIFLAGS}_freebsd${OSREL:R}_.py
+ @cd ${WRKSRC} && ${SETENV} LD_LIBRARY_PATH=${WRKSRC} \
+ ./python -E -m compileall -d ${PREFIX}/lib/python${PYTHON_VER} \
+ ${STAGEDIR}${PREFIX}/lib/python${PYTHON_VER}/_sysconfigdata_${ABIFLAGS}_freebsd${OSREL:R}_.py
+ @cd ${WRKSRC} && ${SETENV} LD_LIBRARY_PATH=${WRKSRC} \
+ ./python -E -O -m compileall -d ${PREFIX}/lib/python${PYTHON_VER} \
+ ${STAGEDIR}${PREFIX}/lib/python${PYTHON_VER}/_sysconfigdata_${ABIFLAGS}_freebsd${OSREL:R}_.py
@${REINPLACE_CMD} -e 's=/nxb-bin==' \
- ${STAGEDIR}${PREFIX}/lib/python${PYTHON_VER}/config-${PYTHON_VER}m/Makefile
+ ${STAGEDIR}${PREFIX}/lib/python${PYTHON_VER}/config-${PYTHON_VER}${ABIFLAGS}/Makefile
.endif
for i in ${STAGEDIR}${PREFIX}/lib/python${PYTHON_VER}/lib-dynload/*.so; do \
${STRIP_CMD} $$i; done # Strip shared extensions