aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2014-09-01 21:32:06 +0000
committerMatthias Andree <mandree@FreeBSD.org>2014-09-01 21:32:06 +0000
commit5ab8c07e58180fc55ab73ef19fe06b3c23d34390 (patch)
tree3ec94c09aa36051d6141c09f8fd50e36dd14c206
parent17c4b0d2588b916054ae7dd6a8d48cddab665694 (diff)
downloadports-5ab8c07e58180fc55ab73ef19fe06b3c23d34390.tar.gz
ports-5ab8c07e58180fc55ab73ef19fe06b3c23d34390.zip
Notes
-rw-r--r--LEGAL1
-rw-r--r--misc/Makefile1
-rw-r--r--misc/susv2/Makefile2
-rw-r--r--misc/susv2/pkg-descr4
-rw-r--r--misc/susv3/Makefile2
-rw-r--r--misc/susv3/pkg-descr4
-rw-r--r--misc/susv4/Makefile30
-rw-r--r--misc/susv4/distinfo2
-rw-r--r--misc/susv4/pkg-descr10
9 files changed, 50 insertions, 6 deletions
diff --git a/LEGAL b/LEGAL
index f38e8202e8e9..982f0dff8637 100644
--- a/LEGAL
+++ b/LEGAL
@@ -235,6 +235,7 @@ stuffit* archivers/stuffit Only unmodified original package can be distributed
su2-1.3.tar.gz sysutils/su2 Do not sell for profit
susv2.tar.bz2 misc/susv2 Redistribution of the documents is not permitted
susv3.tar.bz2 misc/susv3 Redistribution of the documents is not permitted
+susv4tc1.tar.bz2 misc/susv4 Redistribution of the documents is not permitted
svm_light.tar.gz science/svmlight The software must not be further distributed without prior permission of the author
taetgen-* math/tetgen Academic or personal use only
tarsnap-* sysutils/tarsnap license restricts redistribution of source and binaries
diff --git a/misc/Makefile b/misc/Makefile
index 2688fc48bb2f..2b9129e77eb6 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -418,6 +418,7 @@
SUBDIR += sssnips
SUBDIR += susv2
SUBDIR += susv3
+ SUBDIR += susv4
SUBDIR += sword
SUBDIR += table.el
SUBDIR += talkfilters
diff --git a/misc/susv2/Makefile b/misc/susv2/Makefile
index 4765b1575fa2..2f34848fa66a 100644
--- a/misc/susv2/Makefile
+++ b/misc/susv2/Makefile
@@ -19,7 +19,7 @@ PORTDOCS= *
.include <bsd.port.pre.mk>
.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX})
-IGNORE= may not be redistributed because of licensing reasons. Please visit http://www.unix-systems.org/online.html to accept their license and download ${DISTFILES} into ${DISTDIR}
+IGNORE= may not be redistributed because of licensing reasons. Please visit http://www.unix.org/version2/online.html to accept their license and download ${DISTFILES} into ${DISTDIR}
.endif
do-install:
diff --git a/misc/susv2/pkg-descr b/misc/susv2/pkg-descr
index 14411d6b082c..29ded60dbd19 100644
--- a/misc/susv2/pkg-descr
+++ b/misc/susv2/pkg-descr
@@ -1,4 +1,4 @@
-The Singe UNIX Specification Version 2 is a set of
+The Single UNIX Specification Version 2 is a set of
numerous HTML pages describing this standard.
-WWW: http://www.unix-systems.org/online.html
+WWW: http://www.unix.org/version2/online.html
diff --git a/misc/susv3/Makefile b/misc/susv3/Makefile
index 5c499d0a702c..23eb460dc3ae 100644
--- a/misc/susv3/Makefile
+++ b/misc/susv3/Makefile
@@ -19,7 +19,7 @@ PORTDOCS= *
.include <bsd.port.pre.mk>
.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX})
-IGNORE= may not be redistributed because of licensing reasons. Please visit http://www.unix-systems.org/version3/online.html to accept their license and download ${DISTFILES} into ${DISTDIR}
+IGNORE= may not be redistributed because of licensing reasons. Please visit http://www.unix.org/version3/online.html to accept their license and download ${DISTFILES} into ${DISTDIR}
.endif
do-install:
diff --git a/misc/susv3/pkg-descr b/misc/susv3/pkg-descr
index 0a2aec127748..9e2c3cd90977 100644
--- a/misc/susv3/pkg-descr
+++ b/misc/susv3/pkg-descr
@@ -1,4 +1,4 @@
-The Singe UNIX Specification Version 3 is a set of
+The Single UNIX Specification Version 3 is a set of
numerous HTML pages describing this standard.
-WWW: http://www.unix-systems.org/version3/online.html
+WWW: http://www.unix.org/version3/online.html
diff --git a/misc/susv4/Makefile b/misc/susv4/Makefile
new file mode 100644
index 000000000000..31192295a7f2
--- /dev/null
+++ b/misc/susv4/Makefile
@@ -0,0 +1,30 @@
+# Based in a port created by: Simon 'corecode' Schubert <corecode@corecode.ath.cx>
+# $FreeBSD$
+
+PORTNAME= susv4
+PORTVERSION= 20140725
+CATEGORIES= misc
+MASTER_SITES= #
+DISTNAME= susv4tc1
+DIST_SUBDIR= ${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= mandree@FreeBSD.org
+COMMENT= The Open Group Base Specifications Issue 7/IEEE Std 1003.1, 2013 Edition
+
+RESTRICTED= Redistribution of the documents is not permitted
+
+USES= tar:bzip2
+NO_BUILD= yes
+PORTDOCS= *
+
+.include <bsd.port.pre.mk>
+
+.if !exists(${DISTDIR}/${DIST_SUBDIR}/${DISTNAME}${EXTRACT_SUFX})
+IGNORE= may not be redistributed because of licensing reasons. Please visit http://www.unix.org/online.html to accept their license and download ${DISTFILES} into ${DISTDIR}/${DIST_SUBDIR}
+.endif
+
+do-install:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ cd ${WRKSRC} && ${COPYTREE_SHARE} \* ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.post.mk>
diff --git a/misc/susv4/distinfo b/misc/susv4/distinfo
new file mode 100644
index 000000000000..c7a4787cd2f0
--- /dev/null
+++ b/misc/susv4/distinfo
@@ -0,0 +1,2 @@
+SHA256 (susv4-20140725/susv4tc1.tar.bz2) = 0ff54ec49d875752f6ee0063a5cf7c6801b56dbe9b2c3a99fa1d9ebb4c933f39
+SIZE (susv4-20140725/susv4tc1.tar.bz2) = 3729856
diff --git a/misc/susv4/pkg-descr b/misc/susv4/pkg-descr
new file mode 100644
index 000000000000..1a1ae880c192
--- /dev/null
+++ b/misc/susv4/pkg-descr
@@ -0,0 +1,10 @@
+The Single UNIX Specification Version 4, technically identical to IEEE
+Std 1003.1, 2013 Edition or The Open Group Base Specifications Issue 7
+is a technical standard. It includes IEEE Std 1003.1-2008/Cor 1-2013,
+the Technical Corrigendum 1 addressing problems discovered since the
+approval of the 2008 edition.
+
+This port permits to install and register the HTML personal copy
+that the user must download in .tar.bz2 format by himself.
+
+WWW: http://www.unix.org/online.html