aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2020-06-18 20:23:45 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2020-06-18 20:23:45 +0000
commit65a956cdb57f9dad50f10c58a96b0c00d1307907 (patch)
tree96a91b0b0d7a2455e6fbd2c1f852baa239e4b4a3
parent3aed3473402bc4c100782a6880dcb418397c8506 (diff)
downloadports-65a956cdb57f9dad50f10c58a96b0c00d1307907.tar.gz
ports-65a956cdb57f9dad50f10c58a96b0c00d1307907.zip
MFH: r539568
Fix runtime error by adding security/py-pycryptodome and sysutils/py-distro dependencies. Remove py-ioflo and py-ioflo from tcp transport as they are not required anymore. PR: 247391 Submitted by: ohauer@ Approved by: maintainer Approved by: portmgr (blanket)
Notes
Notes: svn path=/branches/2020Q2/; revision=539569
-rw-r--r--sysutils/py-salt/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/sysutils/py-salt/Makefile b/sysutils/py-salt/Makefile
index e2fa42e89e00..b82399b7c533 100644
--- a/sysutils/py-salt/Makefile
+++ b/sysutils/py-salt/Makefile
@@ -3,6 +3,7 @@
PORTNAME= salt
PORTVERSION= 3001
+PORTREVISION= 1
CATEGORIES= sysutils python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -17,6 +18,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}Jinja2>0:devel/py-Jinja2@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}MarkupSafe>0:textproc/py-MarkupSafe@${PY_FLAVOR} \
${PY_ENUM34} \
${PY_FUTURES} \
+ ${PYTHON_PKGNAMEPREFIX}distro>1.4.0:sysutils/py-distro@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}libcloud>=0.14.0:net/py-libcloud@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}msgpack>=0.3:devel/py-msgpack@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}progressbar>0:misc/py-progressbar@${PY_FLAVOR} \
@@ -71,15 +73,13 @@ AWS_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}boto3>0:www/py-boto3@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}boto>=2.32.1:devel/py-boto@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}botocore>0:devel/py-botocore@${PY_FLAVOR}
-RAET_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}libnacl>=1.0.0:security/py-libnacl@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}ioflo>=1.1.7:devel/py-ioflo@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}raet>=0.6.0:net/py-raet@${PY_FLAVOR}
+RAET_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}libnacl>=1.0.0:security/py-libnacl@${PY_FLAVOR}
-TCP_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pycrypto>=2.6.1:security/py-pycrypto@${PY_FLAVOR}
+TCP_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pycryptodomex>=3.9.7:security/py-pycryptodomex@${PY_FLAVOR}
ZEROMQ_BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pyzmq>=2.2.0:net/py-pyzmq@${PY_FLAVOR}
ZEROMQ_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pyzmq>=2.2.0:net/py-pyzmq@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}pycrypto>=2.6.1:security/py-pycrypto@${PY_FLAVOR}
+ ${PYTHON_PKGNAMEPREFIX}pycryptodomex>=3.9.7:security/py-pycryptodomex@${PY_FLAVOR}
post-patch:
.for file in conf/minion conf/master doc/man/salt-key.1 \