aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrej Zverev <az@FreeBSD.org>2013-09-06 09:21:19 +0000
committerAndrej Zverev <az@FreeBSD.org>2013-09-06 09:21:19 +0000
commit69f02904e70bba5028181729a9047df0481896f0 (patch)
tree31f9decc63133fb11f18e2ffde4c5fa535c2355e
parent8e7abd2285f873c34bf019cdc1bcee521f4fa8da (diff)
downloadports-69f02904e70bba5028181729a9047df0481896f0.tar.gz
ports-69f02904e70bba5028181729a9047df0481896f0.zip
Notes
-rw-r--r--net/p5-Apache2-SOAP/Makefile3
-rw-r--r--net/p5-Growl-GNTP/Makefile3
-rw-r--r--net/p5-Net-APNS/Makefile3
-rw-r--r--net/p5-Net-Amazon-Thumbnail/Makefile3
-rw-r--r--net/p5-Net-Cassandra/Makefile3
-rw-r--r--net/p5-Net-DHCPClient/Makefile3
-rw-r--r--net/p5-Net-Frame-Layer-IPv6/Makefile3
-rw-r--r--net/p5-Net-IP-RangeCompare/Makefile3
-rw-r--r--net/p5-Net-Ident/Makefile3
-rw-r--r--net/p5-Net-MAC/Makefile3
-rw-r--r--net/p5-Net-Mosso-CloudFiles/Makefile3
-rw-r--r--net/p5-Net-OAuth/Makefile3
-rw-r--r--net/p5-Net-OpenStack-Attack/Makefile3
-rw-r--r--net/p5-Net-SSH/Makefile3
-rw-r--r--net/p5-Net-Wake/Makefile3
-rw-r--r--net/p5-Net-WhitePages/Makefile3
-rw-r--r--net/p5-Net-Whois-RIPE/Makefile3
-rw-r--r--net/p5-URI-SmartURI/Makefile3
-rw-r--r--net/xrdesktop/Makefile2
19 files changed, 37 insertions, 19 deletions
diff --git a/net/p5-Apache2-SOAP/Makefile b/net/p5-Apache2-SOAP/Makefile
index cf84928ee1c2..b7836389171c 100644
--- a/net/p5-Apache2-SOAP/Makefile
+++ b/net/p5-Apache2-SOAP/Makefile
@@ -19,7 +19,8 @@ BUILD_DEPENDS= ${APACHE_PKGNAMEPREFIX}mod_perl2>=0:${PORTSDIR}/www/mod_perl2 \
p5-SOAP-Lite>=0:${PORTSDIR}/net/p5-SOAP-Lite
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
USE_APACHE= 22+
MAN3= Apache2::SOAP.3
diff --git a/net/p5-Growl-GNTP/Makefile b/net/p5-Growl-GNTP/Makefile
index a12ab48ea707..ab53bcecc514 100644
--- a/net/p5-Growl-GNTP/Makefile
+++ b/net/p5-Growl-GNTP/Makefile
@@ -16,7 +16,8 @@ BUILD_DEPENDS= p5-Data-UUID>=0:${PORTSDIR}/devel/p5-Data-UUID \
p5-Crypt-CBC>=0:${PORTSDIR}/security/p5-Crypt-CBC
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Growl::GNTP.3
diff --git a/net/p5-Net-APNS/Makefile b/net/p5-Net-APNS/Makefile
index e12676ca476b..4406f1cef6f4 100644
--- a/net/p5-Net-APNS/Makefile
+++ b/net/p5-Net-APNS/Makefile
@@ -21,7 +21,8 @@ RUN_DEPENDS= \
p5-Sub-Exporter>=0.982:${PORTSDIR}/devel/p5-Sub-Exporter
BUILD_DEPENDS= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Net::APNS.3 \
Net::APNS::Notification.3
diff --git a/net/p5-Net-Amazon-Thumbnail/Makefile b/net/p5-Net-Amazon-Thumbnail/Makefile
index e15f82ec8220..eed1730872fc 100644
--- a/net/p5-Net-Amazon-Thumbnail/Makefile
+++ b/net/p5-Net-Amazon-Thumbnail/Makefile
@@ -23,7 +23,8 @@ RUN_DEPENDS= p5-Class-Accessor>=0:${PORTSDIR}/devel/p5-Class-Accessor \
p5-XML-XPath>=0:${PORTSDIR}/textproc/p5-XML-XPath
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN3= Net::Amazon::Thumbnail.3
diff --git a/net/p5-Net-Cassandra/Makefile b/net/p5-Net-Cassandra/Makefile
index dc29fb8c2e2a..e7a2d9a43970 100644
--- a/net/p5-Net-Cassandra/Makefile
+++ b/net/p5-Net-Cassandra/Makefile
@@ -19,6 +19,7 @@ RUN_DEPENDS= p5-Moose>0:${PORTSDIR}/devel/p5-Moose \
p5-MooseX-StrictConstructor>0:${PORTSDIR}/devel/p5-MooseX-StrictConstructor
MAN3= Net::Cassandra.3
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
.include <bsd.port.mk>
diff --git a/net/p5-Net-DHCPClient/Makefile b/net/p5-Net-DHCPClient/Makefile
index 0b1f3afd0756..9cb999d133fe 100644
--- a/net/p5-Net-DHCPClient/Makefile
+++ b/net/p5-Net-DHCPClient/Makefile
@@ -15,7 +15,8 @@ MAINTAINER= sem@FreeBSD.org
COMMENT= A Perl implementation of a DHCP client API
RUN_DEPENDS+= p5-Net-RawIP>=0:${PORTSDIR}/net/p5-Net-RawIP
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
WRKSRC= ${WRKDIR}/${PORTNAME}
diff --git a/net/p5-Net-Frame-Layer-IPv6/Makefile b/net/p5-Net-Frame-Layer-IPv6/Makefile
index e9b3bed3b365..a23312198320 100644
--- a/net/p5-Net-Frame-Layer-IPv6/Makefile
+++ b/net/p5-Net-Frame-Layer-IPv6/Makefile
@@ -16,7 +16,8 @@ BUILD_DEPENDS= p5-Bit-Vector>=0:${PORTSDIR}/math/p5-Bit-Vector \
p5-Class-Gomor>=1.00:${PORTSDIR}/devel/p5-Class-Gomor
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Net::Frame::Layer::IPv6.3 \
Net::Frame::Layer::IPv6::Fragment.3 \
diff --git a/net/p5-Net-IP-RangeCompare/Makefile b/net/p5-Net-IP-RangeCompare/Makefile
index 224d506dda81..f5b0a4c4a6a9 100644
--- a/net/p5-Net-IP-RangeCompare/Makefile
+++ b/net/p5-Net-IP-RangeCompare/Makefile
@@ -17,7 +17,8 @@ COMMENT= Perl extension for IP Range Comparisons
RUN_DEPENDS= p5-Data-IPV4-Range-Parse>=0.05:${PORTSDIR}/net/p5-Data-IPV4-Range-Parse \
p5-Data-Range-Compare>=1.030:${PORTSDIR}/devel/p5-Data-Range-Compare
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Net::IP::RangeCompare.3
diff --git a/net/p5-Net-Ident/Makefile b/net/p5-Net-Ident/Makefile
index 92308045f65c..314e38f8b7b1 100644
--- a/net/p5-Net-Ident/Makefile
+++ b/net/p5-Net-Ident/Makefile
@@ -15,7 +15,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= kai@xs4all.nl
COMMENT= Lookup the username on the remote end of a TCP/IP connection
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Net::Ident.3
diff --git a/net/p5-Net-MAC/Makefile b/net/p5-Net-MAC/Makefile
index ce8305421959..dde78832e566 100644
--- a/net/p5-Net-MAC/Makefile
+++ b/net/p5-Net-MAC/Makefile
@@ -19,6 +19,7 @@ RUN_DEPENDS= p5-libwww>=0:${PORTSDIR}/www/p5-libwww
MAN3= Net::MAC.3
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
.include <bsd.port.mk>
diff --git a/net/p5-Net-Mosso-CloudFiles/Makefile b/net/p5-Net-Mosso-CloudFiles/Makefile
index 6a3b14cdfb7c..2d34474a46de 100644
--- a/net/p5-Net-Mosso-CloudFiles/Makefile
+++ b/net/p5-Net-Mosso-CloudFiles/Makefile
@@ -28,7 +28,8 @@ RUN_DEPENDS= p5-Digest-MD5-File>=0:${PORTSDIR}/security/p5-Digest-MD5-File \
BUILD_DEPENDS:= ${RUN_DEPENDS}
TEST_DEPENDS= p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Net::Mosso::CloudFiles.3 \
Net::Mosso::CloudFiles::Container.3 \
diff --git a/net/p5-Net-OAuth/Makefile b/net/p5-Net-OAuth/Makefile
index d21eaff28bbe..502836172488 100644
--- a/net/p5-Net-OAuth/Makefile
+++ b/net/p5-Net-OAuth/Makefile
@@ -22,7 +22,8 @@ BUILD_DEPENDS= p5-Class-Accessor>=0.31:${PORTSDIR}/devel/p5-Class-Accessor \
RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= p5-Test-Warn>=0:${PORTSDIR}/devel/p5-Test-Warn
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN3= Net::OAuth.3 \
Net::OAuth::AccessToken.3 \
diff --git a/net/p5-Net-OpenStack-Attack/Makefile b/net/p5-Net-OpenStack-Attack/Makefile
index a8c5a0d63bc5..1eb6bc96e2ad 100644
--- a/net/p5-Net-OpenStack-Attack/Makefile
+++ b/net/p5-Net-OpenStack-Attack/Makefile
@@ -19,7 +19,8 @@ RUN_DEPENDS= p5-Any-Moose>=0:${PORTSDIR}/devel/p5-Any-Moose \
p5-Net-HTTPS-NB>=0:${PORTSDIR}/net/p5-Net-HTTPS-NB \
p5-libwww>=0:${PORTSDIR}/www/p5-libwww
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN1= stackattack.1
MAN3= Net::OpenStack::Attack.3
diff --git a/net/p5-Net-SSH/Makefile b/net/p5-Net-SSH/Makefile
index e882c5377d6b..64a5dc6946ea 100644
--- a/net/p5-Net-SSH/Makefile
+++ b/net/p5-Net-SSH/Makefile
@@ -14,7 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= miwi@FreeBSD.org
COMMENT= Perl5 module to access and use ssh protocol
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Net::SSH.3
diff --git a/net/p5-Net-Wake/Makefile b/net/p5-Net-Wake/Makefile
index 18a966070961..9294da662e31 100644
--- a/net/p5-Net-Wake/Makefile
+++ b/net/p5-Net-Wake/Makefile
@@ -14,7 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= sarumaru@jp.FreeBSD.org
COMMENT= Send Wake On Lan (WOL) packets to power on computers
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Net::Wake.3
diff --git a/net/p5-Net-WhitePages/Makefile b/net/p5-Net-WhitePages/Makefile
index f4732920ffd8..a7c6f53f768f 100644
--- a/net/p5-Net-WhitePages/Makefile
+++ b/net/p5-Net-WhitePages/Makefile
@@ -20,7 +20,8 @@ BUILD_DEPENDS= p5-Params-Validate>=0:${PORTSDIR}/devel/p5-Params-Validate \
p5-libwww>=0:${PORTSDIR}/www/p5-libwww
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Net::WhitePages.3
diff --git a/net/p5-Net-Whois-RIPE/Makefile b/net/p5-Net-Whois-RIPE/Makefile
index f0ffe94443f0..d3123e136579 100644
--- a/net/p5-Net-Whois-RIPE/Makefile
+++ b/net/p5-Net-Whois-RIPE/Makefile
@@ -23,7 +23,8 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception \
p5-WWW-Mechanize>=0:${PORTSDIR}/www/p5-WWW-Mechanize
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Net::Whois::Object.3 \
Net::Whois::Object::AsBlock.3 \
diff --git a/net/p5-URI-SmartURI/Makefile b/net/p5-URI-SmartURI/Makefile
index 745cda01577e..6c2ca71b0ddf 100644
--- a/net/p5-URI-SmartURI/Makefile
+++ b/net/p5-URI-SmartURI/Makefile
@@ -28,7 +28,8 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= p5-Test-Fatal>0:${PORTSDIR}/devel/p5-Test-Fatal \
p5-Test-NoWarnings>0:${PORTSDIR}/devel/p5-Test-NoWarnings
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= URI::SmartURI.3
diff --git a/net/xrdesktop/Makefile b/net/xrdesktop/Makefile
index 3cb97e4d30ce..1cc61f0c6cd2 100644
--- a/net/xrdesktop/Makefile
+++ b/net/xrdesktop/Makefile
@@ -14,7 +14,7 @@ RUN_DEPENDS= rdesktop:${PORTSDIR}/net/rdesktop \
p5-Gtk>=0:${PORTSDIR}/x11-toolkits/p5-Gtk
NO_BUILD= yes
-USE_PERL5= yes
+USES= perl5
PLIST_FILES= bin/xrdesktop