aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2020-06-08 16:17:40 +0000
committerRene Ladan <rene@FreeBSD.org>2020-06-08 16:17:40 +0000
commit6b76064908a144c335d94e6d9334cc00cc1cc04d (patch)
treed31e9da239824523aa633dbf1634e055085ba3c9
parentab20c6d48093e0963b73a2be45cd712ebf4c1737 (diff)
downloadports-6b76064908a144c335d94e6d9334cc00cc1cc04d.tar.gz
ports-6b76064908a144c335d94e6d9334cc00cc1cc04d.zip
MFH: r538214
net-mgmt/ipv6mon: unexpire by downloading from GitHub Use the correct path in ipv6mon(8) and ipv6mon.conf(5) Bump PORTREVISION PR: 242414 Submitted by: takefu Approved by: maintainer timeout (hrs, 6 months) Approved by: ports-secteam (joneum)
Notes
Notes: svn path=/branches/2020Q2/; revision=538229
-rw-r--r--net-mgmt/ipv6mon/Makefile18
-rw-r--r--net-mgmt/ipv6mon/distinfo5
-rw-r--r--net-mgmt/ipv6mon/files/patch-ipv6mon.c8
3 files changed, 18 insertions, 13 deletions
diff --git a/net-mgmt/ipv6mon/Makefile b/net-mgmt/ipv6mon/Makefile
index 49144a01a5ee..24814b6531b4 100644
--- a/net-mgmt/ipv6mon/Makefile
+++ b/net-mgmt/ipv6mon/Makefile
@@ -2,20 +2,21 @@
PORTNAME= ipv6mon
PORTVERSION= 1.0
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= net-mgmt
-MASTER_SITES= http://www.si6networks.com/tools/ipv6mon/
-DISTNAME= ${PORTNAME}-v${PORTVERSION}
MAINTAINER= hrs@FreeBSD.org
COMMENT= Tool for monitoring IPv6 address usage
-BROKEN= unfetchable
-
LICENSE= GPLv3+
LICENSE_FILE= ${WRKSRC}/LICENSE.TXT
USES= uidfix
+GH_ACCOUNT= fgont
+GH_PROJECT= ipv6mon
+GH_TAGNAME= 454292a393ddd79db7131b6e7a8d005a7f49bd92
+USE_GCC= any
+USE_GITHUB= nodefault
CFLAGS+= -DIPV6MON_CONF=\\\"${PREFIX}/etc/ipv6mon.conf\\\"
USERS= ${PORTNAME}
GROUPS= ${PORTNAME}
@@ -26,12 +27,15 @@ PORTDOCS= README.TXT \
ipv6mon-installation-notes.pdf \
ipv6mon-manual.odt \
ipv6mon-manual.pdf
+WRKSRC= ${WRKDIR}/${GH_PROJECT}-${GH_TAGNAME}
OPTIONS_DEFINE= DOCS
post-extract:
- @${INSTALL_DATA} ${FILESDIR}/Makefile ${WRKSRC}
- @${INSTALL_DATA} ${WRKSRC}/manuals/* ${WRKSRC}
+ ${INSTALL_DATA} ${FILESDIR}/Makefile ${WRKSRC}
+ ${INSTALL_DATA} ${WRKSRC}/manuals/* ${WRKSRC}
+ @${REINPLACE_CMD} 's|/etc/|${PREFIX}/etc/|'\
+ ${WRKSRC}/ipv6mon.8 ${WRKSRC}/ipv6mon.conf.5
post-install:
${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${STAGEDIR}${PREFIX}/etc/rc.d
diff --git a/net-mgmt/ipv6mon/distinfo b/net-mgmt/ipv6mon/distinfo
index 70941fde0037..a0caa4080afd 100644
--- a/net-mgmt/ipv6mon/distinfo
+++ b/net-mgmt/ipv6mon/distinfo
@@ -1,2 +1,3 @@
-SHA256 (ipv6mon-v1.0.tar.gz) = f714a877de4fbf80126c4b8ad2e3496739695ee1eb3a914eae344fdd6325e138
-SIZE (ipv6mon-v1.0.tar.gz) = 211625
+TIMESTAMP = 1575355108
+SHA256 (ipv6mon-1.0.tar.gz) = 01545101a5032867363be9d89a0dbf7f9c9eb3d67277e406b56889a9856c2ef8
+SIZE (ipv6mon-1.0.tar.gz) = 207872
diff --git a/net-mgmt/ipv6mon/files/patch-ipv6mon.c b/net-mgmt/ipv6mon/files/patch-ipv6mon.c
index 5e67c75a4b66..6c8dd37f5399 100644
--- a/net-mgmt/ipv6mon/files/patch-ipv6mon.c
+++ b/net-mgmt/ipv6mon/files/patch-ipv6mon.c
@@ -1,6 +1,6 @@
---- ipv6mon.c.orig 2012-09-20 13:02:24.000000000 +0900
-+++ ipv6mon.c 2012-09-20 13:02:26.000000000 +0900
-@@ -277,7 +277,7 @@
+--- ipv6mon.c.orig 2012-10-26 09:06:17 UTC
++++ ipv6mon.c
+@@ -277,7 +277,7 @@ int main(int argc, char **argv){
}
if(!configfile_f){
@@ -9,7 +9,7 @@
}
if(process_config_file(configfile) == -1)
-@@ -888,7 +888,8 @@
+@@ -888,7 +888,8 @@ void print_help(void){
usage();
puts("\nOPTIONS:\n"