aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2016-04-04 12:24:33 +0000
committerKoop Mast <kwm@FreeBSD.org>2016-04-04 12:24:33 +0000
commit6e3ae05a8e20c6e3d96c06e25ad2044a33822f2a (patch)
treee5da8275b38838f3c94d4a3cd3a644dab2118e49
parent7a5720c8c95706eea4d61a44e5334ea9684a4ac5 (diff)
Notes
-rw-r--r--graphics/libGL/Makefile.common7
-rw-r--r--lang/clover/Makefile5
2 files changed, 4 insertions, 8 deletions
diff --git a/graphics/libGL/Makefile.common b/graphics/libGL/Makefile.common
index 106785d76e42..0ad35693405d 100644
--- a/graphics/libGL/Makefile.common
+++ b/graphics/libGL/Makefile.common
@@ -89,8 +89,7 @@ CONFIGURE_ARGS+= --enable-gles2
.if ${OPSYS} == DragonFly || \
(${OPSYS} == FreeBSD && \
(${OSVERSION} >= 1001000 && ${ARCH} == amd64 || \
- ${OSVERSION} >= 1002000 && ${ARCH} == i386))
-# Disabled on 10.1-R i386 because of compile issues with libclc.
+ ${OSVERSION} >= 1001000 && ${ARCH} == i386))
BUILD_DEPENDS+= libclc>=0.0.r222830:devel/libclc
@@ -117,9 +116,9 @@ CONFIGURE_ARGS+= --disable-opencl
CONFIGURE_ARGS+= --enable-osmesa
# gallium
-BUILD_DEPENDS+= llvm${MESA_LLVM_VER}>=0:devel/llvm${MESA_LLVM_VER}
+BUILD_DEPENDS+= llvm${MESA_LLVM_VER}>=3.7.l_1:devel/llvm${MESA_LLVM_VER}
.if ${COMPONENT:Mdri} != "" || ${COMPONENT:Mclover} != "" || ${COMPONENT:Megl} != ""
-RUN_DEPENDS+= llvm${MESA_LLVM_VER}>=0:devel/llvm${MESA_LLVM_VER}
+RUN_DEPENDS+= llvm${MESA_LLVM_VER}>=3.7.1_1:devel/llvm${MESA_LLVM_VER}
.endif
CONFIGURE_ENV+= LLVM_CONFIG=${LOCALBASE}/bin/llvm-config${MESA_LLVM_VER}
diff --git a/lang/clover/Makefile b/lang/clover/Makefile
index eb95e79ae8d7..8897b0cacbae 100644
--- a/lang/clover/Makefile
+++ b/lang/clover/Makefile
@@ -25,12 +25,9 @@ ONLY_FOR_ARCHS_REASON= Clover needs a graphics driver supported by the Radeon KM
#MESA_BUILD_WRKSRC= src/util src/glsl src/mesa src/gallium
MESA_INSTALL_WRKSRC= src/gallium/targets/opencl src/gallium/targets/pipe-loader
-.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1001000 && ${ARCH} == amd64
+.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1001000
IGNORE= Clover is only supported on FreeBSD 10.1 and newer
.endif
-.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1002000 && ${ARCH} == i386
-IGNORE= Clover is only supported on FreeBSD 10.2 and newer
-.endif
.include "${.CURDIR}/../../graphics/libGL/Makefile.targets"