aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2013-04-23 10:26:09 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2013-04-23 10:26:09 +0000
commit79e6679346f4515441bf9f8474233ffb3ebb7234 (patch)
tree04e6170d2cc2b72b73a4fbf4855cbc6d9202f7c0
parentd5da69710473d5ba18bc506a136e760259452a74 (diff)
downloadports-79e6679346f4515441bf9f8474233ffb3ebb7234.tar.gz
ports-79e6679346f4515441bf9f8474233ffb3ebb7234.zip
Notes
-rw-r--r--audio/gbsplay/Makefile2
-rw-r--r--deskutils/xfce4-notification-daemon/Makefile2
-rw-r--r--deskutils/xfce4-notifyd/Makefile2
-rw-r--r--devel/libexplain/Makefile3
-rw-r--r--ftp/weex/Makefile2
-rw-r--r--mail/sylpheed/Makefile2
-rw-r--r--multimedia/subtitleeditor/Makefile2
-rw-r--r--net-im/pidgin-bs/Makefile2
-rw-r--r--net-im/pidgin-privacy-please/Makefile2
-rw-r--r--shells/bash-devel/Makefile6
-rw-r--r--sysutils/dvdbackup/Makefile2
11 files changed, 13 insertions, 14 deletions
diff --git a/audio/gbsplay/Makefile b/audio/gbsplay/Makefile
index ce17e032031a..2b8007ded3fc 100644
--- a/audio/gbsplay/Makefile
+++ b/audio/gbsplay/Makefile
@@ -12,8 +12,8 @@ MAINTAINER= ehaupt@FreeBSD.org
COMMENT?= Emulates the sound hardware of the Nintendo Game Boy(TM)
HAS_CONFIGURE= yes
+USES= gettext
USE_GMAKE= yes
-USE_GETTEXT= yes
MAKE_JOBS_SAFE= yes
USE_CSTD= gnu89
diff --git a/deskutils/xfce4-notification-daemon/Makefile b/deskutils/xfce4-notification-daemon/Makefile
index 07f046a8c409..0427abff61be 100644
--- a/deskutils/xfce4-notification-daemon/Makefile
+++ b/deskutils/xfce4-notification-daemon/Makefile
@@ -45,7 +45,7 @@ OPTIONS_DEFAULT=CLOSE NLS
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNLS}
-USE_GETTEXT= yes
+USES+= gettext
PLIST_SUB+= NLS=""
.else
PLIST_SUB+= NLS="@comment "
diff --git a/deskutils/xfce4-notifyd/Makefile b/deskutils/xfce4-notifyd/Makefile
index 91012a5ce094..3adfc23dbc90 100644
--- a/deskutils/xfce4-notifyd/Makefile
+++ b/deskutils/xfce4-notifyd/Makefile
@@ -35,7 +35,7 @@ OPTIONS_DEFINE= NLS
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNLS}
-USE_GETTEXT= yes
+USES+= gettext
CONFIGURE_ARGS+=--enable-nls
PLIST_SUB+= NLS=""
.else
diff --git a/devel/libexplain/Makefile b/devel/libexplain/Makefile
index 5593dff52a85..9fe460a73ab7 100644
--- a/devel/libexplain/Makefile
+++ b/devel/libexplain/Makefile
@@ -18,8 +18,7 @@ BUILD_DEPENDS= pdfopt:${PORTSDIR}/print/ghostscript9 \
gsed:${PORTSDIR}/textproc/gsed
USE_AUTOTOOLS= libtool
-USES= bison
-USE_GETTEXT= yes
+USES= bison gettext
USE_GMAKE= yes
USE_LDCONFIG= yes
diff --git a/ftp/weex/Makefile b/ftp/weex/Makefile
index 5dcd6371be9c..23e5000ec106 100644
--- a/ftp/weex/Makefile
+++ b/ftp/weex/Makefile
@@ -22,7 +22,7 @@ OPTIONS_DEFINE= DOCS NLS
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNLS}
-USE_GETTEXT= yes
+USES+= gettext
PLIST_SUB+= NLS=""
.else
CONFIGURE_ARGS+=--disable-nls
diff --git a/mail/sylpheed/Makefile b/mail/sylpheed/Makefile
index f2bf19ab9e65..c782cda89189 100644
--- a/mail/sylpheed/Makefile
+++ b/mail/sylpheed/Makefile
@@ -14,8 +14,8 @@ COMMENT= Lightweight, featureful, and fast GTK+ based e-mail client
LIB_DEPENDS= aspell:${PORTSDIR}/textproc/aspell
RUN_DEPENDS= ${LOCALBASE}/etc/mime.types:${PORTSDIR}/misc/mime-support
+USES= gettext
USE_BZIP2= yes
-USE_GETTEXT= yes
USE_GMAKE= yes
USE_ICONV= yes
USE_GNOME= gtk20
diff --git a/multimedia/subtitleeditor/Makefile b/multimedia/subtitleeditor/Makefile
index 93e178e4ca9b..544606e59473 100644
--- a/multimedia/subtitleeditor/Makefile
+++ b/multimedia/subtitleeditor/Makefile
@@ -34,7 +34,7 @@ OPTIONS_DEFINE= NLS
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNLS}
-USE_GETTEXT= yes
+USES+= gettext
PLIST_SUB+= NLS=""
.else
CONFIGURE_ARGS+=--disable-nls
diff --git a/net-im/pidgin-bs/Makefile b/net-im/pidgin-bs/Makefile
index 23ac137459dc..118480daae15 100644
--- a/net-im/pidgin-bs/Makefile
+++ b/net-im/pidgin-bs/Makefile
@@ -17,8 +17,8 @@ LIB_DEPENDS= purple:${PORTSDIR}/net-im/libpurple
RUN_DEPENDS= pidgin:${PORTSDIR}/net-im/pidgin
GNU_CONFIGURE= yes
+USES= gettext
USE_BZIP2= yes
-USE_GETTEXT= yes
USE_GMAKE= yes
USE_GNOME= gtk20
USE_LDCONFIG= ${PREFIX}/lib/pidgin
diff --git a/net-im/pidgin-privacy-please/Makefile b/net-im/pidgin-privacy-please/Makefile
index 4ae734098966..8089a8ffb2b9 100644
--- a/net-im/pidgin-privacy-please/Makefile
+++ b/net-im/pidgin-privacy-please/Makefile
@@ -17,8 +17,8 @@ BUILD_DEPENDS= pidgin:${PORTSDIR}/net-im/pidgin
RUN_DEPENDS= pidgin:${PORTSDIR}/net-im/pidgin
GNU_CONFIGURE= yes
+USES= gettext
USE_GMAKE= yes
-USE_GETTEXT= yes
USE_GNOME= gtk20
USE_LDCONFIG= ${PREFIX}/lib/pidgin
diff --git a/shells/bash-devel/Makefile b/shells/bash-devel/Makefile
index 45ca5857b9e2..3b67ee7480e8 100644
--- a/shells/bash-devel/Makefile
+++ b/shells/bash-devel/Makefile
@@ -33,7 +33,7 @@ HELP_DESC= Enable builtin help
USES= bison
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MIMPLICITCD}
EXTRA_PATCHES+= ${PATCHDIR}/extrapatch-implicitcd
@@ -76,7 +76,7 @@ CONFIGURE_ARGS+= --disable-nls
PLIST_SUB+= NLS="@comment "
.else
USE_ICONV= yes
-USE_GETTEXT= yes
+USES+= gettext
PLIST_SUB+= NLS=""
.endif
@@ -137,4 +137,4 @@ cklatest:
ftp://ftp.cwru.edu/pub/${PORTNAME}/${PORTNAME}-${PORTVERSION:C/\.[0-9a-z]*$//}-patches/ \
| fgrep -v .sig | ${TAIL}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/sysutils/dvdbackup/Makefile b/sysutils/dvdbackup/Makefile
index b4a8a1dfed6b..8c4497899b68 100644
--- a/sysutils/dvdbackup/Makefile
+++ b/sysutils/dvdbackup/Makefile
@@ -29,7 +29,7 @@ OPTIONS_DEFINE= DOCS NLS
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNLS}
-USE_GETTEXT= yes
+USES+= gettext
CONFIGURE_ARGS+= --enable-nls
PLIST_SUB+= NLS=""
.else