aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2020-06-06 23:10:04 +0000
committerJan Beich <jbeich@FreeBSD.org>2020-06-06 23:10:04 +0000
commit870d6c9c1aded5ae2a5fa0605ca450578b9df995 (patch)
tree942ad4f221fbc82464f545f9e1b0ceb35b62d80c
parent9703b224f28078ca54c30ad18cea5596ec32a2fc (diff)
downloadports-870d6c9c1aded5ae2a5fa0605ca450578b9df995.tar.gz
ports-870d6c9c1aded5ae2a5fa0605ca450578b9df995.zip
MFH: r538136
emulators/ppsspp: unbreak Vulkan on Wayland after r512863 Regressed by https://github.com/hrydgard/ppsspp/commit/3e4faea6adcb $ SDL_VIDEODRIVER=wayland LD_PRELOAD=libGLEW-wayland.so ppsspp [...] I: VulkanLoader.cpp:451: VulkanLoad: Found library 'libvulkan.so' W: VulkanLoader.cpp:472: VulkanLoad: Base functions loaded. W: VulkanLoader.cpp:548: Vulkan instance functions loaded. I: VulkanContext.cpp:502: Chose physical device 0: 0x8056427c0 I: VulkanContext.cpp:538: Memory Types (1): I: VulkanContext.cpp:547: 0: Heap 0; Flags: DEVICE_LOCAL HOST_VISIBLE HOST_CACHED HOST_COHERENT W: VulkanLoader.cpp:555: Vulkan device functions loaded. I: VulkanLoader.cpp:571: Missing (device): vkGetPhysicalDeviceSparseImageFormatProperties I: VulkanContext.cpp:659: Device created. Vulkan subsystem 6 not supported Approved by: ports-secteam blanket
Notes
Notes: svn path=/branches/2020Q2/; revision=538137
-rw-r--r--emulators/ppsspp/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/emulators/ppsspp/Makefile b/emulators/ppsspp/Makefile
index fed34a221177..f04d9b71c87b 100644
--- a/emulators/ppsspp/Makefile
+++ b/emulators/ppsspp/Makefile
@@ -3,7 +3,7 @@
PORTNAME= ppsspp
DISTVERSIONPREFIX= v
DISTVERSION?= 1.9.4
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES= emulators
# XXX Get from Debian once #697821 lands
MASTER_SITES= https://bazaar.launchpad.net/~sergio-br2/${PORTNAME}/debian-sdl/download/5/${PORTNAME}.1-20140802045408-dd26dik367ztj5xg-8/:manpage
@@ -39,7 +39,7 @@ EXCLUDE= libzip zlib
EXTRACT_AFTER_ARGS=${EXCLUDE:S,^,--exclude ,}
USE_GL= gl glew glu
USE_SDL= sdl2 # joystick
-CMAKE_ON= USE_SYSTEM_FFMPEG USE_SYSTEM_LIBZIP
+CMAKE_ON= USE_SYSTEM_FFMPEG USE_SYSTEM_LIBZIP USE_WAYLAND_WSI
CMAKE_OFF= USE_DISCORD
SUB_FILES= pkg-message
PORTDATA= assets ${PORTNAME}