aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2012-09-04 06:57:36 +0000
committerMark Linimon <linimon@FreeBSD.org>2012-09-04 06:57:36 +0000
commit8e65c59121fbb53bcf7950f6a0f9b6f261ac6398 (patch)
treebbaf5dbd314f3a0807509b03d87030411873b44e
parent0321c9291bf93b4ef8048f699fc841610c52885c (diff)
downloadports-8e65c59121fbb53bcf7950f6a0f9b6f261ac6398.tar.gz
ports-8e65c59121fbb53bcf7950f6a0f9b6f261ac6398.zip
Notes
-rw-r--r--databases/mysac/Makefile8
-rw-r--r--graphics/mesa-demos/Makefile4
-rw-r--r--lang/luajit/Makefile8
-rw-r--r--lang/mosh/Makefile4
-rw-r--r--security/nacl/Makefile4
-rw-r--r--security/ophcrack/Makefile8
-rw-r--r--x11-fm/rodent/Makefile8
7 files changed, 40 insertions, 4 deletions
diff --git a/databases/mysac/Makefile b/databases/mysac/Makefile
index cc92be1fd7ea..a4c51dc9c2fc 100644
--- a/databases/mysac/Makefile
+++ b/databases/mysac/Makefile
@@ -36,4 +36,10 @@ do-install:
${INSTALL_LIB} ${WRKSRC}/libmysac-static.a ${PREFIX}/lib/libmysac-static.a
${INSTALL_DATA} ${WRKSRC}/mysac.h ${PREFIX}/include/mysac.h
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "ia64" || ${ARCH} == "powerpc" || ${ARCH} == "sparc64"
+BROKEN= Does not compile on ia64, powerpc, or sparc64
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/graphics/mesa-demos/Makefile b/graphics/mesa-demos/Makefile
index 3c8366481b4e..c871e89d2d6d 100644
--- a/graphics/mesa-demos/Makefile
+++ b/graphics/mesa-demos/Makefile
@@ -85,4 +85,8 @@ CFLAGS+= -DWITH_NVIDIA_GL=1
ARCH!= uname -p
.endif
+.if ${ARCH} == "ia64" || ${ARCH} == "powerpc" || ${ARCH} == "sparc64"
+BROKEN= Does not compile on ia64, powerpc, or sparc64
+.endif
+
.include <bsd.port.post.mk>
diff --git a/lang/luajit/Makefile b/lang/luajit/Makefile
index 5ed03913222e..3fe4147b8dee 100644
--- a/lang/luajit/Makefile
+++ b/lang/luajit/Makefile
@@ -29,4 +29,10 @@ post-install:
@${INSTALL_MAN} ${WRKSRC}/etc/luajit.1 ${MAN1PREFIX}/man/man1
.endif
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "ia64" || ${ARCH} == "powerpc" || ${ARCH} == "sparc64"
+BROKEN= Does not compile on ia64, powerpc, or sparc64
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/lang/mosh/Makefile b/lang/mosh/Makefile
index 0779d02df3ae..65b2b3b828bb 100644
--- a/lang/mosh/Makefile
+++ b/lang/mosh/Makefile
@@ -36,6 +36,10 @@ MAN1= mosh.1 mosh_config.1
BROKEN= Does not build on FreeBSD 7.x
.endif
+.if ${ARCH} == "ia64" || ${ARCH} == "powerpc" || ${ARCH} == "sparc64"
+BROKEN= Does not compile on ia64, powerpc, or sparc64
+.endif
+
post-patch:
${REINPLACE_CMD} 's|mosh-$$PACKAGE_VERSION|mosh|' ${WRKSRC}/configure
diff --git a/security/nacl/Makefile b/security/nacl/Makefile
index 76b5cb9857dc..b58e2e0e46a8 100644
--- a/security/nacl/Makefile
+++ b/security/nacl/Makefile
@@ -19,6 +19,10 @@ MAKE_JOBS_UNSAFE= YES
.include <bsd.port.pre.mk>
+.if ${ARCH} == "ia64" || ${ARCH} == "powerpc" || ${ARCH} == "sparc64"
+BROKEN= Does not compile on ia64, powerpc, or sparc64
+.endif
+
HOSTNAME_CMD?= /bin/hostname
do-build:
diff --git a/security/ophcrack/Makefile b/security/ophcrack/Makefile
index 8f7431ae2002..a3aef5b5af61 100644
--- a/security/ophcrack/Makefile
+++ b/security/ophcrack/Makefile
@@ -52,4 +52,10 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/ChangeLog ${WRKSRC}/README ${DOCSDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "ia64" || ${ARCH} == "powerpc" || ${ARCH} == "sparc64"
+BROKEN= Does not compile on ia64, powerpc, or sparc64
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/x11-fm/rodent/Makefile b/x11-fm/rodent/Makefile
index dc243857b039..58c1ce304a4e 100644
--- a/x11-fm/rodent/Makefile
+++ b/x11-fm/rodent/Makefile
@@ -47,4 +47,10 @@ post-patch:
${REINPLACE_CMD} -e 's,^\(docdir = \).*,\1${DOCSDIR},' \
${WRKSRC}/Build/share/Makefile.in
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "ia64" || ${ARCH} == "powerpc" || ${ARCH} == "sparc64"
+BROKEN= Does not compile on ia64, powerpc, or sparc64
+.endif
+
+.include <bsd.port.post.mk>