aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-11-29 03:06:54 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-11-29 03:06:54 +0000
commit90de16aeba3d8d0d6dd661b7412cad935f071c76 (patch)
tree244b0ad7bf2cd5f506633c7a1ca2ba1505769e3b
parentcdd2a9ce418709ce4633ca403421b916de8fa3fd (diff)
downloadports-90de16aeba3d8d0d6dd661b7412cad935f071c76.tar.gz
ports-90de16aeba3d8d0d6dd661b7412cad935f071c76.zip
Notes
-rw-r--r--net/Makefile1
-rw-r--r--net/p5-BBS-UserInfo-SOB/Makefile30
-rw-r--r--net/p5-BBS-UserInfo-SOB/distinfo3
-rw-r--r--net/p5-BBS-UserInfo-SOB/pkg-descr3
-rw-r--r--net/p5-BBS-UserInfo-SOB/pkg-plist8
5 files changed, 45 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 70843597d646..e1590c7c9b25 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -405,6 +405,7 @@
SUBDIR += p5-BBS-UserInfo-Maple3
SUBDIR += p5-BBS-UserInfo-Maple3itoc
SUBDIR += p5-BBS-UserInfo-Ptt
+ SUBDIR += p5-BBS-UserInfo-SOB
SUBDIR += p5-BBS-UserInfo-Wretch
SUBDIR += p5-EasyTCP
SUBDIR += p5-File-Rsync
diff --git a/net/p5-BBS-UserInfo-SOB/Makefile b/net/p5-BBS-UserInfo-SOB/Makefile
new file mode 100644
index 000000000000..d0d249698524
--- /dev/null
+++ b/net/p5-BBS-UserInfo-SOB/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: p5-BBS-UserInfo-SOB
+# Date created: 2006-08-20
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= BBS-UserInfo-SOB
+PORTVERSION= 0.01
+CATEGORIES= net perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../../authors/id/G/GS/GSLIN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Get user information of SOB-style BBS
+
+RUN_DEPENDS= ${SITE_PERL}/Expect.pm:${PORTSDIR}/lang/p5-Expect
+
+PERL_CONFIGURE= yes
+
+MAN3= BBS::UserInfo::SOB.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800 # Inherited from lang/p5-Expect
+IGNORE= requires perl 5.8.0 or newer. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net/p5-BBS-UserInfo-SOB/distinfo b/net/p5-BBS-UserInfo-SOB/distinfo
new file mode 100644
index 000000000000..0bb4296cbb52
--- /dev/null
+++ b/net/p5-BBS-UserInfo-SOB/distinfo
@@ -0,0 +1,3 @@
+MD5 (BBS-UserInfo-SOB-0.01.tar.gz) = 22dd2c26cfd51c2f91c4d726ca1597e8
+SHA256 (BBS-UserInfo-SOB-0.01.tar.gz) = d2052e0045611f115701dbc84e55afbc21b6a52d5d9d57446edaeda3df746804
+SIZE (BBS-UserInfo-SOB-0.01.tar.gz) = 2444
diff --git a/net/p5-BBS-UserInfo-SOB/pkg-descr b/net/p5-BBS-UserInfo-SOB/pkg-descr
new file mode 100644
index 000000000000..2d06fcb74050
--- /dev/null
+++ b/net/p5-BBS-UserInfo-SOB/pkg-descr
@@ -0,0 +1,3 @@
+Get user information of SOB-style BBS.
+
+WWW: http://search.cpan.org/dist/BBS-UserInfo-SOB/
diff --git a/net/p5-BBS-UserInfo-SOB/pkg-plist b/net/p5-BBS-UserInfo-SOB/pkg-plist
new file mode 100644
index 000000000000..74c25a18e762
--- /dev/null
+++ b/net/p5-BBS-UserInfo-SOB/pkg-plist
@@ -0,0 +1,8 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/BBS/UserInfo/SOB/.packlist
+%%SITE_PERL%%/BBS/UserInfo/SOB.pm
+@dirrmtry %%SITE_PERL%%/BBS/UserInfo
+@dirrmtry %%SITE_PERL%%/BBS
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/BBS/UserInfo/SOB
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/BBS/UserInfo
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/BBS